Jump to content
kymation

[Addon} Theme Switcher

Recommended Posts

Hi, and on the other hand:

 

Somebody know where the code to control CSS depending on the browser is?

 

And what is the code to control CSS and Internet Explorer issues?

 

Thanks you very much, I am breaking my brain with this mistery :-).

Share this post


Link to post
Share on other sites

Your problem is due to something you have changed other than Theme Switcher. Theme switcher makes only the changes to template_top.php, so if you replace that with the originalthere is no change. The database changes are only to install configuration table entries that only Theme Switcher uses.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

This addon provides a simple way of changing themes in your osCommerce store. You can switch to a new theme for the season or to spruce up your store, or just to test out a new look. Just upload your new theme package and then select your new theme in your store's Admin.

 

Instructions are included for using the ThemeRoller tool to download stock themes and design new ones. It includes a method that allows you to design WYSIWYG on your own store pages.

 

Code in the usual location.

 

Regards

Jim

Hi Jim. I am a novice wit Oscommerce but learning. I downloaded theme switcher 1.3 and it is in a tar.gz file that I cannot extract in Vista. Do I just upload the whole thing? If so the location would be appreciated. Thanks for the hard work. Cal (Budsfirearms.com)

Share this post


Link to post
Share on other sites

You need to extract the files and read the User's Manual in the package. There are plenty of free programs that will extract a Gzip archive, WinZip for example.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi all! Sorry if this has already been asked, but I couldnt find it. I have installed a new theme using theme switcher and everythimg looks great except for the header shortcuts. Originally they displayed inline, (Cart Checkout My Account), but after installing my new theme they are displaying stacked on top of one another (Cart

Checkout

My Account).

How do I get them back inline?

Share this post


Link to post
Share on other sites

You have an error somewhere in your installation. Did you install the latest versions of jQuery and the jQuery UI?

 

In your browser, right click and select View Page Source. Click each of the links in the head section, one at a time, and verify that the file appears. If one of these returns a 404 page, that file is missing and needs to be provided.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi Jim,

 

Thanks for your reply. I have upgraded the jQuery and jQuery UI as per the installation instructions. I also went through and clicked all the links in the head section as you suggested. None of the links returned the 404 error, they all went to where they were supposed to (at least, I assume they went where they were supposed to!). Still no luck. Any other suggestions? If it helps, the page in question is www.SweetlandVintage.com/. Thanks again for your help!

Share this post


Link to post
Share on other sites

Your logo image is too wide -- it's pushing the buttons out of place and interfering with their formatting. There is a trick that allows you to overlay the buttons on your image, but they would still cover up part of your logo. The only thing I can think of that will work for you is to move the buttons elsewhere.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

That isn't a logo image, it is the background image. In the logo spot is a single empty pixel. However, I am not opposed to moving the buttons. I actually tried this on my own, but it broke the entire layout. Would you be willing to help me out on this as well? Thanks a bunch Jim!

Share this post


Link to post
Share on other sites

I advise making the logo smaller, since it takes up about a third of the screen height on my big monitor. Reducing that leaves more room for your products.

 

I'm not going to be any help in moving the buttons out of the header area as I haven't actually done that. There was a thread on the forum recently about moving them into the breadcrumb bar. I don't have it bookmarked, but a search should turn it up.

 

Regards

JIm


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hello,

 

I am OSC 2.31 beginner and I need some help please.

 

I already have installed theme switcher 1.3 addon and it is working. Just I realized that the (OSC embebed) Banner Rotator module in the Front Page is not working. After setup up the module and banners, Banner Rotator dont show up any image in my main page, just a small black dot.

When I review my main page source code (index page), I see that the bannerRotator.js and stylesheet.css lines are ABOVE of the JQuery lines. (¿?).

I guess that is has relationship with the following theme switcher instruction to modify the template_top.php:

 

Modified Files: catalog/includes/template_top.php. Delete these three lines:

<link rel="stylesheet" type="text/css" href="ext/jquery/ui/redmond/jquery-ui-1.8.6.css" />

<script type="text/javascript" src="ext/jquery/jquery-1.4.2.min.js"></script>

<script type="text/javascript" src="ext/jquery/ui/jquery-ui-1.8.6.min.js"></script>

 

How can I move the bannerRotaror lines BELOW JQuery lines? or

 

How can I move the new Themeswitcher JQuery lines to the similar position as the orignal JQuery lines were?

 

Thanks a lot.

 

I will really appreciate your help.

Eduardo.

Edited by elara

Share this post


Link to post
Share on other sites

Move the jQuery for the banner rotator to just before the </head> in catalog/includes/template_top.php.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi Jim,

 

thanks a lot for your answer but I am sorry, I didnt understand that you mean.

 

I didnt find any JQuery BannerRotator line in catalog/includes/template_top.php file.

 

Can you tell me what lines you mean?

 

Thanks again.

Edo.

Share this post


Link to post
Share on other sites

The banner rotator I wrote uses bannerRotator.js. Where is the code that calls that file? Are you using the old embedded Banner Rotator or the modular one from Modular Front Page? Or is there some other version that I don't know about?

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi,

 

I using OSC 2.31 and its embedded Banner Rotator into embedded FrontPage.

 

Thanks a lot for help me.

 

Edo.

Share this post


Link to post
Share on other sites

I don't understand. osCommerce 2.3.1 doesn't come with a banner rotator.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi,

 

Upps, sorry, I received my OSC 2.31 with this installed and really now I am not sure it is enbebed or not but..

 

I look into catalog/includes/modules/front_page/banner_rotator.php file and see this:

 

 

/*

$Id: banner_rotator.php v1.1.2 20110108 Kymation $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2010 osCommerce

 

Released under the GNU General Public License

*/

 

Please let me know if it help.

Thanks again Jim.

Edo.

Share this post


Link to post
Share on other sites

Hi again,

 

I asked to people who installed OSC2.31 to my. He said he installed the Modular Front Page.

Today I have reviewed and according to files installed in my server I beleive that it is Modular Front Page 1.2.6 version.

 

Thanks again.

Edo.

Share this post


Link to post
Share on other sites

That was actually a bug in the Modular Front Page code. It only happens when certain modules are installed, including the Theme Switcher module, so I didn't spot it in my testing. Thanks for reporting the bug. Please read this post for more information and to download the patched code.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi Jim, thanks a lot.

 

Excuse me but, last posted link to your server didnt work.

 

Edo.

Edited by elara

Share this post


Link to post
Share on other sites

Just installed this in my webshop, and it works fine exept one thing. The buttons for cart etc. disapear. How do I fix that?

Share this post


Link to post
Share on other sites

Just installed this in my webshop, and it works fine exept one thing. The buttons for cart etc. disapear. How do I fix that?

 

In this post you just said that you installed something else

Share this post


Link to post
Share on other sites

Haha sorry for the confusion. I am totaly lost. But any way, in the read me for the "jQuery theme" it says that I don't have to modify any files if I first install this add on.

But I am sure I´m still in the wrong topic... I just searched jQuery and found this topic, thought it might be linked to each other.

Share this post


Link to post
Share on other sites

Greets and big thank you to Jim and others in the community. Hopefully will have a chance to give back myself down the line.

 

Read through the thread and besides the toy guy who didn't post the fault itself I cannot see a answer for this issue. Is it because my admin folder is a different name? Only thing I can think of that is at all modified from stock install.

 

At the point of adding Themeswitcher it doesn't display only get this:

 

Fatal error: Cannot redeclare class ht_theme_switcher in /home/a9681070/public_html/includes/modules/header_tags/ht_theme_switcher.php on line 13

 

I have looked inside the file and re-replaced the 3 lines as was suggested above just incase but no joy. (They were the same anyways) I cannot see anything that points to the admin theme_switcher.php but since the module registers as being present but fails to load I guess this is a dead end as a fix.

 

This is a clean install of oscommerce 2.3.1 and Themeswitcher 1.3

 

Any pointers much appreciated. Thank you.

Edited by Severanth

Share this post


Link to post
Share on other sites

Incase it helps someone else. I must have placed one of the ht_theme_switcher.php files in the wrong place. As has been said several times on this thread make sure you upload the files to the right folders as per the instructions. Took me several failures before I succeeded.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×