Latest News: (loading..)
kymation

[Addon} Theme Switcher

699 posts in this topic

Hm, i just see that also the New products don't work, i can change themes, all works except new products and fancybox. I try to solve it since no one knows what to do, but i can't do it... All .js and .css files (when i check source) are conected well.....

 

Please can someone help....

Share this post


Link to post
Share on other sites

Error: 'jQuery' is undefined

 

I am getting the above error in

- IE7 <---- error box pops up

- FireFox6 <--- only see the error if I turn on Tools->Web Developer->Web Console

 

The code being pointed to is right at the end of these two files:

 

ext/jquery/fancybox/jquery.fancybox-1.3.4.pack.js

 

and

 

ext/jquery/bxGallery/jquery.bxGallery.1.1.min.js

 

<lots of code here deleted> (jQuery);

 

 

So, I commented this out

<lots of code here deleted>
//(jQuery)
;

 

And the error disappeared from both IE and FF. But commenting out code that looks like it should be there does not sound right????

 

 

But there is a 2nd errror that I can't remove:

 

IE7 Error:

Line: 56

Error: Object doesn't support this property or method

 

FF6 Error:

$("#piGal a[rel^=fancybox]").fancybox is not a function @ /product_info.php?products_id=xxxxxxxxx

 

Setup:

  • Vanilla oscommerce 2.3.1 installation - 24 hrs old (No customizations)
  • Upgraded jQuery UI to jquery-1.6.2.min.js and jquery-ui-1.8.16.min.js to match what ThemeRoller is handing out (used instructions here: http://multimixer.gr...-in-oscommerce/)

BTW - ThemeSwitcher

  • Successfully installed in admin
  • Correctly switches between loaded themes
  • The WWW pages come out looking OK ... but with IE7 .. I have to keep clicking 'No debug' on the Error box to see the pages.

Any ideas?

Share this post


Link to post
Share on other sites

That error would normally mean that jQuery is not being loaded. Did you check that jquery-1.6.2.min.js is where the code thinks it is? If it is, check that you have removed the correct lines in template_top.php. Having two jQuery declarations is as bad as having none.

 

Fancybox and bxGallery are jQuery plugins. Removing/commenting out the association with jQuery will break all sorts of things.

 

Regards

Jim

Edited by kymation

Share this post


Link to post
Share on other sites

Jim,

 

Thanks for the reply.

 

Here is the <head>

 

<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>My Title</title>  <---- edited for this post
<base href="http://mywebsite.com/" />		   <---- edited for this post


<script type="text/javascript" src="ext/jquery/bxGallery/jquery.bxGallery.1.1.min.js"></script>
<link rel="stylesheet" type="text/css" href="ext/jquery/fancybox/jquery.fancybox-1.3.4.css" />
<script type="text/javascript" src="ext/jquery/fancybox/jquery.fancybox-1.3.4.pack.js"></script>
<link rel="stylesheet" type="text/css" href="ext/960gs/960_24_col.css" />
<link rel="stylesheet" type="text/css" href="stylesheet.css" />
<script type="text/javascript" src="ext/jquery/jquery-1.6.2.min.js"></script>
<script type="text/javascript" src="ext/jquery/ui/jquery-ui-1.8.16.min.js"></script>
<link rel="stylesheet" type="text/css" href="ext/jquery/ui/redmond/jquery-ui-1.8.16.css" />
</head>

 

And I have confirmed that all the references are correct:

eg:

http://<mywebsite.com>/ext/jquery/bxGallery/jquery.bxGallery.1.1.min.js

exists.

 

Hmmmm. Stumped.

Share this post


Link to post
Share on other sites

Your Head code shows that Theme Switcher is doing what it is supposed to. I still can't duplicate this problem, so I'm just guessing at a possible solution. Just to check, please try moving these lines in template_top.php:

 

<script type="text/javascript" src="ext/jquery/bxGallery/jquery.bxGallery.1.1.min.js"></script>
<link rel="stylesheet" type="text/css" href="ext/jquery/fancybox/jquery.fancybox-1.3.4.css" />
<script type="text/javascript" src="ext/jquery/fancybox/jquery.fancybox-1.3.4.pack.js"></script>

to just below this line:

 

<?php echo $oscTemplate->getBlocks('header_tags'); ?>

Regards

Jim

Share this post


Link to post
Share on other sites

Well, that should not have worked, but it did. Interesting. Glad to hear you got it to work. I'll add this to the instructions for the new version.

 

If anybody is interested, I also fixed the Themeroller bookmarklet. The code for that will be in the new release as well. All I need is the time to get a release prepared. Maybe if I give up sleeping....

 

Regards

Jim

Share this post


Link to post
Share on other sites

Version 1.3 of Theme Switcher is now available from my server, and from the official site as soon as it gets approved.

 

This release contains the above bug fix, for those of you who were having problems with themes not working.

 

Of more general interest, it adds the working files for the Themeroller Developer's Tool. This allows you to develop a new theme using a WYSIWYG editor on your store, so you see exactly what your store will look like as you build the theme. I got tired of waiting for the jQuery team to fix the bug and fixed it myself. If you want just this new feature and already have Theme Switcher installed, you just need these four files:

catalog/developertool.js.php

catalog/developertool.php

catalog/images/fflogo.png

catalog/images/icon_bookmarklet_dragger.gif

The manual has been updated to reflect these changes.

 

Regards

Jim

Share this post


Link to post
Share on other sites

<p> </p>

<div style="font-family: 'Helvetica Neue', Arial, Verdana, sans-serif; font-size: 14px; color: rgb(34, 34, 34); background-color: rgb(255, 255, 255); ">

<p style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; ">Help<br />

I have done a clean install of OSC 2.3.1 and right after that i did a download and install of theme switcher. once i did that when i log into the admin its all in text form, not like the normal layout. So i go to the header tag section to install the theme switcher. when i click install i get these code errors. any help is greatly needed. just to cover the basic again this is a clean install not one thing has been modified before i installed theme switcher, i have double checked the location of every file and reloaded them. thanks in advance for any advice.<img alt="" src="http://masterworkspromotions.com/errorpage.jpg" /></p>

</div>

 

Share this post


Link to post
Share on other sites

i need a drink. the message i posted is not even showing the image i added. this is a conspiracy by the Obama administration. LOL

Edited by scheibel

Share this post


Link to post
Share on other sites

<snipped Microsoft outrage>

I have done a clean install of OSC 2.3.1 and right after that i did a download and install of theme switcher. once i did that when i log into the admin its all in text form, not like the normal layout. So i go to the header tag section to install the theme switcher. when i click install i get these code errors. any help is greatly needed. just to cover the basic again this is a clean install not one thing has been modified before i installed theme switcher, i have double checked the location of every file and reloaded them. thanks in advance for any advice.

The error message says that catalog/admin/includes/functions/modules/header_tags/theme_switcher.php is missing. Verify that it is really there. If you have renamed your Admin, that file needs to be in whatever you renamed your admin folder to. If you have not installed your osCommerce in the catalog folder, then change the path of all the files to wherever you have installed osC.

 

If none of that works, have you installed another language other than English?

 

In case you haven't noticed, HTML does not work in board posts.

 

Regards

Jim

Share this post


Link to post
Share on other sites

jim,

I think you may have give me the answer i did name the admin folder just because it ask you what to name it. i am going to try this now.

Thanks

Eric

Share this post


Link to post
Share on other sites

Hello,

I have a website, I downloaded Theme Switcher. I use Fliezilla and I cannot seem to find where to upload it at. I have used a Dolphin Engine many times with Filezilla but this is a whole new ball of wax. Can you please tell me where it goes? I got the catalog/ ect.... but how do you get there? I would appreciate any assistance. This is much different than my other websites I have built.

 

Thank you

LadyKs

www.witchesandwizardsemporium.com

Share this post


Link to post
Share on other sites

It goes wherever you have installed osCommerce. We use the catalog folder in the instructions because osCommerce is normally installed in a folder named catalog. Substitute the name of the folder where you installed osCommerce for the catalog in the instructions.

 

The URL you provided does not seem to be an osCommerce 2.3.1 store, so I can't give any more specific advice.

 

Regards

Jim

Share this post


Link to post
Share on other sites

Hi everybody,

 

please, any help will be welcome :-).

 

I have Oscommerce 2.31., and after installing Theme Switcher 1.3 and the corresponding Jquery and JQuery UI upgrade (1.4.2 ->1.6.2 and 1.8.6->1.8.16),

I started to have a problem with display of the admin menu. Now, graffics of menu and pulldown on the left collumm are lost and its texts seems to be in text mode and some of them are outside of the screen.

 

Thanks a lot.

Share this post


Link to post
Share on other sites

The Admin also depends on jQuery and the jQuery UI. Don't delete the old versions of those files or you'll mess up the Admin. As an alternative, there is an Admin Theme Switcher that allows you to change the theme on the Admin side and use the updated jQuery files.

 

Regards

Jim

Chrison likes this

Share this post


Link to post
Share on other sites

<p>Other simphom I just realized,</p>

<p> </p>

<p>Site display is slow using Chrome and Firefox and is incorrect using IE.</p>

<p>Using Chrome and Firefox many times Skype icon is lost.</p>

<p>Using IE the complete right columm appears in left side, above and mixed with the correct left columm. On the other hand the entire site is moved on the left side of the screen.</p>

<p> </p>

<p>Seems to be JQuery update is not working at all.<img alt=":&#39;(" class="bbc_emoticon" src="http://forums.oscommerce.com//public/style_emoticons/default/crying.gif" title=":&#39;(" /></p>

<p> </p>

<p>Thanks again,</p>

<p>Edo.</p>

<div> </div>

 

Share this post


Link to post
Share on other sites

It's likely that you got one of the Javascript files in the wrong place, or used the wrong file. Using View Page Source, check the files linked in the page head. Click on each one, one at a time, and see if you get the proper code. If you get a 404 message on any of those, that's where you made the error.

 

Regards

Jim

Share this post


Link to post
Share on other sites

Hi Jim,

 

thanks a lot for your help. Sorry If I do some trivial comment, I am absolutely beginner in PHP and OScommerce.

 

I didn´t delete any file. Let me give some new data about it.

 

1) For admin menu problem: I discovered that the admin page is running the old versions of Jquery and Jquery-UI, besides, this page is pointng to the new Redmond folder called now of course Redmond, that is update compatible. Then I renamed the new Redmond folder to Redmond.new and rename the original folder Redmond.orig to original folder name "Redmond" and wow, the problem was gone. Question now is: Where can I change this in order to the admin page run the new Jquery, Jquery-UI updates and the new Redmond folder content?.

 

2) IE, the complete right columm appears on the left: I saw that the admin page is running the new versions of Jquery and Jquery-UI,

 

<script type="text/javascript" src="ext/jquery/jquery-1.6.2.min.js"></script>

 

<script type="text/javascript" src="ext/jquery/ui/jquery-ui-1.8.16.min.js"></script>

<link rel="stylesheet" type="text/css" href="ext/jquery/ui/Redmont_Mod3/jquery-ui-1.8.16.css" />

 

I guess that Jquery and Jquery-UI new versions are IE9 incompatible, so, I guess that some exception or special intruction in code is missed.

 

 

Thanks a lot.

Share this post


Link to post
Share on other sites

1. The easiest way is to use the Admin Theme Switcher. If you don't want to do that, change the filenames in admin/includes/template_top.php to point to the new versions of jQuery, jQuery UI, and the Redmond theme stylesheet.

 

2. The problem seems to be with IE9. The code that pushes the left and right columns into place is pure CSS.

 

Regards

Jim

Edited by kymation

Share this post


Link to post
Share on other sites
Note: If you are starting with an unmodified copy of osCommerce 2.3, you can simply upload all

of the New and Modified files in the Catalog directory of this Distribution to your site, copying

over any existing files. You can now skip to the Configuration section of these instructions.

 

What do I do with V. 2.3.1?

Share this post


Link to post
Share on other sites

Do I really have to explain the version numbering system here? Seriously, the key word in that sentence is unmodified.

 

Regards

Jim

Share this post


Link to post
Share on other sites

Hi Jim again,

 

I went back with the instalation, but the problem still there. I put the original template_top file and original Jquery and Jquery UI files back in place but...., my site still on the left side of the screen when I use IE. I checked the index page with firefox and everything seems to be like before, but it dont work like before. I unistalled the Theme Switcher module but, it was the same, site dont display correctly in IE. I check other 2.31 OScommerce page iqual to mine and it works fine with IE.

 

Some idea??, Are there other changes that the Theme Switcher instalation did in me site? (not detailed in the instalation doc). What is that is mentioned about some automatic changes on the data base?

 

Thanks a lot for your help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now