Jump to content
kymation

[Addon} Theme Switcher

Recommended Posts

@@mdtaylorlrim

 

To be honest, I wouldn't use that version. It's quite outdated, and many people here on the forum are loathe to provide help with it even though it is the official release. The bootstrap version is far superior (http://forums.oscommerce.com/topic/396152-bootstrap-3-in-234-responsive-from-the-get-go/?p=1692204) and the next version of osCommerce (2.4 series) is based on this so addon upgrades will be much easier. It's all modular too, so installing addons is a breeze. If you aren't too far in you should reconsider.


Let's make things easier for new osCommerce users http://forums.oscommerce.com/topic/402638-discussion-about-hard-coded-database-tables/?p=1718900  Getting there with osCommerce 2.4! :thumbsup:

Share this post


Link to post
Share on other sites

@@mdtaylorlrim

 

I've been using osCommerce 2.3.4BS on my production site since January 24, 2015 (over 2 years) and had sales of several million dollars since then. It's installed on hundreds, if not thousands, of other production stores too. It's finished, tested and proven :)


Let's make things easier for new osCommerce users http://forums.oscommerce.com/topic/402638-discussion-about-hard-coded-database-tables/?p=1718900  Getting there with osCommerce 2.4! :thumbsup:

Share this post


Link to post
Share on other sites

@@mdtaylorlrim

 

According to the Github page, minimum requirement is PHP 5.3. Most hosts are on PHP 5.6 with some now moving to PHP 7.0.

 

I'm sure @@burt will chime in and let you know of any other requirements, but I haven't seen anybody who can run 2.3.4 unable to run 2.3.4BS


Let's make things easier for new osCommerce users http://forums.oscommerce.com/topic/402638-discussion-about-hard-coded-database-tables/?p=1718900  Getting there with osCommerce 2.4! :thumbsup:

Share this post


Link to post
Share on other sites

If you can run 2.3.4, you can run the Community Responsive.

 

I have been using a Responsive version of osCommerce since 2013!!

A number of my shopowner clients have been using similar since early 2014.

It was released into the wild on Github over 3 years ago.

 

Since then as Frank rightly says hundreds if not thousands of shopowners have tried it and/or are using it live.

Updates are made fairly regularly to stop the historical nonsense of osCommerce going years between updates.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

Is it normal to get "The jQuery file is missing" when Theme Switcher is first installed prior to updating anything else?

 

This didn't happen on the stock 2.3.4 install. But did on the BS-Edge version.

 

What needs to be fixed here?


Community Bootstrap Edition, Edge

 

Avoid the most asked question. See How to Secure My Site and How do I...?

Share this post


Link to post
Share on other sites

Now I am down to it complaining that the language file is missing. But...

 

/html/includes/languages/english/modules/header_tags/ht_theme_switcher.php is there. Is there another language file it is referring to?


Community Bootstrap Edition, Edge

 

Avoid the most asked question. See How to Secure My Site and How do I...?

Share this post


Link to post
Share on other sites

@@mdtaylorlrim 

The script checks for that file, so you won't be seeing a warning if it's actually there. Are you running a different language in your Admin? If so you need to copy that file over and translate it.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

No, this is a Bootsrap Edge installed this morning. This is the first add on to be installed. This is what I get:

 

Switch your store theme from the admin.

 
Module Version
1.5.3

Enable Theme Switcher
True

Sort Order
1

Theme
css


The selected theme was found.


template_top.php has not been modified!


The language file is missing!

Community Bootstrap Edition, Edge

 

Avoid the most asked question. See How to Secure My Site and How do I...?

Share this post


Link to post
Share on other sites

Ok, I did some troubleshooting and found that DIR_WS_LANGUAGES is not translated to /includes/languages/ so where does that happen?

 

 

The selected theme was found.


template_top.php has not been modified!


The language file is missing! /home/mdtaylorlrim/html/DIR_WS_LANGUAGESenglish/modules/header_tags/ht_theme_switcher.php


Community Bootstrap Edition, Edge

 

Avoid the most asked question. See How to Secure My Site and How do I...?

Share this post


Link to post
Share on other sites

I changed the code to DIR_WS_CATALOG_LANGUAGES and the error went away, but it still says template_top.php has not been modified.

 

I'm thinking I may not be using the right theme_switcher module? I'm using the one out of the Bootstrap directory.


Community Bootstrap Edition, Edge

 

Avoid the most asked question. See How to Secure My Site and How do I...?

Share this post


Link to post
Share on other sites

If you are using the latest Edge version, you will need to install the Compatibility Addon (or patch the missing constants by hand) to get most Addons to work. This one is no exception.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I am in the process of getting the Theme Switcher installed.

 

On page 14 of the Products Specifications User's Manual, item #13 it says

 

"You should now have a directory with the same name as the above file. Open that directory.

If you're using the copy provided in the Extras section, open the jquery-ui-1.9.2.custom
directory."
 
I did get the directory however there is no Extras section and I can't find the jquery-ui-1.9.2.custom directory.
Please see attached image.
 
Ideas please?
 
Thanks
Kelvin

post-343297-0-59907000-1492301486_thumb.png

Share this post


Link to post
Share on other sites

osCommerce supports jQueryUI version 1.10.x or older. Check that you did not download a newer version, as those will not work without modifying osCommerce.

 

It also helps if you tell me what version of osCommerce you are using. I hate guessing.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

osCommerce supports jQueryUI version 1.10.x or older. Check that you did not download a newer version, as those will not work without modifying osCommerce.

 

It also helps if you tell me what version of osCommerce you are using. I hate guessing.

 

Regards

Jim

 

Sorry Jim.

 

I am using osC Versions 2.3.4 and it is a fresh upload. jQueryUI version 1.10.4

 

Regards,

Kelvin

Share this post


Link to post
Share on other sites

If you're just starting with a fresh upload, dump it and install the Responsive version. You'll have a lot fewer problems with the themes. Unless you need some big Addon that hasn't been updated yet, it'll be a lot easier to build a store with the Responsive version.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Thank you Jim.

 

Yes it is a fresh store. I will try the version you suggested.

 

However, I will be looking to hopefully add a gallery addon if you can recommend one for the responsive version or the other up to date version of osC.

 

Kelvin

Share this post


Link to post
Share on other sites

There are a couple of gallery Addons for the old osCommerce 2.3.x, but both of them are pretty outdated. I think @@burt has a commercial offering for the Responsive version if you're willing to spend a few bucks.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
On 2/27/2017 at 8:16 PM, mdtaylorlrim said:

Got it. Thanks Although it is working without me changing the code back.

 

Whatever works I suppose.

Hey @mdtaylorlrim 

Hope your online store has been moving well. I saw the issue you were having and I think I'm experiencing the same thing you were, could you walk me through what you did in order to fix it? I'd really appreciate it :) 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×