Jump to content
kymation

[Addon} Theme Switcher

Recommended Posts

There's a new file on addons site, uploaded by @@beauty_Bar, versioned as theme_switcher_1.5.3_1 but it hasn't any differences to previous version theme_switcher_1.5.3 by @@kymation. Maybe an error?

Share this post


Link to post
Share on other sites

No, it's just more spam. The Addons area is nearly useless due to the amount of spam being added these days. I reported it, but I have little hope that anything will be done.

 

I've locked the Addon so I'm the only one who can update it. I'll go lock the rest of my Addons as soon as I can. It's a shame that I have to do this, but it now appears necessary.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Yeah, you better lock them that is what I do too. Otherwise you'll have people uploading all kinds of crap.

I wish they would give you more administrative features like edit dscription and title or maybe be able to delete packages that are not appropriate.

Share this post


Link to post
Share on other sites

We were promised an updated Addons area about 10 years ago, and several times since. I'm not holding my breath.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Instructions for creating and downloading themes are in the Theme Switcher manual, included in the download. The "design it on your store" feature is no longer supported by Themeroller. Unfortunately I can't edit that description to remove the obsolete part.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Trying to install Theme Switcher on a fresh install of OSC 2.3.4.

 

Been working on this since this past Sunday. I'm just not getting it.

I have the error, The theme CSS file is the wrong version or missing!

 

Checking the users manual in the troubleshooting section, 4.3 Theme Doesn't Show in Theme Switcher, I copied the themes to catalog/ext/jquery/ui

 

Went back to section 3.2,

 

The selected version of the theme was found. This tells you that the version of your theme
matches the version of your jQuery UI file. If you see The theme CSS file is the wrong
version or missing! instead, you probably updated the jQuery UI file without updating the
theme. Go check that again.

 

In the Theme Switcher package, there are two directories, Boostrap and OsCommerce 2.3.x. I used the files from the 2.3.x directory. The files in Boostrap, break things.

 

Not sure what I'm doing wrong.

 

TIA

Share this post


Link to post
Share on other sites

You didn't say which version of osCommerce you are running, but it sounds like a stock 2.3.x version. For that version, just follow the instructions in the manual. You will need to rename the JQueryUI file or the theme file so that they have the same version number. It doesn't really matter which number you use as long as they are the same. Then enter that number in the JQueryUI box in the Theme Switcher setup menu.

 

JQueryUI versions later than 10 are not supported by osCommerce. You would need to modify the code to use the new versions, or stick with an older version. I don't know if themes generated for the newer versions will work with the older code. You could try it and find out.

 

If you are just starting out, I suggest that you dump your install and replace it with the new Responsive build. The support is much better, and you have an upgrade path to the new version of osCommerce when it is released.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

You didn't say which version of osCommerce you are running, but it sounds like a stock 2.3.x version. For that version, just follow the instructions in the manual. You will need to rename the JQueryUI file or the theme file so that they have the same version number. It doesn't really matter which number you use as long as they are the same. Then enter that number in the JQueryUI box in the Theme Switcher setup menu.

 

JQueryUI versions later than 10 are not supported by osCommerce. You would need to modify the code to use the new versions, or stick with an older version. I don't know if themes generated for the newer versions will work with the older code. You could try it and find out.

 

If you are just starting out, I suggest that you dump your install and replace it with the new Responsive build. The support is much better, and you have an upgrade path to the new version of osCommerce when it is released.

 

Regards

Jim

 

 

Not sure if this is a reply to my post, but I am using the most current version of osCommerce (2.3.4) and the Theme Switcher released in July 2016. What is the Responsive build?

 

Been running rc2a for years. Time for a fresh look.

Share this post


Link to post
Share on other sites

@@edukes  Yes I was replying to you. osCommerce 2.3.4 is pretty old now, and the 2.4 release is supposed to happen fairly soon. If you really want the latest look and feel, go with one of the 2.3.4R (Bootstrap) releases until 2.4 is ready. Gold is the safest but lacks some of the cutting-edge features; edge is the latest but may be unstable. Your choice.

 

There are no version issues with Bootstrap themes like there are with JQueryUI themes.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

@@edukes  Yes I was replying to you. osCommerce 2.3.4 is pretty old now, and the 2.4 release is supposed to happen fairly soon. If you really want the latest look and feel, go with one of the 2.3.4R (Bootstrap) releases until 2.4 is ready. Gold is the safest but lacks some of the cutting-edge features; edge is the latest but may be unstable. Your choice.

 

There are no version issues with Bootstrap themes like there are with JQueryUI themes.

 

Regards

Jim

Thanks, Jim!

 

I'm just trying to stay of the game this time.

 

A few year back when my hosting company changed the version php, it took weeks to straighten out all those deprecated functions on a heavily modified shop. This time, I want to keep it simple.

 

When they change to php 5.4x, it will break my shop again. I have a Centos 7 VM with php 5.4 running here at the house on my server and testing opencart, but I don't really like it.

 

Thanks, again!!

Share this post


Link to post
Share on other sites

Hello, I'm encountering a strange problem with this addon. As soon as I move the

ht_theme_switcher.php

into

catalog\includes\modules\header_tags\

the right column disappears in the install modules menu and it won't show all modules.

 

https://s13.postimg.org/ic3tywvfb/image.png

https://s15.postimg.org/az6ojzb23/image.png

 

Edit: It's on a Ubuntu server with Apache 2.4.18.

Edited by itg16

Share this post


Link to post
Share on other sites

Seems like I can't edit my post anymore. The problem was the jquery version. Restored the original from the backup, column appears now.

Share this post


Link to post
Share on other sites

Hi there, im new to oscommerce, i downloaded the file and once extracted it created a Bootstrap folder. i used rsync to move catalog folder to the oscommerce catalog folder, then i installed the module.

 

Now all the themes change the background colour but its just a coloured page with no navigation or products etc.

Share this post


Link to post
Share on other sites

David: Go to the module install page in your Admin and click on Header Tags, then Theme Switcher. Are there any red warning messages in the right column?

 

REgards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

No all green ticks

 

I thought maybe the version was a problem so I updated to the latest osCommerce but issue didn't change so I rolled back to 2.3.3

 

Same thing , the background colour changes for the theme but it wipes all the pages functions so it's just blank

Share this post


Link to post
Share on other sites

A blank page usually means a PHP error. Check your error log for any recent errors.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

The current version of osCommerce does not have an error log, but version 2.4 will. For the current version you need to use your host's error log.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

There should be a PHP error log somewhere. It's often in the site root, but can be anywhere. If you have access to the php.ini file, or can create your own, the location of the error log is set there. You should also check whether the PHP log is enabled in the php.ini, and turn it on it if it's not.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Not Found

The requested URL /catalog/admin/HTTPS_SERVERDIR_WS_HTTPS_ADMINmodules.php was not found on this server.

Apache/2.2.31 (Debian) Server at 192.168.10.100 Port 7556

-- this is the error i get now,

after seeing i was in the old oscommerce 2.3.3 i updated 1 at a time testing the new module on each version eventually at 2.34 it displays the store again but the themes are incorrectly loaded, when i investigate the header tag it gives me this error

Share this post


Link to post
Share on other sites

You are missing the defines for HTTPS_SERVER and DIR_WS_HTTPS_ADMIN. These constants are defined in your /admin/includes.configure.php. The first one is in every version of osC back to 2.2; the second is a more recent addition. It appears that your configure file is corrupt.

 

You can try reinstalling the latest version, or you can patch the file by hand. The osCommerce package contains a blank file that you can use for comparison.You should use the 2.3.4 version or the Gold Responsive version, as the Edge version may be incomplete.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

How important or necessary is it to update jquery and jqueryui?

 

My ui is at 1.10.4

My jquery is at 1.11.1

 

 

The jquery site shows the current is at 3.1.1

 

This is a stock 2.3.4 with almost no add-ons yet. Adding a new Theme that I created presented no problems, but it is huge, comparatively. What options need to be check on the packager and what can we safely uncheck?

 

 

Mark


Community Bootstrap Edition, Edge

 

Avoid the most asked question. See How to Secure My Site and How do I...?

Share this post


Link to post
Share on other sites

@@mdtaylorlrim  Your theme needs to be based on the same version of jQuery as your store is using, or at least fairly close. Too much of a difference in versions may mean that certain functions don't work correctly. There is also no guarantee that newer versions of jQuery will work correctly with the remaining osCommerce code. Check thoroughly to be certain that everything is working.

 

The options that you need from the jQuery package depend on what osCommerce uses. The core osCommerce code uses only the most basic options, but some Addons use much more. Again, test to see if you've removed something essential, and only remove sections after you have all of your Addons installed.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×