Jump to content
kymation

[Addon} Theme Switcher

Recommended Posts

HI Jim,

 

As per ypur comment on my post in general I have re-uploaded the Blitzer theme thinking I may have done something wrong (http://www.raunchyrags.co.uk/shop/index.php). Having now uploaded the fresh blitzer I am getting the error that CSS error suggesting I have not updated the theme.

 

I am thinking this may be where I went wrong the first time. Sorry to be a pain but could you please advise from this step how to correct.

 

Hat is tipped on this great application before I see it in action as hoping it will be helping me much more.

 

Ricardo


Complete Newbie On The Learn - Not A Programmer

But Learning As I Go

Share this post


Link to post
Share on other sites

That means one of the following:

 

1. Your new theme is a different version than your jQueryUI. Check that the version numbers match.

 

2. You didn't rename the CSS file in your new theme to match what Theme Switcher is expecting. See the instructions for the correct naming procedure.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

That means one of the following:

 

1. Your new theme is a different version than your jQueryUI. Check that the version numbers match.

 

2. You didn't rename the CSS file in your new theme to match what Theme Switcher is expecting. See the instructions for the correct naming procedure.

 

Regards

Jim

Hi Jim,

 

Think this is what is baffling me.....I have downloaded the 1.10.4 version and renamed the css file and it is sat there jquery-ui-1.10.4.css?


Complete Newbie On The Learn - Not A Programmer

But Learning As I Go

Share this post


Link to post
Share on other sites

Did you upload the correct directory? The one that you want contains the jquery-ui-1.10.4.css file, and should be named blitzer.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Did you upload the correct directory? The one that you want contains the jquery-ui-1.10.4.css file, and should be named blitzer.

 

Regards

Jim

Yeah if I look in the UI directory I can see the Redmond & the Blitzer directories and open the Blitzer and there are 2 .css files jquery-ui-1.10.4 & jquery-ui-1.10.4.custom.

 

Sorry if I have missed something having a blonde week....lol


Complete Newbie On The Learn - Not A Programmer

But Learning As I Go

Share this post


Link to post
Share on other sites

You should only have the one CSS file, and that is the file that you should have renamed to jquery-ui-1.10.4.css. That is the one that Theme Switcher says it cannot find.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

You should only have the one CSS file, and that is the file that you should have renamed to jquery-ui-1.10.4.css. That is the one that Theme Switcher says it cannot find.

 

Regards

Jim

Thanks Jim I owe you one.......all working great


Complete Newbie On The Learn - Not A Programmer

But Learning As I Go

Share this post


Link to post
Share on other sites

Hello there

 

My problem is, after correct installing in the file ht_theme_switcher ( includes/modules/ header_tag/) I have to remove the following lines: 

$theme_text = '<script type="text/javascript" src="ext/jquery/jquery-' . $jquery_version . '.min.js"></script>' . PHP_EOL;
$theme_text .= '<script type="text/javascript" src="ext/jquery/ui/jquery-ui-' . $jquery_ui_version . '.min.js"></script>' . PHP_EOL;
$theme_text .= '<link rel="stylesheet" type="text/css" href="ext/jquery/ui/' . $theme_name . '/jquery-ui-' . $jquery_ui_version . '.min.css" />' . PHP_EOL;

 

to make the theme switcher working. When I leave them, the add pictures in the product page are all the same size, no small pictures. Fine, this works but when I try to change the theme, nothing happend. I made all the steps as per description. Where could be that mistake?

 

Thank you for helping 

Share this post


Link to post
Share on other sites

I've uploaded a new release that contains a Bootstrap version. This package contains both versions, so use the one that matches your installation of osCommerce.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Google is complaining about :

Eliminate render-blocking JavaScript and CSS in above-the-fold content

From this add-on - will soon effect page rank.

 

I don't agree with Google’s take - it is up to the browser when to load what - not the position on the page - but they are not likely to listen to me.

 


 


------------------------------------------------------------------------

The first panacea for a mismanaged nation is inflation

of the currency; the second is war. Both bring a
temporary prosperity; both bring permanent ruin.
Ernest Hemingway
------------------------------------------------------------------------

Share this post


Link to post
Share on other sites

It's not this addon. Stock osCommerce uses Javascript to render several things above the fold, so it would take a redesign to fix this. That's probably not going to happen. 

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I'm having issues with a stock install of oscommerce (v2.3.4) and the most current version of theme switcher. As soon as I install theme switcher I lose the images on my individual  product pages. 

 

I tested this on a brand new install to make sure it wasnt any of my other addons and I was able to recreate the problem by only installing theme switcher.

 

Any ideas? Thank you!

Share this post


Link to post
Share on other sites

Did you use the version of includes/template_top.php that comes with Theme Switcher or did you patch yours? Also make certain that you used the 2.3.x version of Theme Switcher and not the Bootstrap one.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Did you use the version of includes/template_top.php that comes with Theme Switcher or did you patch yours? Also make certain that you used the 2.3.x version of Theme Switcher and not the Bootstrap one.

 

Regards

Jim

Good morning Jim,

 

I used the version of includes/template_top.php that came with Theme Switcher and I did use the 2.3.x version, not the bootstrap version.  I have access to a different web host, tonight I will do a fresh install and see if by chance it has something to do with the Script software used to install oscommerce. 

 

I had initially thought it was due to JQUERY 1.10.4 vs 1.11.4 versions and what have you, but i never got far enough in the process for that to be the cause. Still digging.

 

Thank you for the prompt reply! 

Share this post


Link to post
Share on other sites

The latest version of Theme Switcher requires osCommerce 2.3.4. Older versions of osC used different scripts to manage the images on the Product pages, so you would see the problem you described with an older version. I suggest always using the latest version from the osCommerce downloads page.

 

If you need/want a responsive design, the Bootstrap version is your best choice.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

The latest version of Theme Switcher requires osCommerce 2.3.4. Older versions of osC used different scripts to manage the images on the Product pages, so you would see the problem you described with an older version. I suggest always using the latest version from the osCommerce downloads page.

 

If you need/want a responsive design, the Bootstrap version is your best choice.

 

Regards

Jim

 

I am using the latest version, but it was installed from my provider's script. I reckon ill just install it manually and see if that doesn't fix the problem.

 

Thank you!

Share this post


Link to post
Share on other sites

Hello!
Went trough the topic, and the issue I have the struggle with was mentioned, but I did not find the solution:

 

After installing theme switcher on oscommerce 2.3.4, works just great except for one bug: the picture on the 2.nd page disappears after half a second. (click the product, then a description + bigger picture appears, but the picture disappears in half a second.)

If I remove the theme switcher, the pictures and everything works fine...

I understand that I have to modify or patch the includes/template_top.php , but how, and where.

Please help!

 

P.S.: Also found a description where the solution would be to stop the jquery froom loading on the other pages except the first...but still no idea how to do it.

 

Thanl you in advance for your help!

AirWin

Share this post


Link to post
Share on other sites

There's a copy of the new includes/template_top.php included in the Theme Switcher package. Just use that if you haven't modified yours.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Thank you Jim, for your fast answer!

 

Unfortunately, I already tried replaceing the original template_top.php with the one included in the theme switcher from 7th March 2015.

 

No positive result... :(

 

If you happen to have any idea on the matter I would be grateful, and happy to try it.

 

If no solution, I think I should remove the theme switcher and adjust the outlook of the page "manually".

 

Best regards,

AirWin

Share this post


Link to post
Share on other sites

The next thing to do is to open View Source in Firefox. You will see a series of links near the top of the page. Click on each one of those in turn. If one or more returns a 404 Not Found message, check the file it's pointing to. That file may be missing or may have incorrect permissions set so the server cannot read it.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Indeed - found some missing files in directories that doesn't exist...:

 

The requested URL /ext/jquery/bxGallery/jquery.bxGallery.1.1.min.js was not found on this server.

The requested URL /ext/jquery/fancybox/jquery.fancybox-1.3.4.css was not found on this server.

The requested URL /ext/jquery/fancybox/jquery.fancybox-1.3.4.pack.js was not found on this server.

 

Downloaded jquery fancybox and jquery bxGallery and put them in the required folders...

 

Now, there are no more 404 errors because of not finding the files...unfortunately still disappearing.... :(

 

During the source code view, I found something else that could be it: (should it be "hidden"?)

 

Thanks for your time again!

All the best!

Share this post


Link to post
Share on other sites

Update:

The now "visible" used to be "hidden"

It did the trick, but only at the first glance, because now, if I click on the image won't open it in the viewer...

So one step closer... I assume the "hidden" is supposed to be hidden there, and not "visible" as I changed it..

 

<script type="text/javascript">
$(function() {
  $('#piGal').css({
    'visibility': 'visible'
  });

  $('#piGal').photosetGrid({
    layout: '<?php echo $photoset_layout; ?>',
    width: '250px',
    highresLinks: true,
    rel: 'pigallery',
    onComplete: function() {
      $('#piGal').css({ 'visibility': 'visible'});

      $('#piGal a').colorbox({
        maxHeight: '90%',
        maxWidth: '90%',
        rel: 'pigallery'
      });
 

Share this post


Link to post
Share on other sites

I could swear that this was fixed. Apparently not. Sigh. So find these lines in includes/template_top.php:

<script type="text/javascript" src="ext/jquery/bxGallery/jquery.bxGallery.1.1.min.js"></script>
<link rel="stylesheet" type="text/css" href="ext/jquery/fancybox/jquery.fancybox-1.3.4.css" />
<script type="text/javascript" src="ext/jquery/fancybox/jquery.fancybox-1.3.4.pack.js"></script>

and replace them with these:

<script type="text/javascript" src="ext/photoset-grid/jquery.photoset-grid.min.js"></script>
<link rel="stylesheet" type="text/css" href="ext/colorbox/colorbox.css" />
<script type="text/javascript" src="ext/colorbox/jquery.colorbox-min.js"></script>

That should fix all the problems. You'll need to revert the other changes you've made.

 

Thanks for reporting this. I'll go fix the distribution.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Yupee! Thanks a lot Jim! Fixed indeed! :)

I should've asked Your help sooner, not digging the internet for 2 days...

 

Thanks again! :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×