Jump to content
kymation

[Addon} Theme Switcher

Recommended Posts

Hi,

Tried to post earlier, but I guess I don't even know how to do this. It didn't show up.

I have been trying to get some add ons to work on a new V2.3.3 . So far so good, but theam switcher is giving me a bad time. I have loaded and unloaded the package and all upgrades three times. 8 good solid hours. All I have to show is I actually have theme switcher showing in Admin, but it is showing the infamous red error message that the CSS file is the wrong version but missing. To avoid lots of time, I have carefully followed the instructions and upgraded the Redmond theme and jquery files. This is version 1.4.2

My admin is showing jquery= 1.7.2 and the iu + 1.8.21

The EXT is showing 1.7.2 for admin, and 1.10.2 for the switcher

The ui is showing 1.8.21 for admin and 1.10.2 for the switcher

The jquery in Redmond has been renamed to jquery-ui-1.10.2.css

 

Any help other than read the instruction would be a help. I am sure I have them memorized. However, if any of the js files are improper, that is the result of my interpretation of the manual.

Any help from an expert would be a great help and met with appreciation.

Share this post


Link to post
Share on other sites

That error message says the CSS file in the (Redmond) theme is named incorrectly. I know you think you renamed it, but you did it wrong. If your jQuery UI version is 1.10.2, then that file needs to be named jquery-ui-1.10.2.css. Check it again.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Darn!!! I sure wish that was it... This is a copy & paste of it: jquery-ui-1.10.2.css. anything else I could try?

Share this post


Link to post
Share on other sites

Then I misunderstood your explanation of the problem. Which of the checks is really red? A screenshot of the Theme Switcher module page would help a lot.

 

Regards

Jim

Edited by kymation

See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

My Brain is so fried I think I am going to the cabin for the weekend and maybe work on this up there. attached is a screen shot.post-320670-0-19840000-1366467507_thumb.jpeg

Share this post


Link to post
Share on other sites

You have the jQuery UI version set to 1.8.21, so the theme file needs to be named jquery-ui-1.8.21.css

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

downloade jquery 1.9.1 from the link in the manual and saved it in my catalog/ext/jquery folder. My installation has version 1.8.0.

 

Theme switcher says I have version 1.7.2 when looking at the admin.

 

Where is it getting that from and any suggestion on how t fix it?

Share this post


Link to post
Share on other sites

@@spcalia That's covered in section 3.2 of the instructions.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Well,

Got back from the Cabin, changed the .CSS file name and the switcher shows all blocks filled with a green check. Now! Just one more idiotic question. How do I make it work. I expected some sort of a window to open that gave me a chance to change colors or something, but it justs sits there. I looked everywhere for some sort of a link or something, but no!! Do I have something else to download that isn't mentioned?

In case you didn't realize by now, this is the first addon that I ever attempted. It was easier to pay my host a few dollars to install add-ons or upgrades, but I fiqured if I am going to pretend to be webmaster for my site, the least I could do was learn about it's inner workings....

This site is still residing in a sub-folder (thank God) while I ineptly attempt to make it presentable.

any help would be greatly, greatly appreciated....

Share this post


Link to post
Share on other sites

Back to the User's Manual with you: read section 3.4.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi Jim,

 

I have found various of your contributions around the Forum and I appreciate your work so much, that I decided to register in the Forum just to tell you THANX!

 

I can't remember if I have installed some of them, currently I am installing the Theme Switcher 1.4.1 (I am in the middle of it and so far it looks ok), but nevertheless the outcome I am just glad that there are people like you. You make my day.

 

I figure since I can't contribute with coding, at least I can show you my gratitude.

 

s.t.

Share this post


Link to post
Share on other sites

I am trying to install this theme switcher and i am getting an error when i go to the INSTALL MODULE section.

 

Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' inD:\inetpub\vhosts\gcextreme.com\httpdocs\catalog\includes\modules\header_tags\ht_theme_switcher.php on line 15

 

 

Here is what is on line 15 in that page:

public $code = 'ht_theme_switcher';

 

not sure what i am doing wrong.

Share this post


Link to post
Share on other sites

Possibly you are running on a very old version of PHP?

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

How do i check to see what version my host server is on??

-----

Ok under my plesk i found 4.4.9 and 5.2.17

 

i changed it to the 5.2.17 and now the error is gone.

 

this is what i get when its installed:

Version: 1.4.2

 

 

Enable Theme Switcher

True

 

Sort Order

1

 

Jquery Version

1.7.2

 

Jquery UI Version

1.8.21

 

Theme

redmond

 

 

cross.gif The jQuery file is missing!

 

 

cross.gif The jQuery UI file is missing!

 

 

tick.gif The selected theme was found.

 

 

cross.gif The theme CSS file is the wrong version or missing!

 

 

tick.gif template_top.php has been modified.

 

 

tick.gif The language file was found.

Edited by gcextreme

Share this post


Link to post
Share on other sites

Read the User's Manual. Those errors are explained in Section 3.2.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Thanks...im slowly working my way thru it.

 

 

Also i have an email problem...it says an inquiry has already been submitted and must wait 15minutes....

Share this post


Link to post
Share on other sites

Please post questions that are not related to Theme Switcher in another thread. You can also search the forum; I believe your question has been answered several times.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I installed TS 1.3.1 on a Clean OSC 2.3.1 it works in the admin. I download a new redmond 1.10.3 read and installed step by step like the manual explain, but NO theme more in the shop!!! I read and read the manual again, did all step by step but the result in the shop is NO THEME.

I my other shops I changed it manually, I toughed this was a easier way, but no luck :(

Share this post


Link to post
Share on other sites

In the admin panel for Theme Switcher, are all of the green check marks showing?

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi Jim,

in version 1.3.1 their no green marks like in version 1.4 and It's not the fault of your addon because in this version I have the same problem when I changed it manually.

I did'n try version 1.4 on a OSC 2.3.3 because the addons I like to use are not compactible with that version.

 

I change the pics manually but that's not the way it should work.

 

grtz

Share this post


Link to post
Share on other sites

Remove your obsolete version of Theme Switcher and install version 1.4.2.

 

Every Addon that works with osC 2.3.1 will work with 2.3.3. In addition, 2.3.1 has security flaws that would need to be patched by hand.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I will try with a new OSC 2.3.3 and start step by step if everything that I need works, it's a hell of a job again.

 

Thx anyway

 

Kozak

Share this post


Link to post
Share on other sites

Dear Jim,

 

Sorry for my bad english. First of all I want to tell you a big "thank you" for the work you did. This addon ist great and helps me to improve design of my website.

 

Only one problem I get is when I edit it in admin panel I always get these errors:

 

Warning: Illegal string offset 'id' in /users/andy2050/www/catalog/includes/modules/header_tags/ht_theme_switcher.php on line 159

 

Warning: Illegal string offset 'id' in /users/andy2050/www/catalog/includes/modules/header_tags/ht_theme_switcher.php on line 186

 

Warning: Illegal string offset 'id' in /users/andy2050/www/catalog/includes/modules/header_tags/ht_theme_switcher.php on line 186

 

Warning: Illegal string offset 'id' in /users/andy2050/www/catalog/includes/modules/header_tags/ht_theme_switcher.php on line 159

 

Warning: Illegal string offset 'id' in /users/andy2050/www/catalog/includes/modules/header_tags/ht_theme_switcher.php on line 159

 

Warning: Illegal string offset 'id' in /users/andy2050/www/catalog/includes/modules/header_tags/ht_theme_switcher.php on line 186

 

Warning: Illegal string offset 'id' in /users/andy2050/www/catalog/includes/modules/header_tags/ht_theme_switcher.php on line 186

 

Warning: Illegal string offset 'id' in /users/andy2050/www/catalog/includes/modules/header_tags/ht_theme_switcher.php on line 186

 

Warning: Illegal string offset 'id' in /users/andy2050/www/catalog/includes/modules/header_tags/ht_theme_switcher.php on line 186

 

Warning: Illegal string offset 'id' in /users/andy2050/www/catalog/includes/modules/header_tags/ht_theme_switcher.php on line 159

 

Warning: Illegal string offset 'id' in /users/andy2050/www/catalog/includes/modules/header_tags/ht_theme_switcher.php on line 159

 

Warning: Illegal string offset 'id' in /users/andy2050/www/catalog/includes/modules/header_tags/ht_theme_switcher.php on line 186

 

Warning: Illegal string offset 'id' in /users/andy2050/www/catalog/includes/modules/header_tags/ht_theme_switcher.php on line 186

 

Warning: Illegal string offset 'id' in /users/andy2050/www/catalog/includes/modules/header_tags/ht_theme_switcher.php on line 186

 

Warning: Illegal string offset 'id' in /users/andy2050/www/catalog/includes/modules/header_tags/ht_theme_switcher.php on line 186

 

 

How do you think, what it is? Actually everything works and these errors confuse me a little bit.

 

Thank you for your answer!

Share this post


Link to post
Share on other sites

That's odd. Are you using Version 1.4.2 of Theme Switcher? What version of PHP are you using?

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×