Jump to content
kymation

[Addon} Theme Switcher

Recommended Posts

In

/public_html/osc/catalog/ext/jquery

jquery-1.8.0.min.js

jquery-1.9.1.min.js

 

Dont delete the old versions

 

In /home/klachman/public_html/bosc/catalog/ext/jquery/ui

jquery-ui-1.10.1.min.js

jquery-ui-1.8.22.min.js

 

Assuming you are using the latest versions. Rename the files to the version numbers, and use the above format.

 

And in the redmond directory below it the

jquery-ui.css -> jquery-ui-1.10.1.css

 

notice that is NOT jquery-ui.1.10.1.css

 

in these examples the versions will change with time

 

I had a devil of a time with the redmond theme file, that was fixed, by simply using another download of it. Themeroller may have a problematic server.

Share this post


Link to post
Share on other sites

However, the icons are image files, and you need some way to change the color of those. That's a bit more difficult task. I believe that it can be done, and can be done in Java if you so choose. It's going to take a lot of work though.

 

https://gist.github.com/westonruter/258215

 

This changes icons to greyscale, but with a bit of imagination other colors should be possible.

(i can deal with Perl, not Java! )

 

I have been absolutely amazed to see that nearly all theme and icon related stuff is the online garbage. Here today, gone tomorrow.

 

Irfanview has a neat batch mode (use advanced) that can be used for changing color schemes.

 

I can use Linux and gimp easily enough, but i am trying to pull something together to permit Windows users to more flexibly manipulate OSC.

 

One of my colleagues successfully managed to use Wordpress for a database driven ecommerce site, but claimed that the experience was such a nightmare that he could not begin to replicate it as a template.

Share this post


Link to post
Share on other sites

Not sure if I am following this right or not, dang meds... :wacko:

 

I recently downloaded a theme I created at the JQuery website, it loaded fine.

 

I didn't like the colors of some of the button icons so I edited the proper little icons in Photoshop (recently deleted Fireworks :( ).

I even created a few custom button colors.

 

Just my useless 2 cents. (w00t)


- :: Jim :: -

- My Toolbox ~ Adobe Web Bundle, XAMPP & WinMerge | Install ~ osC v2.3.3.4 -

Share this post


Link to post
Share on other sites

@@kelagedart This code is supposed to be a replacement for the Themeroller code, including the local Dev tool. It depends on a file from the Themeroller site that has been moved. Even with that correction I can't get it to work properly. Maybe you can figure out where the problem is.

 

@@jhande The icons can be recolored using Photoshop or GIMP, if you know how to use one of those. Most business owners would not want to invest the time to learn. Something simpler is needed.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

@@jhande The icons can be recolored using Photoshop or GIMP, if you know how to use one of those. Most business owners would not want to invest the time to learn. Something simpler is needed.

 

Regards

Jim

 

Got yah... :thumbsup:


- :: Jim :: -

- My Toolbox ~ Adobe Web Bundle, XAMPP & WinMerge | Install ~ osC v2.3.3.4 -

Share this post


Link to post
Share on other sites

Is this of any possible help:

https://gist.github.com/pmorch/1715924/download#

http://www.saltos.net/portal/en/detail/wiki/77/the-themeroller-in-saltos.htm

 

this is supposedly themeRoller Source, just 2 days old, and using 1.10.1 version:

https://github.com/jquery/download.jqueryui.com

 

I haven't the foggiest idea of what npm or grunt is or how to use it!

 

Oh, and found this:

 

https://github.com/harborhoffer/Super-Theme-Switcher

(Though it hasnt been updated in 4 months.....)

Share this post


Link to post
Share on other sites

The first link is a patch to the old Themeroller Dev tool, similar to what i provided in a previous version of Theme Switcher. It's dead now that the supporting files have been removed from the jQuery UI website.

 

The second looks like a nice start to a utility that might replace the original Themeroller (but not the dev tool). It's a bit incomplete at this stage.

 

I've tried to get the Themeroller source working. After a couple of hours resolving dependencies and decoding their incomplete documentation I gave up. I didn't know what npm or grunt were either, but I do now. Not that it helps much. It's probably not all that useful since the code seems to be trying to build a Wordpress module. Converting that to something that works with osCommerce would be quite a task.

 

The last one is a variant of the jQuery theme switcher. That's a Javascript module that allows the site's visitors to select a theme. Not all that useful for a store, in my opinion.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

. Not that it helps much. It's probably not all that useful since the code seems to be trying to build a Wordpress module. Converting that to something that works with osCommerce would be quite a task.

 

The last one is a variant of the jQuery theme switcher. That's a Javascript module that allows the site's visitors to select a theme. Not all that useful for a store, in my opinion.

 

 

Its a start . Right now I can start with something as simple as a theme switcher, and improvise from there.

Theme Switcher is great for that.

There are some themes/color schemes which are useless for book sellers, which can perhaps be replaced with modified forms made by tweaking the css, making the footer useful, and a few other additions/changes.

 

If this is what WordPress can do with ecommerce:

http://www.aj-scruffles.co.uk/

Then perhaps OSC, which is designed for ecommerce, can give it a run for its money.

I do see however, that there is virtually nothing about WP to OSC conversion, which makes anything related to it a daunting task.

A brief look at catalog.php of both sites is a bit unnerving.

 

Drupal would even be better than WP, but a quick look at my decently modified version using modules including their ecommerce modules, shows a hefty 50+ MB database size (without inventory) that would get sites shut down on many hosts.

 

I will post a link to the source code to my colleagues, 2 of whom are Java programmers. Perhaps one can unravel it, especially

as one seems good with mobile devices, where JQuery is probably abundant.

 

I just needed a place to start!

 

Many thanks :)

Share this post


Link to post
Share on other sites

This could be done on the server with PHP and ImageMagick. Grab a copy of a page from the site and use it as the template to build the theme on. Doing the same thing offline on a Windows box will be a lot more challenging.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hello,

 

Thank you for this grate code, making life easy.

lately i made some changes as i download new themes from the themeroller - http://jqueryui.com/themeroller/

every thing working fine something wrong with the PiGal div as you can see the difference in the two image i attached -

fine - http://you10.net/Shops/pigal-well.JPG

problem - http://you10.net/Shops/p.JPG

 

Thank you

Share this post


Link to post
Share on other sites

This is usually caused by installing a theme that is not compatible with your version of jQuery UI. Follow the instructions in the User's Manual to update your jQuery and jQuery UI files. You may need to update your bxGallery as well.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

sir, I copied the contents of theme Switch to my oscommerce 2.3.3 website . and from admin panel when I add theme switch I get following error. "1364 - Field 'configuration_value' doesn't have a default value

 

insert into configuration ( configuration_title, configuration_key, configuration_group_id, sort_order, use_function, set_function ) values ( 'Version: 1.4.2', 'MODULE_HEADER_TAGS_THEME_SWITCHER_VERSION', '6', '0', '', 'tep_cfg_do_nothing(' )

 

[TEP STOP]

Please let me know what is the mistake ?

Share this post


Link to post
Share on other sites

That's odd. What version of MySQL are you running?

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

MySQL 5.0? That has a large number of serious bugs. You need to update it to a newer version.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

That's going to be difficult since I can't see the problem. I can try, but no promises.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
You may need to update your bxGallery as well.

 

Regards

Jim

Hi, please advise where to get the updated bxGallery. I have jquery.bxGallery.1.1.min.js and it hangs image loading if there are more than 1 image attached to a product.

Share this post


Link to post
Share on other sites

Jim, sorry to post with a problem that should be easy, but I think I've read through this entire topic as well as the PDF, and just can't find the solution!.

 

Brand new installation of osCommerce, 2.3.3

Downloaded Theme Switcher 1.4.2 min

Copied ht_theme_switcher.php files into respective folders, and template_top.php into catalog/includes folders. Checked many times that the ht_theme_switcher.php files are not reversed.

 

When I go to the modules panel and select Header Tags, the 'Install Module' button shows 4 modules available, but when I click it, only three modules are listed -- Theme Switcher isn't there!

 

If I've missed something, I just can't find it...

Share this post


Link to post
Share on other sites

That usually means that you have put one of the files in the wrong place. If you have other languages installed, you'll need to copy the includes/languages/english/modules/header_tags/ht_theme_switcher.php to your other language(s) and translate the defines.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hello, I'm starting with installing the Theme Switcher, I use OSC version 2.3.3 and installing all te given instructions..when I go to the Admin page, to switch the theme, I see nothing wrong, but there changing nothing when I chose a installed theme

Switch your store theme from the admin.

Version: 1.4.2

 

 

Enable Theme Switcher

True

 

Sort Order

1

 

Jquery Version

1.8.0

 

Jquery UI Version

1.10.2

 

Theme

ui-darkness

 

 

tick.gifThe jQuery file was found.

 

 

tick.gifThe jQuery UI file was found.

 

 

tick.gifThe selected theme was found.

 

 

tick.gifThe selected version of the theme was found.

 

 

tick.giftemplate_top.php has been modified.

 

 

tick.gifThe language file was found. Where do I go wrong? Thnx for assisstance.

Share this post


Link to post
Share on other sites

Refresh the page using <ctrl> - F5, or navigate to a store page that you have not visited recently.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hello Jim, I have tried these, but nothing, I have again reading the manual, and go point to point and have make the jQuery items to 1.9.2, but nothing happens, even when I close the explorer browser and open a new..When I look in the bron code, there are loaded the right theme, that I put in the Admin:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" dir="ltr" lang="nl">

<head>

<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

<title>Tattoo Set - Get Naughty Party, store4more</title>

<base href="http://www.romastore.be/catalog/" />

<link rel="stylesheet" type="text/css" href="ext/960gs/960_24_col.css" />

<link rel="stylesheet" type="text/css" href="stylesheet.css" />

<script type="text/javascript" src="ext/jquery/jquery-1.9.2.min.js"></script>

<script type="text/javascript" src="ext/jquery/ui/jquery-ui-1.9.2.min.js"></script>

<link rel="stylesheet" type="text/css" href="ext/jquery/ui/lightness/jquery-ui-1.9.2.css" />

<link rel="canonical" href="http://www.romastore.be/catalog/product_info.php?products_id=1941" />

<script type="text/javascript">

// fix jQuery 1.8.0 and jQuery UI 1.8.22 bug with dialog buttons; http://bugs.jqueryui.com/ticket/8484

if ( $.attrFn ) { $.attrFn.text = true; }

</script>

<script type="text/javascript" src="ext/jquery/ui/i18n/jquery.ui.datepicker-nl.js"></script>

<script type="text/javascript">

$.datepicker.setDefaults($.datepicker.regional['nl']);

</script>

<script type="text/javascript" src="ext/jquery/bxGallery/jquery.bxGallery.1.1.min.js"></script>

<link rel="stylesheet" type="text/css" href="ext/jquery/fancybox/jquery.fancybox-1.3.4.css" />

<script type="text/javascript" src="ext/jquery/fancybox/jquery.fancybox-1.3.4.pack.js"></script>

</head>

<body> Thanks in Advance, Roger

Share this post


Link to post
Share on other sites

Most of the links in the head section of your pages return a 500 server error. This is probably a permissions issue. Please ask your host what permission settings are needed for their servers to make these files readable.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hello Jim,thnx for your advice, I have check your accomodations, and now its work! The only thing I have to fix, are the position of the theme, they going in to the logo on the pages. Best Regards.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×