Jump to content
kymation

[Addon} Theme Switcher

Recommended Posts

I installed this on 2.3.3 and it isn't working.

I followed the directions to the "t" ..

Everything is in the right place.

Does it work in 2.3.3 ?

Share this post


Link to post
Share on other sites

Yes it works on 2.3.3. Go through the instructions again. Are all of the module checks green?

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I'm sorry..not sure what you mean by module checks...

Maybe thats the problem. I went through the instructions again.

no module is added in the header tags.

The only thing that does happen is the "top" page on the website doesnt have any blue anymore.

How do I know if the module checks green?

Share this post


Link to post
Share on other sites

It's possible that the includes/template_top.php is messed up. The module checks for that are incomplete. Did you use the one from the Theme Switcher package or modify yours?

 

The other possibility is that you have an incompatible theme. Switch back to the Redmond theme that comes with osComemrce, and switch the jQuery and jQuery UI file version numberss back to the originals. Does the page look normal?

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

You really need to read the User's Manual. It explains all of this.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

catalog/includes/english/modules/header_tags/

 

this is where the file "ht_theme_switcher.php" was placed.

this is the right location?

Share this post


Link to post
Share on other sites

ok i found the redmond directory.. directions say, "Is the theme directory you uploaded there?

if not, upload it there." is the theme directory this file?? template_top.php

Share this post


Link to post
Share on other sites

The jquery file is missing

the jquery UI file is missing

the theme css file is the wrong version or missing..

 

How to fix this issue??

 

thanks

Share this post


Link to post
Share on other sites

Every question you have asked since my last post is covered in the User's Manual. You seem to think I have nothing better to do than to repeat all of that information here.

 

You're wrong.


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I've read the manual from top to bottom..No where does it say where to get the right jquery file. It just says put the right one in there.

Where do I get the right one?

Share this post


Link to post
Share on other sites

Every question you have asked since my last post is covered in the User's Manual. You seem to think I have nothing better to do than to repeat all of that information here.

 

The manual is simply wrong for newer versions such as 1.10.1

First its clear as mud about the .js files in the /js dir. There are *two* jquery-ui files

Share this post


Link to post
Share on other sites

Not letting me edit...

 

Every question you have asked since my last post is covered in the User's Manual. You seem to think I have nothing better to do than to repeat all of that information here.

 

The manual is simply wrong for newer versions such as 1.10.1

First its clear as mud about the .js files in the /js dir. There are *two* jquery-ui files.

 

jquery-ui-1.10.1.custom.js

jquery-ui-1.10.1.custom.min.js

 

 

its jquery-ui-1.10.1.custom.min.js

that must be renamed to

jquery-ui-1.10.1.min.js

 

And then...

In /development\bundle\themes\redmond

it is jquery.ui.theme

that must be renamed to

jquery-ui-1.10.1.css

 

However, the Catalogs pane has butted up against the graphic and wiped out the breadcrumb and its functionality in Redmond.Havent installed others yet.

 

Might have to go to the 1.8.23 themes from the link in an earlier post.

Using OSC 2.3.3

Share this post


Link to post
Share on other sites

The User's Manual is correct for the version of jQuery that it references. It is not correct for future versions. Sorry that my crystal ball was not working properly.

 

You are correct that jQuery now includes two UI Javascript files. Either one will work if renamed, but the jquery-ui-1.10.1.custom.min.js is preferred as it is smaller.

 

You're wrong about the theme file: it's the jquery-ui.css file, not the jquery.ui.theme.css. The latter is missing a number of elements.

 

The 10.x release of the jQuery UI is remarkably buggy. You can still download themes for the 1.9.1 version, but that's nearly as buggy. There is currently no good solution for custom themes.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I stand corrected about jquery-ui.css . I see that when checking again, but from a second copy of Redmond, that this file loaded fine in OSC. That file worked fine when renamed in all the other themes which I also installed. Perhaps a corrupted file in the first Redmond, as there was a definite file size difference in the zip file !

 

Lost about 5 hours on that one.

 

I am not a programmer, so please forgive if this is a dumb question:

Is there a way to modify these themes without that Theme Roller site?

Perhaps a local (not server) based app that handles jquery?

 

There are a couple of Rails JQury UIs on Github,

and on Sourceforge:

https://sourceforge.net/projects/jqueryuilesscss/files/latest/download?source=directory

 

Would any of these be helpful to create a new version of your developer tool, which was apparently sabotaged when the link was removed?

 

Let me explain where I am coming from.

I am a bookseller, and am trying to assist a colleague in developing an open source java cloud database that directly feeds an OSCommerce 2.3 site modified for booksellers (and likely any database driven collectible site) MUCH more elegant than EZpopulate or its recent fork.

 

I am trying to create a revised template which would include all the basic options to turn an OSCommerce site into a modern looking website, as the default setup is a bit antiquated for many users. (I myself am happy with it for my own OSC 2.2rc2a site).

But we are talking 2.3 here....

 

Your Theme Switcher is apparently the only addon I have been able to find that would give the site some flexibility at the admin panel. But I need something stable, and working. In fact as of now, other than a crushed Navbar, I have no clue as to what is not working in the new JQuery.

 

Can the 1.8.3 file be modified to act as a complete addon?

And if so, would you mind if I added it to the Sourceforge Project?

 

As far as modifications, wouldnt most be doable right from CSS?

Like changing the Top, Bottom, Left, Right format to something more like the CMS site structure using the 960 grid.

 

I have some colleagues who are Java programmers, but are not really familiar with OSC, so I guess the main question is CAN IT BE DONE, especially by just changing the CSS on the scripts. Whatever works with JQuery would simply be a bonus.

 

I just need to know that this awesome contribution and all the time invested in it, is not a dead end, and hopefully be a channel in gaining further assistance on the project.

Share this post


Link to post
Share on other sites

The local version of the Themeroller dev tool was dependent on code residing on the main jQuery website. That code has been removed, and I don't know of any location where you could get that code. If you can find it, that would provide a server-based solution to generating new themes. Anything else would have to be coded from scratch.

 

Themeroller modifies the CSS in the jquery-ui.css theme file. That you can do by hand, and it should not be too hard to build a tool that will do that in a fashion similar to the Themeroller tool. However, the icons are image files, and you need some way to change the color of those. That's a bit more difficult task. I believe that it can be done, and can be done in Java if you so choose. It's going to take a lot of work though.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi,

i am totally new to all this but somehow i have managed to install the switcher and having these errors in it...can you please help me with this but in very simple steps thanks.

 

 

Switch your store theme from the admin.

Version: 1.4.2

 

 

Enable Theme Switcher

True

 

Sort Order

1

 

Jquery Version

1.7.2

 

Jquery UI Version

1.8.21

 

Theme

redmond

 

 

The jQuery file is missing!

 

The jQuery UI file is missing!

 

 

The selected theme was found.

 

 

The theme CSS file is the wrong version or missing!

 

 

template_top.php has been modified.

 

 

The language file was found.

Edited by needi

Share this post


Link to post
Share on other sites

The User's Manual tells you how to fix these errors.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×