Jump to content
kymation

[Addon} Theme Switcher

Recommended Posts

The User's Manual for Theme Roller tells you to rename the files if they don't match the expected names. Unfortunately the jQuery team has not been consistent in the file naming, and we had to standardize on something.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

The min version is just a smaller file. The larger version has the same functionality and can be used in the place of the min version if necessary. There should be a min version of jQuery along soon, if you want to wait, or just replace your copy when it is released.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

small problem with the instructions on installation...

in the installation PDF that came with the addon there's a part that says:

12. Now go back to the main directory and open the directory named development-bundle
inside it.
13. Now open the directory named themes inside that.
14. You should now see two directories: One named base and one named redmond. Open the
redmond directory.
[b][color=#ff0000]15. Find the file named jquery-ui-###.custom.css. Change the name of that file to jquery-ui-
###.css. Again, that file may already be named jquery-ui-###.css, in which case you have
nothing to change.[/color][/b]

 

for the part in red when I go to the "development-bundle>themes>redmond directory there is NO file named "jquery-ui-###.custom.css"....there are a bunch of files but not the one mentioned...the closest there is in the directory is a file named "jquery-ui.css" but it has no version number...

there IS a file named "jquery-ui-###.custom.css" in the "js" directory though...could that possibly be the file?

Share this post


Link to post
Share on other sites

The jQuery team has changed their file naming again. This is annoying. The file that you want is jquery-ui.css in the redmond directory. The file in the js directory is the main jQuery UI file.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

is there an updated/easy install instructions??

i updated the jquery so all checks in admin are green but now when I try to apply the theme all my infoboxes /headers disappear...

is there any instructions that tell you exactly how to make the custom themes work instead of "to add theme revert to #11-#13 in the instructions in 3.3"?

it's kinda confusing...

 

to get the new theme I made working what do I do?

repeat the process from the instructions but use the new custom theme instead??

when I select my custom theme I get the red "missing css file" in admin...

Share this post


Link to post
Share on other sites

The instructions are correct. Follow them and your theme will work. No, there's no magic shortcut that will let you skip all of the work.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

no matter what I do I keep getting The theme CSS file is the wrong version or missing! in my admin...I looked in the redmond theme folder and there is a jquery-ui-1.8.22.css AND a jquery-ui-1.8.6.css file(s) and that theme works correctly...but in my theme folder there is only a jquery-ui-1.8.2.css file...do I have the numbers wrong? should it be 1.8.0, 1.8.6, 1.8.22 or 1.9.0??

and why is there 2 jquery-ui folders in the redmond theme folder and only one in my theme folder??

 

the name of the custom theme I made/downloaded from Theme Roller is "jquery-ui-1.9.0.custom"....should all my files have "1.9.0"?

which are the correct version numbers to go by/use?

Share this post


Link to post
Share on other sites

The correct version is the version number of the jQuery UI file. The current latest version is 1.9.0. Both your jQuery UI Javascript file and the CSS file in your theme should have this number. See the instructions (Section 3.3) on updating your jQuery files to the latest version. Do this before installing your custom theme.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

yeah I downloaded the redmond theme and updated it before anything....made the new theme, followed the instructions word for word but I can't get it to work.

 

to be clear-in my admin the jquery version and jquery-ui version should both be set to 1.9.0 when I install the new theme?

Share this post


Link to post
Share on other sites

got the theme to work but for some reason it's messing up an addon i have installed...

I have Product Tabs (http://addons.oscommerce.com/info/8536) installed and when the theme is installed & working when I click on an item on the front page the product-info page pulls the header/logo of the site down into the tabs & screws everything up...

any idea why this would happen>

something to do with javascript?

Share this post


Link to post
Share on other sites

That sounds like a bug in the Product Tabs code. I've never seen that happen before, so I can't say for sure. You should ask that question in the support thread for that Addon.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi im trying to install the Theme Switcher Module. I have downloaded the vesion which is avalible at this link http://addons.oscommerce.com/info/7663. Ive then added this to catalogue/includes/modules/headertags. However, when I log in to my oscommerce admin pannel the module is not there.

 

I have noticed that the file extension of the theme switcher module is tar.gz whereas all the other modules are php files. Does the Theme Switcher file need converting to php? If so how.

 

Also where are the instructions which it is said to come with. When I download from the link above all i get is the tar.gz file.

 

Sory for being a pain with all these questions any help would be appreciated.

Share this post


Link to post
Share on other sites

As with all Addons on this site, you need to open the archive that you downloaded and extract all of the files it contains. The instructions in this one are in the /Read Me/User's Manual.php file.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hey... Hmmm i can't find this file from the .zip file i download from jQuery site....

12. Now go back to the main directory and open the directory named development-bundle

inside it.

13. Now open the directory named themes inside that.

14. You should now see two directories: One named base and one named redmond. Open the

redmond directory.

15. Find the file named jquery-ui-###.custom.css. Change the name of that file to jquery-ui-

###.css. Again, that file may already be named jquery-ui-###.css, in which case you have

nothing to change..... There are not jquery-ui-###.custom.css in the folder development-bundle/redmond... Hope you can help me

Share this post


Link to post
Share on other sites

@@torgrima

You can install the files on your own server and use them there. I won't guarantee that they'll always be in the same place on my server. In any case, you misspelled the filename.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Thanks for quick reply, I might have misspelled the url in the post, sorry about that.

 

But is there any other thing that is wrong?

 

I have only dragged the Javascript from developertool.php as written.

 

And now I gets the error «404 Not Found nginx/1.2.3»

 

 

If I try to modify the Javascript code with my own url to the …catalog/developertool.js.php file, located in my store, it still generate the same error:

 

The original JavaSript:

javascript:(function(){if%20(!/Firefox[\/\s](\d+\.\d+)/.test(navigator.userAgent)){alert('Sorry,%20due%20to%20security%20restrictions,%20this%20tool%20only%20works%20in%20Firefox');%20return%20false;%20};%20if(window.jquitr){%20jquitr.addThemeRoller();%20}%20else{%20jquitr%20=%20{};%20jquitr.s%20=%20document.createElement('script');%20jquitr.s.src%20=%20'http://www.kymation.com/developertool.js.php';%20document.getElementsByTagName('head')[0].appendChild(jquitr.s);}%20})();

Share this post


Link to post
Share on other sites

The Themeroller bookmarklet relies on code hosted on the jQuery site. Apparently that code has been removed, and the jQuery team no longer supports the bookmarklet. Sorry, it's dead. I'll remove the code from the Addon once I get a chance.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

got the theme to work but for some reason it's messing up an addon i have installed...

I have Product Tabs (http://addons.oscommerce.com/info/8536) installed and when the theme is installed & working when I click on an item on the front page the product-info page pulls the header/logo of the site down into the tabs & screws everything up...

any idea why this would happen>

something to do with javascript?

 

Hi,

Had a javscript conflict before with super fish navagation bar solved with no conflict code.

 

script>

.noConflict();

$('#switcher').themeswitcher();

$(document).ready(function(){

("ul.sf-menu").supersubs({

minWidth: 12, // minimum width of sub-menus in em units

maxWidth: 27, // maximum width of sub-menus in em units

extraWidth: 1 // extra width can ensure lines don't sometimes turn over

// due to slight rounding differences and font-family

}).superfish(); // call supersubs first, then superfish, so that subs are

// not display:none when measuring. Call before initialising

// containing tabs for same reason.

});

 

</script>

 

Maybe something similar with the tabs contribution

Regard

john


To improve is to change; to be perfect is to change often.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×