Jump to content
kymation

[Addon} Modular SEO Header Tags

Recommended Posts

hi

 

i install the module... i have problems with greek language and i decide to uninstall.

 

after that i did NOT get the right header title on product page...

 

I want it back and i don^t know how...

Share this post


Link to post
Share on other sites

What version? If it's older than 2.3 then we know that is the problem.

 

Regards

Jim

 

Uhm, Thats a good question

 

ind my files, it says this at the top:

 

" $Id: english.php,v 1.106 2003/06/20 00:18:31 hpdl Exp $"

 

Though im not sure this is where they spicify the version of the OsC?

 

can it be fixed? i mean the SEO add On?

Share this post


Link to post
Share on other sites

Go to your store's Admin and click on Tools, then Version Checker.

It should say: Installed Version: osCommerce Online Merchant v2.3.1

 

If you don't have the version checker, go to Tools >> Server Info instead.

 

In any case, the file header that you posted has a date of 2003, and osCommerce 2.3 was released in 2010, so you're out of luck. You would have to upgrade to 2.3.1 for this to work.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Go to your store's Admin and click on Tools, then Version Checker.

It should say: Installed Version: osCommerce Online Merchant v2.3.1

 

If you don't have the version checker, go to Tools >> Server Info instead.

 

In any case, the file header that you posted has a date of 2003, and osCommerce 2.3 was released in 2010, so you're out of luck. You would have to upgrade to 2.3.1 for this to work.

 

Regards

Jim

 

it says: osCommerce 2.2-MS2

 

So it seems i need to opgrade. that i will try then :)

 

I'll be back! :)

 

- Jack

Share this post


Link to post
Share on other sites

Go to your store's Admin and click on Tools, then Version Checker.

It should say: Installed Version: osCommerce Online Merchant v2.3.1

 

If you don't have the version checker, go to Tools >> Server Info instead.

 

In any case, the file header that you posted has a date of 2003, and osCommerce 2.3 was released in 2010, so you're out of luck. You would have to upgrade to 2.3.1 for this to work.

 

Regards

Jim

 

Uhm, now i have a question.

 

When going to the updater under 2,2->2,3 i says

 

"This upgrade guide only provides the minimum required changes in the form of security updates and bug fixes. These changes will not upgrade your store to a complete v2.3 version. Please continue to use v2.2 add-ons and do not install v2.3 optimized add-ons as the may not function with your installation. If you wish to upgrade to a full v2.3 version, perform only (SQL) Database Changes and use the database with a new v2.3 installation."

 

 

So when i want to use this add on, then am i forced to start all over from scratch? (design wise, and picture wise?) or can i get by with the minimum required changes?

Share this post


Link to post
Share on other sites

The minimum required changes do not include the module code. You can't use any of the new modules without the module code. You need the full version 2.3.1 for this to work.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

hello, new problem, in to google web master tool, reports duplicate meta name and meta description for page product_new.php, specials.php, contact_us.php, create_account.php, ecc... using module (all page title string) not possible using different title for page?

and miss module form keyword, does not exist only google....many engines they use keyword ;)

Share this post


Link to post
Share on other sites

Notice there is a slight difference between my local host and live store. But am having no errors though, just trying to figure this out. When adding products, there is a text field called "Products Meta Description:" just below the "Products Description:". As the snap shot below shows, it's missing from my live store. I've used Beyond Compare to compare files on drives to files in the download. But am not seeing it. So am hoping you can lighten me some where I might find this piece of code. Am assuming it is located in admin/categories.php. Both live and local host is the same.

 

meta_tag.jpg

 

Believe this code below does refer to Products Meta Description:

 

<script type="text/javascript"><!--
updateGross();
//--></script>
<?php
   for ($i=0, $n=sizeof($languages); $i<$n; $i++) {
?>
         <tr>
           <td class="main" valign="top"><?php if ($i == 0) echo TEXT_PRODUCTS_DESCRIPTION; ?></td>
           <td><table border="0" cellspacing="0" cellpadding="0">
              <tr>
               <td class="main" valign="top"><?php echo tep_image(DIR_WS_CATALOG_LANGUAGES . $languages[$i]['directory'] . '/images/' . $languages[$i]['image'], $languages[$i]['name']); ?> </td>
               <td class="main"><?php echo tep_draw_textarea_field('products_description[' . $languages[$i]['id'] . ']', 'soft', '70', '15', (isset($products_description[$languages[$i]['id']]) ? stripslashes($products_description[$languages[$i]['id']]) : tep_get_products_description($pInfo->products_id, $languages[$i]['id']))); ?></td>
             </tr>
           </table></td>
         </tr>
<?php
   }

// Modular SEO Header Tags
 include( DIR_WS_MODULES . 'header_tags/products_insert.php' );   
?>

 

Even checked settings in admin of the two sites.

 

Thank you.

Share this post


Link to post
Share on other sites

The two lines of code before the last ?> are what produces the Products Meta Description. Check that the file includes/modules/header_tags/products_insert.php exists on your site. Also, check that the head_description field exists in your products_description database table.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Check that the file includes/modules/header_tags/products_insert.php exists on your site. Also, check that the head_description field exists in your products_description database table.

 

Regards

Jim

 

The file products_insets.php is there and so is the head_description. Even compared the files located at local host and my live store, both identical. Still Products Meta Description: is located on local host, but not live site.

 

Bennett

Share this post


Link to post
Share on other sites

The file products_insets.php is there and so is the head_description. Even compared the files located at local host and my live store, both identical. Still Products Meta Description: is located on local host, but not live site.

 

Bennett

Try to edit, but am not able to edit now. Looks like I might of compared wrong file. If after i clear cache and restart, Then i will recheck it. If issue still preexist, i will re-post. Thanks.

 

bennett

Share this post


Link to post
Share on other sites

Hi, I have installed this addon and it works well, is there a way to sort out the duplicate meta tags on the manufacturers listings.

 

Thanks

 

John


Driving Lorry £500.00 per week – Website design £0.00 per week – Website Sales £0.00 per week – Continuing to learn html & css Priceless

Share this post


Link to post
Share on other sites

Try to edit, but am not able to edit now. Looks like I might of compared wrong file. If after i clear cache and restart, Then i will recheck it. If issue still preexist, i will re-post. Thanks.

 

bennett

 

When checking categories/products in admin the Products Meta Description: is stationed below the Products Description: text field. But when I want to add a new product, the Products Meta Description: is missing.

 

Thanks.

Bennett

Share this post


Link to post
Share on other sites

When checking categories/products in admin the Products Meta Description: is stationed below the Products Description: text field. But when I want to add a new product, the Products Meta Description: is missing.

 

Thanks.

Bennett

 

Just noticed this. When I add a new product, the Products Meta Description: is missing. But when I go back to edit the new product, than the Products Meta Description: is present. So is this correct?

 

Bennett

Edited by blr044

Share this post


Link to post
Share on other sites

Hi, I have installed this addon and it works well, is there a way to sort out the duplicate meta tags on the manufacturers listings.

 

Thanks

 

John

You'll have to give me more information than that. What tags are duplicated, and by what modules?

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Just noticed this. When I add a new product, the Products Meta Description: is missing. But when I go back to edit the new product, than the Products Meta Description: is present. So is this correct?

 

Bennett

That could be a bug. Try this experiment: Comment out Line 17 and Line 133 of admin/includes/modules/header_tags/products_insert.php and see what happens.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

You'll have to give me more information than that. What tags are duplicated, and by what modules?

 

Regards

Jim

 

 

Hi Jim

 

I am using oscommerce v3.2.1

 

Modluar SEO Header Tags V1.4.2

 

The Manufacturers links are using the same meta tags as the front page, I have 12 manufacturers in a drop down menu (standerd oscommerce).

 

would like to know if it's possible to change title and discription for these pages.

 

Capture.jpg

 

Above are the modules installed and all work, no problems with them.

 

Thanks

 

John


Driving Lorry £500.00 per week – Website design £0.00 per week – Website Sales £0.00 per week – Continuing to learn html & css Priceless

Share this post


Link to post
Share on other sites

The front page title and description should only show on the front page. Are you saying they show on a Category page?

 

If the Manufacturer tags are showing at the same time as the Category tags, you may have found a bug. I'll need to do some testing. Which I don't have time for right now.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

The front page title and description should only show on the front page. Are you saying they show on a Category page?

 

If the Manufacturer tags are showing at the same time as the Category tags, you may have found a bug. I'll need to do some testing. Which I don't have time for right now.

 

Regards

Jim

 

Thanks Jim, I will have a look to see if I can fix this problem, was not sure if you new already, or it was something I had done wrong.

 

Thanks

 

John


Driving Lorry £500.00 per week – Website design £0.00 per week – Website Sales £0.00 per week – Continuing to learn html & css Priceless

Share this post


Link to post
Share on other sites

That could be a bug. Try this experiment: Comment out Line 17 and Line 133 of admin/includes/modules/header_tags/products_insert.php and see what happens.

 

Regards

Jim

 

Did comment out line 17 but there isn't line 133. So saved and did try it anyways to check for any error messages. Got an error message regarding to line 113 of that same file. So went back and commented out line 113 along with line 17. Error message no longer there, but now the Products Meta Description: is below the Products Description:.

 

Bennett

Share this post


Link to post
Share on other sites

Oops, that should have been Line 113. Glad to hear that worked. I'll code in a permanent fix.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Oops, that should have been Line 113. Glad to hear that worked. I'll code in a permanent fix.

 

Regards

Jim

 

Thank you.

 

Bennett

Share this post


Link to post
Share on other sites

Did comment out line 17 but there isn't line 133. So saved and did try it anyways to check for any error messages. Got an error message regarding to line 113 of that same file. So went back and commented out line 113 along with line 17. Error message no longer there, but now the Products Meta Description: is below the Products Description:.

 

Bennett

identical problem, what you writing to the 113?

my code:

echo $body_text;
     } // if( $action
   } // if( $head_title_field
 } // if( $products_id

?>

Share this post


Link to post
Share on other sites

This addon is designed to help you make your pages more attractive to search engines and customers. It allows you to have full control over your site's header title, meta description, and other meta tags. Installation uses the osCommerce 2.3.x module system for ease of installation with minimal edits to core files.

 

The code is here.

 

Regards

Jim

 

Hi Jim,

 

Great work! I found a small language bug in ht_products_title_category.php

$Id: ht_product_title_category.php v1.0 20101122 Kymation $

 

Change:

      	$categories_info_query_raw = "
       	select
         	cd.categories_name
       	from
         	" . TABLE_PRODUCTS_TO_CATEGORIES . " p2c
         	join " . TABLE_CATEGORIES_DESCRIPTION . " cd
           	on cd.categories_id = p2c.categories_id
       	where
         	p2c.products_id = '" . $products_id . "'
     	";

 

to:

      	$categories_info_query_raw = "
       	select
         	cd.categories_name
       	from
         	" . TABLE_PRODUCTS_TO_CATEGORIES . " p2c
         	join " . TABLE_CATEGORIES_DESCRIPTION . " cd
           	on cd.categories_id = p2c.categories_id
       	where
         	p2c.products_id = '" . $products_id . "' and cd.language_id = '" . $languages_id . "'
     	";

 

Now works fine.

 

Best regards,

Gergely


:blink:
osCommerce based shop owner with minimal design and focused on background works. When the less is more.
Email managment with tracking pixel, package managment for shipping, stock management, warehouse managment with bar code reader, parcel shops management on 3000 pickup points without local store.

Share this post


Link to post
Share on other sites

Thanks for the bug report. I fixed my master copy. I need to get a new release together, so I'll include your fix in that.

 

Thanks again for the code.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×