Jump to content
kymation

[Addon} Modular SEO Header Tags

Recommended Posts

In includes/application_top.php $language is set as follows:

    $language = $lng->language['directory'];

So that value should be the directory name. Apparently yours has been modified to do something else.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Those lines are unchanged in applic top.
 

    include(DIR_WS_CLASSES . 'language.php');
    $lng = new language();

    if (isset($HTTP_GET_VARS['language']) && tep_not_null($HTTP_GET_VARS['language'])) {
      $lng->set_language($HTTP_GET_VARS['language']);
    } else {
      $lng->get_browser_language();
    }

    $language = $lng->language['directory'];
    $languages_id = $lng->language['id'];
  }

The installation in admin is creating an entry using the language name of "SUOMI". (Glad I dumped the db contents in my earlier post or would think I was going mad)

 

I have copied over all the latest modules and after remove and re-install still get SUOMI.

 

If I install all pages title I get the correct key

 

MODULE_HEADER_TAGS_ALL_PAGES_TITLE_STRING_TEXT_FINNISH

 

For Front title I get

 

MODULE_HEADER_TAGS_FRONT_TITLE_TEXT_SUOMI

 

Am now off to compare those 2 and see if I can spot the difference.

 

Cheers

 

G


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

The constants are set up in the install() method of each module. The code that sets up the language array should look something like this:

      include_once( DIR_WS_CLASSES . 'language.php' );
      $bm_banner_language_class = new language;
      $languages = $bm_banner_language_class->catalog_languages;

      foreach( $languages as $this_language ) {
        $this->languages_array[$this_language['id']] = $this_language['directory'];
      }

Some early versions had errors in this code, so check that you are using version 1.4.5. If you find a module that still has an error in that code, please let me know which one and I'll fix it.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I am using 1.4.6 and have found problems in these 3

 

ht_product_title_string.php

ht_other_pages_title_string.php

ht_all_pages_title_string.php

 

The error messages are

 

Warning: constant() [function.constant]: Couldn't find constant MODULE_HEADER_TAGS_ALL_PAGES_TITLE_STRING_TEXT_ENGLISH in /home/mctyresc/public_html/xxxxx/includes/modules/header_tags/ht_all_pages_title_string.php on line 43

 

&

 

Fatal error: Cannot redeclare class language in /home/mctyresc/public_html/riekko.eu/includes/classes/language.php on line 16

 

Cheers

 

G[/b]

Edited by geoffreywalton

Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

The first error message tells me that you are using an old version of this addon. That error would occur on line 35 if you had the current version (1.4.5) of ht_all_pages_title_string.php. Please download and install the latest version.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Thanks, I downloaded it again and as you suspected, somehow I had not uploaded 1.4.6, don't know how I did that but mea culpa!!!

 

All the modules tried so far are working fine.

 

Cheers

 

G


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

The language bug that you saw was a pain because I could never duplicate it on any server I had access to. I was rally dreading having to open that can of worms again. I'm very glad to hear that it's working now.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

HI,

 

i´m installin Modular SEO Header Tags 1.4.6, it´s ok to meta description and meta keywords, but i does not know why in ever page does not show title tag,

 

i remove and install again, i check categories.php in admin folder,

 

Any ideia?

 

Thanks for this great contribuition, good week.


I did, helped or traslate.

http://addons.oscommerce.com/profile/104964

 

My english it´s só poor, but of you need help in portuguese, like shipping and payment that´s make a diference in brazil, come one,

Obrigado (thank´s)

 

Share this post


Link to post
Share on other sites

Which title module(s) are you using, and on which pages? Do you have a public site where I can look at this?

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Good night Jim, Thanks for help,

 

i´m trying do install

 

Product Title - Product Name

product title insert

 

and the same in categories and front page,

 

This is my store

 

www.loja3online.com.br

 

this is my admin page

 

http://tinyurl.com/np4uj9o

 

i tryed to install all title options but  does not work,

 

thanks again

@@kymation


I did, helped or traslate.

http://addons.oscommerce.com/profile/104964

 

My english it´s só poor, but of you need help in portuguese, like shipping and payment that´s make a diference in brazil, come one,

Obrigado (thank´s)

 

Share this post


Link to post
Share on other sites

It looks like you have some other header tags addon installed, perhaps as a part of your template. That could be interfering with this one. I can't see any other reason why this would not work.

 

Look in your includes/template_top.php -- are these lines there?

<?php echo $oscTemplate->getBlocks('header_tags'); ?>
</head>

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

hi,

 

yes i have and descriptions and keywords are showing in product info, categories and index page

 

<!-- begin header tags 12/10/2014-->

<meta name="author" content="7 days" />
<meta http-equiv="x-ua-compatible" content="IE=Edge,chrome=1" />
<meta name="description" content="Capa 100% impermeavel, de facil colocação, protege seu veículo do sol, chuva e poeira, no tamanho M" />

<meta name="keywords" content="Capa, forrada, tamanho, M, por R$, 85,11" />

<!-- end header tags -->

 

this code are in

 

http://www.loja3online.com.br/product_info.php/capa-carro-caminhonete-moto-capa-para-cobrir-carro-forrada-para-area-externa-sem-garagem-pode-ficar-no-sol-ou-na-chuva-tamanho-423967-p-119

 

thanks for help


I did, helped or traslate.

http://addons.oscommerce.com/profile/104964

 

My english it´s só poor, but of you need help in portuguese, like shipping and payment that´s make a diference in brazil, come one,

Obrigado (thank´s)

 

Share this post


Link to post
Share on other sites

Yes, but that code would not be at that location in a normal install. The line of PHP that I posted above is what outputs the header tabs, and that is just above the < /head > tag in a normal install. Also, the comments that show just before and after the header tags would not be there. This looks like the output of a different addon, or part of the template code.

 

Please post your template_top.php here.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi, Jim,

 

i change the php code to above </header> and this is my comment.

 

there is my template_top.php

<?php

//TEMPLATE TOP //

  $oscTemplate->buildBlocks();

 if (!$oscTemplate->hasBlocks('boxes_column_left')) {

    $oscTemplate->setGridContentWidth($oscTemplate->getGridContentWidth() + $oscTemplate->getGridColumnWidth());

  }

  if (!$oscTemplate->hasBlocks('boxes_column_right')) {

    $oscTemplate->setGridContentWidth($oscTemplate->getGridContentWidth() + $oscTemplate->getGridColumnWidth());

  }

?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" <?php echo HTML_PARAMS; ?>>



<head>


<!-- animated favicon -->
<link rel="shortcut icon" href="favicon.ico" >

      <link rel="icon" href="animated_favicon.gif" type="image/gif" >
<!-- Animatad favicon end -->      

<base href="<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_CATALOG; ?>" />

<!--
 _       _____       _       ___   _____   _____   __   _   _       _   __   _   _____  
| |     /  _  \     | |     /   | |___  | /  _  \ |  \ | | | |     | | |  \ | | | ____| 
| |     | | | |     | |    / /| |    _| | | | | | |   \| | | |     | | |   \| | | |__   
| |     | | | |  _  | |   / / | |   |_  { | | | | | |\   | | |     | | | |\   | |  __|  
| |___  | |_| | | |_| |  / /  | |  ___| | | |_| | | | \  | | |___  | | | | \  | | |___  
|_____| \_____/ \_____/ /_/   |_| |_____/ \_____/ |_|  \_| |_____| |_| |_|  \_| |_____| 
2005 - 2015
-->


<!-- CSS files -->

<link rel="stylesheet" type="text/css" href="ext/css/<?php echo ((stripos(HTML_PARAMS, 'dir="rtl"') !== false) ? 'rtl_' : ''); ?>mj-template.css" />

<link rel="stylesheet" type="text/css" href="ext/css/<?php echo ((stripos(HTML_PARAMS, 'dir="rtl"') !== false) ? 'rtl_' : ''); ?>mj_tabcontent.css" />

<link rel="stylesheet" type="text/css" href="ext/css/<?php echo ((stripos(HTML_PARAMS, 'dir="rtl"') !== false) ? 'rtl_' : ''); ?>template.css" />

<link rel="stylesheet" type="text/css" href="ext/css/<?php echo ((stripos(HTML_PARAMS, 'dir="rtl"') !== false) ? 'rtl_' : ''); ?>mj-tab.css" />

<link rel="stylesheet" type="text/css" href="ext/css/<?php echo ((stripos(HTML_PARAMS, 'dir="rtl"') !== false) ? 'rtl_' : ''); ?>bootstrap.css" />

<link rel="stylesheet" type="text/css" href="ext/css/<?php echo ((stripos(HTML_PARAMS, 'dir="rtl"') !== false) ? 'rtl_' : ''); ?>bootstrap-responsive.css" />

<link rel="stylesheet" type="text/css" href="ext/css/<?php echo ((stripos(HTML_PARAMS, 'dir="rtl"') !== false) ? 'rtl_' : ''); ?>mj-general.css" />

<link rel="stylesheet" type="text/css" href="ext/css/<?php echo ((stripos(HTML_PARAMS, 'dir="rtl"') !== false) ? 'rtl_' : ''); ?>mj-mobile.css" />

<link rel="stylesheet" type="text/css" href="ext/css/<?php echo ((stripos(HTML_PARAMS, 'dir="rtl"') !== false) ? 'rtl_' : ''); ?>mj-ie.css" />

<link rel="stylesheet" type="text/css" href="ext/css/<?php echo ((stripos(HTML_PARAMS, 'dir="rtl"') !== false) ? 'rtl_' : ''); ?>mj-layout.css" />

<link rel="stylesheet" type="text/css" href="ext/css/<?php echo ((stripos(HTML_PARAMS, 'dir="rtl"') !== false) ? 'rtl_' : ''); ?>flexslider.css" />

<link rel="stylesheet" type="text/css" href="ext/jquery/ui/redmond/jquery-ui-1.8.22.css" />

<link rel="stylesheet" type="text/css" href="ext/jquery/fancybox/jquery.fancybox-1.3.4.css" />

<!--<link href="ext/jquery/jpecrga/jpecrga-default.css" rel="stylesheet" type="text/css" /> -->

<?php

if((basename($PHP_SELF) == FILENAME_DEFAULT && $cPath == '') && !isset($_GET['manufacturers_id'])) { ?>

	<link rel="stylesheet" type="text/css" href="ext/css/<?php echo ((stripos(HTML_PARAMS, 'dir="rtl"') !== false) ? 'rtl_' : ''); ?>homepage.css" />

<?php }else

{ ?>

	<link rel="stylesheet" type="text/css" href="ext/css/<?php echo ((stripos(HTML_PARAMS, 'dir="rtl"') !== false) ? 'rtl_' : ''); ?>nohomepage.css" />

<?php } ?>  

<!--[if IE]>

<link rel="stylesheet" type="text/css" href="ext/css/<?php echo ((stripos(HTML_PARAMS, 'dir="rtl"') !== false) ? 'rtl_' : ''); ?>mj-ie8.css" />

<![endif]-->

<!-- CSS files ends -->

<!-- JS files -->

<script type="text/javascript" src="ext/jquery/jquery-1.8.0.min.js"></script>

<script type="text/javascript" src="ext/jquery/ui/jquery-ui-1.8.22.min.js"></script>

<script type="text/javascript" src="ext/jquery/css_browser_selector.js"></script>

<script type="text/javascript" src="ext/jquery/jquery.carouFredSel-6.0.4-packed.js"></script>

<!--<script type="text/javascript">             

// #WHATS THIS?  MARCELO 10/07/2014  

var jqqqnoconf=jQuery.noConflict();

// fix jQuery 1.8.0 and jQuery UI 1.8.22 bug with dialog buttons; http://bugs.jqueryui.com/ticket/8484

if ( jqqqnoconf.attrFn ) { jqqqnoconf.attrFn.text = true; }

 </script> -->


<?php

  if (tep_not_null(JQUERY_DATEPICKER_I18N_CODE)) {

?>

<script type="text/javascript" src="ext/jquery/ui/i18n/jquery.ui.datepicker-<?php echo JQUERY_DATEPICKER_I18N_CODE; ?>.js"></script>

<script type="text/javascript">

var jqnnndatre=jQuery.noConflict();

jqnnndatre.datepicker.setDefaults(jqnnndatre.datepicker.regional['<?php echo JQUERY_DATEPICKER_I18N_CODE; ?>']);

</script>

<?php

  }

?>

<script type="text/javascript" src="ext/jquery/bxGallery/jquery.bxGallery.1.1.min.js"></script>

<script type="text/javascript" src="ext/jquery/fancybox/jquery.fancybox-1.3.4.pack.js"></script>

<script type="text/javascript" src="ext/jquery/bootstrap.js"></script>

<script type="text/javascript" src="ext/jquery/jquery.flexslider.js"></script>

<script type="text/javascript" src="ext/jquery/osmart.js"></script>

<script type="text/javascript" src="ext/jquery/jpecrga/jpecrga-3.0.0.js"></script>

<script type="text/javascript" src="ext/jquery/tabcontent.js"></script>

<script type="text/javascript">

      var jjjcok=jQuery.noConflict();

		jjjcok(document).ready( function () {

                                        jjjcok.ws.jpecrga({

                                                gaKey: 'UA-22333772-9',

                                                geolocate: false,

                                                optMethod: 'optin',

                                                displaySettingsSelector: '.displayCookieSettings'

                                        });

                                });

        </script>

  <script type="text/javascript">

                  var _gaq = _gaq || [];

                  _gaq.push(['_setAccount', 'UA-22333772-9']);

                  _gaq.push(['_trackPageview']);

                  (function() {

                          var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;

                          ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';

                          var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);

                  })();

  </script>

<?php

if ($request_type == 'SSL') {

	?>


        <script type="text/javascript">

		var jqn=jQuery.noConflict();

		jqn(document).ready( function () {

                                        jqn.ws.jpecrga({

                                               gaKey: '<?php echo tep_output_string(MODULE_HEADER_TAGS_GOOGLE_ANALYTICS_ID); ?>',

						geolocate: false

					

                                        });

                                });

        </script> 

        <?php 

}else{

	?>

        <script type="text/javascript">

		var jqnd=jQuery.noConflict();

		jqnd(document).ready( function () {

                                        jqnd.ws.jpecrga({

                                                gaKey: '<?php echo tep_output_string(MODULE_HEADER_TAGS_GOOGLE_ANALYTICS_ID); ?>',

						geolocate: true

					

                                        });

                                });

        </script>

        

    <?php

}

	?>

<!-- JS files ends -->

<!-- Google Fonts -->

<link href='http://fonts.googleapis.com/css?family=Oswald' rel='stylesheet' type='text/css' />

<link href='http://fonts.googleapis.com/css?family=PT+Sans' rel='stylesheet' type='text/css' />

<!-- Google fonts ends -->

<?php require(DIR_WS_MODULES . 'top_bar.php'); ?>


<!-- begin header tags 12/10/2014 (this is my coment)--> 

<?php echo $oscTemplate->getBlocks('header_tags'); ?>

<!-- end header tags -->


</head>

<body> <!--body area starts -->

	<div id="mj-container"> <!-- mj-container -->

		<?php //require(DIR_WS_INCLUDES . 'header.php'); ?> <!-- inclusion of header file --> 
        <?php
// BOF: Store Mode
// Hide header.php if not to show
  if (((HEADER_OFF == 'false') && (strstr($PHP_SELF,MAINTENANCE_FILENAME))) || (!strstr($PHP_SELF,MAINTENANCE_FILENAME))) {
    require(DIR_WS_INCLUDES . 'header.php');
  }
// EOF: Store Mode
?>

		<div id="mj-maincontent"> <!-- mj-maincontent starts -->

			<div class="mj-subcontainer"> <!-- mj-subcontainer starts -->

				<div id="mj-contentarea" <?php if(($oscTemplate->hasBlocks('boxes_column_left') &&  basename($PHP_SELF) == FILENAME_PRODUCT_INFO) && ($oscTemplate->hasBlocks('boxes_column_right') &&  basename($PHP_SELF) == FILENAME_PRODUCT_INFO) ) { ?> class="mj-grid80 mj-lspace" style="right:0%; left:0%" <?php } elseif($boxes_column_left == true) { ?> class="mj-grid96 mj-lspace" style="right:17.5%" <?php } elseif($boxes_column_right == true) { ?> class="mj-grid64 mj-lspace" style="right:-1%" <?php }else { ?> class="mj-grid64 mj-lspace" <?php } ?>> <!-- mj-contentarea starts --> 

                

<!--<div id="bodyContent" class="grid_<?php echo $oscTemplate->getGridContentWidth(); ?> <?php echo ($oscTemplate->hasBlocks('boxes_column_left') ? 'push_' . $oscTemplate->getGridColumnWidth() : ''); ?>">-->


and my admin header tags configurations

http://easycaptures.com/fs/uploaded/936/2539366128.png

 

Thank you Jim.


I did, helped or traslate.

http://addons.oscommerce.com/profile/104964

 

My english it´s só poor, but of you need help in portuguese, like shipping and payment that´s make a diference in brazil, come one,

Obrigado (thank´s)

 

Share this post


Link to post
Share on other sites

That should work. Does the text box to enter the title show up in your Admin for all products? Do you have any products where you have entered a title?

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Yes, i have all products with title, description and keywords, i  tried to do a order and in all pages doesn't show title, example www.loja3online.com.br/contact_us.php,


I did, helped or traslate.

http://addons.oscommerce.com/profile/104964

 

My english it´s só poor, but of you need help in portuguese, like shipping and payment that´s make a diference in brazil, come one,

Obrigado (thank´s)

 

Share this post


Link to post
Share on other sites

The module that you have installed will show a title only on the product pages. You need to use other modules for the other pages. Please see the instructions.

 

Please take a screenshot of your Admin showing the Title tag entry on a product page and post it here.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I did, helped or traslate.

http://addons.oscommerce.com/profile/104964

 

My english it´s só poor, but of you need help in portuguese, like shipping and payment that´s make a diference in brazil, come one,

Obrigado (thank´s)

 

Share this post


Link to post
Share on other sites

That should be working. You must have some other change that is interfering with this module. Sorry, but that's all I can do in this forum.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi, thank´s Jim, i will make this changes again, i think i forget to do a small change, rsrs if you need translate your´s contribuitions you can call me, good night.


I did, helped or traslate.

http://addons.oscommerce.com/profile/104964

 

My english it´s só poor, but of you need help in portuguese, like shipping and payment that´s make a diference in brazil, come one,

Obrigado (thank´s)

 

Share this post


Link to post
Share on other sites

I did, helped or traslate.

http://addons.oscommerce.com/profile/104964

 

My english it´s só poor, but of you need help in portuguese, like shipping and payment that´s make a diference in brazil, come one,

Obrigado (thank´s)

 

Share this post


Link to post
Share on other sites

What version of osCommerce are you using?

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

osCommerce 2.3.3 and later have some changes that make the canonical module in this addon misbehave. i suggest that you use the canonical module that ships with your version of osCommerce, as it is designed to work with those changes.

 

The rest of the modules in this addon package should still work without any problems.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

if i insert new product, product meta description and meta keywords won't appear. but they appear if i edit a product.

I removed all modules, the meta description and keywords still appear when i edit a product.

 

does it happened previously with someone ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×