Jump to content
Latest News: (loading..)
kymation

[Addon} Modular Front Page

Recommended Posts

hi Jim @kymation

I’ve been through the error logs and it seems to be problem with the tep_customer_greeting definition. My error log: 

Quote

 PHP Fatal error:  Uncaught Error: Call to undefined function customer_greeting() in /Users/Desktop/LiveSiteBootstrap/catalog/includes/modules/content/front_page/templates/cm_fp_customer_greeting.php:13

Stack trace:

#0 /Users/Desktop/LiveSiteBootstrap/catalog/includes/modules/content/front_page/cm_fp_customer_greeting.php(40): include()

#1 /Users/Desktop/LiveSiteBootstrap/catalog/includes/classes/osc_template.php(146): cm_fp_customer_greeting->execute()

#2 /Users/Desktop/LiveSiteBootstrap/catalog/index.php(222): oscTemplate->getContent('front_page')

#3 {main}

  thrown in /Users/Desktop/LiveSiteBootstrap/catalog/includes/modules/content/front_page/templates/cm_fp_customer_greeting.php on line 13

With the line in question (line 13) having 

Quote

<?php echo tep_customer_greeting(); ?>

I’ve checked english.php for a customer greeting field but there wasn’t a definition for it,I then added one in but this still didn’t work and have since removed it. Furthermore I think it may have something to do with the cm_fp_customer_greeting.php file located in /catalog/includes/modules/content/front_page which when compared to the ‘customer_greeting.php’ file in /Users/Desktop/LiveSiteBootstrap/catalog/includes/modules/content/index is much more different ,in the sense that I think it may need to be re-written for bootstrap edge ? The reason I think this is because of the syntax looking a bit like the old syntax I’ve noted in the MFP index.php file which wouldn’t work with Edge. 

please do let me know what you think of my theory. I have since tried to ‘re-write’ it but to no avail.

Much appreciated Jim :)

 

Edited by mmotala10

Share this post


Link to post
Share on other sites

That error makes no sense. There is no call to customer_greeting() in that file. Further, the call to tep_customer_greeting() is on line 17, not line 13.

Are you using version 2.2.2 of Modular Front Page? And are you using the Responsive code from that version and not the stock 2.3.x code?

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
2 hours ago, kymation said:

That error makes no sense. There is no call to customer_greeting() in that file. Further, the call to tep_customer_greeting() is on line 17, not line 13.

Are you using version 2.2.2 of Modular Front Page? And are you using the Responsive code from that version and not the stock 2.3.x code?

Regards

Jim

@kymation do you mean theres no customer_greeting(); call or no tep_customer_greeting(); call ? as I didn’t mention any use of ‘customer_greeting();’ 

Also the reason line number 13 is showing is because I had just deleted a few blank lines in the file as I have multiple editor windows open so it makes it easier to view without white lines :) 

I am using version 2.2.2 as well as the responsive code section, NOT the 2.3.x code. I apologise if my previous explanation was a bit confusing. 

Share this post


Link to post
Share on other sites
7 hours ago, mmotala10 said:

PHP Fatal error:  Uncaught Error: Call to undefined function customer_greeting() in

I can only read what you've given me. I'm not psychic. If that's not the real error message, and I suspect it's not, then please in future use cut and paste to put the real error message in your post.

It appears that recent versions of EDGE do not contain the tep_customer_greeting() function. Please add this code to the bottom of catalog/includes/modules/content/front_page/templates/cm_fp_customer_greeting.php:

////
// Return a customer greeting
  function tep_customer_greeting() {
    global $customer_id, $customer_first_name;

    if (tep_session_is_registered('customer_first_name') && tep_session_is_registered('customer_id')) {
      $greeting_string = sprintf(TEXT_GREETING_PERSONAL, tep_output_string_protected($customer_first_name), tep_href_link(FILENAME_PRODUCTS_NEW));
    } else {
      $greeting_string = sprintf(TEXT_GREETING_GUEST, tep_href_link(FILENAME_LOGIN, '', 'SSL'), tep_href_link(FILENAME_CREATE_ACCOUNT, '', 'SSL'));
    }

    return $greeting_string;
  }

That should fix this problem. I have no idea how many more things have been removed that I depended on when this code was written, so you may find more things that don't work.

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Thanks a million @kymation . Works like a charm, you’re awesome !

Just a small note, in case anyone else ends up following this thread and requires the same/similar fixes, I made the changes Jim recommended to the cm_fp_customer_greeting.php in the following directory :   catalog/includes/modules/content/front_page/cm_fp_customer_greeting.php and not in the catalog/includes/modules/content/front_page/templates/cm_fp_customer_greeting.php. Was probably just a slight mix up.

 

Share this post


Link to post
Share on other sites

The code should be fine in either file, as long as it's in a PHP block. The critical issue is that it's available to use when the module is instantiated.

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

 

Hi All

I noticed that this thread also seems to be the help thread for the Banner Rotator Content Module for Modular Front Page (according to the installation documents). I've managed to successfully implement it in my test store, but was wondering if anyone might have some input as to how I can modify if such that the carousel banner stretches from one end of the screen to the other and the left and right columns will appear after/underneath it? 

this is what it looks like currently as per the attachment. The picture itself is small, so it doesn't highlight my point, however, I do have the content width set to maximum possible (12 in the admin options).  Does anyone have any info as to how I could get this to stretch all the way across the screen and then get the columns to appear after?

Any help would be greatly appreciated.

Thanks in advance!

 

 

Untitled2.png

Share this post


Link to post
Share on other sites

Only the Header and Footer Content modules fit the entire width of the page. I seem to recall a Content module for the Header that is similar to this one. If you can't find one, you can probably modify this one to work in the header, but it will take a bit of work.

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

@mmotala10 please see this image which might help to understand the layout.

Overall is 12 wide made of 2 - 8 - 2
Each of those three columns can be further split in 12s.


Thus by setting the content width to "12", you are setting it to full width of the 8 wide column.
Note that as you reduce the screen size, all three of these 2 - 8 -2 columns become 12 wide;  12 - 12 - 12 and drop below each other - so in small screens the slider would indeed be full width already.

 

As @kymation points out, the header and footer is usually always 12 wide, so to get a full width item in there...upload the slider module into the header content or footer content system and turn it on...

motala.jpg

 

Please excuse my elite photoshop skills.

Edited by burt

This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

Thanks as always @kymation and thank you so much as well @burt ,  those superb photoshop skills actually helped me understand the design perfectly well. I'll certainly try and load the slider in the header and report back on the outcome. Hopefully it'll also help anyone else who'd like to try the same :) 

Share this post


Link to post
Share on other sites

Hi

Can some one tell me how I can make the rotator banner (banner_rotator_content_module_v1.0.2) to show up on the first page of site?

I am using Responsive-osCommerce-2.3.4-GOLD.

But nothing shows up!

Many thanks in advance

Mitchell

Share this post


Link to post
Share on other sites

Did you assign any banners to the module? The module won't show up if there is nothing to show.

You can change the type of banner transition with the Easing setting in the module Admin.

All of this is covered in the instructions. Please go read them.

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi again,

 

1- Can someone PLEASE help me, why I am getting this error when I press any category;

 
1054 - Unknown column 'cd.categories_description' in 'field list'

select c.categories_image, cd.categories_name as catname, cd.categories_description as catdesc from categories c, categories_description cd where c.categories_id = '8' and c.categories_id = cd.categories_id and cd.language_id = '1'

[TEP STOP]
 
2- Is there any way I can move the Superfish Categories Box to the header top and make it a horizontal ldropbox menu?
 
3- I have installed the store logo through Admin/Config/Logo but it doesn't seem to uplaod, I even tried manual FTP upload, the file is there but no logo shows up!
 
Many thanks in advance
Mitchell
 
Edited by austcoll

Share this post


Link to post
Share on other sites

#1:  It looks like your database could be damaged. Use your host's database tool to look at the categories_description table. Does that table contain a field named categories_description? If it does, that SQL will probably need to be rewritten to meet modern standards.

#2:  I believe that there is a Superfish module for the header. Go take a look through the Addons section.

#3:  Look at the source of the page in your browser. What is the image filename and path for the logo. Is it correct?

Regards

Jim

PS: No, I didn't forget to close a bold tag. This editor is seriously broken. I'm really really hating this forum software.


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi all

I am using the latest version of responsive OSC v2.3.4.1,  Any idea where and how I can get a module that works with this version?

1- Rotating Front Page banner

2- Horizontal Dropdown Menus like Suprfish!

 

Many thanks in advance

Mitchell

 

 

 

Edited by austcoll

Share this post


Link to post
Share on other sites

Hi all,

 

Where do you actually change the colours etc, which CSS file I have to work on to change the colour of buttons and links etc!

I tried bootsrap.css but it is huge file!

Thanks

Share this post


Link to post
Share on other sites

Those colors are all set by the Bootstrap Theme. For information on the theme I suggest you read the instructions for the Bootstrap version of Theme Switcher. It's also a quick way to test out different themes.

Since this discussion has nothing to do with the Modular Front Page Addon, please ask any further questions in the general forum.

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Did you install any modules? The page is blank if there is nothing to show.

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Yes I did install some of the modules, but it is absolutely blank, not even a single word on it!

But this is for Gold version or for Edge as well?

Cheers

Mitchell

 

Edited by austcoll

Share this post


Link to post
Share on other sites

It was written for a version of Edge that is now about a year old, so it doesn't exactly match the current Edge.

Do you have the Compatibility Addon installed? If not, do that first. If you are still seeing a blank page, take a look at your PHP error log. A completely blank page is usually caused by an error that will show up in the log.

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi Kymation,

I just installed the front page featured products carousel add on: https://apps.oscommerce.com/m0JMb&featured-products-carousel-content-modul

I would be most grateful if you could point me in the right direction on the following, as I am stuck:

1. The carousel does not collapse when resizing the screen (viewing on different sized devices). Is it meant to? If so, any ideas why it would not be doing so (things I can check to see which might be contributing to it)? Note that the new products carousel, which I have also tested, does collapse: https://apps.oscommerce.com/KmAQo&category-new-products-carousel-bootstra So I am assuming that the featured products carousel should collapse.

2. Is there a simple way to create the rectangular thumbnail border around each of the products like which appears on the standard front page new products or front page featured products? I am thrown off because this carousel add on is structured differently with a "slides" class where it would normally be thumbnail class so not sure where I can make this change.

The front page add-ons are exceptional and I am grateful that you took the time to put these together for our benefit.

Peter 


Full-time I am the COO of a large retail company in Australia.

In my spare time (what little I have), I enjoy buying, selling, and trading ancient coins and antiquities as a hobby: http://www.ancientcointraders.com.

I am enjoying learning about web-design.

 

osCommerce responsive is the best version of osCommerce.

Download it here: https://github.com/gburton/Responsive-osCommerce

Please donate so the team can continue their work on that project: https://pledgie.com/campaigns/31724

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×