Jump to content
kymation

[Addon} Modular Front Page

Recommended Posts

It should work with PHP 5.3 or higher. Remember that PHP 5.3 is obsolete, not supported, and should be assumed to be unsafe to use.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Dear @kymation

 

I recently installed the module : featured_products_carousel_content_module_v1.0.4.

 

It works well but does not show the forward and backward arrows instead its show the text : "next" and "Previous" .

 

it seem its looking for th images : catalog/images/slideshow/prev4.png and catalog/images/slideshow/next4.png.

 

any clue? 

 
Best regards Valqui

I'm using oscommerce Edge v2.3.4.1

Get here the latest osCommerce Online Merchant Community Bootstrap Edition v2.3.4.1 CE

Share this post


Link to post
Share on other sites

I forgot to put the images in the package. I'm somewhat surprised that nobody has noticed this before. Anyway, you can get the images here. I'll add them to the package and upload a new version in a bit.

 

Thanks a lot for reporting this bug.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I've uploaded version 1.0.5 of the Featured Products Carousel Content Module. Hopefully I got it all right this time. Please post here if you find any more bugs.

 

Thanks to @@valquiria23 for reporting this bug.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Dear @kymation

 

Its worked very well, thank you very much.

 

When I visualize the featured products on a cell phone, depending on the length of the product description the buttons view / buy are not stay in one horizontal line.

 

Can it be fixed?

 

Best regards Valqui


I'm using oscommerce Edge v2.3.4.1

Get here the latest osCommerce Online Merchant Community Bootstrap Edition v2.3.4.1 CE

Share this post


Link to post
Share on other sites

Yes, that's due to the different lengths of the product names. I don't know of any way to fix that.

 

Install the Equal Heights header tag module if you haven't already. That will keep the rows from being distorted due to this issue.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

You might be able to set a min-height CSS on the product name/description. That could look a bit odd if all of the text is short. That's all I know.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Dear @@kymation

 

I just installed the modul.. everything's fine except that I cannot change the 'Easing' option.. the default is 'swing'... when I try to assign other option (jswing for instance).. after I saved the change.. the setting for 'Easing' still on 'swing'..

 

rgrds,

pit

Share this post


Link to post
Share on other sites

I don't know how you managed to do that. Check that you have installed all of the files and that they are in the proper location.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

For products that have attributes so that a customer knows there are attributes i implemented a piece of code to change the buttons from VIEW / BUY to MORE OPTIONS in products listing.

 

The code i have is:

	  $show_buy_query = tep_db_query("select count(*) as total from " . TABLE_PRODUCTS_OPTIONS . " popt, " . TABLE_PRODUCTS_ATTRIBUTES . " patrib where patrib.products_id='" . (int)$listing['products_id'] . "' and patrib.options_id = popt.products_options_id and popt.language_id = '" . (int)$languages_id . "'");
	  $show_buy = tep_db_fetch_array($show_buy_query);
	  if ($show_buy['total'] > 0) {
	    $prod_list_contents .= '       <div class="col-xs-6 text-right">' . tep_draw_button(IMAGE_BUTTON_SELECT_OPTIONS, null, tep_href_link(FILENAME_PRODUCT_INFO, ($cPath ? 'cPath=' . $cPath . '&' : '') . 'products_id=' . $listing['products_id']) , NULL, NULL, 'btn-sm btn-info') . '</div>';
	  } else {
        $prod_list_contents .= '       <div class="col-xs-6 text-right">' . tep_draw_button(IMAGE_BUTTON_BUY_NOW, 'fa fa-shopping-cart', tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('action')) . 'action=buy_now&products_id=' . $listing['products_id']), NULL, NULL, 'btn-success btn-sm') . '</div>';

From what i understand the query and IF and ELSE statement needs to be modified for this following code:

 

In /includes/modules/content/front_page/cm_fp_featured_products.php

        			$featured_products_content .= '        <div class="btn-group">';
        			$featured_products_content .= '          <a href="' . tep_href_link('product_info.php', tep_get_all_get_params(array('action')) . 'products_id=' . $products_data['products_id']) . '" class="btn btn-default" role="button">' . SMALL_IMAGE_BUTTON_VIEW . '</a>';
        			$featured_products_content .= '          <a href="' . tep_href_link($PHP_SELF, tep_get_all_get_params(array('action')) . 'action=buy_now&products_id=' . $products_data['products_id']) . '" class="btn btn-success" role="button">' . SMALL_IMAGE_BUTTON_BUY . '</a>';
        			$featured_products_content .= '        </div>';

Could someone please help me with the query and the IF ELSE statement to change the buttons to MORE OPTIONS from VIEW / BUY

Share this post


Link to post
Share on other sites

If you want to change the Buy button to a More Options button, use something like:

If( tep_has_product_attributes( $products_id ) ) {
  //Show the More Options button
} else {
  // Show the Buy button
}

Regrds

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I did this:

If( tep_has_product_attributes( $products_id ) ) {
        			$featured_products_content .= '        <div class="btn-group">';
        			$featured_products_content .= '          <a href="' . tep_href_link('product_info.php', tep_get_all_get_params(array('action')) . 'products_id=' . $products_data['products_id']) . '" class="btn btn-default" role="button">' . SMALL_IMAGE_BUTTON_VIEW . '</a>';
        			$featured_products_content .= '        </div>';
} else {
        			$featured_products_content .= '        <div class="btn-group">';
        			$featured_products_content .= '          <a href="' . tep_href_link('product_info.php', tep_get_all_get_params(array('action')) . 'products_id=' . $products_data['products_id']) . '" class="btn btn-default" role="button">' . SMALL_IMAGE_BUTTON_VIEW . '</a>';
        			$featured_products_content .= '          <a href="' . tep_href_link($PHP_SELF, tep_get_all_get_params(array('action')) . 'action=buy_now&products_id=' . $products_data['products_id']) . '" class="btn btn-success" role="button">' . SMALL_IMAGE_BUTTON_BUY . '</a>';
        			$featured_products_content .= '        </div>';
}

It didn't work. Am i placing it in the wrong place?

Share this post


Link to post
Share on other sites

I've just upload a new module.

Banner Rotator in Header and/or Footer (http://addons.oscommerce.com/info/9500)

 

A simple adaptation of that great addon made by @@kymation

I have it working on a 234 BS Gold. Not tested on Edge version...

 

If you want to have a look at it:

www.impactarjetas.com

www.tiendingtopics.com
 
Note: @@valquiria23, translations into spanish included... ;-)

Shopowner, not coder, experienced copypaster  :D

Share this post


Link to post
Share on other sites

Dear @@kymation

 

I just installed the modul.. everything's fine except that I cannot change the 'Easing' option.. the default is 'swing'... when I try to assign other option (jswing for instance).. after I saved the change.. the setting for 'Easing' still on 'swing'..

 

rgrds,

pit

 

 

I don't know how you managed to do that. Check that you have installed all of the files and that they are in the proper location.

 

Regards

Jim

 

An excellent addon from kymation ( as always ), but i am facing the exact same problem. All settings of the banner rotator are working with the exception of "easing" which always stays on "swing" effect.

 

I would appreciate any suggestions...

Share this post


Link to post
Share on other sites

I can't help unless I can duplicate the problem, which I have so far been unable to do. Maybe if you give me your version of osCommerce and PHP I can figure something out.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I can't help unless I can duplicate the problem, which I have so far been unable to do. Maybe if you give me your version of osCommerce and PHP I can figure something out.

 

Regards

Jim

I understand the difficulty.

 

I am using the bootstrap gold version in a local installation via Xampp and my php is 7.0.1 as i can see. So far i ve tried twice the installation of the module, but with the same results.

Share this post


Link to post
Share on other sites

I have never tested this module in PHP 7.0 so I can't guarantee it will work. I believe that most of the available Addons will not work in PHP 7. I'm not sure if the latest Edge version has been fully updated, but I am certain that Gold and stock 2.3.4 will not work. 

 

I suggest that you back down to PHP 5.6. That's still supported for another two years, and most hosting services will continue to offer it for at least that long. Once osCommerce 2.4 is released, and enough Addons have been updated to work with it, then you can safely go to PHP 7.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Thank you for your response.
 
My problem is that a friend ( and a client ) of mine, insists on PHP 7, so i am trying to setup a shop on this version.
 
I believe you are wright about the incompatibility, cause i couldnt also find any other reason for this behavior, pluw ive tried another addon, also from you which seems to have problems. Its the Options with images which gives me the following error

 

1054 - Unknown column 'sort_order' in 'field list'

update products_attributes set products_id = '1', options_id = '4', options_values_id = '1', options_values_price = '0', price_prefix = '+', sort_order = '' where products_attributes_id = '1'

[TEP STOP]

 

 

and also a double show of the products attributes.

 

Anyway, thank you for your time and help.

Share this post


Link to post
Share on other sites

Tell your friend that his choice of PHP 7 is going to mean a lot of expensive custom code to get his store the way he wants.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi, i have a problem whit banner rotator, the addon show only images saved on server but not show images from html code or java script like adssense.

Any ideas?

Regards


No external links here, thank you

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×