Jump to content
kymation

[Addon} Modular Front Page

Recommended Posts

HI I need to know if its possible to not show price if (0 $)

 

I can't answer your other question (about categories), but you might want to take a look at the Email For Quote add-on as it's a rather elegant solution to handling products with a $0 price. When the user clicks on the link, they're presented with a mailto dialog to e-mail the store owner for a quotation for the product. As far as I can tell, this add-on works with the Modular Front Page add-on, or at least it does for my site.

 

Hope that helps....

 

Regards,

 

Chris

Share this post


Link to post
Share on other sites

Thanks

I can't answer your other question (about categories), but you might want to take a look at the Email For Quote add-on as it's a rather elegant solution to handling products with a $0 price. When the user clicks on the link, they're presented with a mailto dialog to e-mail the store owner for a quotation for the product. As far as I can tell, this add-on works with the Modular Front Page add-on, or at least it does for my site.

 

Hope that helps....

 

Regards,

 

Chris

Thanks Chris

Share this post


Link to post
Share on other sites

@@kymation

 

Hi Jim

 

Quick question about featured products and scroller, both work fine, but are very unresponsive when changing thro admin so I get around the issue by changing the products required in configuration table.

 

Could this be something to with the fact that I have more than 30000 products so the drop down boxes are taking a lot of time to populate ?

 

Regards

 

Ken


Os-commerce v2.3.3

Security Pro v11

Site Monitor

IP Trap

htaccess Protection

Bad Behaviour Block

Year Make Model

Document Manager

X Sell

Star Product

Modular Front Page

Modular Header Tags

Share this post


Link to post
Share on other sites

Yes, the pulldown menus have to pull all products from the database every time they load. I should probably make that happen only once, store the data in an array, and then fill all the pulldown menus from the array. Large stores like yours often need some optimizing to keep things responsive.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi Jim

 

No worries, thanks for the confirmation.

 

I do optimize the database quite frequently, but am on a shared server, so don't know how much others are interfering or how much is actually my site slowing down the server.

 

sooner or later will have to upgrade as we've only added about 5% of the products we want to

 

regards

 

Ken


Os-commerce v2.3.3

Security Pro v11

Site Monitor

IP Trap

htaccess Protection

Bad Behaviour Block

Year Make Model

Document Manager

X Sell

Star Product

Modular Front Page

Modular Header Tags

Share this post


Link to post
Share on other sites

I run a store that sells a lot of one-off items. Because of this, we'd like to put a "sold out stamp" on the photos of items that have sold. Is there a way to determine if an item's quantity is zero in the Featured, New Products, or Specials?

 

EDIT: Never mind. I figured it out. Had to add "p.products_quantity," to the query. Naturally I figure this out seconds after posting this.

Edited by B!!!

Share this post


Link to post
Share on other sites

@B!!!

 

All of those modules are written to determine stock control. Stock control is configured from the admin area. As for as the 'Sold Out' stamp, you would have to custom code that image.

 

 

 

Chris


:|: Was this post helpful ? Click the LIKE THIS button :|:

 

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

Share this post


Link to post
Share on other sites

All of those modules are written to determine stock control. Stock control is configured from the admin area. As for as the 'Sold Out' stamp, you would have to custom code that image.

 

I got the custom coding for the image done, but couldn't figure out how determine when it should appear. All I really needed was an "if" statement but couldn't figure out the variable to test with. In the end I used this:

 

if($specials_products['products_quantity'] == 0

 

But I had to add "p.products_quantity," to the query. If there is a better or more efficient way, please let me know. I tried to keep things as vanilla as possible, but this works quite well.

Share this post


Link to post
Share on other sites

Good morning Jim,

it is possible to use the product scroller to place between the header image and the breadcrump, I have an image attached to an arrow so you can see where I scroller would like to have. Is this possible?

 

Waiting for your response,

 

hotgrips.jpg

Share this post


Link to post
Share on other sites

Jim, first of all wanted to thank you for this wonderful module. Has made my life a whole lot easier with the ability to make a custom homepage. What i was looking to find out is it possible to setup a banner like the attachment...

 

I am currently in the process of setting this up and have made the following changes to the files, but just wanted to make sure I am taking the right steps and not over complicated things for myself.

 

catalog\includes\modules\front_page\banner_rotator.php (changes)

 

added the following divs to line 60

 

	  $body_text .= '  <div id="container"><div id="wrapper"><div id="bannerRotator">' . PHP_EOL;

 

and the additions to the css file (banner_rotator\stylesheet.css)

 

#container {
margin:0;
height: 500px;
width:950px;
   overflow: hidden; /* clear the float */
}
#wrapper {
margin:0;
height: 262px;
width:950px;
   overflow: hidden; /* clear the float */
background:#dcdedc;
}

 

This has now given me the grey background and also managed to add banner1, but now I am stuck not sure how I go about adding banner 2 and banner 3.

 

Any advice would be really appreciated.

 

Thanks in advance.

 

post-193464-0-49551900-1365281181_thumb.jpg

Share this post


Link to post
Share on other sites

I'm not sure what you need those extra divs for, but you need to close them (Line 80 in my copy).

 

You add the additional banners the same way you did the first one: in the admin banner manager. See the instructions for more info.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Thanks kymation, forgot to mention the close tags have been added. I removed the container tag as not sure why I had that there in the first place! The wrapper tag was so that I can apply the grey background. I guess I need to work out how to show (positions, css styles) on the page as banner 2 and 3 have been added in the banner manager, but just need to work out how to show it next to banner 1.

 

Thanks for your help, much appreciated.

Edited by aftabn10

Share this post


Link to post
Share on other sites

kymation, sorry to trouble, just wondering as I require 3 different banner rotators, would it be cause of duplicating the banner rotator files in the front page folder? As i need to use 3 different groups rather than them coming off 1 group...

Share this post


Link to post
Share on other sites

How to solve this:

 

Warning: constant() [function.constant]: Couldn't find constant MODULE_FRONT_PAGE_NEW_PRODUCTS_TITLE_JAPANESE in /home/abcd/public_html/includes/modules/front_page/new_products.php on line 38

 

Warning: constant() [function.constant]: Couldn't find constant MODULE_FRONT_PAGE_TEXT_MAIN_JAPANESE in /home/abcd/public_html/includes/modules/front_page/text_main.php on line 39

 

I installed japanese language addon,and it appear these errors.Also does anyone know how can I change the dimensions of the japanesse flag from the main page?

Edited by alexman

Share this post


Link to post
Share on other sites

How to solve this:

 

Warning: constant() [function.constant]: Couldn't find constant MODULE_FRONT_PAGE_NEW_PRODUCTS_TITLE_JAPANESE in /home/abcd/public_html/includes/modules/front_page/new_products.php on line 38

 

Warning: constant() [function.constant]: Couldn't find constant MODULE_FRONT_PAGE_TEXT_MAIN_JAPANESE in /home/abcd/public_html/includes/modules/front_page/text_main.php on line 39

 

I installed japanese language addon,and it appear these errors.Also does anyone know how can I change the dimensions of the japanesse flag from the main page?

 

 

I solved by uninstall and install again all modules from admin area.Thx anyway.

Share this post


Link to post
Share on other sites

@@aftabn10 You would need to clone the module and make two new modules, then add some CSS to position them. Or you could change the code in the existing module to do th same thing. Either way would take some PHP coding.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

@@kymation, thanks for that. Thought as much, will go through with cloning the banner_rotator module and see how i get on. Thanks once again.

Share this post


Link to post
Share on other sites

i have been looking for anybody having this problem, but have not seen it anywhere in the thread. If you create and HTML banner, that works fine with the normal banner.php program to display on the page, when you use the same file in the banner_rotator.php program it displays the html code as plain text in the box.

 

Anybody have and answer or edit change to make it work.

 

Thanks,

Bill V

Share this post


Link to post
Share on other sites

The banner rotator only works on images; it won't accept text. This is a limitation of the Javascript/CSS used to exchange the images.

 

Regards

JIm


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi Jim

I am having trouble installing this module from the admin panel. I am sure it's something really basic but I can't seem to identify the problem. I have transferred all of the files into my installation, which has had some customisation but not a lot. I have also tried various tweaks on the index.php file according to your guidance and with the help of this forum. I can see the module in the admin panel and it indicates 10 sections but there is no option to install them, just the file path is visible. I would be very grateful if you could help? I am a keen but confused novice! :(

Share this post


Link to post
Share on other sites

This usually means that you have put something in the wrong place. Check that you have uploaded everything to the locations shown in the instructions.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi Jim

 

Have to say this is a great addon. I do have one slight problem in that with the MAIN TEXT module, when i install it worked ok and shows the text for the main screen, but when i look to edit the text it the text is not shown with only options to enable main text or change the sort order.

Edited by Hoog

Share this post


Link to post
Share on other sites

Hi Jim

 

Have to say this is a great addon. I do have one slight problem in that with the MAIN TEXT module, when i install it worked ok and shows the text for the main screen, but when i look to edit the text it the text is not shown with only options to enable main text or change the sort order.

 

Don't worry Jim as i just saw the earlier comments in this thread so will use those to work through it. Thanks anyway and keep up the great work

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×