Jump to content
kymation

[Addon} Modular Front Page

Recommended Posts

Use your database management tool to check the database. Is the text there after you save it?

 

Also, did you click the Save button or the icon in ckeditor when you saved the text?

 

Regards

Jim

 

Oh thank you Jim for your answer.

Well your question are reasonable and yes, the text is there after i save (using the page button, not the ckeditor one) and it appears in the homepage correctly.

Also the "missing text" was missing even before ckeditor installation the exact same way; in fact that's why i tried installing ckeditor... Cause looking at the function tep_draw_textwhatever, i noticed the "value" parameter was shifted... that driven me to think about a ckeditor workaround in order to pass textarea content, but i was wrong...

Share this post


Link to post
Share on other sites

Are you certain that you have made the required changes to index.php? Do any of the other modules work correctly? Is your store osCommerce version 2.3.1, and have you added a template or other Addon designed for a previous version?

 

Regards

JIm


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Well i'm doing some heavy modification to the store in order to satisfy my client requirements.

Yes i had to use a previous versione mod but i applied by hand with comparison tools and paying attention.

All works perfectly but the frontpage main text textarea during update operation just after clicking "edit" appears empty.

i will look deeper, i had no time until now...

But your answers were useful first of all to understand there is something wrong on my side.

I will update when and if i will find solution.

Share this post


Link to post
Share on other sites

The module code depends heavily on the osC 2.3.1 code. That is, code that is not in any of the previous versions. I have no idea how much you would have to backport to get a 2.2x installation to work with these modules, and would hate to even try. Good luck with that.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Yes, it is, but i'm using 2.3.1! i just ported a couple of 2.2 contribs on the 2.3.1 core

All works even MVS, just i had this little problem

Edited by giuseppe_urso

Share this post


Link to post
Share on other sites

I suspect that one of your 2.2 imports is interfering with the module code. I can't be any more specific than that here.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi Jim, I've just added modular front page to a site that was already running theme switcher 1.3... after a bit of digging around, it seemed that the only thing needed to make the scroller work was to move the include of the jquery stuff above the scroller. This could be achieved simply by hacking the value of configuration entry TEMPLATE_BLOCK_GROUPS and changing the order so that header_tags comes before front_page; it makes the scroller work and doesn't interfere with the banners - e.g. http://www.yourmontage.co.uk/shop23/

 

Are there any other compatibility issues that require reverting theme switcher to the earlier version?

 

Thanks for another great addon


For a new install or if your store isn't mobile-friendly, get the community-supported responsive osCommerce (Phoenix).

here: on the official osc download page

Working on generalising bespoke solutions for Quickbooks integration, Easify integration and pay4later (DEKO) integration at 2.3.x

Share this post


Link to post
Share on other sites

That should work, at least as far as I can tell without testing it. The problem is that I have not had time to test it out.

 

That was the only bug that I know of. Changing the order so the jQuery and jQuery UI files get loaded first fixes the bug. Now all I have to do is figure out a way to automate that as part of the installation.

 

Thanks for providing the bug fix.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I've added a new release to the Addons section. This package fixes the problem with certain modules when using this Addon along with Theme Switcher. There are upgrade instructions in the package if you already have this installed.

 

Many thanks to @ for putting me on the right track.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I've installed Modular Front Page and think it's great. Makes it so easy for us noobies.

 

I do have a problem though with the categories add-on. Pictures work fine but I find that on some versions of IE the writing doesn't line up with the pictures. It's very obb because on most systems it's fine - tested with ipad, iphone, IE 8 and Safari.

 

Please see the attached picture. Does anyone have any suggestions on how to fix this issue? It's annoying because it's not doing it on my home PC.

 

http://dl.dropbox.com/u/7360131/category_problem.JPG

 

Thanks in advance.

Share this post


Link to post
Share on other sites

That happens when the box is too small to contain the text. Fonts are rendered differently depending on the browser, the operating system, and the user's settings. Setting font size in pixels helps with this problem, but does not scale well.

 

I suggest that you make your boxes slightly taller. That's the best compromise I've been able to come up with.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Well i'm doing some heavy modification to the store in order to satisfy my client requirements.

Yes i had to use a previous versione mod but i applied by hand with comparison tools and paying attention.

All works perfectly but the frontpage main text textarea during update operation just after clicking "edit" appears empty.

i will look deeper, i had no time until now...

But your answers were useful first of all to understand there is something wrong on my side.

I will update when and if i will find solution.

 

Just came across this myself There's a bug in the setting function of the Text Main module. If you find the install function in includes\modules\front_page\text_main.php, you'll see at the end a foreach loop that goes through each language. Replace it with this:

  foreach ($this->languages_array as $language_id => $language_name) {
	tep_db_query("insert into " . TABLE_CONFIGURATION . " (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) values ( '" . ucwords($language_name) . " Text', 'MODULE_FRONT_PAGE_TEXT_MAIN_" . strtoupper($language_name) . "', 'Quid ergo hunc aliud moliri, quid optare censetis aut quam omnino causam esse belli?', 'Enter the text that you want to show on the front page in " . $language_name . "', '6', '2', 'tep_draw_textarea_field(\'configuration[MODULE_FRONT_PAGE_TEXT_MAIN_" . strtoupper($language_name) . "]\', false, 35, 20, MODULE_FRONT_PAGE_TEXT_MAIN_" . strtoupper($language_name) . ", \' class=\"ckeditor\"\',  ', now())");
  }

making sure that you don't lose the final } of the function which should come immediately afterwards.

 

Basically, the change feeds the value of the config variable into the text parameter of the function tep_draw_textarea instead of ''

 

Hope this helps

 

Edit: forgot to mention - it won't make any difference until you remove the module and install it again.

Edited by JohnAtYM

For a new install or if your store isn't mobile-friendly, get the community-supported responsive osCommerce (Phoenix).

here: on the official osc download page

Working on generalising bespoke solutions for Quickbooks integration, Easify integration and pay4later (DEKO) integration at 2.3.x

Share this post


Link to post
Share on other sites

Thanks for the bug report and for the code to fix it. I'll add this to the next release.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hello,

 

I'm kind of new here and I'm going to ask you guys give me some advices about installing Modular Front Page, first of all what changes I have to do with my catalog/index.php to make Modular Front Page works?

 

Bottom of index.php from add-on looks:

 

<?php

} else { // default page

// Start Modular Front Page

?>

 

<div class="contentContainer">

 

<?php echo $oscTemplate->getBlocks('front_page'); ?>

 

</div>

 

<?php

// End Modular Front Page

}

 

require(DIR_WS_INCLUDES . 'template_bottom.php');

require(DIR_WS_INCLUDES . 'application_bottom.php');

?>

 

 

 

 

Bottom of index.php from my page looks:

 

<?php

} else { // default page

?>

 

<h1><?php echo HEADING_TITLE; ?></h1>

 

<div class="contentContainer">

<div class="contentText">

<?php echo tep_customer_greeting(); ?>

</div>

 

<?php

if (tep_not_null(TEXT_MAIN)) {

?>

 

<div class="contentText">

<?php echo TEXT_MAIN; ?>

</div>

 

<?php

}

 

include(DIR_WS_MODULES . FILENAME_NEW_PRODUCTS);

include(DIR_WS_MODULES . FILENAME_UPCOMING_PRODUCTS);

?>

 

</div>

 

<?php

}

 

require(DIR_WS_INCLUDES . 'template_bottom.php');

require(DIR_WS_INCLUDES . 'application_bottom.php');

?>

 

 

What should I add/delete in index.php at my page to make the Modular Front Page add-on works.

 

Thank you.

Share this post


Link to post
Share on other sites

Which comparison program are you using?

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

So Winmerge highlighted those two chunks of code as being the differences? It's right. Copy the part from the Modular Front Page version into yours and it should work.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hello Jim,

 

I did what you suggested me and now the bottom index.php looks:

 

<?php

} else { // default page

// Start Modular Front Page

?>

 

<div class="contentContainer">

 

<?php echo $oscTemplate->getBlocks('front_page'); ?>

 

</div>

 

<?php

// End Modular Front Page

 

<h1><?php echo HEADING_TITLE; ?></h1>

 

<div class="contentContainer">

<div class="contentText">

<?php echo tep_customer_greeting(); ?>

</div>

 

<?php

if (tep_not_null(TEXT_MAIN)) {

?>

 

<div class="contentText">

<?php echo TEXT_MAIN; ?>

</div>

 

<?php

}

 

include(DIR_WS_MODULES . FILENAME_NEW_PRODUCTS);

include(DIR_WS_MODULES . FILENAME_UPCOMING_PRODUCTS);

?>

 

</div>

 

<?php

}

 

require(DIR_WS_INCLUDES . 'template_bottom.php');

require(DIR_WS_INCLUDES . 'application_bottom.php');

?>

 

web-page doesn't work, gives me an error:

 

Parse error: syntax error, unexpected '<' in /home/a3714745/public_html/index.php on line 257

 

 

What did I do wrong? thank you for your help.

Share this post


Link to post
Share on other sites

You need to replace the code, not add it.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi all,

 

I am new to OSC v2.3.1 (used a previous version in the past) and have succsessfully installed the Modular Front Page add on (its great, thank you :) )

 

I am just a bit stuck trying to insert additional images/text.

 

Here is my site (in progress!): http://www.caleda.co.uk/

 

For example, how would I insert my own one off image underneath the "category images"? The category images is obviously part of the modular front page and I just cant work out how to 'word around' it.

 

I have looked through the code and experiemented and I just cannot figure it out!

 

Any help greatlyfully recieved.

Share this post


Link to post
Share on other sites

I have been looking for an answer to this for a day or so and finally I figure it out 2 minutes after posting this request for help!

 

In case others are interested see the red line below:

 

<?php

} else { // default page

// Start Modular Front Page

?>

<div class="contentContainer">

<?php echo $oscTemplate->getBlocks('front_page'); ?>

<?php echo tep_image(DIR_WS_IMAGES . 'yourimage.png','your alt text'); ?>

</div>

<?php

// End Modular Front Page

Share this post


Link to post
Share on other sites

I've released a new version -- see the Addons page. This release fixes a bug in the Text Main module. If you are using this module, copy your text before uninstalling the module, then reinstall and add your text back.

 

All credit for the fix goes to John Ferguson (@). Thanks again for the code.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I finally got this to work in 2.3.1.

 

I have a question tho and it might seem 'lame' BUT... seeing as I really only used 2.2 before this, what I want to do, is edit the New Products list on the main page, to be LONG wide listings, instead of a 3x3 box.

 

Even just a list of files would help, Im looking but its just not 'clicking' .. *passes out the sledgehammer to drive it home* *grins*

 

Thomas


A signature is something that reflects its user. - The dictionary

 

The question is not, 'to code, or not to code'

the question is, 'if we do not code, are we really alive?'

-- anonymous

Share this post


Link to post
Share on other sites

The number of columns in the New Products box can be set in your Admin >> Modules >> Front Page >> New Products. If that doesn't make it look the way that you want it to, edit the execute() method in catalog/includes/modules/front_page/new_products.php.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×