Jump to content
kymation

[Addon} Modular Front Page

Recommended Posts

Flash carousel has been added to the wish list. Depending on how much time this takes, and how busy I am, it could take a while.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I am still working on this. Great work.

I have a modified store, and I dont seem to get which parts of the catalog/index.php file that I must add, can you please post the additional line that we must add and where. I am new in this and would greatly appreciate your help

 

Felix

Share this post


Link to post
Share on other sites

Many problems with the Flash carousel. The osCommerce Addon that I found uses code that is not legal to distribute on this site. I don't have the Flash authoring tools so I'm unable to design one myself. A search for free/open source components has come up empty so far. If anyone knows of such a package, please send me a link to it.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I am still working on this. Great work.

I have a modified store, and I dont seem to get which parts of the catalog/index.php file that I must add, can you please post the additional line that we must add and where. I am new in this and would greatly appreciate your help

 

Felix

It's not an addition; it's a replacement. Replace all of the code between

<?php
 } else { // default page
?>

and

<?php
 }

 require(DIR_WS_INCLUDES . 'template_bottom.php');
 require(DIR_WS_INCLUDES . 'application_bottom.php');
?>

What are you using to compare the files?

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

It's not an addition; it's a replacement. Replace all of the code between

<?php
 } else { // default page
?>

and

<?php
 }

 require(DIR_WS_INCLUDES . 'template_bottom.php');
 require(DIR_WS_INCLUDES . 'application_bottom.php');
?>

What are you using to compare the files?

 

Regards

Jim

 

 

Thanks Jim, I have just downloaded Winmerge and still trying to figure it it out itself.

But I've seen what needs to be changed and will be doing that manually for now. Will give feedback.

Otherwise it looks good. Thanks againg

 

Regards

 

Felix

Share this post


Link to post
Share on other sites

I've used Winmerge. It's decent, but I like Meld better. Unfortunately it's not available for Windows. Use whatever works for you.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi again Jim

 

Having made installed this, I get the following message;

 

Fatal error: Call to a member function getBlocks() on a non-object in /home/mysite/index.php on line 295

 

 

This is the last bit of code;

<?php

} else { // default page

?>

 

<div class="contentContainer">

 

<?php echo $oscTemplate->getBlocks('front_page'); ?>

 

</div>

 

<?php

}

 

require(DIR_WS_INCLUDES . 'template_bottom.php');

require(DIR_WS_INCLUDES . 'application_bottom.php');

?>

Share this post


Link to post
Share on other sites

As stated in the instructions, this means that the osC 2.3.x template class is missing/not initialized/invalid. The only way I can see this happening is installing this addon onto an older version of osC that does not have the class.

 

If you installed an early version of 2.3 from Github, this class has changed in the released version. You need the latest version of the class to make this work.

 

Check your catalog/includes/classes/osc_template.php for this code at Line 37:

    function getBlocks($group) {
     if ($this->hasBlocks($group)) {
       return implode("\n", $this->_blocks[$group]);
     }
   }

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

As stated in the instructions, this means that the osC 2.3.x template class is missing/not initialized/invalid. The only way I can see this happening is installing this addon onto an older version of osC that does not have the class.

 

If you installed an early version of 2.3 from Github, this class has changed in the released version. You need the latest version of the class to make this work.

 

Check your catalog/includes/classes/osc_template.php for this code at Line 37:

    function getBlocks($group) {
     if ($this->hasBlocks($group)) {
       return implode("\n", $this->_blocks[$group]);
     }
   }

 

Regards

Jim

 

Thanks Jim, my bad didnt go back to you install instructions. will be getting back to it now

Share this post


Link to post
Share on other sites

I have osCommerce Online Merchant v2.3

 

It is heavily modified and don't think it has something to do with your contribution, but that maybe you could identify what the problem could be.

Share this post


Link to post
Share on other sites

Early versions of 2.3 had a slightly different class. Look at the code that I posted above. If that isn't in your version, you have an old version and will need to update. This will affect the code that handles the boxes in the side columns as well, so you will need to update those as well.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

The forum doesn't seem to want me to post today. Let's see if this works....

 

Wow, it did. Amazing.

 

Anyway, I've uploaded a new version. This one fixes some bugs in the Featured module. Replace your module if you're using Featured. Don't forget to uninstall first before replacing a module.

 

Regards

Jim

Edited by kymation

See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Thanks Jim, my bad didnt go back to you install instructions. will be getting back to it now

 

I don't have this file. Sadly looks like I'd have to drop what I think is a valuable contribution

Share this post


Link to post
Share on other sites

in the user manual pdf.. it states :

 

The changes to the existing file in this distribution are marked with // Modular Front Page

for single line changes and

// Start Modular Front Page

<code>

// End Modular Front Page

 

however in the index.php there are no comments at all ???

 

ive got it working no problems at all in 2.3.1.. and have added a few extra pages to it too.. works really well..

 

 

Steve

Edited by Steve9R

Share this post


Link to post
Share on other sites

Yes, I accidentally left out those comments. Fixed now. I have another hew module running -- the side scroller worked. I just need to finish the instructions and I'll post it.

 

Regards

Jim

Edited by kymation

See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Version 1.2 has been uploaded to the Addons section. This includes a new module: a horizontal/side scroller. This box can be used as a specials, new products, or featured products module. It shows images of your products scrolling across the page. The most common options are provided as Admin settings.

 

This makes a total of 10 modules currently available. Anybody who wants to can add their own favorite front page addon as a module. If you need help figuring out the code, just ask. Please let us know hare if you upload a new module.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Still showing up as 1.1.5 on the addons page ???

 

any thoughts about that news module ?

 

Steve

Edited by Steve9R

Share this post


Link to post
Share on other sites

Sigh -- over the size limit again. If you don't want to wait, the new version is available here.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Steve -- that sounds like it would make a useful module. Go ahead and do it if you want. The more modules the better for everyone.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

The new version is up. Thanks to the moderator who got stuck with this job.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Thanks Jim,

works O.K.

It would be very nice however if all the all needed parts in the module could be MultiLanguage.


"If you're working on something new, then you are necessarily an amateur."

Share this post


Link to post
Share on other sites

That's due to the database structure. The Admin uses the configuration database table to store the text, and that is single-language. Making it multi-language would require a major restructuring of the osCommerce admin. Not exactly modular....

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Can anyone provide a demo or a screenshot?


Santa's little freelancer

Share this post


Link to post
Share on other sites

I knew someone was going to ask that. This is a completely modular system, with (currently) 10 modules, each of which has up to 30 different settings, and each setting has anywhere from two to thousands of possible values. So, lessee, carry the two ... I think we can safely say that there are billions of different ways this could look. So, are you going to provide the storage for those billions of screenshots? And the team of dedicated testers to spend the next several years producing them? No? Too bad.... :-" :'( :(

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Works great, thank you.

 

A feature I would like to see is, on both featured and new products to randomly show images that are predetermined by me, not scrolling.

 

Keep up the good work

 

Cheers

 

PS I have some modules installed if somebody wants to see it.

 

http://www.koolkatjazz.com/oscommerce-2.3.1/catalog/

Edited by pederb

-Peder Beckman-

Kool Kat Jazz Records

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×