Jump to content
kymation

[Addon} Modular Front Page

Recommended Posts

That URL returns a 404 Not Found.

 

The error you describe is caused by an incorrect edit in one of the files. Given the previous problem, I believe that your index.php is still wrong. Try substituting the one from this Addon and see if that works.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Jim,

I love this contribution because its so easy to move things around to get a different look. I'm playing with the banner rotator and trying to place it at the top of my body above the Heading Title. In doing so the module takes up a lot of space. The space below the banner but to the left of the rotating meter is dead space correct. Is there any way of eliminating that rotating meter so that just the banner shows on the page so that all that space under the banner can be used as part of another module?. The second question I have is I would like to install a video clip on my home page. Could a new module be created for this that would accomodate text wrap around or can I just cut and paste the code into the "Text Main" module?...Thanks....Bob

Share this post


Link to post
Share on other sites

What is a "rotating meter?" Sounds like you messed something up.

 

New modules are easy to create, or you could just use the text_main module and paste HTML into it. Either will work. If you want text to flow around an image/movie, add a float style to the image/movie:

<div style="float:left;">
 <img src="foo.gif" />
</div>
Some text here.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Jim, I don't know what the correct terminology is. You have the banner and underneath it to the right is the little scale that that clicks from dot to dot as the banners rotate. It has a button in which you can stop the banner rotation.Thats all I can see since my background color on my site is black. This meter or whatever its called, is grey and not too visible but there is a large area to the left of this "meter" that leaves a big gap of space. It also places the banner in a off-center position on the page. Everything is working properly otherwise so I feel fairly confident it was installed correctly.My questions center on this "meter" and if it really is needed on the home page or can it be eliminated so that space could be used for moving another module up the screen? If you want to go to my site you can see what I mean www.moviepressphotos.com

Share this post


Link to post
Share on other sites

That box is the controls for the banners. It is supposed to overlay the bottom right corner of the banner. This only works if you have banners the same size you are telling the stylesheet they are. Change the lines marked Banner width and Banner height in ext/modules/front_page/banner_rotator/stylesheet.css.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Ok Jim, we're almost there. It put the control button in the upper right of the banner but does not look good. Its too dark and the bottom of my banner was cut off. The actual size of my banner is 468 x 50. I entered 478 x50 because your comment instructed to +10...so I changed settings to 478 instead of 468. The banner did not center but did eliminate the space under it so I'm almost there. What do I need to do?. It's up on my site if you want to look at it. Thanks....Bob

Share this post


Link to post
Share on other sites

Jim,

After looking over the stylesheet it appears I need to change the width of the banner to the size of the scroller and create a new transblack75.png to a redish color the background color of my banner and limit the text in my banner leaving the right side void of text so the control does not overlap any text in the ad. Does that sound right or can I change settings in the stylesheet to accomplish the same thing with less work....Thanks for your help...Bob

Share this post


Link to post
Share on other sites

That's right. You can move the controls elsewhere if you like, but lower right is really the best location for them.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Must be doing something wrong with the banner rotator. The only banners I have right now are from Amazon, which just come in html form, not pictures to download. They work fine when they are in the footer, but when I use the rotator it only shows the html text, and not the animated banner picture like it does in the footer.

Am I missing some setting?

 

Marianne

Share this post


Link to post
Share on other sites

I've never tried using HTML in the banner rotator. The Javascript that runs it was designed to work with images, so i may just not work. Can you get the images and use those instead?

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I've never tried using HTML in the banner rotator. The Javascript that runs it was designed to work with images, so i may just not work. Can you get the images and use those instead?

 

Regards

Jim

No, Amazon does not use seperate pictures, it uses html, since your affiliate account is embedded into the html. That is how you earn your money....You can't make your own banner, you have to use theirs.

Guess I'll just have to keep the banner at the bottom....

 

Marianne

Share this post


Link to post
Share on other sites

Hi Jim,

 

Thanks for this great addon!

 

I'm having some odd behavior with the fades in the Banner Rotator. I currently have three test images. I slowed down the fade time to 2 seconds (2000) to see exactly what is happening, and what's happening is this:

 

Image A loads with the page.

(pause)

Image A fades to white over 2 seconds, then Image B appears instantly.

(pause)

Image B fades to white over 2 seconds, then Image C appears instantly. (<- this is the last image in the sequence.)

(pause)

Image C disappears instantly, then image A fades in from white over 2 seconds.

 

 

Based on your first-page description, it seems that the images should "fade into each other" directly. That's what I would like to happen, at any rate. :)

 

If that's not possible, I would like them to "fade through white," with one image fading out and the next one fading in, so no image ever appears/disappears instantly.

 

Any ideas?

Edited by PureBlissBathCo

Share this post


Link to post
Share on other sites

The first image should fade to white, then the next fade in. I've installed this several times, on both 2.2x and 2.3.1, and it always just works. I have no idea how you've managed to change that.

 

Regards

JIm


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hello... perhaps I am noob but I want to install this Modular Front Page on a fresh osCommerce installation. I copied all the files isn't that all? I cannot view in Modules the Front Page chapter. I read the manual ten time ... i can't see what else I need to do...

Share this post


Link to post
Share on other sites

The most common cause of this is putting the files in the wrong place. The next possibility is trying to install on a version 2.2x store.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

The most common cause of this is putting the files in the wrong place. The next possibility is trying to install on a version 2.2x store.

 

Regards

Jim

version is 2.3.1. and I copied all catalog folder from modular_front_page_1.2.6.tar.gz over my catalog folder from my hosting.

Share this post


Link to post
Share on other sites

Then it should show up. Try doing a forced refresh of your browser (Control-Refresh).

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Great add-on just wanted to say first.

 

I apologize if this question has already been asked/answered but I was not able to find. Running OSC 2.3.1.

 

The scroller is neato but I would really like to feature 20 products. I tried changing scroller.php near the beginning to this

 

// Set the number in the following line to the number of featured products desired.

var $featured_products = 20;

 

Back in the admin panel I am now seeing 10 additional "fields" under my first 10 product selection drop-downs but unlike the first 10 these are not actual interactive drop downs. Just blank fields.

 

I am green with PHP, OSC AND WWW even really so maybe I have not found an answer in this forum because it is something obvious.

 

Cheers and thanks.

Share this post


Link to post
Share on other sites

You need to uninstall and reinstall the module after changing that value.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Kymation just downloaded the module, this is brilliant! Just what I needed, thanks! Just a couple of questions, the featured products module is it possible to have more than 1 as I would like to show 3, also is it possible to add banners to the left and right columns?

 

Thanks once again, really love this, u made it all easy for me

Share this post


Link to post
Share on other sites

You can duplicate modules but it takes a bit of work. If you're comfortable with PHP:

1. Rename the module and language files named featured.php to something else.

2. In the module file, change featured (case sensitive) to the name of your new file.

3. In both files, change _FEATURED_ (case sensitive) to match your new file.

4. Change the text in the language file so you can tell this one from the regular featured module.

 

Now upload and install your new modules.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

You need to uninstall and reinstall the module after changing that value.

 

Regards

Jim

 

Yep thank you for the prompt solution.

Solid contributions and the level and quality of your active role in support is at least to the newbie here really amazing.

Share this post


Link to post
Share on other sites

Thank you. I wish I had more time to put into this. So many ideas, so little time....

 

Regards

JIm


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Thanks kymation, that seems pretty straightforward. Lastly can banners be added to the left and right column? Thanks once again btw..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×