Jump to content
spoofy

Google XML Sitemap SEO compatible with FWR Media Ultimate SEO URL 5

Recommended Posts

I am getting the same error(s) as previously posted in this thread but I haven't seen a fix for them.

 

Right now I get

 

1054 - Unknown column 'c.categories_status' in 'where clause'

 

SELECT p.products_id as pID, p.products_date_added as date_added, p.products_last_modified as last_mod, p.products_ordered

FROM products p, categories c, products_to_categories p2c where c.categories_status='1' and p.products_id = p2c.products_id and p2c.categories_id = c.categories_id and p.products_status='1'

ORDER BY products_ordered DESC

 

[TEP STOP]

 

Any solution to this?

 

??

Share this post


Link to post
Share on other sites

Can anyone help with this problem?

 

And me too, same problem:

 

1054 - Unknown column 'c.categories_status' in 'where clause'

 

SELECT p.products_id as pID, p.products_date_added as date_added, p.products_last_modified as last_mod, p.products_ordered

FROM products p, categories c, products_to_categories p2c where c.categories_status='1' and p.products_id = p2c.products_id and p2c.categories_id = c.categories_id and p.products_status='1'

ORDER BY products_ordered DESC

 

[TEP STOP]

 

 

If this is not going to work, which Google XML Sitemap contribution would you recommend to use on top of FWR Media Ultimate SEO URL 5 ?

 

Thanks.

Share this post


Link to post
Share on other sites

I am getting the same error. Anyone figured this one out?

 

1054 - Unknown column 'c.categories_status' in 'where clause'

SELECT p.products_id as pID, p.products_date_added as date_added, p.products_last_modified as last_mod, p.products_ordered
FROM products p, categories c, products_to_categories p2c where c.categories_status='1' and p.products_id = p2c.products_id and p2c.categories_id = c.categories_id and p.products_status='1'
ORDER BY products_ordered DESC

[TEP STOP]

Share this post


Link to post
Share on other sites

Whell it works for a while now but forgot too let you know :oops:

 

Thanks for this graet addon

 

Jasper

Share this post


Link to post
Share on other sites

I am getting the same error. Anyone figured this one out?

 

1054 - Unknown column 'c.categories_status' in 'where clause'

SELECT p.products_id as pID, p.products_date_added as date_added, p.products_last_modified as last_mod, p.products_ordered
FROM products p, categories c, products_to_categories p2c where c.categories_status='1' and p.products_id = p2c.products_id and p2c.categories_id = c.categories_id and p.products_status='1'
ORDER BY products_ordered DESC

[TEP STOP]

c.categories_status is not standard code. It comes from the contribution, enable/disable categories

Share this post


Link to post
Share on other sites

I have a problem after generating the sitmap for products.

 

I have one empty line in the sitmap and now google thinks it is an bad sitemap.

 

I think one of the SEO url's has a bad sign in the name but i cant find out wich one.

 

Is the sitemap making the file random or can i find out by line numer (654) witch URL has the bad name?

 

In the sitemap i looks like this

	<url>
	<loc></loc>
	<lastmod>2011-04-04</lastmod>
	<changefreq>weekly</changefreq>
	<priority>0.1</priority>
</url> 

loc /loc is empty an should be filled wiht a SEO URL.

There is only one empty loc /loc from all 25.000

 

Can some one help me out?

 

Jasper

Share this post


Link to post
Share on other sites

If may help others

 

I've installed this on a RC 2.2 store with the FWR SEO and it works just fine.

 

The CRON job also works OK but I had to use either of these variations to get it to run after setting file permissions as per the readme

 

wget -O - -q -b /server/path/to/catalog/googlesitemap/index.php

 

or

 

/usr/bin/wget "http://www.mystore.com/googlesitemap/index.php"

 

Graeme

Share this post


Link to post
Share on other sites

??

 

Hi. I have just effected a new install and getting this dreaded 1054 error - c.categories_status

I see that pdcelec gave a solutions: c.categories_status is not standard code. It comes from the contribution, enable/disable categories

 

I'm new to oscommerce, can someone please explain how I can rectify this problem.

 

Thanks


Theory is an exact science that rarely works in practice!

Share this post


Link to post
Share on other sites

Hi. I have just effected a new install and getting this dreaded 1054 error - c.categories_status

I see that pdcelec gave a solutions: c.categories_status is not standard code. It comes from the contribution, enable/disable categories

 

I'm new to oscommerce, can someone please explain how I can rectify this problem.

 

Thanks

Replace

SELECT p.products_id as pID, p.products_date_added as date_added, p.products_last_modified as last_mod, p.products_ordered
FROM products p, categories c, products_to_categories p2c 
where c.categories_status='1' and p.products_id = p2c.products_id and p2c.categories_id = c.categories_id and p.products_status='1'
ORDER BY products_ordered DESC

To

SELECT p.products_id as pID, p.products_date_added as date_added, p.products_last_modified as last_mod, p.products_ordered
FROM products p, categories c, products_to_categories p2c 
where p.products_id = p2c.products_id and p2c.categories_id = c.categories_id and p.products_status='1'
ORDER BY products_ordered DESC

 

Alternatively, install enable/disable categories

Edited by pdcelec

Share this post


Link to post
Share on other sites

Has anyone solved the permissions problem? I set the permissions of the sitemap.xml files to 777 but it still says it doesn't have permission to write to them. I can't give it more permission than that.

Share this post


Link to post
Share on other sites

Hello.

 

i moved the website to another server but now the sitemap will not be made anymore.

I deleted all sitemaps and the map googlesitemap and uploaded a fresh one from the addons section but even then nothing.

 

when i enter my.domain/googlesitemap/index.php it takes about 2 minuts and the i get a http 500 error.

whit the alternate class he wont also work.

and because of the http 500 diagnostic is not showing too in standard

when i use alternate is shows this

Opening   /sitemapproducts.xml
FS_CAT    /var/www/vhosts/jps-autosport.nl/httpdocs/webshop/
Server    http://www.jps-autosport.nl
Save Path /
WS_CAT    /webshop/ 
ERROR: Google Product Sitemap Generation FAILED!

Opening   /sitemapcategories.xml
FS_CAT    /var/www/vhosts/jps-autosport.nl/httpdocs/webshop/
Server    http://www.jps-autosport.nl
Save Path /
WS_CAT    /webshop/ 
ERROR: Google Category Sitemap Generation FAILED!

Opening   /sitemapmanufacturers.xml
FS_CAT    /var/www/vhosts/jps-autosport.nl/httpdocs/webshop/
Server    http://www.jps-autosport.nl
Save Path /
WS_CAT    /webshop/ 
ERROR: Google Manufacturers Sitemap Generation FAILED!

Opening   /sitemapspecials.xml
FS_CAT    /var/www/vhosts/jps-autosport.nl/httpdocs/webshop/
Server    http://www.jps-autosport.nl
Save Path /
WS_CAT    /webshop/ 
ERROR: Google Specials Sitemap Generation FAILED!

Opening   /sitemappages.xml
FS_CAT    /var/www/vhosts/jps-autosport.nl/httpdocs/webshop/
Server    http://www.jps-autosport.nl
Save Path /
WS_CAT    /webshop/ 
ERROR: Google Pages Sitemap Generation FAILED!

Opening   /sitemapindex.xml
FS_CAT    /var/www/vhosts/jps-autosport.nl/httpdocs/webshop/
Server    http://www.jps-autosport.nl
Save Path /
WS_CAT    /webshop/ 
ERROR: Google Sitemap Index Generation FAILED!

Array
(
   [QUERY] => Array
       (
           [PRODUCTS] => Array
               (
                   [sTATUS] => success
                   [NUM_ROWS] => 24648
               )

           [CATEOGRY] => Array
               (
                   [sTATUS] => success
                   [NUM_ROWS] => 25412
               )

           [MANUFACTURERS] => Array
               (
                   [sTATUS] => success
                   [NUM_ROWS] => 29
               )

           [sPECIALS] => Array
               (
                   [sTATUS] => success
                   [NUM_ROWS] => 1159
               )

       )

   [sAVE_FILE_XML] => Array
       (
           [0] => Array
               (
                   [file] => /sitemapproducts.xml
                   [status] => failure
                   [file_exists] => false
               )

           [1] => Array
               (
                   [file] => /sitemapcategories.xml
                   [status] => failure
                   [file_exists] => false
               )

           [2] => Array
               (
                   [file] => /sitemapmanufacturers.xml
                   [status] => failure
                   [file_exists] => false
               )

           [3] => Array
               (
                   [file] => /sitemapspecials.xml
                   [status] => failure
                   [file_exists] => false
               )

           [4] => Array
               (
                   [file] => /sitemappages.xml
                   [status] => failure
                   [file_exists] => false
               )

           [5] => Array
               (
                   [file] => /sitemapindex.xml
                   [status] => failure
                   [file_exists] => false
               )

       )

)

 

i set all .xml to 777 and even tryed googlesitemap/ to set 777

 

can someone help me out?

Share this post


Link to post
Share on other sites

Dear Spoofy and Robert,

 

First of all, thanks for your contributions!.

 

So, I am a little bit frustrated because it is my second time with a compatibility problem without a solution. I have Oscommerce 2.3.1 with USU5 and Google XML Sitemap SEO 1.5.5 and I am getting the following error message:

 

1054 - Unknown column 'c.categories_status' in 'where clause'

 

SELECT p.products_id as pID, p.products_date_added as date_added, p.products_last_modified as last_mod, p.products_ordered

FROM products p, categories c, products_to_categories p2c where c.categories_status='1' and p.products_id = p2c.products_id and p2c.categories_id = c.categories_id and p.products_status='1'

ORDER BY products_ordered DESC

 

[TEP STOP]

 

 

I read your comments above but I was unable to find the solution, Could you please tell me what is the solution to the problem?

 

Thanks in advanced.

Edo.

Edited by elara

Share this post


Link to post
Share on other sites

It's saying you don't have the column categories_status in your categories table. Check the installation instructions again for information to insert the required rows for the contrib into your database. :)

 

Of course, BACKUP first!

 

Peace,

Chris

Share this post


Link to post
Share on other sites

It's saying you don't have the column categories_status in your categories table. Check the installation instructions again for information to insert the required rows for the contrib into your database. smile.png

 

Of course, BACKUP first!

 

Peace,

Chris

 

Hi Chris,

but I already have run the google_xml_sitemap_seo.sql file according to the instruccions... :-(

 

Thanks again

Share this post


Link to post
Share on other sites

Then you might wanna take a look at the categories table and verify it's there. Because that error says it's not. :P

 

Peace,

Chris

Share this post


Link to post
Share on other sites

Hello Again,

 

I got some progress.

Now on alternate method is dont have the http 500 error but i can new see some errors

ERROR: Google Product Sitemap Generation FAILED!
ERROR: Google Category Sitemap Generation FAILED!
Opening /sitemapindex.xmlFS_CAT /var/www/vhosts/jps-autosport.nl/httpdocs/webshop/Server http://www.jps-autosport.nlSave Path /WS_CAT /webshop/ ERROR: Google Sitemap Index Generation FAILED!
Array
(
[QUERY] => Array
(
[PRODUCTS] => Array
(
[sTATUS] => success
[NUM_ROWS] => 30330
)
[CATEOGRY] => Array
(
[sTATUS] => success
[NUM_ROWS] => 25413
)
)
[sAVE_FILE_COMPRESS] => Array
(
[0] => Array
(
[file] => /sitemapproducts.xml.gz
[status] => failure
[file_exists] => false
)
[1] => Array
(
[file] => /sitemapcategories.xml.gz
[status] => failure
[file_exists] => false
)
)
[sAVE_FILE_XML] => Array
(
[0] => Array
(
[file] => /sitemapindex.xml
[status] => failure
[file_exists] => false
)
)
)

 

Can someone help me out i dont know what to do.

I placed all files under /webshop/ but the error is [file_exists] => false

Now i made a copy and placed it in my root instead of /webshop/ but the error is the same.

 

Greets,

 

Jasper

Share this post


Link to post
Share on other sites

Hello, tried to instaal sitemaps but cannot get it to work, i tried standard and alternate from the admin menu but still get the error as shown below. I set the permissions to 777 so that will not be the problem I guess?

Opening   /sitemapproducts.xmlFS_CAT    /Server    http://www.davelaarscooters.nlSave Path /WS_CAT    / ERROR: Google Product Sitemap Generation FAILED!
Opening   /sitemapcategories.xmlFS_CAT    /Server    http://www.davelaarscooters.nlSave Path /WS_CAT    / ERROR: Google Category Sitemap Generation FAILED!
Opening   /sitemapmanufacturers.xmlFS_CAT    /Server    http://www.davelaarscooters.nlSave Path /WS_CAT    / ERROR: Google Manufacturers Sitemap Generation FAILED!
Opening   /sitemapspecials.xmlFS_CAT    /Server    http://www.davelaarscooters.nlSave Path /WS_CAT    / ERROR: Google Specials Sitemap Generation FAILED!
ERROR: Google Pages Sitemap Generation FAILED!
Opening   /sitemapindex.xmlFS_CAT    /Server    http://www.davelaarscooters.nlSave Path /WS_CAT    / ERROR: Google Sitemap Index Generation FAILED!
Array
(
   [QUERY] => Array
    (
	    [PRODUCTS] => Array
		    (
			    [sTATUS] => success
			    [NUM_ROWS] => 96
		    )
	    [CATEOGRY] => Array
		    (
			    [sTATUS] => success
			    [NUM_ROWS] => 48
		    )
	    [MANUFACTURERS] => Array
		    (
			    [sTATUS] => success
			    [NUM_ROWS] => 8
		    )
	    [sPECIALS] => Array
		    (
			    [sTATUS] => success
			    [NUM_ROWS] => 6
		    )
    )
   [sAVE_FILE_XML] => Array
    (
	    [0] => Array
		    (
			    [file] => /sitemapproducts.xml
			    [status] => failure
			    [file_exists] => false
		    )
	    [1] => Array
		    (
			    [file] => /sitemapcategories.xml
			    [status] => failure
			    [file_exists] => false
		    )
	    [2] => Array
		    (
			    [file] => /sitemapmanufacturers.xml
			    [status] => failure
			    [file_exists] => false
		    )
	    [3] => Array
		    (
			    [file] => /sitemapspecials.xml
			    [status] => failure
			    [file_exists] => false
		    )
	    [4] => Array
		    (
			    [file] => /sitemapindex.xml
			    [status] => failure
			    [file_exists] => false
		    )
    )
)


I don't understand the most of what I'm reading but I do know how to read and copy/paste

Share this post


Link to post
Share on other sites

and my includes/configure.php

<?php
 define('HTTP_SERVER', 'http://www.davelaarscooters.nl');
 define('HTTPS_SERVER', 'http://www.davelaarscooters.nl');
 define('ENABLE_SSL', false);
 define('HTTP_COOKIE_DOMAIN', '');
 define('HTTPS_COOKIE_DOMAIN', '');
 define('HTTP_COOKIE_PATH', '/');
 define('HTTPS_COOKIE_PATH', '/');
 define('DIR_WS_HTTP_CATALOG', '/');
 define('DIR_WS_HTTPS_CATALOG', '/');
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
 define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');
 define('DIR_FS_CATALOG', '/');
 define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
 define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');
 define('DB_SERVER', '127.0.0.1');
 define('DB_SERVER_USERNAME', '*****');
 define('DB_SERVER_PASSWORD', '*****'');
 define('DB_DATABASE', '*****'');
 define('USE_PCONNECT', 'false');
 define('STORE_SESSIONS', 'mysql');
?>


I don't understand the most of what I'm reading but I do know how to read and copy/paste

Share this post


Link to post
Share on other sites

I'm encounter exact same problem i have Oscommerce 2.3.1 with SEO URL 5

 

error message i'm receiving

1054 - Unknown column 'c.categories_status' in 'where clause'
SELECT p.products_id as pID, p.products_date_added as date_added, p.products_last_modified as last_mod, p.products_ordered
   FROM products p, categories c, products_to_categories p2c where c.categories_status='1' and p.products_id = p2c.products_id and p2c.categories_id = c.categories_id and p.products_status='1'
   ORDER BY products_ordered DESC
[TEP STOP]

 

with alternate option on

Opening   /sitemapproducts.xml
FS_CAT    /home/eddiec/public_html/gdm-usa.com/shop/
Server    http://gdm-usa.com
Save Path /
WS_CAT    /shop/

Warning:  fopen(/sitemapproducts.xml) [function.fopen]: failed to open stream: Permission denied in /home/eddiec/public_html/gdm-usa.com/shop/googlesitemap/sitemap.class_Alternate.php on line 353
ERROR: Google Product Sitemap Generation FAILED!
Opening   /sitemapcategories.xml
FS_CAT    /home/eddiec/public_html/gdm-usa.com/shop/
Server    http://gdm-usa.com
Save Path /
WS_CAT    /shop/

Warning:  fopen(/sitemapcategories.xml) [function.fopen]: failed to open stream: Permission denied in /home/eddiec/public_html/gdm-usa.com/shop/googlesitemap/sitemap.class_Alternate.php on line 353
ERROR: Google Category Sitemap Generation FAILED!
Opening   /sitemapindex.xml
FS_CAT    /home/eddiec/public_html/gdm-usa.com/shop/
Server    http://gdm-usa.com
Save Path /
WS_CAT    /shop/

Warning:  fopen(/sitemapindex.xml) [function.fopen]: failed to open stream: Permission denied in /home/eddiec/public_html/gdm-usa.com/shop/googlesitemap/sitemap.class_Alternate.php on line 353
ERROR: Google Sitemap Index Generation FAILED!
Array
(
   [QUERY] => Array
    (
	    [PRODUCTS] => Array
		    (
			    [sTATUS] => success
			    [NUM_ROWS] => 128
		    )
	    [CATEOGRY] => Array
		    (
			    [sTATUS] => success
			    [NUM_ROWS] => 89
		    )
    )
   [sAVE_FILE_XML] => Array
    (
	    [0] => Array
		    (
			    [file] => /sitemapproducts.xml
			    [status] => failure
			    [file_exists] => false
		    )
	    [1] => Array
		    (
			    [file] => /sitemapcategories.xml
			    [status] => failure
			    [file_exists] => false
		    )
	    [2] => Array
		    (
			    [file] => /sitemapindex.xml
			    [status] => failure
			    [file_exists] => false
		    )
    )

Share this post


Link to post
Share on other sites

Replace

SELECT p.products_id as pID, p.products_date_added as date_added, p.products_last_modified as last_mod, p.products_ordered
FROM products p, categories c, products_to_categories p2c
where c.categories_status='1' and p.products_id = p2c.products_id and p2c.categories_id = c.categories_id and p.products_status='1'
ORDER BY products_ordered DESC

To

SELECT p.products_id as pID, p.products_date_added as date_added, p.products_last_modified as last_mod, p.products_ordered
FROM products p, categories c, products_to_categories p2c
where p.products_id = p2c.products_id and p2c.categories_id = c.categories_id and p.products_status='1'
ORDER BY products_ordered DESC

 

Alternatively, install enable/disable categories

 

Where is this file to replace? or where in the phpadmin?

Share this post


Link to post
Share on other sites

First a big thanks to FWR media and contributors

 

I don't know if my version of this mod is still original, but I noticed the last modifaction date of the static_pages.xml is rarely updated, becaused the last modification date of these pages is bases on the modificationtime of the language-file.

 

Since I have some pages which have dynamic content, which are mentioned in the pages.xml, I would like to have the modificationtime updates with the update of the dynamic content. F.i. faq.php , products_new.php etcetera

 

I solved this with a simple touch(/path/to/language/file.php); added to admin/categories.php so each time when I add new products or modify products, the languagefile gets a new lastmodificationtime.

 

I have placed the touch fuction in the switch part of the code, where the product is previewed.

 

I hop this information is clear enough, or else I will clarify it more. I am sure that is FWR thinks this to be valuable, it will be added in a next version.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×