Jump to content
Sign in to follow this  
FastEddy

Event Calender

Recommended Posts

Great contribution - it works beautifully!

Edited by kllw

Share this post


Link to post
Share on other sites
I have an event that lasts from 12.3. until 31.3., but link in calendar shows only on 12.3.

 

Is it possible to have links on all days until 31.3., or I have to manually add 20 separate events to achieve this?

 

Does anyone know for a modification or something?

Thanks, Rok

That's a good question. Although for most events you need to book for the whole thing there are of course the sort of events that last for maybe a couple of weeks and you can go along on any day.

 

I don't know of any mod to do that but I'm sure you could do it by adding an extra field to the database to indicate such an event then when the details are read, showing it based on whether the end date had been passed rather than whether the start date had been passed. It would be a useful small mod to create if you have some free time :P

Share this post


Link to post
Share on other sites

Unfortuanately i'm not that skilled, to make mod :( . I'would just like to use this very usefull and worldly wanted calendar.

 

I think this is the most used calendar script in combination with oscommerce in the world, but i'm suprised after installation I discovered it does not support for my opinion basic function - links for multiple day events. It looks like event last only 1 day, and is also very easy to overlook particular event which actually lasts several days.

 

I had an opportunity to work as an administrator with some other calendar which supported this 'multiple day linking'. Unfortunately I'm not good enough to use it on oscommerce.

 

Well I also encourage, if there is someone or maybe an author himself, that would upgrade calendar to enable multiple links for events that last more than one day.

Share this post


Link to post
Share on other sites

I just installed this contrib a couple of days ago and have it working to a degree. I have the events box on the left side and it is only showing whitespace in the box. When I enable scrolling in boxes/calendar.php for the iframe I can then scroll down to see the calendar, but the top portion is still white. Any idea how I can fix this?

Any suggestions would be greatly appreciated.

Share this post


Link to post
Share on other sites

Hi!

 

I have a same problem, as below! So I installed the latest version of this contrib, and in the admin section while filling out the form of the new events, THERE IS NOT any button, or link for save the events! ? not any error message.... ???

When I try to link the events with a category, or products, after selecting the product, the "link form" has reseted. Sorry for my bad english at all! :)

 

Thanks for your help guyz!

 

Cheers,

 

B.

Share this post


Link to post
Share on other sites

Is there a way to add multiple external web links to the bottom of event details pages rather than just one? I tried adding a href entries in the body but when I have ' or " in the link \\\ is automatically added.

 

Anthony

Edited by analli

Share this post


Link to post
Share on other sites
Is there a way to add multiple external web links to the bottom of event details pages rather than just one? I tried adding a href entries in the body but when I have ' or " in the link \\\ is automatically added.

 

Anthony

 

A new update was released but I have new issues.

 

1) When I insert an a href link in the body of the event, I CAN view the link in the preview but when I take the next step and save the event it turns out to be 0 bytes with no text in the body of any kind.

 

2) The heading bar background color for some reason changed from the default grey to a beige color. This does not match any other part of my site's color scheme.

 

Anthony

Share this post


Link to post
Share on other sites

i d love to know if there are still people who want to work hard on this contribution, im willing to be a part of it , i just saw the last release:

 

Events Calendar for 2.2 MS2 eurolife 1 May 2007

 

This is a update from the previos versions released.

 

There was a javascript typo in the catalog/inlcudes/classes/calendar.php file that would create a bad link when you added events to the calendar.

 

This contrib is a mixture between the original

Events calendar 2.0 MS2 Ivan Pascutti 7 Aug 2003

and the

Events Calendar Update pnkranger 3 May 2006

 

and when i compare to my file i see we are loosing features like :

 

- in the catalog\includes\boxes : a link to the event calendars page

- in my version i installed the patch for the multilanguage month NAMES given in the forum here

 

 

and i hope that eurolife could explain us what is the changing in the class file and what errors he founded previously :

 

 

he change this line :

 $s .= (($link == "") ? $d : "<a href=java script:// onClick=top.window.location=\"$link\" title=\"$click\">$d</a>");

 

to this line :

				 $s .= (($link == "") ? $d : "<a href=\"$link\" target=\"_parent\" title=\"$click\">$d</a>");

 

by the way i would like to make a list of todo and bug that are still remaining i can begin by requests :

 

 

TODO IN FUTUR:

- when adding a image to an event to be able to give a size to it so that she dont take all the page if she is in large format

- checking the css to have something that would work in all shops , black bagrounk shop included

- finding a solution to the iframe using

- being able to use european and american format date

- having the javascript calendar in multilanguage


MS2

Share this post


Link to post
Share on other sites

PLEASE CAN SOMEONE HELP ME....

 

I've installed the Event Calendar and whilst it looks great... it doesn't work correctly. My immediate problems are:

 

1. In the iframe/info box when I click either < or > to move to the next month it just defaults to December everytime.

 

2. I am able to enter Events via Admin and when I call them from catalog site they display the text heading of the event but I can not click on the event to obtain more information.

 

3. I'm unable to delete an event via Admin - I click the delete button but nothing deletes.

 

I have been struggling with this problem for months and I have updated to various versions of the contribution to no avail, I have read countless forum postings but haven't come across anyone mention these type of issues.

 

However what I have concluded is that it MAY have something to do with Register Globals which I set to OFF via the Register Global contribution at my intital install. I have read that this can often be the problem why many contributions do not work. ??

 

I really do not know if this is an issue and some guidance would be helpful please. I have read the fix in Register Globals regarding OTHER_CONTRIBUTIONS re: Annoy_factor etc but I just don't get it, can not work out what I am meant to do and of course I don't know if this is indeed the problem??

 

Please if anyone reading this thinks they understand my problem, any assistance would be appreciated.

 

Thanks

Leigh B)

Share this post


Link to post
Share on other sites

again...:(

 

Hi!

 

I have a same problem, as below! So I installed the latest version of this contrib, and in the admin section while filling out the form of the new events, THERE IS NOT any button, or link for save the events! ? not any error message.... ???

When I try to link the events with a category, or products, after selecting the product, the "link form" has reseted. Sorry for my bad english at all! smile.gif

 

Thanks for your help guyz!

 

Cheers,

 

B.

 

I hope somebody could help me! ;)

Share this post


Link to post
Share on other sites

Regarding images in event listings... I find that when I am editing an event that has an image file included, despite the image appearing in the bottom right of the event editor unless I REATTACH the image it will be lost on saving.

 

Is there a way to have the image retained as to avoid reattaching every time I edit?

 

Anthony

Share this post


Link to post
Share on other sites
by the way i would like to make a list of todo and bug that are still remaining i can begin by requests :

TODO IN FUTUR:

- when adding a image to an event to be able to give a size to it so that she dont take all the page if she is in large format

- checking the css to have something that would work in all shops , black bagrounk shop included

- finding a solution to the iframe using

- being able to use european and american format date

- having the javascript calendar in multilanguage

 

i would like to have different event categories like example:

- Motorcycle events

- Bycicle events

and so on

Share this post


Link to post
Share on other sites
by the way i would like to make a list of todo and bug that are still remaining i can begin by requests :

TODO IN FUTUR:

- when adding a image to an event to be able to give a size to it so that she dont take all the page if she is in large format

- checking the css to have something that would work in all shops , black bagrounk shop included

- finding a solution to the iframe using

- being able to use european and american format date

- having the javascript calendar in multilanguage

 

i would like to have different event categories like example:

- Motorcycle events

- Bycicle events

and so on

Share this post


Link to post
Share on other sites

Hey,

 

I had the same issue and although I'm not sure what prompted the issue to begin with, the fix (or at least my fix) is to take a look at line 346 of your catalog/admin/events_manager.php file.

 

remove the following bit of code and your Event Manager administration should render as expected.

 

<?php include(DIR_WS_BOXES . 'event_drop_dns.php'); ?>

 

 

Hope this helps someone

Scott

 

 

 

 

 

 

again...:(

 

Hi!

 

I have a same problem, as below! So I installed the latest version of this contrib, and in the admin section while filling out the form of the new events, THERE IS NOT any button, or link for save the events! ? not any error message.... ???

When I try to link the events with a category, or products, after selecting the product, the "link form" has reseted. Sorry for my bad english at all! smile.gif

 

Thanks for your help guyz!

 

Cheers,

 

B.

 

I hope somebody could help me! ;)

Share this post


Link to post
Share on other sites

Thanks for the tip, worked for me.

 

 

 

Hey,

 

I had the same issue and although I'm not sure what prompted the issue to begin with, the fix (or at least my fix) is to take a look at line 346 of your catalog/admin/events_manager.php file.

 

remove the following bit of code and your Event Manager administration should render as expected.

 

<?php include(DIR_WS_BOXES . 'event_drop_dns.php'); ?>

Hope this helps someone

Scott


_________________________________________________________________________

 

David G Aschenbrener

Tranquil | Sense - Your Stop for Tranquility.

Share this post


Link to post
Share on other sites

Great contrib! I just installed on my test site and everything seems to work with the contrib. I'm having a problem though with two different button that perform the same function, just in different screens. The "Back" button on the Product info page and the "Continue Shopping" button on the shopping cart page.

 

Both of these worked fine before the Event calender was installed, but since I installed it, when either of those two buttons are clicked, it takes you to this link

 

http://pinetreecandles.com/catalog/calenda...nth=&_year=

 

It doens't matter if your logged in or not and from what page you come from. I unistalled it and the buttons worked fine again so I know it's something to do with this contrib. I really don't see how it would effect those, but it is.

 

Anyone have any ideas as to what may be happening?

 

Thanks


Currently running 76 contibutions.

Share this post


Link to post
Share on other sites

 

I have added some simple formating to introduce some whitespace.

 

to do the same:

in eventscalendar.php

at line 207

replace:

<?php
       }
echo stripslashes($event_array['description']);
?>

 

with:

<?php
       }
       $description = stripslashes($event_array['description']);
$description = ereg_replace("\r",'',$description);
$description = ereg_replace("\n\n",'</p><p>',$description);
$description = ereg_replace("\n",'<br />',$description);
echo ("$description");
?>

 

does anyone know how to get rid of the backslash created by the apostrophe when you add an OSC Link?

Edited by VibeX

Rob

----------

working on a way to make Price Groups, any ideas?

Share this post


Link to post
Share on other sites

Hi all,

 

I've installed this contrib (May 2nd download) and checked all the code changes twice but am getting the following errors:

 

Parse error: syntax error, unexpected T_VARIABLE in /home//public_html/includes/boxes/calendar.php on line 1

 

and selecting Events Manager in the Admin Tool...

Parse error: syntax error, unexpected T_REQUIRE in /home/public_html/admin/events_manager.php on line 1

 

I'm a bit lost - can anyone shed any light? :blink:

 

Thanks in advance.

Share this post


Link to post
Share on other sites
Hi all,

 

I've installed this contrib (May 2nd download) and checked all the code changes twice but am getting the following errors:

 

Parse error: syntax error, unexpected T_VARIABLE in /home//public_html/includes/boxes/calendar.php on line 1

 

and selecting Events Manager in the Admin Tool...

Parse error: syntax error, unexpected T_REQUIRE in /home/public_html/admin/events_manager.php on line 1

 

I'm a bit lost - can anyone shed any light? :blink:

 

Thanks in advance.

 

Sounds like you may have an ' where there shouldn't be

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×