Jump to content
Sign in to follow this  
Stouffers3

Facebook Connect Support Thread

Recommended Posts

sorry i had not have time :blush: ... but i will

 

:D This is absolutely worth waiting for, I'm just thankful that you taking your time to help.

 

//Andreas

Edited by addeaz

Share this post


Link to post
Share on other sites

Hi. im facing a problem wich im not able to solve by reading diffrent solutions in the internet

 

the problem is that i have a quiet heavily modefied shop. and when i push the button on the login page. i get this script error

 

FB.login() called before calling FB.init().

 

in firefox debug console.

 

i have been searching for solutions to this problem. and one problem could be that the same file is loaded twice. but thats not the case.

Share this post


Link to post
Share on other sites

sorry i had not have time :blush: ... but i will

 

 

Hi!

In login.php I tryed to change the css from <link rel="stylesheet" type="text/css" href="stylesheet.css"> to <link rel="stylesheet" type="text/css" href=""> to just test if that do change the issue. The same issue still appear, that it is still the same problem with the login in IE :(

 

One mysterious thing is also that if I have logged in to facebook and then when my site constantly is reloading in IE without getting loggged in to the site, sometimes randomly I get inlogged at my website...this is happening very seldom thou. Strange that it can get connection, but that it mostly don't..

 

Why can't everyone use another browser than IE, than my life would be easier right now..lol B)

 

Please give me some clarification in this issue, if anyone knows what causes this.

 

 

Best Regards

Andreas

Share this post


Link to post
Share on other sites

HI.

 

I try to use the fb connect in my page, but i don,t know why dosn,t work.

 

I look for white spaces, and i read all post about, but when i try to use the button, is like work, but any form from create acount is filled. All forms are empty.

 

Then, if i press again on the button, i go to logoff page, like if i,m identified in the shop.

 

The problem is... no fill forms in create account. Then, no acount create.... (cry..)

 

Can you help me?

 

Thanks.

Share this post


Link to post
Share on other sites

Hi i have added FB connect to my test site. Its a wonderful add-on. However i have a problem with the logout.

 

Login and create account works fine. But when i logout i am redirected to the log off page and it says i am logged out. And when i click the login button now, i am automatically logged in.

 

This happens even if i try after logging out of facebook.

 

Please help..

 

 

Aarthi

Share this post


Link to post
Share on other sites

:D

 

Great... all work right¡ Mmmm.. neely, right.

 

The button in login page some time is load, and some times don,t load.

 

Do you know why?

 

Thanks.

Edited by JaumeUbach

Share this post


Link to post
Share on other sites

Hello,

 

This is a great contribution because most customers will have a facebook account. Has anyone successfully integrated this into OSCommerce v2.3? If so, please help me with login.php, create_account.php and logout.php. There are different because in OSC 2.3 <div>s are used instead of <table>

 

Thanks for any help.

Share this post


Link to post
Share on other sites

Aaaaa shit, my server is running with php4 :( damn. maybe there is a way around... let's hope at least :)

 

 

girolimoni

 

Finally got mine to work! Try adding the following to your .htaccess file... you may or may not have to remove the pound symbols

 

#<IfModule !mod_php5.c>

AddType x-mapp-php5 .php

AddHandler x-httpd-php5 .php

#</IfModule>

Share this post


Link to post
Share on other sites

I have just installed OSC2.3.1 with Facebook Connect.

Great work here!!! Just replace the tr td with div.

The instructions were splendid but it would be good to run xd_receiver.htm to check the link.

 

Have anybody manage to add it into the login box (side column)?

I have look thru the coding but i am very lost here.

Anybody Samaritan care to help and point me to the correct direction?

 

Thks.

Share this post


Link to post
Share on other sites

Hi!

Facebook connect did work for me in januar and suddenly it stopped working, so I uninstalled it. Now I will give it a try again, so I did try to install it in a test-domain Kameraexperten.com

 

When I did install it with my created facebook APP, I was stuck in a constantly loop in the login.php page, this was happened if I already was logged in to my facebookaccount. Sometimes under the constantly loop I did get through with the login and was redirected correctly to the index.php site.

 

I now did try to recreate my Facebook APP and changed to the new data in the fbconnect.php file. Now nothing happens when I click in the facebook login button, no pop-up windows opens. I tryed in most of the browsers.

 

 

Please help me with this awesome addon, here is the link to the login at my test site:

Kameraexperten.com/login.php

 

Best regards

Andreas :)

Edited by addeaz

Share this post


Link to post
Share on other sites

girolimoni

 

Finally got mine to work! Try adding the following to your .htaccess file... you may or may not have to remove the pound symbols

 

#<IfModule !mod_php5.c>

AddType x-mapp-php5 .php

AddHandler x-httpd-php5 .php

#</IfModule>

 

hi thanks, for your post, just tried it, but all the page gets messed up hehe :). any other solution? or does one know know what to alter to upate to php 5?

 

Greetings

Share this post


Link to post
Share on other sites

Hi!

Facebook connect did work for me in januar and suddenly it stopped working, so I uninstalled it. Now I will give it a try again, so I did try to install it in a test-domain Kameraexperten.com

 

When I did install it with my created facebook APP, I was stuck in a constantly loop in the login.php page, this was happened if I already was logged in to my facebookaccount. Sometimes under the constantly loop I did get through with the login and was redirected correctly to the index.php site.

 

I now did try to recreate my Facebook APP and changed to the new data in the fbconnect.php file. Now nothing happens when I click in the facebook login button, no pop-up windows opens. I tryed in most of the browsers.

 

 

Please help me with this awesome addon, here is the link to the login at my test site:

Kameraexperten.com/login.php

 

 

Best regards

Andreas :)

 

 

Hi!

I now tryed to install a new webshop template at Kameraexperten.com. Guess what happened, Everything did work in IE8 and Chrome, bur in Firefox no button is displayed..only the text that is not clickable...I have been trying changing doctype but nothing happens. I'm amazed how hard this Facebook connect integration is and how it works/not works....

 

Anyone got a clue why Firefox does not show the log in button?

 

BR

Andreas

Share this post


Link to post
Share on other sites

Hi!

I now tryed to install a new webshop template at Kameraexperten.com. Guess what happened, Everything did work in IE8 and Chrome, bur in Firefox no button is displayed..only the text that is not clickable...I have been trying changing doctype but nothing happens. I'm amazed how hard this Facebook connect integration is and how it works/not works....

 

Anyone got a clue why Firefox does not show the log in button?

 

BR

Andreas

 

Now I'm more amazed:) ..the button did just display, but nothing happens when I click on it...so still firefox problems....

 

BR

Andreas

Share this post


Link to post
Share on other sites

Now I'm more amazed:) ..the button did just display, but nothing happens when I click on it...so still firefox problems....

 

BR

Andreas

 

I did reinstall Firefox, now it works... Now I just need to figure out, why this testshop works..and not my other highly modificated site works,...

:)

BR

Andreas

Share this post


Link to post
Share on other sites

I did reinstall Firefox, now it works... Now I just need to figure out, why this testshop works..and not my other highly modificated site works,...

:)

BR

Andreas

 

I just wanted to say that I solved it. The thing that disturbed Facebook Connect was my "xbmfl" facebook like-box installation in column_left.php I changed it to an iframe, then it worked!!

 

This was the script I erased/changed to make it work:

<script src="http://connect.facebook.net/en_US/all.js#xfbml=1"></script><fb:like-box href="http://www.facebook.com/pages/StylingAgentense/177623922250291?ref=ts" width="255" show_faces="true" stream="false" header="false"></fb:like-box>

 

I hope it may help anyone else:)

Cheers!! :thumbsup:

Andreas

Edited by addeaz

Share this post


Link to post
Share on other sites

Hi i have added FB connect to my test site. Its a wonderful add-on. However i have a problem with the logout.

 

Login and create account works fine. But when i logout i am redirected to the log off page and it says i am logged out. And when i click the login button now, i am automatically logged in.

 

This happens even if i try after logging out of facebook.

 

Please help..

 

 

Aarthi

 

To prevent autologin, adds this code to the file logoff.php

 

<div id="fb-root"></div>
<script type="text/javascript">
window.fbAsyncInit = function() {
FB.init({appId: '<?=$fbconfig['appid' ]?>', status: true, cookie: true, xfbml: true});
/* All the events registered */
FB.api({ method: 'Auth.revokeAuthorization' }, function(response) {  

});
};
(function() {
var e = document.createElement('script');
e.type = 'text/javascript';
e.src = document.location.protocol + '//connect.facebook.net/en_US/all.js';
e.async = true;
document.getElementById('fb-root').appendChild(e);
}());					
</script>

Share this post


Link to post
Share on other sites

To prevent autologin, adds this code to the file logoff.php

 

<div id="fb-root"></div>
<script type="text/javascript">
window.fbAsyncInit = function() {
FB.init({appId: '<?=$fbconfig['appid' ]?>', status: true, cookie: true, xfbml: true});
/* All the events registered */
FB.api({ method: 'Auth.revokeAuthorization' }, function(response) {  

});
};
(function() {
var e = document.createElement('script');
e.type = 'text/javascript';
e.src = document.location.protocol + '//connect.facebook.net/en_US/all.js';
e.async = true;
document.getElementById('fb-root').appendChild(e);
}());					
</script>

 

Hi, Thanks for your reply, It works great.

Now if i click login after signing out of face book, it goes to login page which is good

But if i had already signed into facebook before visiting the login page, then it automatically logs me in. Just confused. Is this what suppose to happen or should the user be prompted to click connect with facebook again

Share this post


Link to post
Share on other sites

Hi, Thanks for your reply, It works great.

Now if i click login after signing out of face book, it goes to login page which is good

But if i had already signed into facebook before visiting the login page, then it automatically logs me in. Just confused. Is this what suppose to happen or should the user be prompted to click connect with facebook again

 

It always ask to the user to allow connect with facebook again.

 

You can test how it works here: www.farmaciaclubahorro.com

Share this post


Link to post
Share on other sites

It always ask to the user to allow connect with facebook again.

 

You can test how it works here: www.farmaciaclubahorro.com

 

It doesn't happen the same way in my site. When i click login button it directly logs me in - if i have already signed in to face book. I will check the installation instructions and check if i have done something wrong

Share this post


Link to post
Share on other sites

Hi, Thanks for your reply, It works great.

Now if i click login after signing out of face book, it goes to login page which is good

But if i had already signed into facebook before visiting the login page, then it automatically logs me in. Just confused. Is this what suppose to happen or should the user be prompted to click connect with facebook again

 

When you return to log in, if you get an error you need to modify the fbconnect.php

if ($session) {
  try {
    $uid = $facebook->getUser();
    $fbme = $facebook->api('/me');
  } catch (FacebookApiException $e) {
    error_log($e);
  }
}

Share this post


Link to post
Share on other sites

It doesn't happen the same way in my site. When i click login button it directly logs me in - if i have already signed in to face book. I will check the installation instructions and check if i have done something wrong

 

First of all go to your facebook account and delete the app in your app settings.

 

And check the permissions in the login button.

 

<fb:login-button autologoutlink="true" perms="email,user_birthday,user_location"></fb:login-button>

Share this post


Link to post
Share on other sites

Hello, sorry for my english.

 

This is a great contribution! A lot of thanks. I installed the contribution but i have a problem with the login. Always send me this error:

 

API Error Code: 191

API Error Description: The specified URL is not owned by the application

Error Message: redirect_uri is not owned by the application.

 

I use osCommerce 2.2 RC2 and others contributions installed.

Share this post


Link to post
Share on other sites

Thanks for the addon.

 

Someone with same issue -

I had FB image size problem using Firefox when showing login button

find on login.php:

<p>

<fb:login-button autologoutlink="true" perms="email,offline_access,user_birthday,user_location,user_work_history,user_religion_politics,user_relationships">Login with Facebook</fb:login-button>

</p>

 

Replace with:

<p style="width:190px">

<fb:login-button autologoutlink="true" perms="email,offline_access,user_birthday,user_location,user_work_history,user_religion_politics,user_relationships">Login with Facebook</fb:login-button>

</p>

 

I only find with IE8 I have to refresh the login page to show FB login correctly as it will only show "Login with Facebook" with no link or image - could need some help on this please!


Getting the Phoenix off the ground

Share this post


Link to post
Share on other sites

Hey,

 

I've got the same problem as kahlo. I get this message whenever I hit the Facebook button:

 

API Error Code: 191

API Error Description: The specified URL is not owned by the application

Error Message: redirect_uri is not owned by the application.

 

My website is on a shared server, so the login page looks like this:

 

https://sslrelay.com/mywebsite.co.uk/login.php?osCsid=455a291ab433f2e1113a2d6a32cb7571

 

I have told Facebook that my url and domain are:

http://www.mywebsite.co.uk

mywebsite.co.uk

 

Could it be that the sslrelay.com part of my shared server login page is causing Facebook to reject my website? If so is there a way around this?

 

Cheers,

Daz

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×