Jump to content
Sign in to follow this  
Stouffers3

Facebook Connect Support Thread

Recommended Posts

Hi,

I have been following this thread. I just want to add that I am having the same issue as Andreas. I have installed the contrib and created the app, however in firefox there is a button that does nothing and in IE there is just a small bit of text with no link and no button.

Thank you

Share this post


Link to post
Share on other sites

Hi!

I'm trying to integrate this awsome addon, but I'm not getting it to work. On the login page there are no clickable button, only the text "Login with Facebook ". Do anyone know what's wrong? Pleeeeaase help me...I need to get this work! :)

Here is my login.php code:

<?php
/*
 $Id: login.php 1739 2007-12-20 00:52:16Z hpdl $

 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

//Facebook Connect
include 'includes/classes/facebook.php';
include_once "fbconnect.php";

//if user is logged in and session is valid.
if ($fbme){
//collect some data using legacy api
   $param  =   array(
   	'method'     => 'users.getinfo',
       'uids'       => $fbme['id'],
       'fields'     => 'birthday_date, locale',
       'callback'   => ''
   );

   try{
       $info           =   $facebook->api($param);
   }
   catch(Exception $o){
       error_log("Legacy Api Calling Error!");
   }
}
//end of Facebook Connect

 require('includes/application_top.php');

// redirect the customer to a friendly cookie-must-be-enabled page if cookies are disabled (or the session has not started)
 if ($session_started == false) {
   tep_redirect(tep_href_link(FILENAME_COOKIE_USAGE));
 }

 require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_LOGIN);

 $error = false;
 if (isset($HTTP_GET_VARS['action']) && ($HTTP_GET_VARS['action'] == 'process')) {
   $email_address = tep_db_prepare_input($HTTP_POST_VARS['email_address']);
   $password = tep_db_prepare_input($HTTP_POST_VARS['password']);

// Check if email exists
   $check_customer_query = tep_db_query("select customers_id, customers_firstname, customers_password, customers_email_address, customers_default_address_id from " . TABLE_CUSTOMERS . " where customers_email_address = '" . tep_db_input($email_address) . "'");
   if (!tep_db_num_rows($check_customer_query)) {
     $error = true;
   } else {
     $check_customer = tep_db_fetch_array($check_customer_query);
// Check that password is good
     if (!tep_validate_password($password, $check_customer['customers_password'])) {
       $error = true;
     } else {
       if (SESSION_RECREATE == 'True') {
         tep_session_recreate();
       }

       $check_country_query = tep_db_query("select entry_country_id, entry_zone_id from " . TABLE_ADDRESS_BOOK . " where customers_id = '" . (int)$check_customer['customers_id'] . "' and address_book_id = '" . (int)$check_customer['customers_default_address_id'] . "'");
       $check_country = tep_db_fetch_array($check_country_query);

       $customer_id = $check_customer['customers_id'];
       $customer_default_address_id = $check_customer['customers_default_address_id'];
       $customer_first_name = $check_customer['customers_firstname'];
       $customer_country_id = $check_country['entry_country_id'];
       $customer_zone_id = $check_country['entry_zone_id'];
       tep_session_register('customer_id');
       tep_session_register('customer_default_address_id');
       tep_session_register('customer_first_name');
       tep_session_register('customer_country_id');
       tep_session_register('customer_zone_id');

       tep_db_query("update " . TABLE_CUSTOMERS_INFO . " set customers_info_date_of_last_logon = now(), customers_info_number_of_logons = customers_info_number_of_logons+1 where customers_info_id = '" . (int)$customer_id . "'");

// restore cart contents
       $cart->restore_contents();

       if (sizeof($navigation->snapshot) > 0) {
         $origin_href = tep_href_link($navigation->snapshot['page'], tep_array_to_string($navigation->snapshot['get'], array(tep_session_name())), $navigation->snapshot['mode']);
         $navigation->clear_snapshot();
         tep_redirect($origin_href);
       } else {
         tep_redirect(tep_href_link(FILENAME_DEFAULT));
       }
     }
   }
 }

 if ($error == true) {
   $messageStack->add('login', TEXT_LOGIN_ERROR);
 }

 $breadcrumb->add(NAVBAR_TITLE, tep_href_link(FILENAME_LOGIN, '', 'SSL'));
?>
<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">
<html <?php echo HTML_PARAMS; ?>>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">
<title><?php echo TITLE; ?></title>
<base href="<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_CATALOG; ?>">
<link rel="stylesheet" type="text/css" href="stylesheet.css">
<script type="text/javascript" src="iepngfix_tilebg.js"></script>
<style type="text/css">
.ie6_png 			{behavior: url("iepngfix.htc") }
.ie6_png img		{behavior: url("iepngfix.htc") }
.ie6_png input		{behavior: url("iepngfix.htc") }
</style>
<!--[if IE]>
  <script type="text/javascript" src="ie_png.js"></script>
  <script type="text/javascript">
      ie_png.fix('.png');
  </script>
<![endif]-->
<script language="javascript"><!--
function session_win() {
 window.open("<?php echo tep_href_link(FILENAME_INFO_SHOPPING_CART); ?>","info_shopping_cart","height=559,width=445,toolbar=no,statusbar=no,scrollbars=yes").focus();
}
//--></script>
</head>
<body>
<!-- header //-->
<?php $tab_sel = 6; ?>
<?php require(DIR_WS_INCLUDES . 'header.php'); ?>
<!-- header_eof //-->

<!-- body //-->
<table border="0" class="<?php echo MAIN_TABLE; ?>" cellspacing="0" cellpadding="0">
<tr>
   <td class="<?php echo BOX_WIDTH_TD_LEFT; ?>"><table border="0" class="<?php echo BOX_WIDTH_LEFT; ?>" cellspacing="0" cellpadding="0">
<!-- left_navigation //-->
<?php require(DIR_WS_INCLUDES . 'column_left.php'); ?>
<!-- left_navigation_eof //-->
   </table></td>
<!-- body_text //-->
   <td class="<?php echo CONTENT_WIDTH_TD; ?>"><?php echo panel_top(); ?><?php echo tep_draw_form('login', tep_href_link(FILENAME_LOGIN, 'action=process', 'SSL')); ?>

<?php echo tep_draw_top();?>

<?php echo tep_draw_title_top();?>

			<?php echo HEADING_TITLE; ?>

<?php echo tep_draw_title_bottom();?>

<?php echo tep_draw1_top();?>

<?php
 if ($messageStack->size('login') > 0) {
?>
   <table cellpadding="0" cellspacing="0" border="0">
  <tr>
       <td><?php echo $messageStack->output('login'); ?></td>
     </tr>
     <tr>
       <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
     </tr>
</table>
<?php
 }

 if ($cart->count_contents() > 0) {
?>
   <table cellpadding="0" cellspacing="0" border="0">
  <tr><td style="padding:0px 10px 0px 10px;" class="smallText"><?php echo TEXT_VISITORS_CART; ?></td></tr>
</table>

<?php echo tep_pixel_trans();?>

<?php
 }
?>
<table border="0" width="100%" cellspacing="0" cellpadding="0">
         <tr>
           <td class="main indent_2" width="50%"><b><?php echo HEADING_NEW_CUSTOMER; ?></b></td>
		<td><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>
           <td class="main indent_2" width="50%"><b><?php echo HEADING_RETURNING_CUSTOMER; ?></b></td>
         </tr>
         <tr>
           <td width="50%" height="100%">

<?php echo tep_draw_infoBox_top();?>

			<table border="0" width="100%" height="100%" cellspacing="5" cellpadding="0" style="height:240px;">
                 <tr>
                   <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
                 </tr>
                 <tr>
                   <td class="main" style="height:100%;"><?php echo TEXT_NEW_CUSTOMER . '<br><br>' . TEXT_NEW_CUSTOMER_INTRODUCTION; ?></td>
                 </tr>
                 <tr>
                   <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
                 </tr>
                 <tr>
                   <td><table border="0" width="100%" cellspacing="0" cellpadding="2">
                     <tr>
                       <td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>
                       <td align="right"><?php echo '<a href="' . tep_href_link(FILENAME_CREATE_ACCOUNT, '', 'SSL') . '">' . tep_image_button('button_continue.gif', IMAGE_BUTTON_CONTINUE) . '</a>'; ?></td>
                       <td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>
                     </tr>
                   </table>

				</td>
                 </tr>
               </table>

<?php echo tep_draw_infoBox_bottom();?>

		</td>
		<td><?php echo tep_draw_separator('pixel_trans.gif', '1', '1'); ?></td>
           <td width="50%" height="100%">

<?php echo tep_draw_infoBox_top();?>

			<table border="0" width="100%" height="100%" cellspacing="5" cellpadding="0" style="height:240px;">
                 <tr><td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td></tr>
                 <tr> <td class="main" colspan="2"><?php echo TEXT_RETURNING_CUSTOMER; ?></td></tr>
                 <tr><td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td></tr>
                 <tr><td class="main"><b><?php echo ENTRY_EMAIL_ADDRESS; ?></b></td></tr>
                 <tr><td class="main"><?php echo tep_draw_input_field('email_address'); ?></td></tr>
                 <tr><td class="main"><b><?php echo ENTRY_PASSWORD; ?></b></td></tr>
                   <td class="main"><?php echo tep_draw_password_field('password'); ?></td></tr>
                 <tr><td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td></tr>
                 <tr><td class="smallText"><?php echo '<a href="' . tep_href_link(FILENAME_PASSWORD_FORGOTTEN, '', 'SSL') . '">' . TEXT_PASSWORD_FORGOTTEN . '</a>'; ?></td></tr>
                 <tr><td height="100%"><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td></tr>
                 <tr><td>
                 	<table border="0" width="100%" cellspacing="0" cellpadding="2">
                     <tr>
                       <td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>
                       <td align="right"><?php echo tep_image_submit('button_login1.gif', IMAGE_BUTTON_LOGIN); ?></td>
                       <td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>
                     </tr>

                     <tr>
<td>
<div id="fb-root"></div>
       <script type="text/javascript">
           window.fbAsyncInit = function() {
               FB.init({appId: '<?=$fbconfig['appid' ]?>', status: true, cookie: true, xfbml: true});

               /* All the events registered */
               FB.Event.subscribe('auth.login', function(response) {
                   // do something with response
                   login();
               });
               FB.Event.subscribe('auth.logout', function(response) {
                   // do something with response
                   logout();
               });
           };
           (function() {
               var e = document.createElement('script');
               e.type = 'text/javascript';
               e.src = document.location.protocol +
                   '//connect.facebook.net/en_US/all.js';
               e.async = true;
               document.getElementById('fb-root').appendChild(e);
           }());

           function login(){
               document.location.href = "login.php";
           }

           function logout(){
               document.location.href = "logoff.php";
           }

           function createAccount(){
               document.location.href = "create_account.php";
           }

</script>
   <p>
       <fb:login-button autologoutlink="true" perms="email,offline_access,user_birthday,user_location,user_work_history,user_religion_politics,user_relationships">Login with Facebook</fb:login-button>
   </p>
   <?php
   if($fbme>0){ 
    $fb_customer_query = tep_db_query("select customers_id, customers_firstname, customers_password, customers_email_address, customers_default_address_id from " . TABLE_CUSTOMERS . " where customers_email_address = '" . $fbme['email'] . "'");
   	$fb_customer_check = tep_db_num_rows($fb_customer_query);

    if($fb_customer_check > 0){
    	$fb_customer = tep_db_fetch_array($fb_customer_query);
    	$fb_country_query = tep_db_query("select entry_country_id, entry_zone_id from " . TABLE_ADDRESS_BOOK . " where customers_id = '" . (int)$fb_customer['customers_id'] . "' and address_book_id = '" . (int)$fb_customer['customers_default_address_id'] . "'");
        $fb_country = tep_db_fetch_array($fb_country_query);
    	$customer_id = $fb_customer['customers_id'];
    	$customer_default_address_id = $fb_customer['customers_default_address_id'];
    	$customer_first_name = $fb_customer['customers_firstname'];
    	$customer_country_id = $fb_country['entry_country_id'];
    	$customer_zone_id = $fb_country['entry_zone_id'];
    	tep_session_register('customer_id');
    	tep_session_register('customer_default_address_id');
    	tep_session_register('customer_first_name');
    	tep_session_register('customer_country_id');
    	tep_session_register('customer_zone_id');

   		tep_db_query("update " . TABLE_CUSTOMERS . " set fb_user_id = " . $fbme['id'] . " where customers_id = '" . (int)$customer_id . "'");
   		tep_db_query("update " . TABLE_CUSTOMERS_INFO . " set customers_info_date_of_last_logon = now(), customers_info_number_of_logons = customers_info_number_of_logons+1 where customers_info_id = '" . (int)$customer_id . "'");


    	//restore cart contents
    	$cart->restore_contents();

        if (sizeof($navigation->snapshot) > 0) {
          $origin_href = tep_href_link($navigation->snapshot['page'], tep_array_to_string($navigation->snapshot['get'], array(tep_session_name())), $navigation->snapshot['mode']);
          $navigation->clear_snapshot();
          echo "<script type='text/javascript'>document.location.href = '".$origin_href."';</script>";

        } else {
          echo "<script type='text/javascript'>document.location.href = '".FILENAME_DEFAULT."';</script>";
       	}
   	}else{
       	echo "<script type='text/javascript'>document.location.href = '".FILENAME_CREATE_ACCOUNT."';</script>";
    	}
}

   ?>
</td>
</tr>
                   </table>
                 </td></tr>
               </table>

<?php echo tep_draw_infoBox_bottom();?>

		</td>
         </tr>
       </table>

<?php echo tep_draw1_bottom();?>

<?php echo tep_draw_bottom();?>

</form></td>
<!-- body_text_eof //-->
<td class="<?php echo BOX_WIDTH_TD_RIGHT; ?>"><table border="0" class="<?php echo BOX_WIDTH_RIGHT; ?>" cellspacing="0" cellpadding="0">
<!-- right_navigation //-->
<?php require(DIR_WS_INCLUDES . 'column_right.php'); ?>
<!-- right_navigation_eof //-->
   </table></td>
 </tr>
</table>
<!-- body_eof //-->

<!-- footer //-->
<?php require(DIR_WS_INCLUDES . 'footer.php'); ?>
<!-- footer_eof //-->
</body>
</html>
<?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?>

 

Cheers!

 

//Andreas

 

 

Andreas,

I found on another thread that if you add

 

 

<html xmlns:fb="http://www.facebook.com/2008/fbml" xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">

 

your buttom will appear in IE from the plain text.

Now, for me this buttom still does not do anything.

Share this post


Link to post
Share on other sites

Andreas,

I found on another thread that if you add

 

 

<html xmlns:fb="http://www.facebook.com/2008/fbml" xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">

 

your buttom will appear in IE from the plain text.

Now, for me this buttom still does not do anything.

 

Hi Jellybean!

I will try that and reply how it worked, thanx for your help so far!!

 

I hope you get it to work soon!

 

BR

 

Andreas

Share this post


Link to post
Share on other sites

Hi Jellybean!

I will try that and reply how it worked, thanx for your help so far!!

 

I hope you get it to work soon!

 

BR

 

Andreas

 

 

Hi again!

I still have the same problem after trying that update. I see that I also have the samr problem in create_account.php,only the text appear and no button. :(

 

Did anyone get this worked?

 

 

//Andreas

Share this post


Link to post
Share on other sites

Hi again!

I still have the same problem after trying that update. I see that I also have the samr problem in create_account.php,only the text appear and no button. :(

 

Did anyone get this worked?

 

 

//Andreas

 

Hi again!

I'm going through the code, I,m kinda rookie in php, but since I can't see any image source in the code instructions...I don't get it :'(

 

//Andreas

Share this post


Link to post
Share on other sites

Hi again!

I'm going through the code, I,m kinda rookie in php, but since I can't see any image source in the code instructions...I don't get it :'(

 

//Andreas

 

Now the button is showed! I had a whitespace in the application code that I filled in to the fbconnect.php file. With the fix you told about Jelly, I also solved the IE8 button fixed problem.

 

Now I got this fault when I click the login button

 

"API Error Code: 191

API Error Description: The specified URL is not owned by the application

Error Message: redirect_uri is not owned by the application."

 

I will start to research what the problem may be, if anyone have a clue, feel free to tell me :) . I did fill in the website URL in the settings for the application i FB.

 

Cheers

Andreas

Share this post


Link to post
Share on other sites

Now the button is showed! I had a whitespace in the application code that I filled in to the fbconnect.php file. With the fix you told about Jelly, I also solved the IE8 button fixed problem.

 

Now I got this fault when I click the login button

 

"API Error Code: 191

API Error Description: The specified URL is not owned by the application

Error Message: redirect_uri is not owned by the application."

 

I will start to research what the problem may be, if anyone have a clue, feel free to tell me :) . I did fill in the website URL in the settings for the application i FB.

 

Cheers

Andreas

 

 

Hi

It works great now! The fault above was a setting issue in my application in FB, as I thought. I question thou, when I logged in and then log out. The site will automatically log in when I'm in login.php without me clicking the facebook button. Should it be like this, can I change that setting?

 

Cheers again!

Andreas

Share this post


Link to post
Share on other sites

Hi Again,

Im glad it is working. Unfortunately, I have all the buttone where i want them but my buttons dont do anything. I gave checked for white spaces. I dont get any error message. The buttons seem to click when you hover over them, but nothing after that. Is it on the facebook app side? The whole canvas url thing ....Im just not sure about it.

Share this post


Link to post
Share on other sites

Hi Again,

Im glad it is working. Unfortunately, I have all the buttone where i want them but my buttons dont do anything. I gave checked for white spaces. I dont get any error message. The buttons seem to click when you hover over them, but nothing after that. Is it on the facebook app side? The whole canvas url thing ....Im just not sure about it.

 

Hi!

Strange, my first problem, when the button did not displayed, I had the unique ID's like below in fbconnect.php file, it became like that when I copy-pasted. It was no white-space, but a new row. It was like the for all my ID-keys. When I changed this, the button did appear again.

 

Was

$fbconfig['api' ] = "XXXXXXXXXXXXX

"; //your api key

 

Should be

$fbconfig['api' ] = "XXXXXXXXXXXXX"; //your api key

 

Good luck!

//Andreas

Share this post


Link to post
Share on other sites

I have install it but the array $fbme is empty. I can allow the fb application and log-in with facebook screen but no data are received with the call

 

$fbme = $facebook->api('/me');

 

CURL and JSON extensions are both installed on my server. I don't know what else check, can you please help? Thanks.


My osCommerce of italian brands shoes and bags

Share this post


Link to post
Share on other sites

Please forgive me in advance I'm new to osCommerce and PHP, old school HTML guy here...slowly but surely I'm getting there :)

 

Three Questions:

1. I do not understand this step in the directions: 4. Run the database.sql file

I saw it referenced in the previous posts, but did not see any (or understand) responses

 

2. What location are the folling files at: login.php, logoff.php, & create_account.php

I am 99% sure its the files in the directory /catalog/

 

3. What is this whitespace issue I see in a lot of the posts? I've done some research, but still a bit confused.

 

 

Thanks

Edited by RotheStyle

Share this post


Link to post
Share on other sites

Please forgive me in advance I'm new to osCommerce and PHP, old school HTML guy here...slowly but surely I'm getting there :)

 

Three Questions:

1. I do not understand this step in the directions: 4. Run the database.sql file

I saw it referenced in the previous posts, but did not see any (or understand) responses

 

2. What location are the folling files at: login.php, logoff.php, & create_account.php

I am 99% sure its the files in the directory /catalog/

 

3. What is this whitespace issue I see in a lot of the posts? I've done some research, but still a bit confused.

 

 

Thanks

 

1. Andes1 answers this on page 3 of this thread. The confusing part is that the sql file wasn't actually included in the download I used. The command is: ALTER TABLE customers ADD fb_user_id VARCHAR(32);

 

2. Correct, your root directory, whatever that is.

 

3. I didn't have this issue, but they discuss it on page one. Whitespace is unseen tabs, line returns and spacebar spaces. Some text editors will let you view whitespace. In this case they are talking about the whitespace at the end of the file it looks like.

 

Good Luck, and this extension works in my heavily modified store.

Share this post


Link to post
Share on other sites

Now the button is showed! I had a whitespace in the application code that I filled in to the fbconnect.php file. With the fix you told about Jelly, I also solved the IE8 button fixed problem.

 

Now I got this fault when I click the login button

 

"API Error Code: 191

API Error Description: The specified URL is not owned by the application

Error Message: redirect_uri is not owned by the application."

 

I will start to research what the problem may be, if anyone have a clue, feel free to tell me :) . I did fill in the website URL in the settings for the application i FB.

 

Cheers

Andreas

 

Hi Andreas,

 

I still have the same problem you have reported with the error about having to enter the gender after the fb login. What exactly have you done to fix that, please? And also, can you please tell me what setting was wrong? I really wish to use this contrib...

 

Regards

brok

Share this post


Link to post
Share on other sites

Parse error: syntax error, unexpected '{' in /www/site.com/addon_domains/site.com/www/root/catalog/login.php on line 26

 

What I have to do, please help me, because I really need this addon

 

Thanks

And Happy New Year

Share this post


Link to post
Share on other sites

Hi

It works great now! The fault above was a setting issue in my application in FB, as I thought. I question thou, when I logged in and then log out. The site will automatically log in when I'm in login.php without me clicking the facebook button. Should it be like this, can I change that setting?

 

Cheers again!

Andreas

 

 

Hi, I am having the same problem. After I log out and visit login.php, after few seconds I am automatically logged in and redirected to index.php without clicking the facebook login button.

I do not want this.

 

Can anyone share solution how to solve it?

thanx

Share this post


Link to post
Share on other sites

Hi Andreas,

 

I still have the same problem you have reported with the error about having to enter the gender after the fb login. What exactly have you done to fix that, please? And also, can you please tell me what setting was wrong? I really wish to use this contrib...

 

Regards

brok

 

Hi!

I got that error message because I had a new row where I did put my API key, as I described before in this thread, so it was a quite easy deviation I had.

 

BR

Andreas

Share this post


Link to post
Share on other sites

Internet Explorer problem!

Hi,

I did integrate Facebook Connect, everythis did work great. Unfortunately it did start to experience problems with Internet Explorer. I does work perfect with Firefox, but with IE, when Im inlogged at Facebook, it does only update the login site constantly with no success to login. This is also making it impossible to login normally, because when Im start typing my to login the normal way, the site is updating after a few seconds when it is trying to login via Facebook.

 

It seems that it is getting connection but it does not transfer the correct info via API back to the webshop?

 

With Firefox, everything works great...it did also work for a couple a week ago with IE. Nothing is changed inte the code or in the settings in the Facebook application,,so it is strange that it just stop working with IE.

 

Thankful for any help!

 

BR

Andreas

Share this post


Link to post
Share on other sites

Does this contribution a security risk of some kind? It is requiring you to put your Facebook API key, application id and application secret unencryped in a catalog level file, fbconnect.php. Any comments or thoughts about that?


Oscommerce site:

 

 

OSC to CSS, http://addons.oscommerce.com/info/7263 -Mail Manager, http://addons.oscommerce.com/info/8120

Share this post


Link to post
Share on other sites

Does this contribution a security risk of some kind? It is requiring you to put your Facebook API key, application id and application secret unencryped in a catalog level file, fbconnect.php. Any comments or thoughts about that?

no risk... only if your site is hacked... please see the security forum

Share this post


Link to post
Share on other sites

Internet Explorer problem!

Hi,

I did integrate Facebook Connect, everythis did work great. Unfortunately it did start to experience problems with Internet Explorer. I does work perfect with Firefox, but with IE, when Im inlogged at Facebook, it does only update the login site constantly with no success to login. This is also making it impossible to login normally, because when Im start typing my to login the normal way, the site is updating after a few seconds when it is trying to login via Facebook.

 

It seems that it is getting connection but it does not transfer the correct info via API back to the webshop?

 

With Firefox, everything works great...it did also work for a couple a week ago with IE. Nothing is changed inte the code or in the settings in the Facebook application,,so it is strange that it just stop working with IE.

 

Thankful for any help!

 

BR

Andreas

 

ill check it monday.. maybe is the doc type or the css

Share this post


Link to post
Share on other sites

ill check it monday.. maybe is the doc type or the css

 

Hi Andrea!

I'm looking forward to any help:)

 

Here is the test site where facebook is integrated

http://stylingagenten.dev.cetrez.com/login.php

 

The suspect thing is that it did work on IE from start, suddenly it decided to not work for IE (nothing is changed inte the code), but it do still work in Firefox.

 

I really love this addon, so hopefully i can solve the problem with some help:)

 

Sincerely

Andreas

Share this post


Link to post
Share on other sites

Does anyone know a fix or work around for the login.php loop? The problem occur if the user decides to change their email on the store account and is different from their Facebook email, while still logged into their Facebook and click to login on the store, then you'll get this loop and you will never be directed to the create account page. Any ideas?

 

andes1...do you have this problem? if you have fixed it, please post solution. thanks.

Edited by ptt81

Share this post


Link to post
Share on other sites

Does anyone know a fix or work around for the login.php loop? The problem occur if the user decides to change their email on the store account and is different from their Facebook email, while still logged into their Facebook and click to login on the store, then you'll get this loop and you will never be directed to the create account page. Any ideas?

 

andes1...do you have this problem? if you have fixed it, please post solution. thanks.

 

no i did not have this problem, maybe because is so rare a customer who wants to change his email address... i think about a contribution to allow the customer to delete his account and create a new one. http://addons.oscommerce.com/info/4799

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×