Jump to content
Sign in to follow this  
catalunian

Big red cross from Google

Recommended Posts

Hi y'all

I have just started trying put my sitemaps on Google using http://www.diamantesdeespanya.es/sitemapindex.xml .Google gives the green light to my sitemappages,sitemapproducts and sitemapcategories but when it comes to my sitemap.xml i get a big red cross, please check it out https://www.google.com/webmasters/tools/sitemap-details?hl=en&siteUrl=http%3A%2F%2Fwww.diamantesdeespanya.es%2F&sitemapUrl=http%3A%2F%2Fwww.diamantesdeespanya.es%2Fsitemapindex.xml&pl=eyJ0YXJnZXRJZCI6InNpdGVtYXAtbGlzdCIsInBhcmFtcyI6eyJzaXRlVXJsIjoiaHR0cDovL3d3dy5kaWFtYW50ZXNkZWVzcGFueWEuZXMvIiwiaGwiOiJlcyJ9fQ%3D%3D&children.sortBy=5&children.currentOrder=5das you can see it says there are no problems at one stage it did say that the path line was incompatible

"Paths don't match

We've detected that you submitted your Sitemap using a URL path that includes the www prefix (for instance, http://www.example.com/sitemap.xml). However, the URLs listed inside your Sitemap don't use the www prefix (for instance," http://example.com/myfile.htm).

 

Now I have looked at my xml files carefully and it would seem that the problem lies in the domain address because in the sitemap.xml it shows as htpp://diamantesdeespanya.es and not as htpp://www.diamantesdeespanya.es

Here is an small portion to see the whole thing please visit My link http://www.diamantesdeespanya.es/sitemap.xml

<?xml version="1.0" encoding="UTF-8" ?>

- <urlset xmlns="http://www.sitemaps.org/schemas/sitemap/0.9">

- <url>

<loc>http://diamantesdeespanya.es/</loc>

</url>

- <url>

<loc>http://diamantesdeespanya.es/advanced_search.php?osCsid=mef7u49qq4o8ugh05ttai7c2d7</loc>

</url>

- <url>

<loc>http://diamantesdeespanya.es/advanced_search.php?osCsid=rm4bd3o4bhsoird963uc7og723</loc>

</url>

In my sitemapcategories.xml the domain address is formed correctly please visit http://www.diamantesdeespanya.es/admin/file_manager.php?info=sitemapcategories.xml&action=edit

 

I put a small part here:-

<?xml version="1.0" encoding="UTF-8"?>

<?xml-stylesheet type="text/xsl" href="gss.xsl"?>

<urlset xmlns="http://www.google.com/schemas/sitemap/0.84">

<url>

<loc>http://www.diamantesdeespanya.es/index.php?cPath=1</loc>'>http://www.diamantesdeespanya.es/index.php?cPath=1</loc>

<lastmod>2010-08-28</lastmod>

<changefreq>weekly</changefreq>

<priority>0.5</priority>

</url>

<url>

<loc>http://www.diamantesdeespanya.es/index.php?cPath=2</loc>'>http://www.diamantesdeespanya.es/index.php?cPath=2</loc>

<lastmod>2010-08-20</lastmod>

<changefreq>weekly</changefreq>

<priority>0.5</priority>

</url>

<url>

<loc>http://www.diamantesdeespanya.es/index.php?

 

So if anybody could help with this problem of why the the sitemap.xml is formed differently I would be grateful.

I have used this google sitemap before on my other site without any problems and give a vote of thanks to the developers

Edited by catalunian

I live for today I might die tomorrow

Share this post


Link to post
Share on other sites

I have since edited my sitemaps.xmal and inserted the www.into every path and am waitng to see what google says.When google sitemaps program remakes the sitemaps will i need to make this alteration on a regular basis.


I live for today I might die tomorrow

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×