Jump to content
Sign in to follow this  
pyro-ns

Sts install seems to have gone fine, but selecting a template doesn't do anyhting?

Recommended Posts

Hi guys :)

 

I've recently installed OsCommerce and STS is the first module I have installed (ie, I'm running a clean install of OsCommerce). I've tried installing STS twice now (on two separate installs) but I can't seem to get it to work...

 

The first time I manually copied and pasted the files for STS, overwriting as I went. The second time, I just unzipped the contents of STS straight on top of my directory and overwrote as I went.

 

I've since enabled STS and downloaded a few themes for STS to give it a bit of a test, but I can't get it to work. No matter which theme I select, nothing happens to my admin, or my customer side of OsCommerce. I made a few quick and very visible changes to the css of "single" as well, but I can't even see those. I have cleared my cache, tried different browsers, checked and re-checked my settings, but am still turning up blanks.

 

I've been trawling these forums for a little while trying to find the answer, but haven't come across anything like the problem that I'm having, so I'm guessing I've just plain done something wrong. I've been through a few different sources of documentation though and can't find anything additional to what I have done.

 

If anyone can help me, I'd be very grateful :)

 

Thank you for your time,

Josh

Share this post


Link to post
Share on other sites

Josh,

 

Since this is not the support thread for STS, I will only respond this one time here, if you need further help, please visit and post your questions in the proper support thread. You can find this thread link in the STS User Manual as well as in my signature below (STSv4 Forum). When posting in the STSv4 Forum, be sure to click on the "Add Reply" button to post WITHIN the proper thread. Otherwise, you will create an entirely new thread as you have done so here.

 

  1. When installing onto a new osCommerce RC2a (not version 3.x), you should simply upload all of the files WITHIN the STS folder (not the actual STS folder), being sure to keep the file/folder structure intact. The files within the STS folder are new files that are not found in a stock osCommerce RC2a.
  2. The second part of the install is to upload all of the files WITHIN the "Files for RC2" folder (not the actual "Files for RC2" folder), being sure to keep the file/folder structure intact. The files within the "Files for RC2" folder are files that are already found in a stock osCommerce RC2a but have been modified in order to complete the STS installation.
  3. thumbsup.gif After doing the above, it is a good idea to use a file comparison tool such as WinMerge or BeYond Compare to compare the files on your server with the files within the STS and "Files for RC2" folders of the STSv4.6 contribution. This will help rule out a bad upload from your FTP Client software. I have seen numerous accounts of users who claimed they had indeed upload all of the required files but in reality, they were using a poor FTP Client software program which had failed them.
  4. Now, the last part of the installation is to login to your admin, and then "Install" the STS Default Module. At this time, simply click on the install button (or Enable) and leave all of the settings in their default status except of course for the "Use Templates" should be set to "True".
  5. Installation is now complete.

See you in the STSv4 Forum.

 

 

 

 

 


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×