Jump to content
Sign in to follow this  
allybeag

Shipping module - table rates - can't get it working

Recommended Posts

We're in the UK, and charge for shipping by weight, so I'm listing all the products' weights and setting up a table. However, when I try putting a product in my shopping cart, and go to the checkout, I get bizarre results. A product weighing 500 grams, which should cost GBP 5.20 for shipping, came up as GBP 37.40. I tried changing the weights to decimal fractions of a kilo, instead of grams, and now the postage comes up as zero. I'm confused!

 

Here's my current shipping table:

0.35:4.10,0.75:5.20,1.25:6.20,1.75:6.90,3.50:9.30,4.90:10.50,7.00:12.50,9.00:13.70,19.00:15.40 (Weights in decimal fractions of a kilo, and prices in GBPounds.

 

I think I'm missing something vital! Can someone advise please?

 

Thanks.

 

ally

Share this post


Link to post
Share on other sites

I have this same problem.

 

I have an item in my cart that is listed as weighing 0.70lbs (in its description), and the shipping is coming up as $11.50, when it should be $6.50

 

This is my table rate info:

1:6.50,3:8.50,6:11.50,10:13.50,15:16.50,20:21.50,30:27.50,40:37.50,50:49.50

 

Is that wrong in anyway?

 

If I am right, I believe that the above table rate info would be translated to be:

0-1lb charge $6.50, 1.1lbs to 2.9lbs charge $8.50, 3.1lbs to 5.9lbs charge $11.50, and so on, right?

 

Also, where would I go to change the name/text "Table Rate"? I wanted to change it to simply say "USPS Priority Mail"

Share this post


Link to post
Share on other sites

Have you changed the tare wt to 0?

 

G


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

If the charge appears to be for your calculated wt +3 check if have you changed the tare wt to 0 as the default is 3.

 

G


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

If the charge appears to be for your calculated wt +3 check if have you changed the tare wt to 0 as the default is 3.

 

G

 

Exactly what the problem was.

 

Thank you sir.

Share this post


Link to post
Share on other sites

Hi there, I am having a bit of confusion with these table rates as well.

 

Currently, I have my table set up as follows:

1.05:4.95,7:10.70,12:14.95,19:25.65,24:29.90,36:44.85

 

I can confirm that my tare weight is set to zero.

 

Upon testing with a product that is set at .25 pounds for weight, It shows the correct shipping rate of $4.95 for 1, 2 and 3 items. However, when I have four items in the cart - which should reflect a weight of 1 pound - the shipping rate is then incorrectly reflected as $10.70.

 

Thoughts?

Share this post


Link to post
Share on other sites

Just a follow up...

 

I adjusted the table to read 1.1 instead of 1.05 for the first rate in the table, and this seems to have it working correctly.

 

Perhaps the rate table only recognizes one digit past the decimal?

Share this post


Link to post
Share on other sites

Sorry for the multiple posts here, but I'm really feeling like there is an element that I am not understanding.

 

In further testing, the shipping still does not seem to be calculating correctly.

Tables are as follows: 1.1:4.95,7:10.70,12:14.95,19:25.65,24:29.90,36:44.85

 

Based on this setup, an order that totals 7 pounds should be charged $10.70 for shipping. However, when I go in and select 7 items that weigh one pound, the shipping is being bumped up to the next rate of $14.95.

 

As before, the tare weight for the packaging is set to zero as my intent is to create flat rates based on weight increments.

 

This is extremely frustrating, as I am spending WAY too much time trying to figure out something that appears to be fairly straightforward.

Share this post


Link to post
Share on other sites

Any luck with your problem? I am having similar issues with a client's store.

Edited by oscarfellini

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×