Jump to content
MailBeez

Automatic Trigger Email Campaigns with MailBeez Modules

Recommended Posts

Merry Christmas

...and a happy new Year!
All the best wishes for the upcoming days!
We would like to say a big thank you to all customers, supporters, users and fans for the thrilling year 2013.
The plans for 2014 are set with high ambitions and you can look forward to many new developments and improvements!
And of course we have not forgotten to set-up a discount campaign (25% off), read more on:



if you want to get a preview of what to expect in 2014, try out the BeezDesk CRM customer insight add-on:


installed in minutes, drop-in and add some code - done.

Edited by burt
remove link

Share this post


Link to post
Share on other sites

Hi,

 

Just installed mailbeez on an osc 2.3.3.4 store and am getting the following error when checking on opt-out graph, have tried removing and re-installing several times (files and database)

 

Warning: Division by zero in /home/username/public_html/adminname/includes/classes/split_page_results.php on line 33

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-0, MAILBEEZ_ANALYTICS_SPLITPAGE_NUM' at line 1

 

select *, c.customers_email_address from mailbeez_block b, customers c where b.customers_id = c.customers_id order by autoemail_id DESC limit -0, MAILBEEZ_ANALYTICS_SPLITPAGE_NUM

 

What could be causing this?

 

Many Thanks


Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Share this post


Link to post
Share on other sites

OK please ignore my previous question, I have now sorted this - but I cant now switch to production from simulation.........


Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Share this post


Link to post
Share on other sites

And ignore that one - it all seems to suddenly work...............


Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Share this post


Link to post
Share on other sites

Bug-Fix: Birthday Modules

Happy New Year!

Like a bad new years joke the MailBeez Birthday Modules (free and premium) have been sending birthday greetings to customers without a given birthday-date.


 

Edited by burt
remove link

Share this post


Link to post
Share on other sites

MailBeez V2.9.3

Just released the new MailBeez V2.9.3 – easy updating with the included update-packs.
Changes since Version 2.9.2:
Enhancements:

  • commerce SEO V2Next compatibility
  • framework enhancements
  • improved CRE Loaded 6.x compatibility
  • support for ZenCart 1.5.2RC (mysqli)
  • smarty 3.1 support
  • improve html code parsing for Outlook compatibility (width and heights attributes are added if dimensions were given only in style attribute)


Bugfixes:

  • fixed included birthday module
Edited by burt
remove link

Share this post


Link to post
Share on other sites

Hi

 

I have just installed the mailbeez module ver. 2.9.3, but when i press the mailbeez link in the admin tools i just get a blank screen. What can be wrong ?

 

My shop i oscommerce 2.2 M2 with PHP version 4.3.9

Share this post


Link to post
Share on other sites

@@jbhobro

 

That is a pretty old shop and might be the reason it is not working...are you upgrading or is this your first time installing Mailbeezs? If it's your first time, you might want to message Cord on his site and see if it works with that version.

Share this post


Link to post
Share on other sites

Hi Dan, ty for the answer.

 

Yes, it is a old shop. But after years work of modifying it to its best, upgrading dont seems like an option.

 

Yes, its a first time install to make use of trustpilot emails.But according to the mailbeez website it should Work on all oscommerce versions. I just dont know if it is working on php 4.

Looks like the new mailbeez version 2.9.3 is just released today ?

I sent a PM to Cord and waiting for answer.

Share this post


Link to post
Share on other sites

MailBeez V2.9.4

Just released the new MailBeez V2.9.4 – easy updating with new simplified update procedure.
and good news for oscommerce 2.3.3.x users: the installation is now 100% drop in thanks to the admin menu plugin - no code changes required!


Enhancements:

  • admin menu plugin for osCommerce 2.3.3.x
  • improved mobile statistics
  • improved template engine for upcoming integrations
  • framework enhancements
  • new simplified update procedure
Edited by burt
remove link

Share this post


Link to post
Share on other sites

Encoding issue.

 

In preview mode and when I send test emails, encoding is fine.

 

But when I send a real email, email title is okay but content is mangled.

 

What is the solution?

 

UTF-8 is what I want and it is set in the email engine.

Share this post


Link to post
Share on other sites

Encoding issue.

 

In preview mode and when I send test emails, encoding is fine.

 

But when I send a real email, email title is okay but content is mangled.

 

What is the solution?

 

UTF-8 is what I want and it is set in the email engine.

 

V. 2.9.5

Share this post


Link to post
Share on other sites

I would say the encoding settings must be different for the test emails than the real emails.

 

Maybe something is happening between "Production" and "Simulation" mode

 

Previewing emails in the admin everything looks okay, regardless of whether it is in production mode or simulation mode.

 

In summary, the only time email encoding appears to be a problem is in production mode when actual emails are sent to the customer. Which is obviously the last place you want there to be problems!

Share this post


Link to post
Share on other sites

Email cord direct on his website as he rarely answers posts here.


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

Encoding issue.

 

In preview mode and when I send test emails, encoding is fine.

 

But when I send a real email, email title is okay but content is mangled.

 

What is the solution?

 

UTF-8 is what I want and it is set in the email engine.

I would say the encoding of your store is different from UTF-8?

 

try to choose "empty" (automatic) encoding in mailbeez > configuration > email engine

Share this post


Link to post
Share on other sites

Hi,

After using MailBeez for a couple of years succesfully, I've just installed the Newsletter Advanced module.

Unfortunatly I can't get it to work.

When I'm trying to "Edit Newsletter" in Newsletter Pro Module > Campaigns >, I just get a blank screen. The URL presnted is this:

http:// www. URL. se/admin/mailbeez.php?app=load_app&app_path=../mailbeez/mb_newsletter/admin_application_plugins/newsletter_items.php&module=mb_newsletter&campaign_id=1

 

I've tried the fix recommended in the FAQ "All popups for advanced modules are blank!" ("Please create a file e.g. “fix.php” in mailhive/common/local/fix.php"), and I've checked that I don't have "Security Pro by FWR Media" installed. But I still don't get it to work.

 

I use MailBeez Version 2.95 on osCommerce 2.2-MS2.

 

Any further hints what I should do?

 

Best regards

Ulf

Edited by liljankoski

Share this post


Link to post
Share on other sites

Hi!

 

i have one weird error, i have an Spanish shop, when modify the birthday greeting module and write "¡" (exclamation mark) all the email encoding goes to trash: letter Ñ, ! marks, accents, etc. appears in bad format.

 

When i erase "¡" the email template fixes.

 

How can i fix this error?

Edited by ladc_314

Share this post


Link to post
Share on other sites

Cord frequently doesn't see these posts...I would suggest posting your question to him directly, using the support area on the mailbeez.com website. His support is excellent so you should get a quick answer there.

Share this post


Link to post
Share on other sites

proudly releasing MailBeez Cloudloader Install & Update:

 

Install & Update MailBeez with a Click

 

Rock-Solid solution with several pre-checks and automatic backup of /mailhive

 

Only files within /mailhive will be updated!

 

post-277634-0-27523300-1410860445_thumb.png

 

http://addons.oscommerce.com/info/9143

 

Install and Update MailBeez on osCommerce 2.2 and 2.3 with a click!

 

Please follow the included instructions (EN and DE), basically

just upload following files:

 

catalog/admin/mailbeez.php

catalog/mailhive/

catalog/mailhive.php

 

add the admin menue entry

 

and you are ready to get the latest MailBeez Version installed.

 

Updates to future Versions of MailBeez can be done with a click!

 

When updating a number of checks are performed to make sure the update will be successful. Also a backup-zip of the current /mailhive installation is created.

 

Only files within /mailhive will be updated!

Edited by burt

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×