Jump to content
Sign in to follow this  
Parikesit

[Contribution] Additional Images Module

Recommended Posts

I use this contribution with the lightbox effect enabled. It works great, but I was expecting if there are more images, the tumbnails of those images also shows up in de lightbox popup.

Now it shows the clicked images, or the images when you click 'prev' or 'next'.

What I want to see is al those thumbails of the extra images, so I can click them as well, being in the lightbox pop up. This way I can easily jump from pic no. 3 to pic no. 12. Now I need to click 9 times on 'next'.

 

Does someone has a solution?

Share this post


Link to post
Share on other sites

If i understand correctly i still cant do this:

 

product page to have thumbnail menu (small pic) with a med main pic with roll over feature. click to get pop up which has thumbnail menu (small pic) with a large main pic with roll over feature.

 

carie

Share this post


Link to post
Share on other sites

did you do this in the installation instructions?

 

--

You may also wish to run the following in your SQL tool, such as phpMyAdmin (provided by

your host). It is not necessary for normal operation, but some have experienced extra

long image names because of the image organization included with this contribution. some

image names may be cut-off because there isn't enough room in the products_image field

of the default shop products table.

 

-- change products_image length to 255.

ALTER TABLE `products` CHANGE `products_image` `products_image` VARCHAR( 255 ) NULL DEFAULT NULL;

--

 

Thanks, can't believe I missed that

Share this post


Link to post
Share on other sites

I use this contribution with the lightbox effect enabled. It works great, but I was expecting if there are more images, the tumbnails of those images also shows up in de lightbox popup.

Now it shows the clicked images, or the images when you click 'prev' or 'next'.

What I want to see is al those thumbails of the extra images, so I can click them as well, being in the lightbox pop up. This way I can easily jump from pic no. 3 to pic no. 12. Now I need to click 9 times on 'next'.

 

Does someone has a solution?

use the popup instead of the lightbox. Sorry at current the lightbox is what it is.

Share this post


Link to post
Share on other sites

If i understand correctly i still cant do this:

 

product page to have thumbnail menu (small pic) with a med main pic with roll over feature. click to get pop up which has thumbnail menu (small pic) with a large main pic with roll over feature.

 

carie

that is correct, that combination is not available in the stock contribution. I didn't see a reason to have 2 completely separate full rollover menus. Seemed overkill to me.

Share this post


Link to post
Share on other sites

having trouble with my popup window size if the product does not have any additional images

 

http://crainartstudi...php?cPath=27_40

 

test4 and test6 have no additional images one entered before update one entered after.

 

any ideas

popup image max width is 600

 

carie

If you are allowing AI to manage your image resizing, then you want to have both settings that refer to "restrict image" to be false. Those settings force your images (through html) to be the sizes specified in the image size settings (like the default shop code does). In this case, the image was not large enough to be resized smaller, so since the image restriction settings are true, the popup makes the image larger then is should be using HTML, but the code calculates the image size as normal and makes the box a size the fit the actual dimensions of the image. hope that makes sense

Share this post


Link to post
Share on other sites

If you are allowing AI to manage your image resizing, then you want to have both settings that refer to "restrict image" to be false. Those settings force your images (through html) to be the sizes specified in the image size settings (like the default shop code does). In this case, the image was not large enough to be resized smaller, so since the image restriction settings are true, the popup makes the image larger then is should be using HTML, but the code calculates the image size as normal and makes the box a size the fit the actual dimensions of the image. hope that makes sense

 

thanks, just in case somone else is looking for same answer.

 

the pop up window was sized to my original picture which was smaller than the pop up setting size. changing the restrict images to false didnt fix it though. i just need originals of proper size.

Share this post


Link to post
Share on other sites

Hi everybody

 

I'm still using the contrib Additional images Version 1 and it's running great! I actually don't want to update it to the latest version as it's running perfectly.

 

Now, I'm currently working on integrating the lightbox effect and it's working for the normal product picture in product_info.php, but I just can't get it to work in the module file /modules/additional images.php.

 

Here's the code in additional_images.php:

 

<?php
 $images_product = tep_db_query("SELECT additional_images_id, products_id, images_description, medium_images, popup_images FROM " . TABLE_ADDITIONAL_IMAGES . " WHERE products_id = '" . $HTTP_GET_VARS['products_id'] . "'");
 if (!tep_db_num_rows($images_product)) {
?>
<br>
<?php
 } else {
?>
<!-- additional_images //-->
<script language="javascript"><!--
function popupImages(url) {
 window.open(url, 'popupWindow', 'toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,resizable=yes,copyhistory=no,width=100,height=100,screenX=150,screenY=150,top=150,left=150')
}
//--></script>
<br> <br> 
<table width="100%">
  <tr>
    <td>

<?php
 $info_box_contents = array();
 $row = 0;
 $col = 0;
 while ($new_products = tep_db_fetch_array($images_product)) {
   $info_box_contents[$row][$col] = array('align' => 'center',
                                          'params' => 'class="smallText" width="33%" valign="top"',
                                          'text' => '<a href="javascript:popupWindow(\'' . tep_href_link(FILENAME_POPUP_ADD_IMAGE, 'imagesID=' . $new_products['additional_images_id']) . '\')">' . tep_image(DIR_WS_IMAGES . $new_products['medium_images'], $new_products['images_description'], DISPLAY_IMAGE_WIDTH, DISPLAY_IMAGE_HEIGHT, 'hspace="5" vspace="5"') . '<br>' . TEXT_CLICK_TO_ENLARGE . '</a>'
                                         );
   $col ++;
   if ($col > 2) {
     $col = 0;
     $row ++;
   }
 }
 new imagesBox($info_box_contents);
?>
    </td>
  </tr>
</table>
<!-- additional_images_eof //-->
<?php
 }
?>

 

 

In the lightbox install file, it's mentioned to add a rel="lightbox" to any link tag. Can someone help me out on this? I just can't get it to work...

 

Any help is highly appreciated.

 

Many thanks

 

- Markus

Share this post


Link to post
Share on other sites

Hi everyone,

 

I finally upgraded to the latest version of additional image successfully but I've noticed something very weird.

Some of the additional images disappear. I noticed that the last letter is missing from the image name,

for example image name is "coat.jpg" but when I check the image properties it says "coa.jpg".

I really don't know what's going on. Does anyone have a clue about what could possibly be causing this?

Share this post


Link to post
Share on other sites

Sorry, I forgot to mention that I have already changed the image length to 255 in the database... :rolleyes:

 

And I have another question too:

Are the additional images always supposed to be deleted when you remove a product?

I have several linked products and when deleting in one category, it naturally deletes the AI for the same product linked in a different category.

Which means you have to keep uploading them...

Edited by JSR

Share this post


Link to post
Share on other sites

did you ask AI to resize the image for you when uploading?

Thanks for the reply - yes, I did. It seems to work if I upload the additional image via the admin, but, when trying to do it via EP it just goes huge, even if I process it after too.

Share this post


Link to post
Share on other sites

Ive some problems:

 

When i enable my watermark there is not coming a watermark only at the thumbnail. How do I fix that?

 

Second when i click: (BOX_CATALOG_IMAGES_PRODUCTS)

I'm getting this error:

Warning: require_once(DIR_WS_LANGUAGES/additional_images_configure.php) [function.require-once]: failed to open stream: No such file or directory in /home/minkyshop/domains/minkyshop.nl/public_html/admin/additional_images_configure.php on line 27

Fatal error: require_once() [function.require]: Failed opening required 'DIR_WS_LANGUAGES/additional_images_configure.php' (include_path='.:/usr/local/lib/php') in /home/minkyshop/domains/minkyshop.nl/public_html/admin/additional_images_configure.php on line 27

Share this post


Link to post
Share on other sites

Ive some problems:

 

When i enable my watermark there is not coming a watermark only at the thumbnail. How do I fix that?

 

Second when i click: (BOX_CATALOG_IMAGES_PRODUCTS)

I'm getting this error:

Warning: require_once(DIR_WS_LANGUAGES/additional_images_configure.php) [function.require-once]: failed to open stream: No such file or directory in /home/minkyshop/domains/minkyshop.nl/public_html/admin/additional_images_configure.php on line 27

Fatal error: require_once() [function.require]: Failed opening required 'DIR_WS_LANGUAGES/additional_images_configure.php' (include_path='.:/usr/local/lib/php') in /home/minkyshop/domains/minkyshop.nl/public_html/admin/additional_images_configure.php on line 27

 

That error when i click in admin on Addiotinal images I mean:

 

FIX:

When i click on:

 

You database needs updated before this will operate correctly. Please run configuration utility.

 

That is in red. When i'm running the configuration utility.

Share this post


Link to post
Share on other sites

Is there a way to improve the image quality of the generated -s and -m images?

The quality now is good, but I need better quality to see more detail.

 

When I resize the images my self, there is more detail (less blur) in the images.

But offcourse I want this contribution to do this for me :)

Share this post


Link to post
Share on other sites

Is there a way to improve the image quality of the generated -s and -m images?

The quality now is good, but I need better quality to see more detail.

 

When I resize the images my self, there is more detail (less blur) in the images.

But offcourse I want this contribution to do this for me :)

not that I know of.

Share this post


Link to post
Share on other sites

That error when i click in admin on Addiotinal images I mean:

 

FIX:

When i click on:

 

You database needs updated before this will operate correctly. Please run configuration utility.

 

That is in red. When i'm running the configuration utility.

 

sounds to me like you haven't completed the install or some file didn't get uploaded.

Share this post


Link to post
Share on other sites

Can this been fixed?

 

yes, when I (or someone else) have time.

Share this post


Link to post
Share on other sites

Hello,

 

I'm not sure if this can be done with this contribution but let me put it simple.

 

I need one specific image to appear instead of all missing images. So instead of ugly missing image links in IE and FF, the predefined GIF or JPG will be shown.

 

Possible?

 

I have already installed AI and it works well.

 

Thanks in advance.

Edited by OSClooking

Share this post


Link to post
Share on other sites

Is there a option to make MINE Thumbnail images better? They are not looking nice now?

 

Is there a code to make them better? What to change? Please help me!!

Share this post


Link to post
Share on other sites

Hi.

I have the last version install, and it works really good, until I decid me to have a special product_info file (STS product_info.php.html)

If I turn lightbox effect off everything works good, but when I turn it on, i cant see my additional images, just my main image I upload.

 

What can be wrong? Please help! :)

Edited by xciso

Share this post


Link to post
Share on other sites

When, now I must do all things myself all images.

 

it works fine if you allow AI to manage your image resizing.

Share this post


Link to post
Share on other sites

Is there a option to make MINE Thumbnail images better? They are not looking nice now?

 

Is there a code to make them better? What to change? Please help me!!

if you allow AI to manage your image sizing, you should minimize issues with the contribution. If you want to upload all 3 image sizes that you sized and watermarked, then you should have the restrict images sizes config options false so that they are shown on the shop in the correct perspective.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×