Jump to content
Sign in to follow this  
Parikesit

[Contribution] Additional Images Module

Recommended Posts

To your questions

 

1) yes, thats the purpose, to have the lightbox effect for all images, not just the additional

2) You can not have both, lightbox AND rolover effect, you need to choose this or that.

 

To your problem: Please answer me to following questions:

a) Do you have in your admin --> configuration --> additional images the lightbox entry? Is is switched to "true"?

b ) Do you have other contributions installed, that affect product_info.php?

c) Do following: Backup your product_info.php and includes/classes/displayimages.php, and upload the 2 files that are in the package. Then post again and tell me the results

 

item 2, both effects: Do you mean like in this site ?

Share this post


Link to post
Share on other sites
item 2, both effects: Do you mean like in this site ?

 

i believe that is what he is saying. What you see there is not possible with the stock code he is offering.

Edited by surfalot

Share this post


Link to post
Share on other sites
item 2, both effects: Do you mean like in this site ?

 

No, thats not possible right now, I'm sorry. Right now you have 2 options (regarding this display ways you mention):

- You turn lightbox off, then you have the rolover effect

- You turn lightbox on, then you have lightbox

 

To get both, like on your link, it will be necessary to "merge" the 2 effects in includes/displayimages.php, taking care not to damage the regular pop up window

Share this post


Link to post
Share on other sites

Hi everyone

I hope someone would be able to help me, since this situation seems very weird.

So here is the scoop.

 

The product images in my Men, subcategories shows fine, but when it comes to Women subcategories it doesn't show.

 

If you take a peek at www.parsuaclothing.com/store/

 

you got to men's long sleeves, you will see the images showing there, but now if you were to switch to ladies, dresses or anything else nothing comes.

 

if someone is able to help me, it would be awesome.

Share this post


Link to post
Share on other sites
If you take a peek at www.parsuaclothing.com/store/

 

What I see is that there are no images at all in product listings, just in the "whats new" module.

 

About the product info images, in the women section the lightbox is loading but not showing the image. I can not tell you exactly whats going wrong, since you have a template.

 

Do you have AI installed? Or just the lightbox effect? Can you turn it off? How is the behavior then?

Share this post


Link to post
Share on other sites
What I see is that there are no images at all in product listings, just in the "whats new" module.

 

About the product info images, in the women section the lightbox is loading but not showing the image. I can not tell you exactly whats going wrong, since you have a template.

 

Do you have AI installed? Or just the lightbox effect? Can you turn it off? How is the behavior then?

 

Hi

Thank you for your help! your right the problem is from product listings. and i returned the file to original state and it works fine.

I believe the problem begins when i did this.

 

"You will need to look for this following text in a variety of files. This allows

Additional Images better control over how the thumbs are displayed about the site.

 

 

search for this:

SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT

 

Replace with this:

(ADDIMAGES_RESTRICT_IMAGE_SIZE == 'true'?SMALL_IMAGE_WIDTH:''), (ADDIMAGES_RESTRICT_IMAGE_SIZE == 'true'?SMALL_IMAGE_HEIGHT:'')

 

 

You will find most of it in the product list files, box files, and a couple admin file:

/catalog/products_new.php

/catalog/reviews.php

/catalog/shopping_cart.php

/catalog/specials.php

/catalog/admin/categories.php

/catalog/admin/reviews.php

/catalog/admin/specials.php

/catalog/includes/boxes/reviews.php

/catalog/includes/boxes/specials.php

/catalog/includes/boxes/whats_new.php

/catalog/includes/modules/also_purchased_products.php

/catalog/includes/modules/new_products.php

/catalog/includes/modules/product_listing.php"

 

thats from upgrade to 2.1.1.....

I do have have Additional Images installed, i begin from 2.1.0, upgrade to 2.1.1 then installed the lightbox, and then finally i installed lightbox effect in AI version 2.

 

and btw, if i want to turn of lightbox, how do i do it? i check configuration and i couldn't find it there.

 

Regards

Share this post


Link to post
Share on other sites
No, thats not possible right now, I'm sorry. Right now you have 2 options (regarding this display ways you mention):

- You turn lightbox off, then you have the rolover effect

- You turn lightbox on, then you have lightbox

 

To get both, like on your link, it will be necessary to "merge" the 2 effects in includes/displayimages.php, taking care not to damage the regular pop up window

 

Yes, I know, I have created the webshop I linked to. I thought you might be interested in the way it's done.

Share this post


Link to post
Share on other sites
Yes, I know, I have created the webshop I linked to. I thought you might be interested in the way it's done.

 

Of course I would like to know :)

 

PS. I realized just now who you are, I hope you don't mind that I used your older post to make this small addon

Share this post


Link to post
Share on other sites
(......)

I believe the problem begins when i did this.

 

"You will need to look for this following text in a variety of files. This allows

Additional Images better control over how the thumbs are displayed about the site.

 

search for this:

SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT

 

Replace with this:

(ADDIMAGES_RESTRICT_IMAGE_SIZE == 'true'?SMALL_IMAGE_WIDTH:''), (ADDIMAGES_RESTRICT_IMAGE_SIZE == 'true'?SMALL_IMAGE_HEIGHT:'')

 

(........)

 

and btw, if i want to turn of lightbox, how do i do it? i check configuration and i couldn't find it there.

 

So, I don't understand, is everything fine now?

 

This replacements make it possible to control via the AI admin the various places where images are displayed

 

You can find the lightbox "on/off" at the bottom of your AI controls in Admin --> configuration --> additional Images

Share this post


Link to post
Share on other sites
Of course I would like to know :)

 

PS. I realized just now who you are, I hope you don't mind that I used your older post to make this small addon

 

I'll send you the files.

 

I don't mind you using my input, that's what the community is for.

Share this post


Link to post
Share on other sites
So, I don't understand, is everything fine now?

 

This replacements make it possible to control via the AI admin the various places where images are displayed

 

You can find the lightbox "on/off" at the bottom of your AI controls in Admin --> configuration --> additional Images

 

Well i undo that update, cause that pretty much messed everything up.

and the funny thing is AI control doesn't have lightbox on/off with it. which thats something i am finding weird.

also i get a lot of this error, would you know why

 

Error:

" Error returned from alterimage class: 5

Thumb file: ............................................/images/products/women/short-sleeves/D1001s.jpg could not be created.

Error returned from alterimage class: 5

Products Info file:.................................../images/products/women/short-sleeves/D1001m.jpg could not be created."

Share this post


Link to post
Share on other sites
Well i undo that update, cause that pretty much messed everything up.

and the funny thing is AI control doesn't have lightbox on/off with it. which thats something i am finding weird.

also i get a lot of this error, would you know why

 

Error:

" Error returned from alterimage class: 5

Thumb file: ............................................/images/products/women/short-sleeves/D1001s.jpg could not be created.

Error returned from alterimage class: 5

Products Info file:.................................../images/products/women/short-sleeves/D1001m.jpg could not be created."

 

check the folder permissions on all of these folders: /images/products/women/short-sleeves/

Make sure you have the correct permissions to allow a PHP script to write to it. Ask you host what the correct permissions should be (either 0755 or 0777). FileZilla (freeware) can set permissions for you.

Share this post


Link to post
Share on other sites
check the folder permissions on all of these folders: /images/products/women/short-sleeves/

Make sure you have the correct permissions to allow a PHP script to write to it. Ask you host what the correct permissions should be (either 0755 or 0777). FileZilla (freeware) can set permissions for you.

 

no luck, it doesn't work at all. any other suggestions?

Edited by pouyak

Share this post


Link to post
Share on other sites
Error:

" Error returned from alterimage class: 5

Thumb file: ............................................/images/products/women/short-sleeves/D1001s.jpg could not be created.

Error returned from alterimage class: 5

Products Info file:.................................../images/products/women/short-sleeves/D1001m.jpg could not be created."

sorry, error 5 is an unsupported file type. This support gif,png,jpg

 

What kind of image is it?

Share this post


Link to post
Share on other sites
sorry, error 5 is an unsupported file type. This support gif,png,jpg

 

What kind of image is it?

 

file was damaged, thats why...it was 5mb damged jpg.

Thank you for your help. and all this time i though there was something wrong with the installation!!

once again. thank you

Share this post


Link to post
Share on other sites

Hi, don't know if anyone of you can help me for this.

 

I installed "STSv4.5.8_1_2_1" first and then I installed "Additional Images v2.1.1", I could see the "Additional Images" option in the configuration panel, everything looks fine and I could set the witdh and height for images and set "Automatically create 3 image set"...etc. However, when I go to create new product (or edit product) page, I couldn't find the "3 product image upload locations", there is only one "Thumb or Single Large Image" option for me to upload image, which means I couldn't create multiple images...

 

I don't know if I have missed any setting or installation step, please kindly help me for this, thank you very much!!

Share this post


Link to post
Share on other sites
Hi, don't know if anyone of you can help me for this.

 

I installed "STSv4.5.8_1_2_1" first and then I installed "Additional Images v2.1.1", I could see the "Additional Images" option in the configuration panel, everything looks fine and I could set the witdh and height for images and set "Automatically create 3 image set"...etc. However, when I go to create new product (or edit product) page, I couldn't find the "3 product image upload locations", there is only one "Thumb or Single Large Image" option for me to upload image, which means I couldn't create multiple images...

 

I don't know if I have missed any setting or installation step, please kindly help me for this, thank you very much!!

 

So on the product edit page you only see the one image upload spot called "Thumb or Single Large Image". you don't see the "Products Info Image (Optional):" upload spot or the "Popup Image (Optional):" upload spot? Those should appear, but be unavailable since you have selected in the setting for AI to automatically create the other 2 for you. You will only have one image upload spot there with that setting.

 

If you are looking for the place to upload the "unlimited" images, that is in the right side product summary of the product list page in your admin. The button to add additional images is below the "Edit" and "Delete" buttons of the product summary.

 

does that help or did I miss the point? :)

Share this post


Link to post
Share on other sites
So on the product edit page you only see the one image upload spot called "Thumb or Single Large Image". you don't see the "Products Info Image (Optional):" upload spot or the "Popup Image (Optional):" upload spot? Those should appear, but be unavailable since you have selected in the setting for AI to automatically create the other 2 for you. You will only have one image upload spot there with that setting.

 

If you are looking for the place to upload the "unlimited" images, that is in the right side product summary of the product list page in your admin. The button to add additional images is below the "Edit" and "Delete" buttons of the product summary.

 

does that help or did I miss the point? :)

 

Thank you very much for your reply.

 

First of all, I go to "configuration/Additional Images" and then I set the "Automatically create 3 image set" to false, but in the product edit page or create new product page, there is only one "Thumb or Single Large Image" option at the bottom, there is no upload slot for "Products Info Image (Optional):" and "Popup Image (Optional):".

 

For unlimited images, I couldn't see the button to add additional images in the right side product summary of the product list page in my admin...

 

I will try to go through the installation process one more time, hope I could find the reason for that... do kindly let me know if you have any other ideas for that, thank you!!

Share this post


Link to post
Share on other sites
So on the product edit page you only see the one image upload spot called "Thumb or Single Large Image". you don't see the "Products Info Image (Optional):" upload spot or the "Popup Image (Optional):" upload spot? Those should appear, but be unavailable since you have selected in the setting for AI to automatically create the other 2 for you. You will only have one image upload spot there with that setting.

 

If you are looking for the place to upload the "unlimited" images, that is in the right side product summary of the product list page in your admin. The button to add additional images is below the "Edit" and "Delete" buttons of the product summary.

 

does that help or did I miss the point? :)

 

Hi, I reinstall everything and it's working now, I think I've missed some files in my previous installation. Sorry for my careless and thank you so much for your help!!!

Share this post


Link to post
Share on other sites
Compare and merge 18 files will take hours. When I have time I will try this addon.

 

only an hour and a half for the experienced ;)

Share this post


Link to post
Share on other sites

I have installed the very useful ADD-ON on my OSC store, but there have a little problem that i hope some one can give me a favor.

 

 

In producst_review.php

 

 

the letters : "click to enlarge" have no font style and colud not be centering.

 

 

How to modify this?

 

 

 

THanks

 

 

JUN

Share this post


Link to post
Share on other sites

I installed additional images 2.1.1 and all is fine except popup images doesn't work any more. It will open small new window but nothing loads in there.

Example here!

 

Where can I start to look for solution?

I have renamed my admin folder, so I carefully changed and uploaded those "admin" files accordingly. Is there any paths in the php files that needs changing?

 

My automatic 3 image set is on and popup image width and height are left blank.

 

Thanks for any help!

Share this post


Link to post
Share on other sites
I installed additional images 2.1.1 and all is fine except popup images doesn't work any more. It will open small new window but nothing loads in there.

Example here!

 

It looks like the problem is solved

Share this post


Link to post
Share on other sites

Really? I don't see it working. I mean when you click product image to get bigger popup image?

I tried with firefox, IE and chrome and popup image don't load, even the small window do open.

Anyone else see it working correctly?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×