Jump to content
Sign in to follow this  
Parikesit

[Contribution] Additional Images Module

Recommended Posts

hello

 

I have installed the great contribution on my OSCOMMERCE.

 

but a little problem appears:

 

when I have to add a new product, in the Admin -> Categories / Products-> new product

There have only the "Thumb or Single Large Image:" option,

and have no both of "Product Info Image(Optional)" and "Popup Image(Optional)" options

 

 

how to make the two options appears while I have to add a new product.

 

thanks a lot.

 

JUN

must have missed a few lines in /catalog/admin/categories.php

lines 746-801 of that file in the package needs to be merged into your script.

Remember all code to be merged is between these markers...

// BOF: Additional Images

// EOF: Additional Images

Share this post


Link to post
Share on other sites
Hello to all

 

when i'm going to add categories in admin , i look this

 

=================

1054 - Unknown column 'c.categories_featured' in 'field list'

 

select c.categories_id, cd.categories_name, c.categories_image, c.parent_id, c.sort_order, c.date_added, c.last_modified, c.categories_featured, c.categories_featured_until from categories c, categories_description cd where c.parent_id = '0' and c.categories_id = cd.categories_id and cd.language_id = '1' order by c.sort_order, cd.categories_name

 

[TEP STOP]

=================

 

I'm not sure I understand this. Additional Images doesn't include categories_featured. I don't know what this is from.

Share this post


Link to post
Share on other sites
must have missed a few lines in /catalog/admin/categories.php

lines 746-801 of that file in the package needs to be merged into your script.

Remember all code to be merged is between these markers...

// BOF: Additional Images

// EOF: Additional Images

 

 

Todd Holforty thank u a lot!

 

 

 

but an another problem appears,

I set the Product Image Behavior to "popup" in the ADMIN,

 

and in my store's product info page, a popup window appears while I click the product image , under the large product image is the [ close window ] text , but the text was covered by the bottom border of the popup window.

 

how to modify it?

 

 

thanks

Edited by zozzoozzz

Share this post


Link to post
Share on other sites

look in popup_add_image.php

there is a javascript section with each browser broken out. the values there are subtracted from the height of the window. So a smaller value increase the size of the window. Negative values are allowed.

Share this post


Link to post
Share on other sites
look in popup_add_image.php

there is a javascript section with each browser broken out. the values there are subtracted from the height of the window. So a smaller value increase the size of the window. Negative values are allowed.

 

 

 

thanks Todd!

Share this post


Link to post
Share on other sites

Hello Todd and everybody

 

I have AI installed since a while and everything is perfect. The only issue I had was with the popup window title. My default it is set to "image_description". This was not ok for me because I have a store in 3 languages and image descriptions are just in 1.

 

The task for me was to put the product name (that is different in each language) into the popup window title.

 

I did following in the file "popup_add_image.php"

 

1) At line 36

 

original:

 

 if (!empty($_GET['imagesID'])) {
   $products_query = tep_db_query( "SELECT ai.products_id, ai.images_description, ai.thumb_images, ai.medium_images, ai.popup_images, p.products_image, p.products_image_med, p.products_image_pop, p.products_image_description FROM " . TABLE_ADDITIONAL_IMAGES . " ai, " . TABLE_PRODUCTS . " p WHERE ai.products_id=p.products_id and ai.additional_images_id = '".(int)$_GET['imagesID']."'");
   $selected_image = tep_db_fetch_array($products_query);
 } elseif (!empty($_GET['pID'])) {
   $products_query = tep_db_query( "SELECT products_id, products_image, products_image_med, products_image_pop, products_image_description FROM " . TABLE_PRODUCTS . " WHERE products_id = '".(int)$_GET['pID']."'");
   $selected_image = tep_db_fetch_array($products_query);
 }

 

my changes:

 if (!empty($_GET['imagesID'])) {
   $products_query = tep_db_query( "SELECT ai.products_id, ai.images_description, ai.thumb_images, ai.medium_images, ai.popup_images, p.products_image, p.products_image_med, p.products_image_pop, p.products_image_description, pd.products_name FROM " . TABLE_ADDITIONAL_IMAGES . " ai, " . TABLE_PRODUCTS_DESCRIPTION . " pd, " . TABLE_PRODUCTS . " p WHERE p.products_id = pd.products_id and ai.products_id=p.products_id and pd.language_id = '" . (int)$languages_id . "' and ai.additional_images_id = '".(int)$_GET['imagesID']."'");
   $selected_image = tep_db_fetch_array($products_query);
 } elseif (!empty($_GET['pID'])) {
   $products_query = tep_db_query( "SELECT p.products_id, p.products_image, p.products_image_med, p.products_image_pop, p.products_image_description, pd.products_name FROM " . TABLE_PRODUCTS_DESCRIPTION . " pd, " . TABLE_PRODUCTS . " p WHERE p.products_id = pd.products_id and pd.language_id = '" . (int)$languages_id . "' and p.products_id = '".(int)$_GET['pID']."'");
   $selected_image = tep_db_fetch_array($products_query);
 }

 

2) At line 68

 

original:

 

<title><?php echo $selected_image['images_description']; ?></title>

 

my changes:

<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">
<title><?php echo $selected_image['products_name']; ?></title>

 

 

I have to admit that I don't really know what I did and what this all mean, but the result is that I can see now the product name on the popup window title, in each language different.

 

I would appreciate it very much if somebody can tell me if I did right or if there somewhere a hidden mistake or handicap in this solution.

 

Also a question:

 

I think that I'll get "dublicate title tags" issues with Google, because 3 or more images (of the same item) have now the same title. My question is, how to add lets say a unique number (like image id) too the product name, to make them appear together in the title of the popup?

Share this post


Link to post
Share on other sites

Hello,

 

Im very new to this oCommerce.

I added the Addition Image contribution and everything looks good, but I cant get it to look like I want..

 

I want the layout on product info to look like this:

 

-------------- Here I want the text about the product
|   Here I   | bla bla bla
|   want a   |
|	pic	 |
|  300x300   |
--------------

---- ---- ----
|tn| |tn| |tn| 
---- ---- ----

^
these 3 images I want to have like small pictures like 100x80

 

And when I click on one picture it will show a pop up with the original size of the image

 

I hope you understand my question and that anyone help me?

Edited by jockem

Share this post


Link to post
Share on other sites
And when I click on one picture it will show a pop up with the original size of the image

 

I hope you understand my question and that anyone help me?

At current, that combination is not available, sorry. When the thumbs are on the product info page the rollovers show the large image above it, but clicking does not show the popup.

Share this post


Link to post
Share on other sites
Hello Todd and everybody

 

I have AI installed since a while and everything is perfect. The only issue I had was with the popup window title. My default it is set to "image_description". This was not ok for me because I have a store in 3 languages and image descriptions are just in 1.

 

I would appreciate it very much if somebody can tell me if I did right or if there somewhere a hidden mistake or handicap in this solution.

 

Also a question:

 

I think that I'll get "dublicate title tags" issues with Google, because 3 or more images (of the same item) have now the same title. My question is, how to add lets say a unique number (like image id) too the product name, to make them appear together in the title of the popup?

looks fine to me.

the following should add the image id to the title

<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">
<title><?php echo (!empty($_GET['imagesID']) ? $_GET['imagesID'] : $_GET['pID'] ) . ' ' . $selected_image['products_name']; ?></title>

Edited by surfalot

Share this post


Link to post
Share on other sites

I have a problem with this contribution that I can not solve. When this module loaded all my products appeared on the front page and in the catagorys. When you click on a catagory the products appear OK. But when you click on any product it does NOT appear. I only get a message saying 'Product not found!'

Can someone please point me in the right direction to solving this. I have reloaded this module 3 times and checked every change several times.

Thanks

Share this post


Link to post
Share on other sites
I have a problem with this contribution that I can not solve. When this module loaded all my products appeared on the front page and in the catagorys. When you click on a catagory the products appear OK. But when you click on any product it does NOT appear. I only get a message saying 'Product not found!'

Can someone please point me in the right direction to solving this. I have reloaded this module 3 times and checked every change several times.

Thanks

Well would you believe it. I've now found the answer to this. Searcg Engine Safe URLs should have been set to false.

BUT....now I haven't got anything in the pop-up window. It just says 'The requested URL /shop/FILENAME_POPUP_ADD_IMAGE was not found on this server.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.'

 

Anyone any ideas PLEASE ?????

Share this post


Link to post
Share on other sites

there is a change to /catalog/includes/filenames.php that you didn't do, or didn't get uploaded.

 

amazing what a search will do for you isn't it? :D

 

If you want SE URLs, don't use the built in function (which you discovered), use Ultimate SEO URLs. Use the version that Jack last updated uploaded last which is a slightly adjusted original version from Chemo.

Share this post


Link to post
Share on other sites

For various perverse reasons I want to do the following but can't work out how:-

 

1st - I want to disable to popups (ie the box that jumps out at you when you click on "click to enlarge").

 

2nd - On the front page in the "Whats New for 'Month'" in the middle of the page I want to change which size image are used for the products. I want to know where it defines which size image (i.e. small, medium or large) is displayed for each product show.

 

3rd - I also want to change the image size used in the product listing.

 

I seem to have got in a muddle and lost my way so any help with the above would be greatly appreciated.

 

Thanks....

Share this post


Link to post
Share on other sites

1) open includes/classes/displayimages.php

 

find:

 

		  $this->groupout .= '
		  <td align="center" class="smallText"><script language="javascript"><!--
			document.write(\'<a href="' . (!$this->onpagemenu ? 'java script:popupWindow(\\\'' : '') . tep_href_link( $this->linkurl, ($item==0&&$this->groupwithparent=='true'?'pID='.$products_id:'imagesID='.$addimages_images[$item]['id'])) . (!empty($_GET['products_id']) ? '&products_id='.$_GET['products_id'] : '') . (!empty($_GET['cPath']) ? '&cPath='.$_GET['cPath'] : '') . (!$this->onpagemenu ? '\\\')' : '') . '"' . $t_menu_mouseover . '>' . tep_image(DIR_WS_IMAGES . $addimages_images[$item]['image'], addslashes($addimages_images[$item]['desc']), (ADDIMAGES_RESTRICT_PARENT=='false'&&$item==0&&$this->groupwithparent=='true'?'':$addimages_image_width), (ADDIMAGES_RESTRICT_PARENT=='false'&&$item==0&&$this->groupwithparent=='true'?'':$addimages_image_height), 'hspace="5" vspace="5"') . '<br>' . (!empty($addimages_images[$item]['desc'])?addslashes($addimages_images[$item]['desc']):TEXT_CLICK_TO_ENLARGE) . '</a>\');
			//--></script><noscript>
			  <a href="' . tep_href_link(DIR_WS_IMAGES . $addimages_images[$item]['popimage']) . '" target="_blank">' . tep_image(DIR_WS_IMAGES . $addimages_images[$item]['image'], $addimages_images[$item]['desc'], $addimages_image_width, $addimages_image_height, 'hspace="5" vspace="5"') . '<br>' . (!empty($addimages_images[$item]['desc'])?$addimages_images[$item]['desc']:TEXT_CLICK_TO_ENLARGE) . '</a>
			  </noscript></td>'."\n";

 

change to:

 

		  $this->groupout .= '
		  <td align="center" class="smallText">' . tep_image(DIR_WS_IMAGES . $addimages_images[$item]['image'], addslashes($addimages_images[$item]['desc']), (ADDIMAGES_RESTRICT_PARENT=='false'&&$item==0&&$this->groupwithparent=='true'?'':$addimages_image_width), (ADDIMAGES_RESTRICT_PARENT=='false'&&$item==0&&$this->groupwithparent=='true'?'':$addimages_image_height), 'hspace="5" vspace="5"') . '</td>'."\n";

 

2) reveiw the getting started section of the install-readme.txt for info on setting image size. The small image (thumbnail) is the image displayed in all the product lists, specials box, new products, etc. Realize you must regenerate the images using the Additional Images utility after you change the image size.

 

the following post may have additional info you may want to read...

http://forums.oscommerce.com/index.php?sho...p;#entry1228232

Share this post


Link to post
Share on other sites

Hi

Thank you, I tried that change to includes/classes/displayimages.php but i'm still getting the pop up box with no image in the box but the message

 

"Not Found The requested URL /shop/FILENAME_POPUP_ADD_IMAGE was not found on this server.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

 

Any ideas please ?

Share this post


Link to post
Share on other sites
Hi

Thank you, I tried that change to includes/classes/displayimages.php but i'm still getting the pop up box with no image in the box but the message

 

"Not Found The requested URL /shop/FILENAME_POPUP_ADD_IMAGE was not found on this server.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

 

Any ideas please ?

 

this error means you have not made the correct changes to /includes/filenames.php. Or maybe did get the file uploaded.

 

what are the settings for additional images in your configuration section in the admin?

Share this post


Link to post
Share on other sites
this error means you have not made the correct changes to /includes/filenames.php. Or maybe did get the file uploaded.

 

what are the settings for additional images in your configuration section in the admin?

 

My additional images settings are:-

 

 

Automatically create 3 image set false

Background color

Pre-fill upload dir w/ Category names true

Pre-fill starting with this sub-dir products

Use image size restrictions false

Product Info: Show Additional Images false

Product Info: Product Image Behavior popup

Product Info: Group parent with sub-images false

Product Info: Restrict parent image size false

Product Info: Table alignment right

Product Info: Table location sides

Product Info: Number of columns 2

Product Info: Number of rows 2

Popup: Show Thumbnail Menu false

Thumb Menu: Show parent image false

Thumb Menu: Use image size restrictions true

Thumb Menu: Table alignment right

Thumb Menu: Table location below

Thumb Menu: Number of columns 2

Thumb Menu: Number of rows 2

Automatically create 3 image set

 

Thanks

Barry

Share this post


Link to post
Share on other sites

You have popup as the behavior, and show additional images on product page false, and Group parent with sub-images false, then there won't be any other images beside the main image shown anywhere. So why install this contribution?

 

to remove the popup from the main image, in product_info.php

 

?><script language="javascript"><!--
document.write('<?php echo '<a href="java script:popupWindow(\\\'' . tep_href_link(FILENAME_POPUP_ADD_IMAGE, 'pID=' . $product_info['products_id']) . '\\\')">' . tep_image(DIR_WS_IMAGES . (!empty($product_info['products_image_med'])?$product_info['products_image_med']:(!empty($product_info['products_image_pop'])?$product_info['products_image_pop']:(!empty($product_info['products_image'])?$product_info['products_image']:''))), addslashes($product_info['products_name']), (ADDIMAGES_RESTRICT_PARENT=='true'?DISPLAY_IMAGE_WIDTH:''), (ADDIMAGES_RESTRICT_PARENT=='true'?DISPLAY_IMAGE_HEIGHT:''), 'hspace="5" vspace="5"') . '<br>' . (!empty($product_info['products_image_description'])?$product_info['products_image_description']:TEXT_CLICK_TO_ENLARGE) . '</a>'; ?>');
//--></script>
<noscript>
<?php echo '<a href="' . tep_href_link(DIR_WS_IMAGES . (!empty($product_info['products_image_pop'])?$product_info['products_image_pop']:$product_info['products_image'])) . '" target="_blank">' . tep_image(DIR_WS_IMAGES . (!empty($product_info['products_image_med'])?$product_info['products_image_med']:(!empty($product_info['products_image_pop'])?$product_info['products_image_pop']:(!empty($product_info['products_image'])?$product_info['products_image']:''))), $product_info['products_name'], (ADDIMAGES_RESTRICT_PARENT=='true'?DISPLAY_IMAGE_WIDTH:''), (ADDIMAGES_RESTRICT_PARENT=='true'?DISPLAY_IMAGE_HEIGHT:''), 'hspace="5" vspace="5"') . '<br>' . (!empty($product_info['products_image_description'])?$product_info['products_image_description']:TEXT_CLICK_TO_ENLARGE) . '</a>'; ?>
</noscript><?php

to

echo tep_image(DIR_WS_IMAGES . (!empty($product_info['products_image_med'])?$product_info['products_image_med']:(!empty($product_info['products_image_pop'])?$product_info['products_image_pop']:(!empty($product_info['products_image'])?$product_info['products_image']:''))), addslashes($product_info['products_name']), (ADDIMAGES_RESTRICT_PARENT=='true'?DISPLAY_IMAGE_WIDTH:''), (ADDIMAGES_RESTRICT_PARENT=='true'?DISPLAY_IMAGE_HEIGHT:''), 'hspace="5" vspace="5"');

Share this post


Link to post
Share on other sites

there is a bug in product_reviews.php

 

 

when I enter the product_reviews.php, a thumbnail pic in the top right , the text " Click to enlarge" below the PIC. when I click the " Click to enlarge" , It only appears as a little thumbnail pic. and have no large pic.

 

how to modify it

 

 

thanks a lot.

 

JUN

Share this post


Link to post
Share on other sites

You have popup as the behavior, and show additional images on product page false, and Group parent with sub-images false, then there won't be any other images beside the main image shown anywhere. So why install this contribution?

 

Many thanks surfalot you've pointed me in the right direction. Just to explain I installed this contribution on the advice of others on this forum to get round a problem I had with some products (signs) where the wording distorted badely when resized in the standard build. The smaller images were the main problem. Changing the default image sizes didn't help but this contribution gives the control and flexability to work around the original problem. A fantastic contribution that has enabled me to enhance my site. In my opinion it should be part of the standard build. Anyway many many thanks for the help i've had on here from you and others i'm one very happy guy......

Regards

Barry

Share this post


Link to post
Share on other sites
there is a bug in product_reviews.php

 

It's more of an oversight then a bug. Updates for those files were never included in the package. Keep an eye on the contribution page for v2.1.1. It has what you need. Upgrade instructions are separate from the main install instructions.

Share this post


Link to post
Share on other sites

1146 - Table 'internat_extinction.TABLE_ADDITIONAL_IMAGES' doesn't exist

 

select additional_images_id, images_description, thumb_images, medium_images, popup_images from TABLE_ADDITIONAL_IMAGES where products_id = '29'

 

[TEP STOP]

 

 

It the above error when i install this add on.

 

Can anyone help me out.

Share this post


Link to post
Share on other sites

changes to the /catalog/includes/database_tables.php and /catalog/admin/includes/database_tables.php have not been made or successfully uploaded. Check that.

Share this post


Link to post
Share on other sites

Hi again,

Is there anyway of adding lightbox to all the additional images instead of having a standard popup window and still have large images come up in lightbox?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×