Jump to content
Sign in to follow this  
Parikesit

[Contribution] Additional Images Module

Recommended Posts

I'm confused. More Pics doesn't have anything to do with Additional Images and posting it there would be inappropriate. Additional images is a bit more advance then More Pics, so anyone currently using AI would downgrade to use it.

 

And supporting More Pics here in this Additional Images contribution support thread would be equally inappropriate.

Edited by surfalot

Share this post


Link to post
Share on other sites

<_< The field in my Admin for adding images to product disspeared and all my existing images don't show.

Anyone can help me figure out what to do? Thank you in advance!

Share this post


Link to post
Share on other sites

I am totally confused! Is this thread for more pics or for additional image?

I just installed the one on the first post of this thread, but it is More pics. Why this thread changed to additional image?

I istalled More Pics 2.01 to my V2.2 RC2, instead of "adding more pictures", my field of adding pictures simply dissapeared!

Maybe I should uninstall all that and install additional image? I have no idea how to uninstall the sql code run in the phpadmin. Is restore database from previous backups a good way?

Please someone help! Thanks!

Share this post


Link to post
Share on other sites
I am totally confused! Is this thread for more pics or for additional image?

I just installed the one on the first post of this thread, but it is More pics. Why this thread changed to additional image?

I istalled More Pics 2.01 to my V2.2 RC2, instead of "adding more pictures", my field of adding pictures simply dissapeared!

Maybe I should uninstall all that and install additional image? I have no idea how to uninstall the sql code run in the phpadmin. Is restore database from previous backups a good way?

Please someone help! Thanks!

This this the support thread for Additional Images. Jim mistakenly uploaded his latest More Pics to the additional images contribution page, then included this thread for support.

 

I hope you didn't loose all your image configuration from the previous version of More Pics. Was it More Pics you had installed previously? If so, in order to remove that, you will need additional SQL.

 

I beleive there is a new tool in the Catalog menu for the product images in the new version of More Pics. You would have to ask Jim in the More Pics thread to be sure.

 

If you want to remove the More Pics, this should clean up the SQL. Run this in your SQL database tool.

DROP TABLE products_images;
delete from configuration_group where configuration_group_id = 6124;
delete from configuration where configuration_group_id = 6124;

 

Then you will need to decide whether you want to go back to the other More Pics or Additional Images contribution.

 

Additional Images has a thumbnailer script to automatically resize your images when they are uploaded. Maybe a couple more variations on how they can be displayed.

Share this post


Link to post
Share on other sites

Thank you so much for detailed information!

I haven't installed any add-ons before. I am going to remove more pics and install additional images!

Thanks again! :lol:

Share this post


Link to post
Share on other sites

Problem with code in function tep_is_image_still_used($image) file 'Additional Images v2.1.0\1_files_to_upload\catalog\admin\includes\functions'

 

Manifested itself with query error due to single quote or backslashes. Crux of problem is that the file name needs to have none file system safe characters replaced and/or tep_db_input() or tep_db_prepare_input() used on variable $image for proper escaping of string for db queries.

 

Am I correct in the diagnosis?

 

[Mon Dec 15 16:30:35 2008] [error] [client 64.142.102.66] File does not exist: /var/www/html/images/products/bath/bath-accessories/Tub Time Rinse n\\' Pour Pitcher 08800 44f6d6396e90a1c9235ab83f0883d388s.jpg, referer: http://www.infantstart.com/admin/categorie...product_preview

[Mon Dec 15 16:33:50 2008] [error] [client 64.142.102.66] File does not exist: /var/www/html/images/Rite-Temp\xe2\x84\xa2 Baby Bath Tub 08084 cd27cb692b23a88e8fe950bae9a5bf, referer: http://www.infantstart.com/admin/categorie...n=edit_category

 

Error in admin panel during product update:

 

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'Pour Pitcher 08800 44f6d6396e90a1c9235ab83f0883d388s.jpg' or products_image_med ' at line 1

 

select count(*) as total from products where products_image = 'products/bath/bath-accessories/Tub Time Rinse n' Pour Pitcher 08800 44f6d6396e90a1c9235ab83f0883d388s.jpg' or products_image_med = 'products/bath/bath-accessories/Tub Time Rinse n' Pour Pitcher 08800 44f6d6396e90a1c9235ab83f0883d388s.jpg' or products_image_pop = 'products/bath/bath-accessories/Tub Time Rinse n' Pour Pitcher 08800 44f6d6396e90a1c9235ab83f0883d388s.jpg'

 

[TEP STOP]

Edited by bbaez

Share this post


Link to post
Share on other sites

hello,

 

thank you for this great contribution!

 

I come here because I had trouble running the contribution on my site, I Installl contribution and repair small error that I had at the beginning but now the thumbnail image is not displayed!

 

when I'm on "popup" I have nothing that appears and when I'm on "product_info" I have the main image that appears and not the sticker so it does not work!

 

Could you help me find a solution?

 

sorry for my English.

 

thank you

Share this post


Link to post
Share on other sites
Problem with code in function tep_is_image_still_used($image) file 'Additional Images v2.1.0\1_files_to_upload\catalog\admin\includes\functions'

 

Manifested itself with query error due to single quote or backslashes. Crux of problem is that the file name needs to have none file system safe characters replaced and/or tep_db_input() or tep_db_prepare_input() used on variable $image for proper escaping of string for db queries.

 

Am I correct in the diagnosis?

 

that should do it, but should go in /admin/includes/functions/additional_images.php

 

just below the line:

 

  function tep_is_image_still_used($image) {

 

add:

 

	$image = tep_db_input($image);

Share this post


Link to post
Share on other sites
hello,

 

thank you for this great contribution!

 

I come here because I had trouble running the contribution on my site, I Installl contribution and repair small error that I had at the beginning but now the thumbnail image is not displayed!

 

when I'm on "popup" I have nothing that appears and when I'm on "product_info" I have the main image that appears and not the sticker so it does not work!

 

Could you help me find a solution?

 

sorry for my English.

 

thank you

I can try, but nothing is coming to me from your description. Have you seen or tried the configuration options in the admin? admin > configuration > additional images ?

Share this post


Link to post
Share on other sites

hello,

 

thank you answer me!

 

is it that I can send my file "product_info.php" perhaps you will see errors that I have not seen.

 

I give you the address of my site you can see what happens.

 

thank you cordially

 

artefaxaudio

Edited by audioshop55

Share this post


Link to post
Share on other sites
Post your settings from the Admin please.

 

hello,

 

I do not think either of the problem just that, I put the photo anyway!

 

thank you for helping me and Mary Christmas to all!

 

 

setting.gif

Share this post


Link to post
Share on other sites

Todd,

 

Additional Images is pretty impressive.

 

I have a couple of questions if you would indulge me:

 

1) When setting the large image + thumb menu to show on the product_info page, where could I override the pop_up image width and height with a smaller set of values? I assume that the 'mainimage' area is where to do this. I don't want the main image to be so large as the actual pop_up. Any advice on the 'how' of doing this?

 

[My intention is to modify my store to show the thumb menu + main image on the product_info page AND on the pop_up page, but the set on the product_info page would be smaller.]

 

2) Have you ever attempted to integrate the MagicZoom toolset with Additional Images? I see where they have coding for 'Extra Images', 'Ultra Pics', and 'Paps'. Any pointers?

 

Thanks for your commitment to the group.

Share this post


Link to post
Share on other sites

HI,

 

1.

I uploaded the files. My oscommerce was not original, but I only deleted some text and boxes, so I think overide every file will be fine, right?

Now when I access my page, it shows :

Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory.

What did I do wrong? How to fix?

 

2. When I access Additional Images Configuration Utility, it showed"page not found"

When I run the aql in phpadmin, it returned error. I didn't remember what was the errow at that time. When I run again, it returned"#1050 - Table 'additional_images' already exists "

What to do in this case?

 

Thank you for being so helpful!

Share this post


Link to post
Share on other sites

I added one php.ini myself. Now main page shows, product info shows some code. I think this is the database problem. Not the biggest trouble is: I can not access my administration tool . Contact my host, waiting for reply......

But still don't know how to fix database problem. It seems that my "table" or something are not inserted.That's why my product page doesn't show. :(

Share this post


Link to post
Share on other sites
hello,

 

I do not think either of the problem just that, I put the photo anyway!

 

thank you for helping me and Mary Christmas to all!

Looks to me like you have a javascript error on the page that is stopping the Additional Images javascript from displaying its stuff.

Share this post


Link to post
Share on other sites
1) When setting the large image + thumb menu to show on the product_info page, where could I override the pop_up image width and height with a smaller set of values? I assume that the 'mainimage' area is where to do this. I don't want the main image to be so large as the actual pop_up. Any advice on the 'how' of doing this?

 

[My intention is to modify my store to show the thumb menu + main image on the product_info page AND on the pop_up page, but the set on the product_info page would be smaller.]

 

2) Have you ever attempted to integrate the MagicZoom toolset with Additional Images? I see where they have coding for 'Extra Images', 'Ultra Pics', and 'Paps'. Any pointers?

 

this should get you started on #1. this will show a medium image on the product page mouseover, and large image in the popup mouseover. In includes/classes/display_images.php, find:

 

 

		if (!empty($image['popup_images'])) { list($t_popimagewidth, $t_popimageheight, $type) = @getimagesize($this->imagedir.$image['popup_images']); }
	$addimages_images[] = array('id' => $image['additional_images_id'], 'image' => $use_image, 'image_width' => $t_imagewidth, 'image_height' => $t_imageheight, 'popimage' => $image['popup_images'], 'popimage_width' => $t_popimagewidth, 'popimage_height' => $t_popimageheight, 'desc' => $image['images_description']);

 

replace with:

 

		if ($this->onpagemenu) {
	if (!empty($image['medium_images'])) { list($t_popimagewidth, $t_popimageheight, $type) = @getimagesize($this->imagedir.$image['medium_images']); }
	$addimages_images[] = array('id' => $image['additional_images_id'], 'image' => $use_image, 'image_width' => $t_imagewidth, 'image_height' => $t_imageheight, 'popimage' => $image['medium_images'], 'popimage_width' => $t_popimagewidth, 'popimage_height' => $t_popimageheight, 'desc' => $image['images_description']);
	} else {
	if (!empty($image['popup_images'])) { list($t_popimagewidth, $t_popimageheight, $type) = @getimagesize($this->imagedir.$image['popup_images']); }
	$addimages_images[] = array('id' => $image['additional_images_id'], 'image' => $use_image, 'image_width' => $t_imagewidth, 'image_height' => $t_imageheight, 'popimage' => $image['popup_images'], 'popimage_width' => $t_popimagewidth, 'popimage_height' => $t_popimageheight, 'desc' => $image['images_description']);
	}

 

sorry I haven't tried to integrate the MagicZoom toolset with Additional Images. Its a commercial package this is an OS community.

Share this post


Link to post
Share on other sites
1.

I uploaded the files. My oscommerce was not original, but I only deleted some text and boxes, so I think overide every file will be fine, right?

Now when I access my page, it shows :

Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory.

What did I do wrong? How to fix?

 

2. When I access Additional Images Configuration Utility, it showed"page not found"

When I run the aql in phpadmin, it returned error. I didn't remember what was the errow at that time. When I run again, it returned"#1050 - Table 'additional_images' already exists "

What to do in this case?

1) you can only replace files if your osCommerce source is unchanged AND is version 2.2ms2-060817 as it says in the docs. You have probably messed up some of the RC2a code that I''m guessing you have. You should restore and go with the merge method.

 

"an error" doesn't help me help you. Restore and try again.

Share this post


Link to post
Share on other sites
Looks to me like you have a javascript error on the page that is stopping the Additional Images javascript from displaying its stuff.

 

yes it is exactly that!

 

I have isolated the problem part for the display, but the onmouseover does not work!

 

peus how I do to fix the error javascript?

Share this post


Link to post
Share on other sites

Hi there!

 

I tried to insert an image with 1280x900 and nothing happens. The file is copied to the server but the app stops and no error msg show.

 

the images will be bigger than the one i used because it's for my real estate company.

 

erro.png

 

My Popup Image size is set to 666x500, when i upload an image smaller than this something strange happens.

 

1.png

 

2.png

 

Any ideia?!?

 

thanks in advance

 

the image try to use: http://www.btu.unesp.br/imagens/fotos/Camp...estudantil1.JPG

Edited by gustavuz

Share this post


Link to post
Share on other sites
yes it is exactly that!

 

I have isolated the problem part for the display, but the onmouseover does not work!

 

peus how I do to fix the error javascript?

 

the problem is not with additional images. This thread is for additional images support.

Share this post


Link to post
Share on other sites
I tried to insert an image with 1280x900 and nothing happens. The file is copied to the server but the app stops and no error msg show.

 

the images will be bigger than the one i used because it's for my real estate company.

 

My Popup Image size is set to 666x500, when i upload an image smaller than this something strange happens.

if it bombs only when the uploaded image is very large, it may be a memory limitation issue with the host. Not sure what could cause the problem of turning an image blue when the image is smaller then the defined size limit. I'm not experiencing either issue on my php5 test site.

Share this post


Link to post
Share on other sites
if it bombs only when the uploaded image is very large, it may be a memory limitation issue with the host. Not sure what could cause the problem of turning an image blue when the image is smaller then the defined size limit. I'm not experiencing either issue on my php5 test site.

 

no, the image don't get bue, the image is resized to 666x500 but with a white border. the rezise just add a withe border insted of strech the image

 

2.png

Edited by gustavuz

Share this post


Link to post
Share on other sites
no, the image don't get bue, the image is resized to 666x500 but with a white border. the rezise just add a withe border insted of strech the image

Oh I see. it's not a good idea to stretch an image. The quality goes out the window when stretching images, no matter how its done. The main purpose of adding image resizing to AI is to increase quality, as apposed to simply specifying the image size in the HTML to achieve the resize like the stock osCommerce.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×