Jump to content

Archived

This topic is now archived and is closed to further replies.

Kjolebutikken

Wrong url's in shop startpage (index.php)

Recommended Posts

Hi,

 

I have changed the name of my catalog folder, from mydomain.no/oscdemo1 to mydomain.no/butikk

 

When I open my site with the link mydomain.no/butikk/index.php, the startpage opens,

but all links at the page, f.ex categories links, login link, advanced search link etc. shows the old url, loike this: mydomain.no/oscdemo1/login.php

 

So where can I change the url's?

 

I have tried to search all files for the word oscdemo1, but no luck. Have also tried to search database.

At the moment I do not have access to my admin because of an error.

 

 

Thanks for your help :-)


Best regards

Kjolebutikken

Share this post


Link to post
Share on other sites

Hi,

 

I have changed the name of my catalog folder, from mydomain.no/oscdemo1 to mydomain.no/butikk

 

When I open my site with the link mydomain.no/butikk/index.php, the startpage opens,

but all links at the page, f.ex categories links, login link, advanced search link etc. shows the old url, loike this: mydomain.no/oscdemo1/login.php

 

So where can I change the url's?

 

I have tried to search all files for the word oscdemo1, but no luck. Have also tried to search database.

At the moment I do not have access to my admin because of an error.

 

 

Thanks for your help :-)

 

 

Just found out that it seems to be something wrong with the code tep_href_link, because in my catalog/includes/boxes/information.php I have this code:

 

 $info_box_contents[] = array('text' => '<a href="http://www.kjolegalleriet.no/butikk/sikkerhet.htm">Sikkerhet</a><br>' .
                                        '<a href="http://www.kjolegalleriet.no/butikk/betingelser.htm">' . BOX_INFORMATION_CONDITIONS . '</a><br>' .
                                        '<a href="http://www.kjolegalleriet.no/butikk/frakt.htm">' . BOX_INFORMATION_SHIPPING . '</a><br>' .
                                        '<a href="' . tep_href_link(FILENAME_TRACKING, '', 'NONSSL') . '">'. BOX_INFORMATION_TRACKING . '</a><br>' .
                                        '<a href="' . tep_href_link(FILENAME_DYNAMIC_SITEMAP) . '">' . BOX_INFORMATION_DYNAMIC_SITEMAP . '</a><br>' .
                                        '<a href="' . tep_href_link(FILENAME_FEEDBACK, '', 'NONSSL') . '">'. BOX_INFORMATION_FEEDBACK . '</a><br>' .
                                        '<a href="' . tep_href_link(FILENAME_CONTACT_US, '', 'NONSSL') . '">' . BOX_INFORMATION_CONTACT . '</a><br>');

 

When I click on the first three links on my index.php page, the url works fine, here I have direct links in the code:

 

<a href="http://www.kjolegalleriet.no/butikk/sikkerhet.htm">Sikkerhet</a><br>' .
                                        '<a href="http://www.kjolegalleriet.no/butikk/betingelser.htm">' . BOX_INFORMATION_CONDITIONS . '</a><br>' .
                                        '<a href="http://www.kjolegalleriet.no/butikk/frakt.htm">' . BOX_INFORMATION_SHIPPING . '</a><br>' .

 

But for the four last links, the url is wrong and goes to the old catalog name:

 

  '<a href="' . tep_href_link(FILENAME_TRACKING, '', 'NONSSL') . '">'. BOX_INFORMATION_TRACKING . '</a><br>' .
                                        '<a href="' . tep_href_link(FILENAME_DYNAMIC_SITEMAP) . '">' . BOX_INFORMATION_DYNAMIC_SITEMAP . '</a><br>' .
                                        '<a href="' . tep_href_link(FILENAME_FEEDBACK, '', 'NONSSL') . '">'. BOX_INFORMATION_FEEDBACK . '</a><br>' .
                                        '<a href="' . tep_href_link(FILENAME_CONTACT_US, '', 'NONSSL') . '">' . BOX_INFORMATION_CONTACT . '</a><br>')

 

So, how can I fix the tep_href_link so that it redirects to the correct url?

 

 

PS! The changes I have done to my files before this error occured was upgrading from MS2 to RC2a, and in addition changed the catalog name for my store.

 

 

Thanks :-)


Best regards

Kjolebutikken

Share this post


Link to post
Share on other sites

includes/configure.php


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Make includes configure.php writable and make the necessary changes.

 

When you are done, make sure the configure.php is no longer writable again.

Share this post


Link to post
Share on other sites

Make includes configure.php writable and make the necessary changes.

 

When you are done, make sure the configure.php is no longer writable again.

 

 

Thanks both of you :-)

Had done the canges, but forgot to make the file writable first, so the changes was not saved :-)

Silly mistake, thanks for pointing it out to me.

Works fine now :-)


Best regards

Kjolebutikken

Share this post


Link to post
Share on other sites

Just found out that it seems to be something wrong with the code tep_href_link, because in my catalog/includes/boxes/information.php I have this code:

 

 $info_box_contents[] = array('text' => '<a href="http://www.kjolegalleriet.no/butikk/sikkerhet.htm">Sikkerhet</a><br>' .
                                        '<a href="http://www.kjolegalleriet.no/butikk/betingelser.htm">' . BOX_INFORMATION_CONDITIONS . '</a><br>' .
                                        '<a href="http://www.kjolegalleriet.no/butikk/frakt.htm">' . BOX_INFORMATION_SHIPPING . '</a><br>' .
                                        '<a href="' . tep_href_link(FILENAME_TRACKING, '', 'NONSSL') . '">'. BOX_INFORMATION_TRACKING . '</a><br>' .
                                        '<a href="' . tep_href_link(FILENAME_DYNAMIC_SITEMAP) . '">' . BOX_INFORMATION_DYNAMIC_SITEMAP . '</a><br>' .
                                        '<a href="' . tep_href_link(FILENAME_FEEDBACK, '', 'NONSSL') . '">'. BOX_INFORMATION_FEEDBACK . '</a><br>' .
                                        '<a href="' . tep_href_link(FILENAME_CONTACT_US, '', 'NONSSL') . '">' . BOX_INFORMATION_CONTACT . '</a><br>');

 

When I click on the first three links on my index.php page, the url works fine, here I have direct links in the code:

 

<a href="http://www.kjolegalleriet.no/butikk/sikkerhet.htm">Sikkerhet</a><br>' .
                                        '<a href="http://www.kjolegalleriet.no/butikk/betingelser.htm">' . BOX_INFORMATION_CONDITIONS . '</a><br>' .
                                        '<a href="http://www.kjolegalleriet.no/butikk/frakt.htm">' . BOX_INFORMATION_SHIPPING . '</a><br>' .

 

But for the four last links, the url is wrong and goes to the old catalog name:

 

  '<a href="' . tep_href_link(FILENAME_TRACKING, '', 'NONSSL') . '">'. BOX_INFORMATION_TRACKING . '</a><br>' .
                                        '<a href="' . tep_href_link(FILENAME_DYNAMIC_SITEMAP) . '">' . BOX_INFORMATION_DYNAMIC_SITEMAP . '</a><br>' .
                                        '<a href="' . tep_href_link(FILENAME_FEEDBACK, '', 'NONSSL') . '">'. BOX_INFORMATION_FEEDBACK . '</a><br>' .
                                        '<a href="' . tep_href_link(FILENAME_CONTACT_US, '', 'NONSSL') . '">' . BOX_INFORMATION_CONTACT . '</a><br>')

 

So, how can I fix the tep_href_link so that it redirects to the correct url?

 

 

PS! The changes I have done to my files before this error occured was upgrading from MS2 to RC2a, and in addition changed the catalog name for my store.

 

 

Thanks :-)

 

 

Look at configure.php inside "includes" folder, if problem persist tell me!

Share this post


Link to post
Share on other sites

Look at configure.php inside "includes" folder, if problem persist tell me!

 

Thanks :-) Yes, it was the configure.php :-)


Best regards

Kjolebutikken

Share this post


Link to post
Share on other sites

×