Jump to content

Archived

This topic is now archived and is closed to further replies.

sijo

Urgent!: Blank page when login

Recommended Posts

Have got a strange problem here.

Users can browse my shop with no problems, but if the try to login with their email and password this happens:

 

When users fill in their username and password and then click the LogIn button they only get a blank page.

There is no error shown and no error logged on my site.

The page coming up is emty, nothing listed trying to see the source.

 

The same thing happens when new users try to register.

They get a blank page, but an email is sent for them to activate their registration.

I find new users registered in my admin section.

 

What can cause this problem and what should i look at to fix this?

 

You can try to register at my site if you want: My site

Any and all help would be appreciated!


---------------

regards

sijo

---------------

 

Contrib: JMrating10 - Rate your products / osCommerce VTS - Virus & Threat Scanner

 

(osCommerce VTS now also checks for leading and trailing whitespace and also have a grep function)

Share this post


Link to post
Share on other sites

Have got a strange problem here.

Users can browse my shop with no problems, but if the try to login with their email and password this happens:

 

When users fill in their username and password and then click the LogIn button they only get a blank page.

There is no error shown and no error logged on my site.

The page coming up is emty, nothing listed trying to see the source.

 

The same thing happens when new users try to register.

They get a blank page, but an email is sent for them to activate their registration.

I find new users registered in my admin section.

 

What can cause this problem and what should i look at to fix this?

 

You can try to register at my site if you want: My site

Any and all help would be appreciated!

What is the URL at the top of the browser on the blank page?


Community Bootstrap Edition, Edge

 

Avoid the most asked question. See How to Secure My Site and How do I...?

Share this post


Link to post
Share on other sites

What is the URL at the top of the browser on the blank page?

http://www.emti.no/catalog/

account.php

checkout_shipping.php

 

are both doing it.

 

I thought something maybe wrong with the sessions but I added items to the cart and it was saved. I've never seen this issue before.

Share this post


Link to post
Share on other sites

Read the posts by steve_s starting here on how to get the site to make an error log.

 

That thread is aboiut admin problems but it would work on the catalog side, too (I've tried it).

 

Until you know where the problem lies you can't fix it.

:'(


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

Read the posts by steve_s starting here on how to get the site to make an error log.

 

That thread is aboiut admin problems but it would work on the catalog side, too (I've tried it).

 

Until you know where the problem lies you can't fix it.

crying.gif

 

I've tried this now, but nothing is written to the error_log file. I've placed one in root, catalog and includes folders, but no errors reported..

 

Any other ideas for me to try?


---------------

regards

sijo

---------------

 

Contrib: JMrating10 - Rate your products / osCommerce VTS - Virus & Threat Scanner

 

(osCommerce VTS now also checks for leading and trailing whitespace and also have a grep function)

Share this post


Link to post
Share on other sites

I've tried this now, but nothing is written to the error_log file. I've placed one in root, catalog and includes folders, but no errors reported..

 

Any other ideas for me to try?

 

Thanks to KissER I did find my problems laugh.gifthumbsup.gif

 

This is what some few spaces can do:

in two files, catalog/includes/functions/general.php and catalog/includes/classes/breadcrumb.php there was a few spaces after the ending ?>

How they came there, I have no clue...


---------------

regards

sijo

---------------

 

Contrib: JMrating10 - Rate your products / osCommerce VTS - Virus & Threat Scanner

 

(osCommerce VTS now also checks for leading and trailing whitespace and also have a grep function)

Share this post


Link to post
Share on other sites

Thanks to KissER I did find my problems laugh.gifthumbsup.gif

 

This is what some few spaces can do:

in two files, catalog/includes/functions/general.php and catalog/includes/classes/breadcrumb.php there was a few spaces after the ending ?>

How they came there, I have no clue...

Did you check for hack code?

:unsure:

 

It would severly bother me if something got changed and I didn't know how or when or by whom...

:huh:


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

Did you check for hack code?

It would severly bother me if something got changed and I didn't know how or when or by whom...

 

Yes, I scan my site every day..


---------------

regards

sijo

---------------

 

Contrib: JMrating10 - Rate your products / osCommerce VTS - Virus & Threat Scanner

 

(osCommerce VTS now also checks for leading and trailing whitespace and also have a grep function)

Share this post


Link to post
Share on other sites

 

in two files, catalog/includes/functions/general.php and catalog/includes/classes/breadcrumb.php there was a few spaces after the ending ?>

How they came there, I have no clue...

 

 

very common issue after editing with the likes of filemanager, to add confusion, spaces at the end do not always cause issues at first, but issues can randomly occur later, maybe just through re-uploading the same file!!


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

×