Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Sign in to follow this  
rjones@abnllc.com

STSv4 Using Flash

Recommended Posts

Ok, I am making headway. I found the post on the flash movie, Bill Kellum post #4735. I copied the code box to a text file and named it "swfobject.js" I then created a flash folder and placed the file inside the flash folder. The path is mystore/includes/sts_templates/freeoscomm_061/flash/swfobject.js.

I then copied this line of code to the sts_template.html "<script type="text/javascript" src="$templatedir/flash/swfobject.js"></script>".

I then pasted this code in the index.php_0.html file inside the freeoscomm_061 folder where I want the movie to play.

<td class="styleFlash">

<script type="text/javascript" src="$templatedir/flash/swfobject.js"></script>

<div id="flashcontent">This text is replaced by the Flash movie.

</div>

<script type="text/javascript">

var so = new SWFObject("images/flash/your_flash_movie.swf", "movie", "763", "368", "8", "#ffffff");

so.write("flashcontent");

</script>

</td>

 

and finally I added a folder to my base images folder called flash and copied my flash movie to this folder..... I also renamed my flash movie to "your_flash_movie.swf" thinking that matched all the references.

 

Any ideas as to why all I see is the code text I added to my index.php_0.html file when I view the store in a browser?

 

Thanks for the help.

RJ

Share this post


Link to post
Share on other sites

Ok, I am making headway. I found the post on the flash movie, Bill Kellum post #4735. I copied the code box to a text file and named it "swfobject.js" I then created a flash folder and placed the file inside the flash folder. The path is mystore/includes/sts_templates/freeoscomm_061/flash/swfobject.js.

I then copied this line of code to the sts_template.html "<script type="text/javascript" src="$templatedir/flash/swfobject.js"></script>".

I then pasted this code in the index.php_0.html file inside the freeoscomm_061 folder where I want the movie to play.

<td class="styleFlash">

<script type="text/javascript" src="$templatedir/flash/swfobject.js"></script>

<div id="flashcontent">This text is replaced by the Flash movie.

</div>

<script type="text/javascript">

var so = new SWFObject("images/flash/your_flash_movie.swf", "movie", "763", "368", "8", "#ffffff");

so.write("flashcontent");

</script>

</td>

 

and finally I added a folder to my base images folder called flash and copied my flash movie to this folder..... I also renamed my flash movie to "your_flash_movie.swf" thinking that matched all the references.

 

Any ideas as to why all I see is the code text I added to my index.php_0.html file when I view the store in a browser?

 

Thanks for the help.

RJ

 

 

Remember, if you are adding stop end characters to your tags, you must do it for the $tempplatedir$ as well.

 

thumbsup.gif Please visit the STSv4 Support Thread. Link is in the STS User Manual as well as in my signature below.

 

 


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×