Jump to content

Archived

This topic is now archived and is closed to further replies.

sackling

continue shopping not showing up

Recommended Posts

having a weird little issue. The continue shopping button is not showing up in shopping_cart.php

 

However if i make another file with the exact same code and call it shopping_cart2.php the icon shows up...

 

Why is this happeningÉ

Share this post


Link to post
Share on other sites

Hi

I tried it and the continue shopping image shows up fine, it takes me to a default_page.php i think it was called that anyhow.

Nic

 

hmmm that is very weird.. Not sure why it is showing up for you.. thanks for testing though.

Share this post


Link to post
Share on other sites

I'm now getting this problem too, on IE8 and Firefox. I've tried cache clearing. I'm not getting it on another test site, same osC version, same hosting provider, everything apparently the same.

 

It's this bit of code in shopping_cart.php:

 

<?php
   $back = sizeof($navigation->path)-2;
   if (isset($navigation->path[$back])) {
?>
               <td class="main"><?php echo '<a href="' . tep_href_link($navigation->path[$back]['page'], tep_array_to_string($navigation->path[$back]['get'], array('action')), $navigation->path[$back]['mode']) . '">' . tep_image_button('button_continue_shopping.gif', IMAGE_BUTTON_CONTINUE_SHOPPING) . '</a>'; ?></td>
<?php
   }
?>

Evidently the navigation path to 2 pages ago is no longer "set" for some reason. Unfortunately I'm a noob too. Did you find a solution?

Share this post


Link to post
Share on other sites

×