Jump to content
Latest News: (loading..)

Archived

This topic is now archived and is closed to further replies.

m3evl

Using v3 and ssl

Recommended Posts

Hi,

 

I'm having issues using version 3 on https. The administration side works fine, but when a customer logs in it comes up with the following error:

 

Warning: osC_Services::include(includes/modules/services/output_compression.php) [osc-services.include]: failed to open stream: No such file or directory in E:\sslroot\computerandlaptop\includes\classes\services.php on line 51

 

I have had to remove the " includes/ " out of application_top.php just to include the configuration.php. This error message appers for all services.

 

site is computerandlaptop.biz

Share this post


Link to post
Share on other sites

Try adding an include_path declaration in your php.ini (or the equivalent on your server) that adds the store's base directory E:\sslroot\computerandlaptop. That way, whenever the code asks for "includes/...", it should try E:\sslroot\computerandlaptop\includes/...


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

Try adding an include_path declaration in your php.ini (or the equivalent on your server) that adds the store's base directory E:\sslroot\computerandlaptop. That way, whenever the code asks for "includes/...", it should try E:\sslroot\computerandlaptop\includes/...

 

Hi,

 

I don't have access to the php.ini file. Is there another way to set the base dir?

I can show you the config file if thats any help.

Share this post


Link to post
Share on other sites

Ask your hosting service how to set the include_path. Any server I've ever seen has let you set a php.ini file, or something equivalent. Some older Apache installations may permit you to set PHP settings in the .htaccess file (using php_value?). Or, you may have to add an ini_set() call (in application_top.php?) to set it on all pages.

 

If you're on a typical Apache server installation, there may not be a php.ini file by default. In that case, you'll simply create one in the site root. Some installations may require you to put a command in .htaccess to tell the server where to find php.ini. If you're on a Windows server, I dunno.

 

Sorry about not getting back to you sooner, but the forum just today let me see your response!


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

×