Jump to content

Archived

This topic is now archived and is closed to further replies.

semaka

SSL certificate and pictures

Recommended Posts

Hy all!

I'm quite sure that the matter i'll expose in the following rows it has been overdiscuset, but i didn't find anything to resolve my problem.

I've purchased a SSL certificate and done all the changes required in the apropiate files /includes/configure.php and /admin/includes/configure.php, but when I'm using the https protocols all my imges doesn't appear...

Here are my configuration files:

define('HTTP_SERVER', 'http://www.migeco.ro');

define('HTTPS_SERVER', 'https://migeco.ro');

define('ENABLE_SSL', true);

define('HTTP_COOKIE_DOMAIN', 'www.migeco.ro');

define('HTTPS_COOKIE_DOMAIN', 'migeco.ro');

define('HTTP_COOKIE_PATH', 'www.migeco.ro');

define('HTTPS_COOKIE_PATH', 'migeco.ro');

define('DIR_WS_HTTP_CATALOG', '/');

define('DIR_WS_HTTPS_CATALOG', '/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/home/migecoro/public_html/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

and for admin section:

define('HTTP_SERVER', 'http://www.migeco.ro');

define('HTTP_CATALOG_SERVER', 'http://www.migeco.ro');

define('HTTPS_CATALOG_SERVER', 'https://migeco.ro');

define('ENABLE_SSL_CATALOG', 'true');

define('DIR_FS_DOCUMENT_ROOT', '/home/migecoro/public_html/');

define('DIR_WS_ADMIN', '/admin/');

define('DIR_FS_ADMIN', '/home/migecoro/public_html/admin/');

define('DIR_WS_CATALOG', '/');

define('DIR_FS_CATALOG', '/home/migecoro/public_html/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

If someone can help please...?

Thanks

Share this post


Link to post
Share on other sites

You are trying to use the cert as it was intended and not how osC uses them. OSC wants the hppt domain and the https domain the same. So, now that you have already purchased the cert with the domain name migeco.ro your option remaining is to change your entire domain access to use http://migeco.ro and not http://www.migeco.ro

 

Change this line:

define('HTTP_SERVER', 'http://www.migeco.ro');

to this:

define('HTTP_SERVER', 'http://migeco.ro');

and remove all reference to www.migeco.ro and change to migeco.ro

 

You may also have to put a rewrite in an htaccess file and/or alter your servers httpd.conf settings so that http://migeco.ro is answered.


Community Bootstrap Edition, Edge

 

Avoid the most asked question. See How to Secure My Site and How do I...?

Share this post


Link to post
Share on other sites

thank you for you're answer... i did what you told me (changing all references for www.migeco.ro into migeco.ro), but still no effect...

regarding the htaccess and httpd.conf file i don't have enough knowledge to do it myself..

if you are so king to help further more, i'll be grateful...

thank you.

Share this post


Link to post
Share on other sites

thank you for you're answer... i did what you told me (changing all references for www.migeco.ro into migeco.ro), but still no effect...

regarding the htaccess and httpd.conf file i don't have enough knowledge to do it myself..

if you are so king to help further more, i'll be grateful...

thank you.

Do you only have to one files space? Your host does not have you trying to put your http files space in one tree and your https files in a different tree, are they?


Community Bootstrap Edition, Edge

 

Avoid the most asked question. See How to Secure My Site and How do I...?

Share this post


Link to post
Share on other sites

You are showing no images at all at http://migeco.ro/images/ which by the way is browseable. A security risk, but helpful in this case.

The image locations for the https images is at https://migeco.ro/images/ and also shows no images.

 

It is almost as though your host has your images somewhere else, and are linking to them based on the http/https headers.


Community Bootstrap Edition, Edge

 

Avoid the most asked question. See How to Secure My Site and How do I...?

Share this post


Link to post
Share on other sites

i've send an e-mail to the hosting company and i'm waiting for an answer from them...

thank you anyway...

Share this post


Link to post
Share on other sites

the answer from my hosting company was that my pictures are not under https... do i have to copy them else where or....?

can anyone help me ...?

Share this post


Link to post
Share on other sites

Mark has explained your problem in a nutshell.

 

You need to talk to your host about the image problem and stop sending me emails.


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

the answer from my hosting company was that my pictures are not under https... do i have to copy them else where or....?

can anyone help me ...?

Your host is assuming osC uses conventional means to handle ssl certificates. That is, http and https are in completely different file spaces. For example, http://www.your_site.com/ might go to /var/www/your_site but https://your_site.com/ goes to /var/secure/your_site

It is completely transparent to the users.

 

osC does not ustilize the ssl in that manner. It places ssl handling code in the header of pages that should be https but they are still in the same filespace with everything else.

 

You have two choices. Make sure all your files are in one filespace (this is going to be less of a headache, in the long run) or copy your images from the http filespace into the https filespace.


Community Bootstrap Edition, Edge

 

Avoid the most asked question. See How to Secure My Site and How do I...?

Share this post


Link to post
Share on other sites

thank you all for your time and quick responses

Now that you have the SSL images under control, this code in the footer is causing "non secure items" popup in IE:

 

    <td align="center"><div id="none"><script type="text/javascript">Seal("http://www.migeco.ro/images/logo-secured.gif", "GSSL", "none");</script></div></td>

It needs to be:

 

    <td align="center"><div id="none"><script type="text/javascript">Seal("https://migeco.ro/images/logo-secured.gif", "GSSL", "none");</script></div></td>

You can't have HTTP links to scripts or images on HTTPS pages.


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

×