Jump to content
FWR Media

KissMT Dynamic SEO Meta & Canonical Header Tags

Recommended Posts

Got a strange problem here:

When looking at my products and trying to switch pages using:

Searchresult: [<< Previous] 1 2 3 4 5 [Next >>]

i get a 'Page not found' produced by FWR.

I try 'Previous', '2', '4' or 'Next' with the same result.

 

You can try it here: My store

 

Any clue?


---------------

regards

sijo

---------------

 

Contrib: JMrating10 - Rate your products / osCommerce VTS - Virus & Threat Scanner

 

(osCommerce VTS now also checks for leading and trailing whitespace and also have a grep function)

Share this post


Link to post
Share on other sites

Got a strange problem here:

When looking at my products and trying to switch pages using:

Searchresult: [<< Previous] 1 2 3 4 5 [Next >>]

i get a 'Page not found' produced by FWR.

I try 'Previous', '2', '4' or 'Next' with the same result.

 

You can try it here: My store

 

Any clue?

 

Fixed!

It was another 'fix' I had done that caused this problem.

In another message regarding html validation I read this:

"Change the following in catalog/includes/functions/general.php:

$get_url .= $key . '=' . rawurlencode(stripslashes($value)) . '&';

to:

$get_url .= $key . '=' . rawurlencode(stripslashes($value)) . '&amp';

 

I did that, and this caused the problem. I have now changed it back and everything is working ok now.

(But what is right, & or &amp ?)


---------------

regards

sijo

---------------

 

Contrib: JMrating10 - Rate your products / osCommerce VTS - Virus & Threat Scanner

 

(osCommerce VTS now also checks for leading and trailing whitespace and also have a grep function)

Share this post


Link to post
Share on other sites

Got a strange problem here:

When looking at my products and trying to switch pages using:

Searchresult: [<< Previous] 1 2 3 4 5 [Next >>]

i get a 'Page not found' produced by FWR.

I try 'Previous', '2', '4' or 'Next' with the same result.

 

You can try it here: My store

 

Any clue?

 

Hi this certainly is not related to KissMT, you do seem to be using USU5 though. Wrong support thread?

 

I tried the paging and it worked for me .. was there a specific product listing that is not working?

 

P.s please continue this in the USU5 support thread

Share this post


Link to post
Share on other sites

I am trying to add the Categories and Manufacturers Descriptions but I am stuck at the following. I have 4 instances of the code your saying to look for. I found the first within the nested categories but the other one I can't determine from your description.

 

Find ... There are three of these we only want to change the first two. One in nested categories the other in products/manufacturers listings

        </table></td>
     </tr>
     <tr>
       <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

 

Replace with ...

        </table>
       <?php KissMT_Desc_Extn::init()->output(); ?>
       </td>
     </tr>
     <tr>
       <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

 

The second Instance is here

// needed for the new products module shown below
   $new_products_category_id = $current_category_id;
?>
             </tr>
           </table></td>
         </tr>
         <tr>
           <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

 

The third is here

            <td align="right"><?php echo tep_image(DIR_WS_IMAGES . $image, HEADING_TITLE, HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>
         </tr>
       </table></td>
     </tr>
     <tr>
       <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

 

The fourth is here

            <td class="pageHeading" align="right"><?php echo tep_image(DIR_WS_IMAGES . 'table_background_default.gif', HEADING_TITLE, HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>
         </tr>
       </table></td>
     </tr>
     <tr>
       <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

Share this post


Link to post
Share on other sites

I am trying to add the Categories and Manufacturers Descriptions but I am stuck at the following. I have 4 instances of the code your saying to look for. I found the first within the nested categories but the other one I can't determine from your description.

 

Find ... There are three of these we only want to change the first two. One in nested categories the other in products/manufacturers listings

        </table></td>
     </tr>
     <tr>
       <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

 

Replace with ...

        </table>
       <?php KissMT_Desc_Extn::init()->output(); ?>
       </td>
     </tr>
     <tr>
       <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

 

The second Instance is here

// needed for the new products module shown below
   $new_products_category_id = $current_category_id;
?>
             </tr>
           </table></td>
         </tr>
         <tr>
           <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

 

The third is here

            <td align="right"><?php echo tep_image(DIR_WS_IMAGES . $image, HEADING_TITLE, HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>
         </tr>
       </table></td>
     </tr>
     <tr>
       <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

 

The fourth is here

            <td class="pageHeading" align="right"><?php echo tep_image(DIR_WS_IMAGES . 'table_background_default.gif', HEADING_TITLE, HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>
         </tr>
       </table></td>
     </tr>
     <tr>
       <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

 

I can see how this can be difficult to find.

 

Using a space perfect multi line search there are only 3 exact matches .. doing it by eye it probably looks like more .. I'll probably have to increase the size of the snippets to find in order to make it clearer .. e.g.

 

First is in this bit ...

 

    <td width="100%" valign="top"><table border="0" width="100%" cellspacing="0" cellpadding="0">
     <tr>
       <td><table border="0" width="100%" cellspacing="0" cellpadding="0">
         <tr>
           <td class="pageHeading"><?php echo HEADING_TITLE; ?></td>
           <td class="pageHeading" align="right"><?php echo tep_image(DIR_WS_IMAGES . $category['categories_image'], $category['categories_name'], HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>
         </tr>
       </table></td>
     </tr>
     <tr>
       <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
     </tr>
     <tr>
       <td><table border="0" width="100%" cellspacing="0" cellpadding="2">
         <tr>
           <td><table border="0" width="100%" cellspacing="0" cellpadding="2">
             <tr>

 

 

 

 

Second is in this bit ...

 


           <td align="right"><?php echo tep_image(DIR_WS_IMAGES . $image, HEADING_TITLE, HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>
         </tr>
       </table></td>
     </tr>
     <tr>
       <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
     </tr>
     <tr>
       <td><?php include(DIR_WS_MODULES . FILENAME_PRODUCT_LISTING); ?></td>
     </tr>
   </table></td>
<?php
 } else { // default page
?>

Share this post


Link to post
Share on other sites

Thanks for straightening me out promptly, installed and appears to be working great!

 

Now I just have to get time to figure out how to use it properly.

Share this post


Link to post
Share on other sites

Thanks for straightening me out promptly, installed and appears to be working great!

 

Now I just have to get time to figure out how to use it properly.

 

If yours is an English language implementation you don't have to concern yourself with stopwords etc so there's really not much to learn . . the initial settings should be fine.

 

You may want to take a look at includes/languages/english/kissmt.php where the standard text lives.

 

If you add a category/manufacturers description it is worth bearing in mind that KissMT will use that and will stop gathering data from the database so the first X words of the descriptions are very important and should be keyword rich as they will be used for the meta data.

 

Also if you make changes and nothing seems to happen, you haven't reset the cache.

 

Hope that helps.

Share this post


Link to post
Share on other sites

Hi Tom

 

Your English is just fine.

 

How long have you had KissMT installed? Google and friends sometimes take a while to update their listings, there is little anyone can do to speed the process.

Ok maybe it's just that.

I see in google cache that Google robot has crawl my website 15 days ago.

 

Thanks

Share this post


Link to post
Share on other sites

Hi Robert,

 

I'm using the latest version, and I'm getting a blank screen when accessing admin/categories and admin/manufactures.

 

I compared my files with that of your (fresh) files and it's correct.

 

Any take on this?

 

Cheers

Share this post


Link to post
Share on other sites

Hi Robert,

 

I'm using the latest version, and I'm getting a blank screen when accessing admin/categories and admin/manufactures.

 

I compared my files with that of your (fresh) files and it's correct.

 

Any take on this?

 

Cheers

 

Well I just reverted back to the original categories script and now I can see the categories entries again.

Edited by elton123

Share this post


Link to post
Share on other sites

Well I just reverted back to the original categories script and now I can see the categories entries again.

 

Nothing to do with KissMT, no files are changed in admin.

 

If you installed the categories/manufacturers addon then you have installed it incorrectly.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Hi

 

Is this compatible with Custom META Tags per Item v1.0

 

The reason I ask is that I want to write my own title and keywords for certain pages.

 

Thanks in advance

Share this post


Link to post
Share on other sites

Hi

 

Is this compatible with Custom META Tags per Item v1.0

 

The reason I ask is that I want to write my own title and keywords for certain pages.

 

Thanks in advance

 

I don't even know what that is tbh, but I can guess. KissMT only works its wonders on those pages where you have replaced the title/title tags.

Share this post


Link to post
Share on other sites

I tried to install the Admin Settings but only get a blank page when browsing to the installer file. Any suggestions, or can you do a manual SQL statement?

Share this post


Link to post
Share on other sites

I tried to install the Admin Settings but only get a blank page when browsing to the installer file. Any suggestions, or can you do a manual SQL statement?

 

Is the server running PHP 5.2+? you certainly shouldn't be getting a blank page.

 

you are running installer.php and not installer_class.php I presume.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Is the server running PHP 5.2+? you certainly shouldn't be getting a blank page.

 

you are running installer.php and not installer_class.php I presume.

It's running 5.0.4. Will a manual install work?

Share this post


Link to post
Share on other sites

It's running 5.0.4. Will a manual install work?

 

Not a hope 5.0.4 is way too old ( released 31 Mar 2005 ) even 5.2 was released Nov 2006.

Share this post


Link to post
Share on other sites

Why do I get this using your KissER:

 

Date / Time: 30-01-2010 18:48:48

Error Type: [E_STRICT] Non-static method KissMT_Modules::stripStopWords() cannot be called statically, assuming $this from compatible context KissMT_Module

On line 134

File includes/modules/kiss_meta_tags/abstracts/kiss_modules.php


---------------

regards

sijo

---------------

 

Contrib: JMrating10 - Rate your products / osCommerce VTS - Virus & Threat Scanner

 

(osCommerce VTS now also checks for leading and trailing whitespace and also have a grep function)

Share this post


Link to post
Share on other sites

Why do I get this using your KissER:

 

Date / Time: 30-01-2010 18:48:48

Error Type: [E_STRICT] Non-static method KissMT_Modules::stripStopWords() cannot be called statically, assuming $this from compatible context KissMT_Module

On line 134

File includes/modules/kiss_meta_tags/abstracts/kiss_modules.php

 

Odd .. which version/revision are you using?

Share this post


Link to post
Share on other sites

I'm using r72

 

This is extremely odd because I have error reporting set E_ALL | E_STRICT and I get no error .. BUT ..

 

catalog/includes/kiss_meta_tags/abstracts/kiss_modules.php

 

Line 134

 

array_walk( $words_as_array, array( __CLASS__, 'stripStopWords' ) );

 

Does require the method to be static. If line 134 was ..

 

     array_walk( $words_as_array, array( $this, 'stripStopWords' ) );

 

It would not be required to be a static method. YET I get no error .. hmmmm.

 

Anyway you can correct this one of two ways ..

 

either change line 134 to ..

 

     array_walk( $words_as_array, array( $this, 'stripStopWords' ) );

 

Or change ..

 

    private function stripStopWords( &$word ) {

 

to ..

 

    private static function stripStopWords( &$word ) {

 

Doesn't matter which you choose to change. In the next revision I'll probably change the method to static.

Edited by FWR Media

Share this post


Link to post
Share on other sites

 

    private function stripStopWords( &$word ) {

 

to ..

 

    private static function stripStopWords( &$word ) {

 

Doesn't matter which you choose to change. In the next revision I'll probably change the method to static.

 

I'll try this and see what happens.

If you want me to test anything since I produce this error here, then please let me know.


---------------

regards

sijo

---------------

 

Contrib: JMrating10 - Rate your products / osCommerce VTS - Virus & Threat Scanner

 

(osCommerce VTS now also checks for leading and trailing whitespace and also have a grep function)

Share this post


Link to post
Share on other sites

Nothing to do with KissMT, no files are changed in admin.

 

If you installed the categories/manufacturers addon then you have installed it incorrectly.

Hi Robert,

 

Yes I installed the addon, and simply compared the files using Beyond Compare with your fresh install.

 

Perhaps I can forward your the categories script for you to have a look at it?

 

Cheers

Share this post


Link to post
Share on other sites

If yours is an English language implementation you don't have to concern yourself with stopwords etc so there's really not much to learn . . the initial settings should be fine.

 

You may want to take a look at includes/languages/english/kissmt.php where the standard text lives.

 

If you add a category/manufacturers description it is worth bearing in mind that KissMT will use that and will stop gathering data from the database so the first X words of the descriptions are very important and should be keyword rich as they will be used for the meta data.

 

Also if you make changes and nothing seems to happen, you haven't reset the cache.

 

Hope that helps.

 

Is the "description" that I input in the admin side supposed to be displayed on the page under the section heading? Did I do something wrong?

 

http://tougetuning.com/testsite/index.php/dvd-movies-action-c-3_10

Share this post


Link to post
Share on other sites

Is the "description" that I input in the admin side supposed to be displayed on the page under the section heading? Did I do something wrong?

 

http://tougetuning.com/testsite/index.php/dvd-movies-action-c-3_10

 

Looks perfect ..

 

1) The description you added is showing above the categories

 

2) KissMT has recognised that the description is present and is using it for title, keywords and meta description.

 

What I would say is that a description really should be at least 300 characters with the first 90(ish) characters focused on the keywords plus, of course, human readable.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×