Jump to content
FWR Media

KissMT Dynamic SEO Meta & Canonical Header Tags

Recommended Posts

Hello again, I just realized that the when you select the manufacturers filter box and it shows products by that manufacturer it is not putting the manufacturer's name in the <title.

 

<title>Products by at Company - Company</title>

 

Noticed it also has "Company" twice which I found in one of the files that I can remove or edit:

 

Line 46: define('META_FROM_MANU_AT_STORE', 'Products by %s at %s');

 

But do you know why the manufacturer's name is not showing?

 

I haven't added the admin extras but do have your SEO Pro installed.

 

Thank You

Share this post


Link to post
Share on other sites

Ok something is really wrong now, I attempted to reinstall incase I missed something before and just now noticed it but now the index.php page says:

 

<title>My Great Product Range - Full Range of Wiggets - Buy from ME</title>
<meta name="description" content="My Great Product Range, Full Range of Wiggets.">
<meta name="keywords" content="great,product,range,full,wiggets">

 

PLEASE HELP!

Share this post


Link to post
Share on other sites

Ok something is really wrong now, I attempted to reinstall incase I missed something before and just now noticed it but now the index.php page says:

 

<title>My Great Product Range - Full Range of Wiggets - Buy from ME</title>
<meta name="description" content="My Great Product Range, Full Range of Wiggets.">
<meta name="keywords" content="great,product,range,full,wiggets">

 

PLEASE HELP!

 

That is standard on initial installation, please read the instructions.

Share this post


Link to post
Share on other sites

That is standard on initial installation, please read the instructions.

 

I understand thank you I will read them, this never did it before not sure why it is doing it now. Maybe I was using one of your older versions?

 

Any suggestions on the By Manufacturer not working?

 

I see text in the title but don't know how to change it

You'll see text in the title like "Products by Some Manufacturer at My Shop"

These are set in the language files .. catalog/includes/languages/[my language]/kissmt.php

 

I see this but it is not putting the manufacturers name in there, what do I need to do to it?

 

Thank You

Share this post


Link to post
Share on other sites

I am sorry if I appear to be naive here but I just need to get this fixed asap, we just launched a huge integration with our distributors last week and google is caching our site really heavily.

Share this post


Link to post
Share on other sites

Ok so I deleted my KISS cache directory which was really large btw, like I was saying we launched a big project this week. I turned on performance checking and this is what came out:

 

KissMT Dynamic Seo Meta Tags - Performance

Query Count: 1

Query load time 0.0006 seconds

Cache File Size: Not loaded

Queries:

SELECT pd.products_name, m.manufacturers_name FROM manufacturers m LEFT JOIN products p ON p.manufacturers_id = m.manufacturers_id AND p.products_status = 1 LEFT JOIN products_description pd ON pd.products_id = p.products_id AND pd.language_id = 1 WHERE m.manufacturers_id = 8 LIMIT 0

 

then when I refresh the manufacturers page it shows this:

 

KissMT Dynamic Seo Meta Tags - Performance

Query Count: 0

Cache load time 0.0001 seconds

Cache File Size: 0.13 kb

Queries:

 

So see in the query above it gets the manufacturers name and then I assume puts it into the cache under:

 

kissmt_1_index_manufacturers_id_8.cache

 

But I am unable to open this file to find out what is in it. I know this is called KISS and the instructions are pretty simple I am just at a loss on why this isn't working. Is it b/c my store is very large now?

 

I did not see anything in the directions on how to change your homepage keywords and description, did I miss that somewhere too?

 

Thanks again

Share this post


Link to post
Share on other sites

further information, it looks like it has the correct Manufacturer name it is just not being used in the language file.

 

I would also like to note that we moved to a dedicated server, could server permissions be an issue?

 

  [cache_retrieved:private] => 1
           [cache:private] => MYSITE/includes/modules/kiss_meta_tags/cache/kissmt_1_index_manufacturers_id_8.cache
           [cache_md5:private] => 79f4746f35d1d4ef0e7f38beeea3c877
           [cache_name:protected] => kissmt_1_index_manufacturers_id_8.cache
           [get_value:protected] => 8
           [original_get:protected] => 8
           [markers:protected] => Array
               (
               )

           [root_index:protected] => root
       )

   [html_end:private] => >
   [cache_path:private] => MYSITE/includes/modules/kiss_meta_tags/cache/
   [language:private] => english
   [languages_id:private] => 1
   [cache_prefix:private] => kissmt_
   [basename:private] => index.php
   [request_type:private] => NONSSL
   [breadcrumb:private] => Array
       (
           [0] => Accuracy International
       )

   [canonical:private] => http://www.com/accuracy-international-m-8.html
   [title_separator:private] => -
   [title] => Products by at MYSITE - Buy from MYSITE
   [page_title] => Products by  at MYSITE
   [keywords] => products,MY,SITE
   [description] => Products by at MYSITE.
   [cachefile_size] => 0.13 kb
   [stopwords] => Array

 

I may have been using your 2 Minute Try Out for several months and didn't notice it, and when I redid the contrib I installed the full version. I was using cDynamic Meta Tags

 

<?php 
# cDynamic Meta Tags
/*<title><?php echo TITLE; ?>*/
require(DIR_WS_INCLUDES . 'meta_tags.php');
#
?>

 

UPDATE: yes I just replaced the KISS header code in the index.php and it is now showing the manufacturers name in the title, with keywords and descriptions.

 

Not a fix however I would really like to use KISS if possible.

Edited by ShaunB

Share this post


Link to post
Share on other sites

on product_info.php the KISS is working as it should:

 

<title>Accuracy International Magazine Aics Aw Long Action 338 Lapua Magnum Cip 5 Round Steel Matte - 4808</title>
<meta name="description" content="Accuracy International Magazine AICS AW Long Action 338 Lapua Magnum CIP 5 Round Steel Matte, 4808, Firearms - Clips & Magazines, Firearms, by Accuracy International, Factory original 5rd steel magazine for use with new .338 Lapua CIP-length long a...">
<meta name="keywords" content="accuracy,international,magazine,aics,long,action,lapua,magnum,cip,steel">
<link rel="canonical" href="http://www.mysite.com/firearms-clips-magazines/accuracy-international-magazine-aics-long-action-338-lapua-magnum-cip-round-steel-matte-p-52601.html">

Edited by ShaunB

Share this post


Link to post
Share on other sites

Hello,

 

Cannot remove product_model from title tag or description

 

great contribution but i seem to have hit a very small problem that has me beat. I cannot remove the product_model from the title or the description even after removing it from product_info.php. This removes it from the page but it is still being generated in the title tag and description. I have flushed the cache on KissMT Dynamic SEO, oscommerce admin and from the browser but it will not go away. It seems as though it have been recorded somewhere and will not move. Can the title tag be edited to remove products_model? I am using it with Seo Urls 5 and wondered if there was someway that i could also modify the breadcrumb trail to show product name instead of product model

 

Thanks

Edited by Llangrannog

Share this post


Link to post
Share on other sites

I have fixed that by commenting out the products_model in products_info.php in the Kiss folder.

 

Is there any way i can reverse the breadcrumb trail so it reads the same and in the breadcrumb trail in the bar with site name first?

 

Thanks

Share this post


Link to post
Share on other sites

Sorry for the typo it should be as it reads in the breadcrumb trail so it is included in the <title> tag with the site name first then category and then product name.

Share this post


Link to post
Share on other sites

Sorry for the typo it should be as it reads in the breadcrumb trail so it is included in the <title> tag with the site name first then category and then product name.

In application_top change this bit

// add the products model to the breadcrumb trail
to
// add the products name to the breadcrumb trail
and the bit below
 if (isset($_GET['products_id'])) {
   $name_query = tep_db_query("select products_name from " . TABLE_PRODUCTS_DESCRIPTION . " where products_id = '" . (int)$_GET['products_id'] . "' AND language_id=" . (int)$languages_id . "");
   if (tep_db_num_rows($name_query)) {
     $name = tep_db_fetch_array($name_query);
     $breadcrumb->add($name['products_name'], tep_href_link(FILENAME_PRODUCT_INFO, 'cPath=' . $cPath . '&products_id=' . $_GET['products_id']));
   }
 }

Edited by pdcelec

Share this post


Link to post
Share on other sites

Thanks for the help the code throws in a lot of extra links and takes out the structure of site name, category, product description, which i currently have in my breadcrumb trail. This is what i want to duplicate in the product title instead of the other way around using Kissmt header tags. Here is the code

 

// add the products model to the breadcrumb trail

if (isset($HTTP_GET_VARS['products_id'])) {

$model_query = tep_db_query("select products_model from " . TABLE_PRODUCTS . " where products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "'");

if (tep_db_num_rows($model_query)) {

$model = tep_db_fetch_array($model_query);

// $breadcrumb->add($model['products_model'], tep_href_link(FILENAME_PRODUCT_INFO, 'cPath=' . $cPath . '&products_id=' . $HTTP_GET_VARS['products_id']));

}

}

 

Thanks

Share this post


Link to post
Share on other sites

After instaling KissMT Dynamic SEO Meta & Canonical Header Tags

 

In categories meta tags I have HEADER:

 

"Categories Name - Site Name - Product 1 in categorie - Products 2 in categorie ..."

 

and I need the line like:

 

"Categories Name - Site Name"

 

(without products)

 

I edited init.php and set define( 'KISSMT_CATEGORIES_PRODUCTS_LIMIT', 0 ) (default was 30). After this I got what I need, the header line became:

 

"Categories Name - Site Name"

 

but the problem is that after this change "KissMT Dynamic SEO Meta & Canonical Header Tags" doesn't show manufacturer's name when sorting by Manufacturer

(when 'KISSMT_CATEGORIES_PRODUCTS_LIMIT' is 30 it does).

 

 

What can I do to solve this problem ?

Share this post


Link to post
Share on other sites

Hey guys, I'm trying to install this contribution but I get the following error: Parse error: syntax error, unexpected $end in /home/content/s/l/o/xxxx/html/oscommerce/catalog/includes/modules/kiss_meta_tags/classes/kiss_meta_tags_class.php on line 80. Any ideas or suggestions?

 

Thanks,

Emanuel

Share this post


Link to post
Share on other sites

Hey guys, I'm trying to install this contribution but I get the following error: Parse error: syntax error, unexpected $end in /home/content/s/l/o/xxxx/html/oscommerce/catalog/includes/modules/kiss_meta_tags/classes/kiss_meta_tags_class.php on line 80. Any ideas or suggestions?

 

Thanks,

Emanuel

 

 

Hey Guys,

 

I figured it out.

 

Thanks,

Emanuel

Share this post


Link to post
Share on other sites

Just installed this contr. Copied all files to host. Made code changes to index.php & product_info.php

Then when I click on a product on my site I get this error?

 

 

Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /mnt/r0109/d39/s22/b00b868a/www/includes/modules/kiss_meta_tags/kiss_meta_tags.php on line 23

 

 

Any help will be appreciated

Thks, Gary

Share this post


Link to post
Share on other sites

Just installed this contr. Copied all files to host. Made code changes to index.php & product_info.php

Then when I click on a product on my site I get this error?

 

 

Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /mnt/r0109/d39/s22/b00b868a/www/includes/modules/kiss_meta_tags/kiss_meta_tags.php on line 23

 

 

Any help will be appreciated

Thks, Gary

 

Looks like your host is running a ridiculously old version of PHP, this requires only PHP5.2+ ( the 2006 release of PHP ).

Share this post


Link to post
Share on other sites

Looks like your host is running a ridiculously old version of PHP, this requires only PHP5.2+ ( the 2006 release of PHP ).

 

 

Thanks, you right - Just upgraded PHP version to 5.2 and created ini fil for my admin directory and all seems to be fine.

 

Just an observation and a question - I dont see anything re. this add-on in admin? Should their be something?

Also, how do I test the effectiveness of this add-on. I would not know at this stage if it is working or not?

Edited by bksbeat

Share this post


Link to post
Share on other sites

Thanks, you right - Just upgraded PHP version to 5.2 and created ini fil for my admin directory and all seems to be fine.

 

Just an observation and a question - I dont see anything re. this add-on in admin? Should their be something?

Also, how do I test the effectiveness of this add-on. I would not know at this stage if it is working or not?

 

if you installed it correctly there will be a KissMT listing in admin configuration.

 

To see it working products/categories etc should show meaningfull info at the very top of the browser, also if you view the source there should be meta tags, canonical elements etc.

Share this post


Link to post
Share on other sites

if you installed it correctly there will be a KissMT listing in admin configuration.

 

To see it working products/categories etc should show meaningfull info at the very top of the browser, also if you view the source there should be meta tags, canonical elements etc.

 

 

There is nothing in admin/config.

My website is www.nontando.com - Top of browser? do you mean the url description?

 

I wonder if, because I updated the php version after I copied the files to my server, could that have resulted in the admin not being updated?

 

Thanks, Gary

Edited by bksbeat

Share this post


Link to post
Share on other sites

There is nothing in admin/config.

My website is www.nontando.com - Top of browser? do you mean the url description?

 

I wonder if, because I updated the php version after I copied the files to my server, could that have resulted in the admin not being updated?

 

Thanks, Gary

 

Gary this is a support thread for the contribution I don't have the time to explain basic web stuff to you.

 

Perhaps search in Google or ask some questions in the general forum.

 

Your products and categories seem to be producing some output but it doesn't look like KissMT output.

Share this post


Link to post
Share on other sites

Gary this is a support thread for the contribution I don't have the time to explain basic web stuff to you.

 

Perhaps search in Google or ask some questions in the general forum.

 

Your products and categories seem to be producing some output but it doesn't look like KissMT output.

 

 

 

Robert, I apologize. I seemed to have (I had another meta tags contr in index.php)updated index.php and output seems to be working now. Only on my home page www.nontando.com, my source is

<title>My Great Product Range - Full Range of Wiggets - Buy from Nontando</title>

<meta name="description" content="My Great Product Range, Full Range of Wiggets.">

<meta name="keywords" content="great,product,range,full,wiggets">

<link rel="canonical" href="http://www.nontando.com/">

 

Not sure where this is coming from? Nothing is appearing in admin for whatever reason but at least the meta tags on my product/category pages are looking good.

 

Thanks again and sorry, Gary

Share this post


Link to post
Share on other sites

Robert, I apologize. I seemed to have (I had another meta tags contr in index.php)updated index.php and output seems to be working now. Only on my home page www.nontando.com, my source is

<title>My Great Product Range - Full Range of Wiggets - Buy from Nontando</title>

<meta name="description" content="My Great Product Range, Full Range of Wiggets.">

<meta name="keywords" content="great,product,range,full,wiggets">

<link rel="canonical" href="http://www.nontando.com/">

 

Okay just found the answer for the above. Just need to edit...

includes/languages/<my language>/kissmt.php

 

 

So it just trying to figure out why nothing is in admin (I think that is all that is not working).

 

Thanks again and sorry, Gary

Share this post


Link to post
Share on other sites

Robert, I apologize. I seemed to have (I had another meta tags contr in index.php)updated index.php and output seems to be working now. Only on my home page www.nontando.com, my source is

<title>My Great Product Range - Full Range of Wiggets - Buy from Nontando</title>

<meta name="description" content="My Great Product Range, Full Range of Wiggets.">

<meta name="keywords" content="great,product,range,full,wiggets">

<link rel="canonical" href="http://www.nontando.com/">

 

Okay just found the answer for the above. Just need to edit...

includes/languages/<my language>/kissmt.php

 

 

So it just trying to figure out why nothing is in admin (I think that is all that is not working).

 

Thanks again and sorry, Gary

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×