Jump to content
Sign in to follow this  
svouratoys

Helppp

Recommended Posts

Hello

 

i have a problem with payment modules in oscommerce

 

All payment modules sudently lost . All modules are missing . Not even default and i cant find my backups

Can you help me please?

Share this post


Link to post
Share on other sites

Download the osc install file and just copy the relevant scripts to the includes/modules/payment directory..

 

Of course they didn't just disappear by themselves, so you might want to try and figure what you or anyone else did that made them disappear...


www.jyoshna.com. Currently using OsC with STS, Super Download Store, Categories Descriptons, Manufacturers Description, Individual Item Status, Infopages unlimited, Product Sort, Osplayer with flashmp3player, Product Tabs 2.1 with WebFx Tabpane and other bits and pieces including some I made myself. Many thanks to all whose contributions I have used!

Share this post


Link to post
Share on other sites

Download the osc install file and just copy the relevant scripts to the includes/modules/payment directory..

 

Of course they didn't just disappear by themselves, so you might want to try and figure what you or anyone else did that made them disappear...

 

thank you for your reply

i am new on oscommerce

 

i had downloaded my site with an ftp client

 

i upload my old payment direstory but doesnt work

 

i must download the payment module from somewhere?

 

where i can find it?

 

 

i have to make changes to any configuration file??

 

thank you in advance

Share this post


Link to post
Share on other sites

thank you for your reply

i am new on oscommerce

 

i had downloaded my site with an ftp client

 

i upload my old payment direstory but doesnt work

 

i must download the payment module from somewhere?

 

where i can find it?

 

 

i have to make changes to any configuration file??

 

thank you in advance

The payment modules are a number of different scripts for each payment method that should be in the includes/modules/payment directory of your store. When you upload them by ftp they should be uploaded in ascii format. If they are there and you still can't see them or 'install' ie activate them and provided any required configuration details, when you log in to the admin section of your store, then something else is wrong.


www.jyoshna.com. Currently using OsC with STS, Super Download Store, Categories Descriptons, Manufacturers Description, Individual Item Status, Infopages unlimited, Product Sort, Osplayer with flashmp3player, Product Tabs 2.1 with WebFx Tabpane and other bits and pieces including some I made myself. Many thanks to all whose contributions I have used!

Share this post


Link to post
Share on other sites

The payment modules are a number of different scripts for each payment method that should be in the includes/modules/payment directory of your store. When you upload them by ftp they should be uploaded in ascii format. If they are there and you still can't see them or 'install' ie activate them and provided any required configuration details, when you log in to the admin section of your store, then something else is wrong.

thank you

i am trying to find what is wrong

 

i dont know where to look first

 

thank you again

Share this post


Link to post
Share on other sites

thank you

i am trying to find what is wrong

 

i dont know where to look first

 

thank you again

Well, can you confirm that you do have files with names like cc.php, cod.php, paypay_standard.php, etc in the includes/modules/payment directory on the catalog side of your store? Did you do anything to the store before they 'disappeared', if so what? Does anything else seem to be wrong or unusual with your store? When you say they have disappeared, do you mean that when you place an order no payment options are offered, or do you mean that when you log in to the modules/payment option on the admin menu no payment modules are listed (or both)? Which payment module(s) were you using?

 

If you want any more help you will need to give more information about the problem - what the symptoms are, what you have done, where the error is occuring, the text of any error message displayed, etc.


www.jyoshna.com. Currently using OsC with STS, Super Download Store, Categories Descriptons, Manufacturers Description, Individual Item Status, Infopages unlimited, Product Sort, Osplayer with flashmp3player, Product Tabs 2.1 with WebFx Tabpane and other bits and pieces including some I made myself. Many thanks to all whose contributions I have used!

Share this post


Link to post
Share on other sites

Well, can you confirm that you do have files with names like cc.php, cod.php, paypay_standard.php, etc in the includes/modules/payment directory on the catalog side of your store? Did you do anything to the store before they 'disappeared', if so what? Does anything else seem to be wrong or unusual with your store? When you say they have disappeared, do you mean that when you place an order no payment options are offered, or do you mean that when you log in to the modules/payment option on the admin menu no payment modules are listed (or both)? Which payment module(s) were you using?

 

If you want any more help you will need to give more information about the problem - what the symptoms are, what you have done, where the error is occuring, the text of any error message displayed, etc.

 

 

install004.jpg

i have the cc.php, cod.php, paypay_standard.php files as shown in the image

 

i did not do anything before

at 30/12 at 2.00 pm is working and at 2.30 same day day not working

 

when i put an order i have only 1 payment option

 

Shipping Method

This is currently the only shipping method available to use on this order.

 

Table Rate

Best Way 7.00

and when i log in to the modules/payment option on the admin menu no payment modules are listed

 

Snap1.jpg

 

i used the paypal module

 

and i have problem with backup

i cant find my old backups

 

Snap3.jpg

 

and i noticed that the directory of modules is

 

Κατάλογος Modules: /var/www/vhosts/svouratoys.gr/httpdocs/osc/includes/modules/payment/

and httpdocs is on my old site

 

may be a configuration file changed to show the old catalog

 

how can i find the file shown the module path?

 

thank you for your help and your time

Share this post


Link to post
Share on other sites

Hmmm, well that may be too much information. You'd better implement the security measures required to secure osc double quick, or you'll have more to worry about than missing payment modules.

 

check your configure.php files to make sure the FS and WS paths are all correctly specified for your new site.

Edited by Ben Nevis

www.jyoshna.com. Currently using OsC with STS, Super Download Store, Categories Descriptons, Manufacturers Description, Individual Item Status, Infopages unlimited, Product Sort, Osplayer with flashmp3player, Product Tabs 2.1 with WebFx Tabpane and other bits and pieces including some I made myself. Many thanks to all whose contributions I have used!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×