Jump to content
Jack_mcs

Autologon V 2

Recommended Posts

This is the support thread for this addon. One may already exist but I couldn't find it. I did find a lot of threads where some support was offered but it was minor, at best, so I thought it best to create a new thread. This isn't my contribution but I have changed it to allow it to work and to where the instructions make more sense, at least to me.

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

This is the support thread for this addon. One may already exist but I couldn't find it. I did find a lot of threads where some support was offered but it was minor, at best, so I thought it best to create a new thread. This isn't my contribution but I have changed it to allow it to work and to where the instructions make more sense, at least to me.

Hi Jack

 

Thanks, will try this later. The previous versions never worked.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

Yes, I found that out when I tried it and started checking the threads. I've installed it into three shops now though and it is working fine so far. I look forward to hearing if it works for others.

Share this post


Link to post
Share on other sites

Yes, I found that out when I tried it and started checking the threads. I've installed it into three shops now though and it is working fine so far. I look forward to hearing if it works for others.

 

Hi

 

I tried this, but it doesn't seem to work for me (or most likely I don't understand how to operate this).

 

I'm on PHP 5.2.10 and MySQL 5.0.45, having a shared account and have upgraded to osCommerce Online Merchant v2.2 RC2.

 

In Firefox -> Tools -> Settings -> Show Cookies I can see - in the secure part - one cookie called password and one called email_address. In the unsecure part these two cookies aren't present.

 

Anything I can do to troubleshoot?

Share this post


Link to post
Share on other sites

I have FF V3 installed so I can't compare the settings to yours. Assuming the cookie viewer worked in your version, my guess is that you don't have cookies enabled. You could also try IE just to be sure it is not the browser. You will have to login again with IE since the cookies only apply to one browser.

Share this post


Link to post
Share on other sites

I have FF V3 installed so I can't compare the settings to yours. Assuming the cookie viewer worked in your version, my guess is that you don't have cookies enabled. You could also try IE just to be sure it is not the browser. You will have to login again with IE since the cookies only apply to one browser.

 

Thanks for your answer.

 

As far as I can see, I have cookies enabled. I have tried with IE also and it didn't work either.

 

Now I have looked at the cookies and they appear as follows - from FF: Tools -> Web Developer -> Cookies -> View Cookie Information:

 

 

Name email_address

Value my-name%40hotmail.com

Host my-domain-se.secure.com

Path /

Secure Yes

Expires Wed, 29 Dec 2010 13:49:18 GMT

 

 

Name password

Value 802332d0b792a7491bb4a63dab6c415b%3Ac6

Host my-domain-se.secure.com

Path /

Secure Yes

Expires Wed, 29 Dec 2010 13:49:18 GMT

 

The first defines in my includes/configure.php looks like this:

 

define('HTTP_SERVER', 'http://www.my-domain.se/');

define('HTTPS_SERVER', 'https://my-domain-se.secure.com/');

define('ENABLE_SSL', true);

define('HTTP_COOKIE_DOMAIN', 'www.my-domain.se');

define('HTTPS_COOKIE_DOMAIN', 'www.my-domain-se.secure.com');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '/');

define('DIR_WS_HTTP_CATALOG', '');

define('DIR_WS_HTTPS_CATALOG', '');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

Would you mind explain how this contrib is supposed to work. That is, one should log in and finally log out and the next time it is possible to go to the website and one is automatically logged in, right?

Share this post


Link to post
Share on other sites

Yes, that is correct. There is a mistake in your configure file. You have

define('HTTPS_SERVER', 'https://my-domain-se.secure.com/'); 
define('HTTPS_COOKIE_DOMAIN', 'www.my-domain-se.secure.com');

The last line should be

define('HTTPS_COOKIE_DOMAIN', '.my-domain-se.secure.com');

I don't know if that will fix the problem you are having but the obvious needs to be fixed first.

Share this post


Link to post
Share on other sites

Yes, that is correct. There is a mistake in your configure file. You have

define('HTTPS_SERVER', 'https://my-domain-se.secure.com/'); 
define('HTTPS_COOKIE_DOMAIN', 'www.my-domain-se.secure.com');

The last line should be

define('HTTPS_COOKIE_DOMAIN', '.my-domain-se.secure.com');

I don't know if that will fix the problem you are having but the obvious needs to be fixed first.

 

I have changed it now. Also I cleared the cache and all the cookies and made a new attempt but - as it seems - to no avail.

 

PS.

I assume that the www are to be deleted as well here:

define('HTTP_COOKIE_DOMAIN', 'www.my-domain.se');

so it reads:

define('HTTP_COOKIE_DOMAIN', '.my-domain.se');

DS.

Share this post


Link to post
Share on other sites

For the http domain name, it doesn't matter which you use. FOr the https domain name, it usually has to be what the ssl was purchased for, though that depends on the ssl. For both cookie paths, they need to be the same as the above two, whatever they are. If all that is setup, try the following:

 

- login to your site - being sure to check the remember me checkbox

- logoff

- click my account - you should be logged in

Share this post


Link to post
Share on other sites

For the http domain name, it doesn't matter which you use. FOr the https domain name, it usually has to be what the ssl was purchased for, though that depends on the ssl. For both cookie paths, they need to be the same as the above two, whatever they are. If all that is setup, try the following:

 

- login to your site - being sure to check the remember me checkbox

- logoff

- click my account - you should be logged in

 

No sorry, it made no difference.

 

As you can see above in my configure.php, both of the cookie paths are just a slash in each define i.e. /.

 

The cookie domains are now set to:

 

define('HTTP_COOKIE_DOMAIN', '.my-domain.se');
define('HTTPS_COOKIE_DOMAIN', '.my-domain-se.secure.com');

Share this post


Link to post
Share on other sites

That's still not correct (unless you've changed it) since you have

define('HTTP_SERVER', 'http://www.my-domain.se

Share this post


Link to post
Share on other sites

That's still not correct (unless you've changed it) since you have

define('HTTP_SERVER', 'http://www.my-domain.se

 

I remember I scanned a lot of forum pages to get the configure.php settings correct. As I had it set (before) everything worked until now, so I don't know...

 

I did a google search and came across this information and according to that, i guess it won't work with my shared ssl anyway.

 

Btw I tried this auto login contribution and also an other one way back and neither of them worked so I guess the best I can do is to forget all about them alltogether. Though it's a petty because they are not invasive code wise.

 

Nevertheless I want to thank you for your time and effort, much appreciated! :)

Share this post


Link to post
Share on other sites

It might be that this won't work with a shared ssl but, even if that is the case, it can be made to work with it. Unfortunately, I don't have a way to test that so it is not something I can fix.

Share this post


Link to post
Share on other sites

Yes, I found that out when I tried it and started checking the threads. I've installed it into three shops now though and it is working fine so far. I look forward to hearing if it works for others.

Share this post


Link to post
Share on other sites

HI JACK WE ARE WANTING TO APPLY THE VERSION CHECKER TO OUR SITE BESTDISCOUNTPERFUMEONLINE.COM I HAVE DOWNLOADED THE VERSION 2.2 HOWEVER WHEN I WENT TO EDIT MY (INCLUDES/APPLICATION_TOP.PHP) I DO NOT KNOW WHERE TO STORE THE TEXT ALSO XXXX,YYYY,ZZZZZ I DON NOT KNOW HOW TO GET THE CONTRIBUTIONS ID NUMBER , VERSION NO , JUST HAVING A FEW PROBLEMS WE GET OUR DATAFEED FROM FRAGX AND THE VERSION CHECKER AGAINST AMAZON WOULD BE AN ABSOLUTE PISSER AND BEING A NEWBIE REALLY SUCKS

CAN SOMEONE PLEASE HELP THIS POOR LOST SOUL REGARDS DAVE

Share this post


Link to post
Share on other sites

HI JACK WE ARE WANTING TO APPLY THE VERSION CHECKER TO OUR SITE BESTDISCOUNTPERFUMEONLINE.COM I HAVE DOWNLOADED THE VERSION 2.2 HOWEVER WHEN I WENT TO EDIT MY (INCLUDES/APPLICATION_TOP.PHP) I DO NOT KNOW WHERE TO STORE THE TEXT ALSO XXXX,YYYY,ZZZZZ I DON NOT KNOW HOW TO GET THE CONTRIBUTIONS ID NUMBER , VERSION NO , JUST HAVING A FEW PROBLEMS WE GET OUR DATAFEED FROM FRAGX AND THE VERSION CHECKER AGAINST AMAZON WOULD BE AN ABSOLUTE PISSER AND BEING A NEWBIE REALLY SUCKS

CAN SOMEONE PLEASE HELP THIS POOR LOST SOUL REGARDS DAVE

First, please turn off All Caps.

 

Second, this is the support thread for the Autologon contribution, not Version Checker.

 

Third, Version check doesn't have anything to do with a datafeed so maybe you are talking about the CompareMyPrice contribution.

 

For the last two items, see the readme file in whatever contribution you are talking about. I always include the support thread in it.

Share this post


Link to post
Share on other sites

Yes, I found that out when I tried it and started checking the threads. I've installed it into three shops now though and it is working fine so far. I look forward to hearing if it works for others.

Thanks Jack, it works.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

Hello There,

 

I installed this contrib with no errors at all.

But for one reason i can't stay logged in.

When i close IE and after a while i go to my shop page i am not logged in, but when i refresh the page i am logged in.

Also i was wondering what to put in the configure file. I had a previous version installed and all worked.But went to a higher version php 5 and mysql 5. I also have a ssl certicate, some help needed here.

Share this post


Link to post
Share on other sites

It sounds like the code is working correctly but something is wrong with your brwoser. Maybe the page is being loaded from cache when you first visit the site. Clearing the cache may fix it.

 

I don't understand what you mean about the configure file. This contribution doesn't change that.

Share this post


Link to post
Share on other sites

Jack,

 

The cache is set to false in admin.

What i mean about the configure file is this there are some settings about cookie_domain and http_server what do i use for these i tried several settings.

 

Thanx for the quick answer

Share this post


Link to post
Share on other sites

I was referring to the cache in the browser. This is the support thread for the Autologon contribution. For questions about your configure file, please post in this thread.

Share this post


Link to post
Share on other sites

Jack,

 

Cleaned the cache in my browser, but no changes still not logged in.

The thing is when i log in and close the page, and reopen the page i am still logged in but when i wait longer i must login.

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

Jack,

 

I think i got it working again, both in FF and IE.

Checked in FF and waited for 3 hours and still logged in.

 

Removed && ($cookies_on == true)) in the login.php and application_top.php.

Also removed the testcookie code.

The settings in includes/configure.php are :

define('HTTP_SERVER', 'http://www.yourdomain.com/');

define('HTTPS_SERVER', 'https://www.yourdomain.com/');

define('ENABLE_SSL', true);

define('HTTP_COOKIE_DOMAIN', 'www.yourdomain.com');

define('HTTPS_COOKIE_DOMAIN', 'www.yourdomain.com');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '/');

 

As far as i remember these are the only changes i made.

 

Maybe this will help others.

Edited by tdc

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×