Jump to content
Sign in to follow this  
lifeline

Easy Populate Version 2.76i-MS2 file splitting does not work.

Recommended Posts

The file split function does not work "Upload and Split EP File")- after pushing "browse" button and selecting the file to upload, you push the "insert into db" button, the progress bar comes on, then page resets-goes back to the way it was...(the file I am trying to upload has 9876 products...) No split up files show up, especially of the kind: "EP_Split1.txt, EP_Split2.txt,..." as described in the Easy Populate Manual/EP Documents.

 

Neither will the "Import EP file from Temp Dir" dropbox field show any split up files that is supposed to be listed there.

 

However, uploading works for 10 and 300 products under the "Upload and Import EP File". I have tried it. But the "Upload and Split EP File" function does not work as I just described. Anybody can please help solve the problem?

 

ps. I have spent hours checking the configuration, particularly the path to "temp/" file. "temp/" file seems to be set properly as it works for file uploads up to 300 products. And the "temp" file is accessible, and is set to 0777 chmod.

 

I have also checked the file for complete headers and EOREORs and tested it with the original products in the OScommerce shopping cart, added 5 products and then 267 new products and it all has worked. The only thing it won't do is 'file split'.

 

ps2. I have tried the "Create Complete .csv file in temp dir" link in the lower right hand corner of the admin panel under "Create Files in Temp Dir

", and it works. However, I did have to go to "Tools > File Manager > Temp" in the admin panel of OScommerce and push the "upload" button again to get the csv file (with 9876 products to show up in the temp/ folder.

Share this post


Link to post
Share on other sites

Sorry, I forgot to post the information on my settings:

 

EP_SHOW_EP_SETTINGS is set to true.

 

Settings & Info

 

EP vers: 2.76i-MS2

osCommerce Online Merchant v2.2 RC2a

OS: Linux 2.6.24.5-grsec

HTTP: Apache/2.0.63 (Unix) mod_ssl/2.0.63 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635

DB: MySQL 5.0.85-community

PHP: 5.2.9 (Zend: 2.2.0)

 

Temp Directory:

/home/adultno1/public_html/lifelineelectronics.com/temp/

Temp Dir is Writable

Magic Quotes is: off

register_globals is: off

Split files on: 300 records

Model Num Size: 12

Price with tax: false

Calc Precision: 2

Replace quotes: false

Field seperator: comma

Excel safe output: true

Preserve tab/cr/lf: false

Category depth: 7

Enable attributes: true

SEF Froogle URLS: false

 

Other Support:

MVS Support: false

Additional Images: false

More Pics: false

UltraPics Pics: false

HTC: false

SPPC: false

Extra Fields: false

PDF Upload: false

 

Sample of upload CSV file: http://lifelineelectronics.com/sampleEPupload/EP2009Dec16_ORIGINAL_OSCOM_NO_ATTRIBUTES.csv

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×