Jump to content
Latest News: (loading..)
Sign in to follow this  
FWR Media

KissMT Dynamic SEO Meta Tags

Recommended Posts

For some reason it's broken my tables and added a box at the bottom of the index page, see it here http://goldmonger.net

 

 

Hi Christian

 

It is not broken. It is working correctly.

 

Goto

\includes\modules\kiss_meta_tags\includes\init.php

 

and change

 

  @define( 'KISSMT_PERFORMANCE_OUTPUT', 'true' );

 

to

 

  @define( 'KISSMT_PERFORMANCE_OUTPUT', 'false' );

 

 

This will remove the performance data form your website

 

Regards

 

Ken

Share this post


Link to post
Share on other sites

New version uploaded

 

Same download url, the filename changed to .. KissMT_1.0_r50_RC.zip

 

Changes to the way the canonical elements are produced.

 

Minor changes to the extras package.

 

To upgrade the main script.

 

1) Drop on top the uploads directory maintaining the directory structure. Then reset the cache.

 

To upgrade the extras.

 

1) Upload optional_extras/uploads/catalog/includes/modules/kiss_meta_tags/classes/kissmt_descriptions_extension.php

 

2) catalog/index.php

 

Find ( 2 instances of ) ..

 

<?php
 // KissMT start
 KissMT_Desc_Extn::init()->output();
 // KissMT end
?>
       </table></td>
     </tr>
     <tr>
       <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

 

Change to ..

 

        </table>
       <?php KissMT_Desc_Extn::init()->output(); ?>
       </td>
     </tr>
     <tr>
       <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

3) stylesheet.css add the following: -

 

.kissmt_description {
 font-family: Verdana, Arial, sans-serif;
 font-size: 10pt;
 color: #9a9a9a;
 padding: 0.5em;  
}

 

This will style the div which now contains the categories/manufacturers description.

Share this post


Link to post
Share on other sites

Hi, Im new to this.

 

can i also please have the download link?

 

Thanks!

 

Pat

 

Link to download sent. You can ignore the above changes.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Thanks everyone for your help and support, this has now been released.

 

Download.

 

Support Topic.

 

This development thread is now closed.

Share this post


Link to post
Share on other sites

Hi guys!

 

I installed "KissMT_1.0_r55_RC" and everything works perfect.

However when I go into Korean, the following errors come out. Can any one help me?

I copied "kissmt.php" to Japanese, Chinese and Korean folders but only Korean pages are not working.

 

 

Warning: htmlentities() [function.htmlentities]: charset `euc-kr' not supported, assuming iso-8859-1 in /home/devils13/public_html/includes/modules/kiss_meta_tags/abstracts/kiss_modules.php on line 353

 

Warning: htmlentities() [function.htmlentities]: charset `euc-kr' not supported, assuming iso-8859-1 in /home/devils13/public_html/includes/modules/kiss_meta_tags/abstracts/kiss_modules.php on line 354

 

Warning: htmlentities() [function.htmlentities]: charset `euc-kr' not supported, assuming iso-8859-1 in /home/devils13/public_html/includes/modules/kiss_meta_tags/abstracts/kiss_modules.php on line 355

 

Warning: htmlentities() [function.htmlentities]: charset `euc-kr' not supported, assuming iso-8859-1 in /home/devils13/public_html/includes/modules/kiss_meta_tags/abstracts/kiss_modules.php on line 356

 

 

Thanks in advance.

 

Jong.

Share this post


Link to post
Share on other sites

Hi guys!

 

I installed "KissMT_1.0_r55_RC" and everything works perfect.

However when I go into Korean, the following errors come out. Can any one help me?

I copied "kissmt.php" to Japanese, Chinese and Korean folders but only Korean pages are not working.

 

 

Warning: htmlentities() [function.htmlentities]: charset `euc-kr' not supported, assuming iso-8859-1 in /home/devils13/public_html/includes/modules/kiss_meta_tags/abstracts/kiss_modules.php on line 353

 

Warning: htmlentities() [function.htmlentities]: charset `euc-kr' not supported, assuming iso-8859-1 in /home/devils13/public_html/includes/modules/kiss_meta_tags/abstracts/kiss_modules.php on line 354

 

Warning: htmlentities() [function.htmlentities]: charset `euc-kr' not supported, assuming iso-8859-1 in /home/devils13/public_html/includes/modules/kiss_meta_tags/abstracts/kiss_modules.php on line 355

 

Warning: htmlentities() [function.htmlentities]: charset `euc-kr' not supported, assuming iso-8859-1 in /home/devils13/public_html/includes/modules/kiss_meta_tags/abstracts/kiss_modules.php on line 356

 

 

Thanks in advance.

 

Jong.

 

Hi Jong

 

Yes, this is a known issue that has been fixed in the new ( not uploaded yet ) version, send me a PM and I'll return a download link for the latest revision. You won't have to reinstall it, just drop on top the new files within the modules/kiss_meta_tags directory/

 

The issue is that the script uses html_entities to format strings and only the charsets in the following array are supported: -

 

array( 'ISO-8859-1', 'ISO-8859-15', 'UTF-8', 'CP866', 'CP1251', 'CP1252', 'KOI8-R', 'BIG5', 'GB2312', 'BIG5-HKSCS', 'SHIFT_JIS', 'EUC-JP' );

 

The new revision detects if the charset is not supported and if it isn't supported the html_entities function is bypassed.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Hi Jong

 

Yes, this is a known issue that has been fixed in the new ( not uploaded yet ) version, send me a PM and I'll return a download link for the latest revision. You won't have to reinstall it, just drop on top the new files within the modules/kiss_meta_tags directory/

 

The issue is that the script uses html_entities to format strings and only the charsets in the following array are supported: -

 

array( 'ISO-8859-1', 'ISO-8859-15', 'UTF-8', 'CP866', 'CP1251', 'CP1252', 'KOI8-R', 'BIG5', 'GB2312', 'BIG5-HKSCS', 'SHIFT_JIS', 'EUC-JP' );

 

The new revision detects if the charset is not supported and if it isn't supported the html_entities function is bypassed.

 

Thanks, Mate.

 

I am really new to this OSCommerce and have no basic knowledge of programing at all... Can you explain what PM is? And how can I send it to you?

 

Thanks again and sorry for your trouble.

 

Jong.

Share this post


Link to post
Share on other sites

Thanks, Mate.

 

I am really new to this OSCommerce and have no basic knowledge of programing at all... Can you explain what PM is? And how can I send it to you?

 

Thanks again and sorry for your trouble.

 

Jong.

 

PM = Personal Message .. if you look below my forum name theres a link to send a PM.

 

But never mind I'll send you the link now.

Share this post


Link to post
Share on other sites

PM = Personal Message .. if you look below my forum name theres a link to send a PM.

 

But never mind I'll send you the link now.

 

Thanks, Rob.

 

I'd like to share my success here...hehe

As you told me, I re-uploaded the new version of files and it is now working perfect.

 

Many thanks,

 

Jong

Share this post


Link to post
Share on other sites

Hi guys!

Im getting this error:

 

"Error!

Unable to determine the page link!"

 

link: http://panelaseci.dominiotemporario.com/product_info.php

 

Any idea?

 

:/

 

It is nothing to do with KissMT tep_href_link() is being sent a null value for $page.

Share this post


Link to post
Share on other sites

It is nothing to do with KissMT tep_href_link() is being sent a null value for $page.

 

I'm a new here, and in php. What should I to do to solve this problem?

Thanks for helping.

 

:thumbsup:

Share this post


Link to post
Share on other sites

I'm a new here, and in php. What should I to do to solve this problem?

Thanks for helping.

 

:thumbsup:

 

 

Post your issue in the general forum please, people look here for support for KissMT.

Share this post


Link to post
Share on other sites

Post your issue in the general forum please, people look here for support for KissMT.

 

Before replacing the code of KissMt the page was working fine... So seems like the cause was KissMT.

Edited by vinibr

Share this post


Link to post
Share on other sites

Before replacing the code of KissMt the page was working fine... So seems like the cause was KissMT.

 

What version of PHP are you on?

 

If the error was coming through KissMT it would mean that KissMT is passing a null page which is impossible as there would be an E_WARNING issued.

 

What setting do you have in application_top.php for error_reporting? ( search the top of the file for error_reporting )

Edited by FWR Media

Share this post


Link to post
Share on other sites

PHP 5.2

MySQL 5.1 - Linux

 

I edited the above post please read again.

Share this post


Link to post
Share on other sites

I edited the above post please read again.

 

I found:

 

// set the level of error reporting

error_reporting(E_ALL & ~E_NOTICE);

Share this post


Link to post
Share on other sites

I found:

 

// set the level of error reporting

error_reporting(E_ALL & ~E_NOTICE);

 

What happens if you create a brand new php file in the root of your site called mytest.php containing the following: -

 

<?php
     function setBaseName() {
     $base = new ArrayIterator( array( 'SCRIPT_NAME', 'PHP_SELF' ) );
     while ( $base->valid() ) {
       if ( array_key_exists(  $base->current(), $_SERVER ) && !empty(  $_SERVER[$base->current()] ) ) {
         if ( false !== strpos( $_SERVER[$base->current()], '.php' ) ) {
           preg_match( '@[a-z0-9_]+\.php@i', $_SERVER[$base->current()], $matches );
           if ( is_array( $matches ) && ( array_key_exists( 0, $matches ) )
                                     && ( substr( $matches[0], -4, 4 ) == '.php' )
                                     && ( is_readable( $matches[0] ) ) ) {
             return $matches[0];
           } 
         } 
       }
       $base->next();
     }
     // Some odd server set ups return / for SCRIPT_NAME and PHP_SELF when accessed as mysite.com (no index.php) where they usually return /index.php
     if ( ( $_SERVER['SCRIPT_NAME'] == '/' ) && ( $_SERVER['PHP_SELF'] == '/' ) ) {
       return 'index.php';
     } 
     trigger_error( 'KissMT could not find a valid base filename, please inform the developer.', E_USER_WARNING );
   } // end method

   echo 'Basename is ' . setBaseName();
?>

 

Then you browse to it and post what it returns here. ( DELETE the file after )

Edited by FWR Media

Share this post


Link to post
Share on other sites

"Not Found

The requested URL /mytest.php was not found on this server."

 

No .. you have to upload the file to the server .. then it will exist.

Share this post


Link to post
Share on other sites

sorry!

 

"Basename is mytest.php"

 

Well everything seems fine, I can't imagine why you get the tep_href_link error .. nobody else is. Are you sure it was when you added KissMT or do did you install something else as well?

Share this post


Link to post
Share on other sites

Well everything seems fine, I can't imagine why you get the tep_href_link error .. nobody else is. Are you sure it was when you added KissMT or do did you install something else as well?

 

Yes I'm sure. If I change back the line "<?php include_once DIR_WS_MODULES . 'kiss_meta_tags/kiss_meta_tags.php'; ?>" to "<title><?php echo TITLE; ?></title>" it works.

 

My language of my website is "portuguese".

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×