Jump to content
Sign in to follow this  
Keyser Soze

coolMenu

Recommended Posts

Hey there all... I have a few oscommerce sites... this one being my newest (2.2?) I am trying to run the coolmenu cont. but am having a problem getting the menu to go into the categories box. I can move it over the top of the box or anywhere else. Also if I do not call it from /includes/colum_left it will still appear. I get a sytax error on the page but cannot for the life of me figure it out.

 

What is the syntax error?


If at first you don't succeed. Find the answer on a Forum.

Share this post


Link to post
Share on other sites
What is the syntax error?

I now have it up and running however the box is positioned by top and left values rather than being inside of the categories box. I do not use 100% of the browser viewing area which runs me into a positioning problem across different browser settings. The website is Here

Edited by koolcads

Share this post


Link to post
Share on other sites
I now have it up and running however the box is positioned by top and left values rather than being inside of the categories box. I do not use 100% of the browser viewing area which runs me into a positioning problem across different browser settings. The website is Here

 

Thats the problem. the menu doesn't sit inside the box, it is positioned solely by the left and right positions and made to look as if its in the box.

 

To get the menu to position itself correctly for the major browsers, you need to do some workarounds with the positioning.

 

I posted a kinda solution to this problem on PAGE 34 of this forum, it was a bit longwinded and relied on javascript to position the menu as good as possible.

 

Not the best, but may be of some assistance for you.

 

Mark.


If at first you don't succeed. Find the answer on a Forum.

Share this post


Link to post
Share on other sites

Hi, I am trying to get this contrib. to work with my site, but all I see is the javascript code. Now, I do have the sts template management installed, so I am sure it has something to do with that. Here is the site:

 

http://d1.interxstream.com/~fanedge/index....19ee10f16be654e

 

Has anyone been able to get this to work with the STS?

 

I tried to read through this thread, but it was soo long I just couldn't find anything about it.....

 

Thanks,

Damion

Share this post


Link to post
Share on other sites
Hi, I am trying to get this contrib. to work with my site, but all I see is the javascript code. Now, I do have the sts template management installed, so I am sure it has something to do with that. Here is the site:

 

http://d1.interxstream.com/~fanedge/index....19ee10f16be654e

 

Has anyone been able to get this to work with the STS?

 

I tried to read through this thread, but it was soo long I just couldn't find anything about it.....

 

Thanks,

Damion

 

 

Nevermind, I was able to get it working...

Share this post


Link to post
Share on other sites

Hello

 

I have a weird problem with coolmenu. In my shop (2.2 MS2) the menu is successfully installed. It even shows the original categoriemenu at disabled javascript. But in Netscape and Firefox it looks like this:

 

sshot-firefox.jpg

 

Here is my shop: Elbenfeuer.de

 

So if anyone has a solution for this I?d really be thankful, since I?m sitting over this for several evenings by now not having figured it out yet.

 

Greetings ToSam

Share this post


Link to post
Share on other sites
Hello

 

I have a weird problem with coolmenu. In my shop (2.2 MS2) the menu is successfully installed. It even shows the original categoriemenu at disabled javascript. But in Netscape and Firefox it looks like this:

 

sshot-firefox.jpg

 

Here is my shop: Elbenfeuer.de

 

So if anyone has a solution for this I?d really be thankful, since I?m sitting over this for several evenings by now not having figured it out yet.

 

Greetings ToSam

 

I think your missing this step.

 

2.) Replace the following line in your catalog/includes/column_left.php file:

 

Find the following line

include(DIR_WS_BOXES . 'categories.php');

 

Replace it with this

include(DIR_WS_BOXES . 'coolmenu.php');

 

Hope thats it

Share this post


Link to post
Share on other sites

Thanks for your reply, lrm21

 

But as I said, it works in Internet Explorer and Opera. I included the coolmenu.php in my left column. that ain?t the problem, well I?m quite desperate. Nothing seems to help. I installed the menu on another shop and there it works great on each browser. But it?s a different kind of osC. Maybe it is because of that.

 

regards, Tosam

Share this post


Link to post
Share on other sites

what would cause changing the number in '$height.= 12.00*count($categories);' to have no effect on the menu?

 

I added 2 more 3rd level groups....and it shortened the height of coolmenu(for whatever reason). Now I cant make coolmenu fill the catagory box once again. Any ideas?

Share this post


Link to post
Share on other sites

nevermind. For SOME reason it was coming up as '$height.= 12.00*count($categories);' when I downloaded the file....I made all kindsa changes to that number and it did nothing. So I gave up. Then I redownloaded the file and compared it to my original coolmenu file...noticed that now it said '$height.= 5.40*count($categories);' !!

 

Readjusted the number and it worked fine. NO IDEA what in the world was going on. Even the first file that I deleted on my computer says 5.40 after I restored it. weiiiiiirrrd

Share this post


Link to post
Share on other sites

Hello all. I'm new here so bear with me. I am trying to use the coolMenu contribution and have been able to get it to work. However, I cannot figure out how to make the menu maintain it's position with different resolutions and browser resizing. I know there have been a lot of posts on this subject (52 pages worth) and I have spent days trying to find a clear answer. I am almost at the point of giving up...

 

Can someone please post some clear instructions on how to get around the menu position problem? As stated previously, the menu is working, it just does not stay in the correct location when resizing the browser, or viewing under different resolutions. Perhaps an update to the coolMenu contribution with this information is in order?

 

Thanks in advance!

Share this post


Link to post
Share on other sites

Hello, i?m in spain , my english bad, sorry, question :

coolmenu is ok, install ok , in position ok...

problem :

no look the : New Products.... in web.

web : www.fidor.org ( thanks from spain. ) and Merry christmas !!!!

Share this post


Link to post
Share on other sites

Hello,

 

I am a new osCommerce-user, installed it and it works great.

I liked the CoolMenu very much and installed it what didn't work.

Then I did a brand new install, with the CoolMenu-changes in the uninstalled

php-files.

Installation worked fine, put the permissions as said in the Dutch osCommerce-forum.

When I start the Admin-site it works ok.

When I try to start the shop I get the next message :

 

Warning: main(includes/coolmenu.php): failed to open stream: Permission denied in /Library/WebServer/Documents/index.php on line 48

 

Fatal error:main():Failed opening required 'includes/coolmenu.php' (include_path='.:/usr/lib/php') in /Library/WebServer/Documents/index.php on line 48

 

in index.php I put the sentence "<script LANGUAGE="JavaScript1.2"SRC=?ncludes/menu_animation.js"></SCRIPT>"

directly under <head>

 

and

 

<!-- coolMenu //-->

<php? require (DIR_WS_INCLUDES . 'coolmenu.php'); ?>

<!-- ccolMenu_eof //-->

 

just direct under "<bodymargin etc... "

 

Can somebody tell me what I did wrong... and (more important :) ) how to solve the problem.

Share this post


Link to post
Share on other sites
Help on the bug with the categories not fitting into

the box:

This is NOT a bug. You cannot place these DHTML-Layers

RELATIVELY in your HTML-Website because NS 4.x does not

know this feature.

But it is possible to change the ABSOLUTE position of the

menu by modifiying the following lines:

oCMenu.fromLeft=10

oCMenu.fromTop=100

You can also change the height of the trans.gif-image

in the box and by doing this you change the height

of the box, too.

 

Try serching for

$height.= 2.65*count($categories)

in catalog/includes/coolmenu.php and change the number 2.65

to alter the height of the box.

PLEASE DO NOT ASK FOR SUPPORT BY E-MAIL!

I GOT 27(!) E-MAILS DURING THE LAST 2 DAYS AND

I WON'T ANWSER THEM ANY MORE!

Full coolMenu support will be offered via this forum

and NOT via email.

Thanks

&y

 

I am sorry. I might be retarded but I cannot find these variables. you can see what I have so far at http://www.kspersyn.com I am sure that the problem I am having is the same as what is being discussed here. I just cant see how. The site is not live so feel free to test it out. the only page I have contrib installed on is the index of catalog.

 

Thank you very much for this contrib. It is really nice.

Also thanks in advance to any help you can offer.

 

Thanks,

Matthew Stinson


I thought this stuff was gonna be easy!!

BACK IT UP BEFORE YOU JACK IT UP!!!!

Share this post


Link to post
Share on other sites
Hi All,

 

The coolmenu is just what I'm looking for, looks great - so before I populate the site I want to get the look & feel right.

 

I'm new, so sorry to sound dim... hi Andreas..

 

I've got the coolmenu instructions here - I'm stuck right at the beginning -

 

You say -

2.) Replace the following line in your catalog/includes/column_left.php file:

 

REPLACE:

 

include(DIR_WS_BOXES . 'categories.php');

 

BY:

 

include(DIR_WS_BOXES . 'coolmenu.php');

 

I don't seem to have the line - include(DIR_WS_BOXES . 'categories.php'); - anyone know what code to change....

 

here is my includes/column_left.php...

 

<?php

/*

$Id: column_left.php,v 1.1.1.1 2004/03/04 23:40:37 ccwjr Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright ? 2002 osCommerce

 

Released under the GNU General Public License

*/

 

$column_query = tep_db_query('select display_in_column as cfgcol, infobox_file_name as cfgtitle, infobox_display as cfgvalue, infobox_define as cfgkey, box_heading, box_template, box_heading_font_color from ' . TABLE_INFOBOX_CONFIGURATION . ' where template_id = ' . TEMPLATE_ID . ' and infobox_display = "yes" and display_in_column = "left" order by location');

while ($column = tep_db_fetch_array($column_query)) {

 

if ( file_exists(DIR_WS_TEMPLATES . TEMPLATE_NAME . '/boxes/' . $column['cfgtitle'])) {

define($column['cfgkey'],$column['box_heading']);

$infobox_define = $column['box_heading'];

$infobox_template = $column['box_template'];

$font_color = $column['box_heading_font_color'];

$infobox_class = $column['box_template'];

//cache control side box detect

if ((USE_CACHE == 'true') && empty($SID) && ($column['cfgtitle'] == 'categories4.php') ) {

echo tep_cache_categories_box4();

} else if ((USE_CACHE == 'true') && empty($SID) && ($column['cfgtitle'] == 'manufacturers.php') ) {

echo tep_cache_manufacturers_box();

} else {

require(DIR_WS_TEMPLATES . TEMPLATE_NAME . '/boxes/' . $column['cfgtitle']);

}

// end cache control code

}else{

define($column['cfgkey'],$column['box_heading']);

$infobox_define = $column['box_heading'];

$infobox_template = $column['box_template'];

$font_color = $column['box_heading_font_color'];

$infobox_class = $column['box_template'];

require(DIR_WS_BOXES . $column['cfgtitle']);

 

}

}

?>

 

where should I change the line code...

Sorry to be so dim,, thanks in advance...

Has anyone answered this question? I have the same issue and I am running cre loaded with a template installed... the instructions don't fit with this set up - any answers please??? This is the second post ansking this question I have come across in the forums, but I cannot find an answer to them? <_<

Thanks

Share this post


Link to post
Share on other sites

Has anyone answered this question? I have the same issue and I am running cre loaded with a template installed... the instructions don't fit with this set up - any answers please??? This is the second post ansking this question I have come across in the forums, but I cannot find an answer to them? <_<

Thanks

 

<?php
/*
 $Id: column_left.php,v 1.15 2003/07/01 14:34:54 hpdl Exp $

 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

 if ((USE_CACHE == 'true') && empty($SID)) {
echo tep_cache_categories_box();
 } else {
//added cool menu - tongo
//include(DIR_WS_BOXES . 'categories.php');
include(DIR_WS_BOXES . 'coolmenu.php');
//end add
 }

 if ((USE_CACHE == 'true') && empty($SID)) {
echo tep_cache_manufacturers_box();
 } else {
include(DIR_WS_BOXES . 'manufacturers.php');
 }

 require(DIR_WS_BOXES . 'whats_new.php');
//  require(DIR_WS_BOXES . 'search.php');
 //require(DIR_WS_BOXES . 'information.php');

 

This is what column_left should look like if you have MS2. you guys have to figure out which part corresponds to what in your installation or modifications

Share this post


Link to post
Share on other sites
<?php
/*
 $Id: column_left.php,v 1.15 2003/07/01 14:34:54 hpdl Exp $

 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

 if ((USE_CACHE == 'true') && empty($SID)) {
echo tep_cache_categories_box();
 } else {
//added cool menu - tongo
//include(DIR_WS_BOXES . 'categories.php');
include(DIR_WS_BOXES . 'coolmenu.php');
//end add
 }

 if ((USE_CACHE == 'true') && empty($SID)) {
echo tep_cache_manufacturers_box();
 } else {
include(DIR_WS_BOXES . 'manufacturers.php');
 }

 require(DIR_WS_BOXES . 'whats_new.php');
//  require(DIR_WS_BOXES . 'search.php');
 //require(DIR_WS_BOXES . 'information.php');

 

This is what column_left should look like if you have MS2. you guys have to figure out which part corresponds to what in your installation or modifications

 

Thanks for that T-love. I know what the original version of osc should look like, but as mentioned we are running cre loaded with a template installed - there must be heaps of shops who have done this and I was hoping someone might help with what code to change as I haven't got the foggiest idea how to do so :huh: - but I am very good at following instructions :)

This is the reason I and a couple of other people have posted requests for help on this issue because we cannot figure it out - again - any assistance would be greatly appreciated

Share this post


Link to post
Share on other sites

Hi everyone,

 

 

I seem to be having the same problems as most with this contribution.. Mostly, I can't get it positioned right.. It seems to overlapping into the other boxes.. For example.. It's all in my manufacturers box and that looks bad!

 

How the heck do you fix this? I started to think maybe i missed a file or something that I should of put code in as instructed via the install read me.. But I don't think I did.. So now I'm coming here in hopes of some help..

 

Thanks in advance..

 

Christine


If it ain't broke, don't fix it! :)

Share this post


Link to post
Share on other sites
Hi everyone,

I seem to be having the same problems as most with this contribution.. Mostly, I can't get it positioned right.. It seems to overlapping into the other boxes.. For example.. It's all in my manufacturers box and that looks bad!

 

How the heck do you fix this? I started to think maybe i missed a file or something that I should of put code in as instructed via the install read me.. But I don't think I did.. So now I'm coming here in hopes of some help..

 

Thanks in advance..

 

Christine

 

 

Is it bigger than the box it sits in or is it positioned wrong. A screenshot or link to your page would help

Share this post


Link to post
Share on other sites
Is it bigger than the box it sits in or is it positioned wrong. A screenshot or link to your page would help

 

 

Here you go.. These are two pictures that I'm displaying of how I want my page to look.. And this is how it looks now.. Thanks for your help also.. It's much appreciated..

As you can see.. My menu is currently overlapping the other infobox. In this instance, it so happens to be the manuafacturers getting lapped over.. I believe the fix for this would be finding out how long your would want the infobox to be.. The table widthh and height needs to be munipulated in order for the Dynamic HTML to fit in the box.. But where to find this exactly without making other erros most probably.. You know what I mean?

 

This is my cool menu now. Kinda sucks.. LOL

mine.gif

 

This is how I want my menu to look.. Nice! :)

geraet.gif

 

Thank you again,

 

Christine

Edited by Redsonya

If it ain't broke, don't fix it! :)

Share this post


Link to post
Share on other sites
Here you go.. These are two pictures that I'm displaying of how I want my page to look.. And this is how it looks now.. Thanks for your help also.. It's much appreciated..

As you can see.. My menu is currently overlapping the other infobox. In this instance, it so happens to be the manuafacturers getting lapped over.. I believe the fix for this would be finding out how long your would want the infobox to be.. The table widthh and height needs to be munipulated in order for the Dynamic HTML to fit in the box.. But where to find this exactly without making other erros most probably.. You know what I mean?

 

This is my cool menu now. Kinda sucks.. LOL

mine.gif

 

This is how I want my menu to look.. Nice! :)

geraet.gif

 

Thank you again,

 

Christine

 

in /includes/coolmenu.php

find

$height.= 2.65*count($categories);

and mess with the number until you get something that fits. You might also want to move your menu up and to the left a little to make it fit in the box nicely. Change these two values little by little until it looks good:

 

 oCMenu.fromLeft=10
oCMenu.fromTop=100

 

hope that helps

Share this post


Link to post
Share on other sites

Hi again,

 

I just wanted you to know, that this definately did the trick! LOL And now at least I know what controls what in regards to fixing the look and feel to the category box itself..

 

Thank you very much for your time and your help T_Love! It's much appreciated! :D

 

Regards,

 

Christine


If it ain't broke, don't fix it! :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×