Jump to content
Sign in to follow this  
Keyser Soze

coolMenu

Recommended Posts

DAMN! Releasing contirbutions and posting in this forum is hell!

When will people learn not to do testing stuff in live shops..... :evil:

 

 

SHORT DESCRIPTION OF YOUR BUG WITH ERROR-MESSAGES LIKE 404:

 

This happens if you disabled the session-ids in your forum. If you did that, the menu-links look like www.yourschop.com/catalog/default.php&cPath=XX

 

So you just have to replace the (&) by a (?) in "catalog/includes/coolmenu.php"

 

...try searching for "tep_href_link" to find the line..

 

Bye

&y

Share this post


Link to post
Share on other sites

I have just installed this Cool menu contribution on MS1 and the categories boxes are not lined up in the coolmenu.

 

My browser is IE6.

 

Please help!!

 

tim :(

Share this post


Link to post
Share on other sites

Help on the bug with the categories not fitting into

the box:

 

This is NOT a bug. You cannot place these DHTML-Layers

RELATIVELY in your HTML-Website because NS 4.x does not

know this feature.

 

 

But it is possible to change the ABSOLUTE position of the

menu by modifiying the following lines:

 

oCMenu.fromLeft=10

oCMenu.fromTop=100

 

 

 

You can also change the height of the trans.gif-image

in the box and by doing this you change the height

of the box, too.

 

Try serching for

 

$height.= 2.65*count($categories)

 

in catalog/includes/coolmenu.php and change the number 2.65

to alter the height of the box.

 

 

PLEASE DO NOT ASK FOR SUPPORT BY E-MAIL!

I GOT 27(!) E-MAILS DURING THE LAST 2 DAYS AND

I WON'T ANWSER THEM ANY MORE!

 

Full coolMenu support will be offered via this forum

and NOT via email.

 

Thanks

&y

Share this post


Link to post
Share on other sites

I have installed the menu with no problems but when I select any categorie I get a "The page cannot be found" HTTP 404- file not found.

 

regards

 

tim

Share this post


Link to post
Share on other sites

Hi Tim, I had the same problem, this is taken from another page, it should work fine.

 

SHORT DESCRIPTION OF YOUR BUG WITH ERROR-MESSAGES LIKE 404:

 

This happens if you disabled the session-ids in your forum. If you did that, the menu-links look like www.yourschop.com/catalog/default.php&cPath=XX but these links have to be www.yourschop.com/catalog/default.php?cPath=XX

 

So you just have to replace the (&) by a (?) in "catalog/includes/coolmenu.php"

 

...try searching for "tep_href_link" to find the line..

 

Cheers

 

J

Share this post


Link to post
Share on other sites

John,

 

thanks for your quick reply, I actually saw this post just after I sent my post, it is fixed now.

 

thanks for your quick reply.

 

regards

 

tim

Share this post


Link to post
Share on other sites

I have a little problem!

 

I mean i habe install all things correct but in the box ar only the trans.gif, no categories. When I look into the Source Code of my Shop in the browser i see the Categories:

 

oCMenu.makeMenu('top1','','Konsolen','http://www.gamecubex-shop.net/catalog/default.php?osCsid=4aadcf05c0fb904b98a9a2e76b10b4dd?cPath=21')

oCMenu.makeMenu('top2','','Spiele','http://www.gamecubex-shop.net/catalog/default.php?osCsid=4aadcf05c0fb904b98a9a2e76b10b4dd?cPath=22')

oCMenu.makeMenu('sub21','top2','Action','http://www.gamecubex-shop.net/catalog/default.php?osCsid=4aadcf05c0fb904b98a9a2e76b10b4dd?cPath=29')

oCMenu.makeMenu('sub22','top2','Adventure','http://www.gamecubex-shop.net/catalog/default.php?osCsid=4aadcf05c0fb904b98a9a2e76b10b4dd?cPath=28')

oCMenu.makeMenu('sub23','top2','Jump 'n Run','http://www.gamecubex-shop.net/catalog/default.php?osCsid=4aadcf05c0fb904b98a9a2e76b10b4dd?cPath=33')

oCMenu.makeMenu('sub24','top2','Rennspiele','http://www.gamecubex-shop.net/catalog/default.php?osCsid=4aadcf05c0fb904b98a9a2e76b10b4dd?cPath=30')

 

But in the Box is only the trans.gif!

 

I have upload all files in the correct directory und insert the code in the other files. Here a sample of the default.php:

 

<?php

/*

 $Id: default.php,v 1.79 2002/11/23 02:08:10 thomasamoulton Exp $



 osCommerce, Open Source E-Commerce Solutions

 http://www.oscommerce.com



 Copyright (c) 2002 osCommerce



 Released under the GNU General Public License

*/



 require('includes/application_top.php');



// the following cPath references come from application_top.php

 $category_depth = 'top';

 if ($cPath) {

   $categories_products_query = tep_db_query("select count(*) as total from " . TABLE_PRODUCTS_TO_CATEGORIES . " where categories_id = '" . $current_category_id . "'");

   $cateqories_products = tep_db_fetch_array($categories_products_query);

   if ($cateqories_products['total'] > 0) {

     $category_depth = 'products'; // display products

   } else {

     $category_parent_query = tep_db_query("select count(*) as total from " . TABLE_CATEGORIES . " where parent_id = '" . $current_category_id . "'");

     $category_parent = tep_db_fetch_array($category_parent_query);

     if ($category_parent['total'] > 0) {

       $category_depth = 'nested'; // navigate through the categories

     } else {

       $category_depth = 'products'; // category has no products, but display the 'no products' message

     }

   }

 }



 require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_DEFAULT);

?>

<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">

<html <?php echo HTML_PARAMS; ?>>

<head>

<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>"> 

<title><?php echo TITLE; ?></title>

<base href="<?php echo (getenv('HTTPS') == 'on' ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_CATALOG; ?>">

<link rel="stylesheet" type="text/css" href="stylesheet.css"> 

<SCRIPT LANGUAGE="JavaScript1.2" SRC="includes/menu_animation.js"></SCRIPT>

</head>

<body marginwidth="0" marginheight="0" topmargin="0" bottommargin="0" leftmargin="0" rightmargin="0">



<!-- coolMenu //-->

<?php require(DIR_WS_INCLUDES . 'coolmenu.php'); ?>

<!-- coolMenu_eof //-->



<!-- header //-->

<?php require(DIR_WS_INCLUDES . 'header.php'); ?>

<!-- header_eof //-->



<!-- body //-->

 

I insert

 

<!-- coolMenu //-->

<?php require(DIR_WS_INCLUDES . 'coolmenu.php'); ?>

<!-- coolMenu_eof //-->

 

and

 

<SCRIPT LANGUAGE="JavaScript1.2" SRC="includes/menu_animation.js"></SCRIPT>

 

only in the files in the catalog directory, in no subdirectories!

 

Where is the the problem?

Please help me! Thx!

Share this post


Link to post
Share on other sites

I have session problem with this site www.nagrit.com using coolmenu. The result of a link in the coolmenu is like this:

 

default.php?osCsid=4aadcf05c0fb904b98a4d5e76b10b4dd?cPath=29

 

and not:

 

product_info.php?cPath=29osCsid=4aadcf05c0fb904b98a4d5e76b10b4dd

 

 

The problem is that the session (osCsid) is first of the link (?cPath=2...) and generate the problem:

 

 

Warning: session_start() [function.session-start]: The session id contains illegal characters, valid characters are only a-z, A-Z and 0-9 in D:Inetpubwebsnagritcompubliccatalogincludesfunctionssessions.php on line 67

 

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at websnagritcompubliccatalogincludesfunctionssessions.php:67) in websnagritcompubliccatalogincludesfunctionssessions.php on line 67

 

I'm using oscommerce 2.2 CVS snpshot (11/12/2002) and the spider session killer (no SID KILLER!!!)

 

I'm on IIS 5.0 on win 2000 and using PHP 4.3

 

Sorry for my english ....

 

Thanks in advance


They killed Kenny! Bastards!

Share this post


Link to post
Share on other sites

Hi cyberwarrior2k

 

Seem to be having the same problem as you do... the box is there but it's filled with the trans.gif. Source code does suggest that the menu is there somewhere, but I don't see it.

 

I really like to use this menu (looks good!) so if anybody has any suggestions. I followed the install instructions to the letter. Adding the 2 things on all the pages in the catalog folder (no subs).

 

Didn't do it on these files though (checkout_process.php; redirect.php; popup_search_help.php and download.php) since they had no <HEAD> or <BODY> part...

 

that should be ok though?

:?

anyone? :cry:

 

thanks!!!!!!

 

Maarten


_____.:::.________###__________|/______

:(o o): . (o o) (o o)

ooO--(_)--Ooo-ooO--(_)--Ooo-ooO--(_)--Ooo-

Share this post


Link to post
Share on other sites

:cry: I think that the problem is in the coolmenu.php under :

 

echo "','" . tep_href_link(FILENAME_DEFAULT) . "?cPath=" . $categories['id'] . "')n";

}

 

were FILENAME_DEFAULT corresponds to default.php and not to product_info.php and " ?cpath= " is not a compatible with search engine friendly link.

 

but the question is... WHY THE SESSION IS FIRST OF THE LINK AND NOT AFTER?????????? :roll: [/code]


They killed Kenny! Bastards!

Share this post


Link to post
Share on other sites

Hello!

 

I finally got the box on the same spot as the box but now i have my

shop centered on 750 pixels.. but coolmenu still thinks I use the full browser screen... Ok.. But you can't fix this with the height and left counters..

 

For an example see http://www.notebookstore.nl/shop/default.php and resize your screen a little bit... the store keeps 750 pixels but coolmenu goes his own way depending on the resoltion!

 

Please help me on this,

regards erik! (It's a great contribution!!)

Share this post


Link to post
Share on other sites

Hi,

 

First of all, thanks Andreas for this great work!

I need to change the speed of the fading, I need a little shorter than the default one.

Can you help me, please?

Share this post


Link to post
Share on other sites

if you remove ore uncomment the followring line from your coolmenu.php, the fading in MSIE will disappear:

 

oCMenu.level[0].filter="progid:DXImageTransform.Microsoft.Fade(duration=1.2)"

 

You can also change the duration of the fading by modifying duration=1.2

 

best regards

Andy

Share this post


Link to post
Share on other sites

Hi Andy,

 

any idea as to why some of us don't see the menu? But just a box filled with the transparent gif file?

In the source code of the page I can see my menu structure been build up, it just doesn't get displayed...

 

please help us out here if you have the time!

 

thanks!


_____.:::.________###__________|/______

:(o o): . (o o) (o o)

ooO--(_)--Ooo-ooO--(_)--Ooo-ooO--(_)--Ooo-

Share this post


Link to post
Share on other sites
Hi osCommerce-Community.

 

What do you think about the coolMenu on http://www.geraeteland.de ?

 

Does it work with all browsers?

I need to know this because i want to release a contribution for this menu on oscommerce.com soon but i need to that its bugfree...

 

Greetings

&y

 

Just installed your collMenu, looks like it works, but NOT with multilangual sites. Have you managed to make it work in multilangual environment?

-Janusz


J.

Share this post


Link to post
Share on other sites
Hi osCommerce-Community.

 

What do you think about the coolMenu on http://www.geraeteland.de ?

 

Does it work with all browsers?

I need to know this because i want to release a contribution for this menu on oscommerce.com soon but i need to that its bugfree...

 

Greetings

&y

 

Just installed your collMenu, looks like it works, but NOT with multilangual sites. Have you managed to make it work in multilangual environment?

-Janusz


J.

Share this post


Link to post
Share on other sites
Hi there, just installed your contrib and think its great, will surely keep it :) but i found a serious problem. first time i klick on the menu it returns a link in this form :

 

http://www.domain.de/default.php?osCsid=an...any-id&cPath=42 i.e.

 

and i see the correct pages. if i klick again this or other Path i get following url:

 

http://www.domain.de/default.php&cPath=42 i.e.

 

without the session-id. and there i got blank-error-site.

any ideas ?? what did i wrong ?

 

Thank you for soon help.

timmken

 

I had the same problem,

replace & with ? in file /includes/coolmenu.php (line 159)

echo "','" . tep_href_link(FILENAME_DEFAULT) . "& . "')n";

 

echo "','" . tep_href_link(FILENAME_DEFAULT) . "? . "')n";

 

-Janusz


J.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×