Jump to content
FWR Media

Ultimate Seo Urls 5 Pro

Recommended Posts

There is a new download available fixing a redirection bug and adding the ability to force site access of www.mysite.com/index.php to 301 redirect to www.mysite.com/

 

The file is at the same location but named: -

ULTIMATE_Seo_Urls_5_PRO_[beta]_r179_dev.zip

 

To upgrade please do the following: -

 

1) upload the files in the "uploads" and the "drop_on_top" folders overwriting the files currently in place.

 

2) Open up catalog/includes/modules/ultimate_seo_urls5/main/usu5.php

 

On line 34 you will see: -

 

public static $uninstall_db_settings = false;

 

Change this to true .. so ..

 

public static $uninstall_db_settings = true;

 

Save the file then reload/refresh the front of the shop. This will remove the database settings.

 

Re open that file again and change the setting back to true .. then save the file again.

 

When you refresh the front of the shop the database settings will reinstall .. DONE.

Share this post


Link to post
Share on other sites

Thanks for the update.

Actual beta testing has to wait, as I'll be in the hospital next week.

 

Regards.

Share this post


Link to post
Share on other sites

New revision .. same file address different filename: -

 

ULTIMATE_Seo_Urls_5_PRO_[beta]_r180_dev.zip

 

Changelog:

Fixed - issue on Windows IIS servers with request_uri

Fixed - issue with "Force www.mysite.com/ when www.mysite.com/index.php"

index.php?cPath=3 should be 301 redirected to a new seo url, instead it was being redirected to www.mysite.com/

Fixed - Standard install has sqlite as the default cache strategy, the installer now checks if the class SQLiteDatabase exists and if not the default install will be "file". It seems that some generous hosts exclude sqlite from PHP.

 

You just need to drop on top the uploads directory.

 

Also change includes/boxes/languages.php from the extras/replacements/ directory as I have fiddled with it.

Edited by FWR Media

Share this post


Link to post
Share on other sites

I would like to test it also i want to give something back with so many stuff i have learned with you and others in here. :-" :lol:

 

i will pm than and thanks

Edited by Francys

Share this post


Link to post
Share on other sites

I would like to test it also i want to give something back with so many stuff i have learned with you and others in here. :-" :lol:

 

i will pm than and thanks

 

Thanks Francis

 

Download link sent.

Share this post


Link to post
Share on other sites

Hey Rob,

Count me in. I'll try to set up some testing with memcached on my test platform and report what I find. As you already know I have a big db to play with, memcached is functional, so this might fun and informative.

PM on the way.

Share this post


Link to post
Share on other sites

Hey Rob,

Count me in. I'll try to set up some testing with memcached on my test platform and report what I find. As you already know I have a big db to play with, memcached is functional, so this might fun and informative.

PM on the way.

 

Hi thanks for testing, email sent. It would be nice to get some beta test feedback, as you can tell in this thread .. so far I've had very little.

Share this post


Link to post
Share on other sites

Had a little issue on install (this is 5 PRO beta r180);

"No such file or directory" includes/modules/ultimate_seo_urls5/includes/usu_general_functions.php

Found the file had proper caps or was named "Usu_General_Functions.php"

 

Works just fine with memcached on the stock osc db. I copied the following tables from my big db;

categories

categories_description

products

products_description

products_to_categories

 

It pops right through categories with good url's. I'm not sure if I'm overlooking something but all I get for products is back to the index. No rewrites even though it was working fine before I added those tables above.

 

Note;

The products table has about 15 extra columns, and products_description has 11 extras that I can't figure how this install would even know existed. Virgin rc2a, PHP 5.2.6

Share this post


Link to post
Share on other sites

Had a little issue on install (this is 5 PRO beta r180);

"No such file or directory" includes/modules/ultimate_seo_urls5/includes/usu_general_functions.php

Found the file had proper caps or was named "Usu_General_Functions.php"

 

Works just fine with memcached on the stock osc db. I copied the following tables from my big db;

categories

categories_description

products

products_description

products_to_categories

 

It pops right through categories with good url's. I'm not sure if I'm overlooking something but all I get for products is back to the index. No rewrites even though it was working fine before I added those tables above.

 

Note;

The products table has about 15 extra columns, and products_description has 11 extras that I can't figure how this install would even know existed. Virgin rc2a, PHP 5.2.6

 

Hi thanks for the valuable info.

 

"Usu_General_Functions.php" has now been corrected to usu_general_functions.php

 

Re: products I'm not understanding the exact problem .. you say it redirects to index .. are the uris rewritten correctly, do the product uris "look right".

 

I have a feeling it is because your products do not have manufacturers. I think maybe the manufacturers join ought to be a left join as it may not exist.

 

Open ultimate_seo_urls5/page_modules/product_info.php

 

Find ..

 

INNER JOIN :TABLE_MANUFACTURERS m

 

Try changing to ..

 

LEFT JOIN :TABLE_MANUFACTURERS m

 

Then reset the cache.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Bug found ( by motorcity - thanks ) and solved in product_info.php page module:

 

Symptom:

USU5 fails to create an seo url for products.

 

Reason:

manufacturers_name may not exist for every product but the manufacturers table is included in the query as an INNER JOIN, this results in no data being returned by the query if manufacturers_name does not exist.

 

Solution:

Change the join to a LEFT JOIN for manufacturers_name, add some code to deal with the fact it may be missing when building the link text based on user selection.

 

New Revision ( same address different file )

ULTIMATE_Seo_Urls_5_PRO_[beta]_r182_dev.zip

 

Just drop on top the uploads directory, no other changes required.

Share this post


Link to post
Share on other sites

That's awfully cool!

So I had to look it up;

The left join is a mechanism used to join tables before we add other conditions such as WHERE etc.

In the inner-join the comparison we are making between two columns is that they match the same value.

 

Now I seem to be having an issue with "Choose the uri format" rewrite or path_rewrite. I'm running this on a live server that is password protected, and under another test website; http:/myplaysite.com/my_urls5pro_testsite

the trouble is rewrite or path_rewrite take me up a level to myplaysite.com instead of behaving like standard or path_standard which stay in the testsite.

 

Question, is there anything that can be done for displaying fractions in the uri? In my business, size matters. And both the period .375 used for english or metric fractions and the forward slash ala the fraction sign 1/2 disappear in all the uri's I've played with. Is there a way to do that?

Share this post


Link to post
Share on other sites

That's awfully cool!

So I had to look it up;

The left join is a mechanism used to join tables before we add other conditions such as WHERE etc.

In the inner-join the comparison we are making between two columns is that they match the same value.

 

Now I seem to be having an issue with "Choose the uri format" rewrite or path_rewrite. I'm running this on a live server that is password protected, and under another test website; http:/myplaysite.com/my_urls5pro_testsite

the trouble is rewrite or path_rewrite take me up a level to myplaysite.com instead of behaving like standard or path_standard which stay in the testsite.

 

Question, is there anything that can be done for displaying fractions in the uri? In my business, size matters. And both the period .375 used for english or metric fractions and the forward slash ala the fraction sign 1/2 disappear in all the uri's I've played with. Is there a way to do that?

 

If the redirection is to the wrong server location then you have not set RewriteBase correctly in .htaccess. extras/htaccess.txt explains it fully as follows: -

# RewriteBase instructions

# Change RewriteBase dependent on how your shop is accessed as below.

# http://www.mysite.com = RewriteBase /

# http://www.mysite.com/catalog/ = RewriteBase /catalog/

# http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/

 

Text in a uri should only contain latin characters.

Share this post


Link to post
Share on other sites

Hi Robert

Have looked and didn't get any link to download and test, check it and if its worth send me in pm the link ok.

 

Regarding the USU5 PRO, i have questions:

 

> What is the ETA of it being lauched.

 

> Is USU5 PRO an update to USU5 (which is currently the best one to use)?

 

> Will it handle the www.mystore.com/catalog/<insert random characters here and still opens>-p-51.html bug

 

Regards,

Francis

Share this post


Link to post
Share on other sites

Hi Robert

Have looked and didn't get any link to download and test, check it and if its worth send me in pm the link ok.

 

Send me a pm with your email and I will send a link to download. The current package can only be dropped on top of a fresh RC2a there are no install instructions.

 

Regarding the USU5 PRO, i have questions:

 

> What is the ETA of it being lauched.

 

Should have been launched by now but I'm getting no feedback from beta testers.

 

> Is USU5 PRO an update to USU5 (which is currently the best one to use)?

 

USU5 PRO is a new major version of USU5, it is a ground up rewrite with a lot of new functionality. USU5 has no known issues whereas USU5 PRO is undergoing beta testing.

 

> Will it handle the www.mystore.com/catalog/<insert random characters here and still opens>-p-51.html bug

 

Neither USU5 nor USU5 PRO suffer this problem, the "random characters" uri would be 301 redirected to the correct page.

Share this post


Link to post
Share on other sites

Hi there.

 

When I choose a manufacturer from my list it accesses it with no issues, however, if I access manufacturers again and choose the 'Please Select' option, it takes me to the FWR Media Page not found. Do you know why this is, and if so, what file i can edit?

 

many thanks

Share this post


Link to post
Share on other sites

Hi there.

 

When I choose a manufacturer from my list it accesses it with no issues, however, if I access manufacturers again and choose the 'Please Select' option, it takes me to the FWR Media Page not found. Do you know why this is, and if so, what file i can edit?

 

many thanks

 

Are you sure you are posting in the correct place? this is the development topic for USU5 PRO.

Share this post


Link to post
Share on other sites

Are you sure you are posting in the correct place? this is the development topic for USU5 PRO.

 

I'm terribly sorry :blush:

Share this post


Link to post
Share on other sites

Hi Rob

 

I'm glad you picked this up again!

If you want me to testdrive your new version, just send me a pm.

 

Any idea when this pro version will be released?

 

kind regards

wim

Share this post


Link to post
Share on other sites

Hi Rob

 

I'm glad you picked this up again!

If you want me to testdrive your new version, just send me a pm.

 

Any idea when this pro version will be released?

 

kind regards

wim

 

Well to be perfectly honest I am now considering not releasing it. I have had loads of beta test help on another forum .. but here .. nothing, so I'm thinking .. if people cannot be bothered to help me develop it then I don't see why I should pass on many hours of my time. USU5 will still be available and supported however.

Share this post


Link to post
Share on other sites

I'm surprised too that There are only this few beta testers!

I'm willing to help if that makes any difference?! In the first case that would be beta testing this version. And secondly I can try to search more beta testers for you.

 

Offcourse I hope that will change your mind! You allready have put so much effort in this contribution. It would be a shame to do nothing with it.

Your contributions allways are written perfectly and the first version of usu 5 pro looked very promissing to me. In fact I was waiting for the release of this contribution to release my new website...

 

So I'm a bit disappointed just like you...

If you want my help, just ask for it!

 

Kind regards

wim

Share this post


Link to post
Share on other sites

I'm surprised too that There are only this few beta testers!

I'm willing to help if that makes any difference?! In the first case that would be beta testing this version. And secondly I can try to search more beta testers for you.

 

Offcourse I hope that will change your mind! You allready have put so much effort in this contribution. It would be a shame to do nothing with it.

Your contributions allways are written perfectly and the first version of usu 5 pro looked very promissing to me. In fact I was waiting for the release of this contribution to release my new website...

 

So I'm a bit disappointed just like you...

If you want my help, just ask for it!

 

Kind regards

wim

 

I will test it today.

Share this post


Link to post
Share on other sites

Got these two warnings today:

 

Warning: Missing argument 1 for Sqlite_Cache_Module::gc(), called in ***\htdocs\fwrcatalog\includes\modules\ultimate_seo_urls5\main\usu5.php on line 212 and defined in ***\htdocs\fwrcatalog\includes\modules\ultimate_seo_urls5\cache_system\sqlite.php on line 78

 

Warning: SQLiteDatabase::query() [sqlitedatabase.query]: column cache_name is not unique in ***\htdocs\fwrcatalog\includes\modules\ultimate_seo_urls5\cache_system\sqlite.php on line 66

 

Sorry if this has already been mentioned.

 

Regards

Share this post


Link to post
Share on other sites

hi..

 

i want to help you with testing.can i have the download link please.

 

kind regards

 

nafri

Share this post


Link to post
Share on other sites

It's a masterpiece.

 

Would be a shame NOT to release it.

 

Regards.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×