Jump to content
FWR Media

Ultimate Seo Urls 5 Pro

Recommended Posts

hello,

thanks for this very elaborate contribution.

I'm testing a migration from chemo's to USU5 pro, and am wondering how the caching works.

 

As I often upload products with easypopulate, I wonder what happens exactly with the cache.

 

for instance, calling up index.php for a specifica manufacturer, a language specific cache file is created, but what data exactly is cached in that file ?


KEEP CALM AND CARRY ON

I do not use the responsive bootstrap version since i coded my responsive version earlier, but i have bought every 28d of code package to support burts effort and keep this forum alive (albeit more like on life support).

So if you are still here ? What are you waiting for ?!

 

Find the most frequent unique errors to fix:

grep "PHP" php_error_log.txt | sed "s/^.* PHP/PHP/g" |grep "line" |sort | uniq -c | sort -r > counterrors.txt

Share this post


Link to post
Share on other sites

Hi Robert Fisher,

i need sugestion for this. Using the article_info.php contibution the urls goes right. For example:

http:// myweb .com/this-is-an-article-a-17.html

 

but i need to add a word(not category or topic) between as:

http:// myweb .com/articles/this-is-an-article-a-17.html

 

How can I get this??

1) In .htaccess

  # Articles contribution
 RewriteRule ^([a-z0-9/-]+)-t-([0-9_]+).html$ articles.php [NC,L,QSA]
 RewriteRule ^([a-z0-9/-]+)-au-([0-9]+).html$ articles.php [NC,L,QSA]
 RewriteRule ^([a-z0-9/-]+)-a-([0-9]+).html$ article_info.php [NC,L,QSA]

 

2) In your addon. where to add the "articles/" word???

 

Thanks in advance.

Share this post


Link to post
Share on other sites

Choose the uri format path_rewrite Choose how your product link text is made up cp

 

Hi again Robert,

for products (product_info,php) works fine with path_rewrite + cp.

 

But for articles doesnt add the category because they are topics ( xxx-t-3.html).

Is there a way in the articles contribution to add the topic before??

 

I want this:

http:// myweb .com/news/this-is-an-article-a-17.html

http:// myweb .com/articles/this-is-an-article-a-18.html

http:// myweb .com/reviews/this-is-an-article-a-19.html

 

In other way for future releases of your addon it could be interesting to add the category path only for some categories products (selectable).

 

Thanks in advance.

Edited by bhbilbao

Share this post


Link to post
Share on other sites

Hi everyone,

 

I have installed ultimate-seo-urls-5-pro module it is working fine but it does not show any other language

except default language which is english. I have also upgraded the bm_language.php file but still blank page comes with all other

languages.

 

can someone help me?

 

Thanks

Share this post


Link to post
Share on other sites

1)install languages

2)activate Enable multi language support? true

 

then:

www.your web .com (default)

www.your web .com/de/...

www.your web .com/es/...

...etc

Share this post


Link to post
Share on other sites

Open your eyes.

There is an option down in USU admin panel.

FORCE www.mysite.com/en/ when www.mysite.com/index.php/en

Share this post


Link to post
Share on other sites

Hi again Robert,

 

some weeks ago I made you a question about USU5.

I need help for a new open source project im working on.

 

Thanks in advance.

Edited by burt
Remove solicitation

Share this post


Link to post
Share on other sites

Hi,

 

OK, I have install this add-on and at start everything seems alright. But when I try some links that have especial characters I see that I have something missing.

 

Back to add-on package and find in the extras the character_conversion_pack and put the conversion file inside catalog/includes/modules/ultimate_seo_urls5/includes/character_conversion. I put the file named exactly the same as my language file.

 

Then I go back to my site and see the fowling error:

 

Warning: Invalid argument supplied for foreach() in catalog/includes/modules/ultimate_seo_urls5/page_modules/product_info.php on line 102

 

Remove the conversion file and the error disappear but the problem with the especial characters continues.

 

What I'm doing wrong?

 

Thanks in advance.

Share this post


Link to post
Share on other sites

I don't see nothing wrong on file.

 

<?php
$char_convert = array('à' => 'a', 'â' => 'a', 'á' => 'a', 'ã' => 'a',
				 'ê' => 'e', 'ë' => 'e', 'é' => 'e',
				 'ô' => 'o', 'ó' => 'o', 'õ' => 'o', 'ö' => 'o',
				 'ú' => 'u', 'ü' => 'u',
				 'í' => 'i', 'ç' => 'c', 'ñ' => 'n',
				 'À' => 'A', 'Â' => 'A', 'Á' => 'A', 'Ã' => 'A',
				 'Ê' => 'E', 'Ë' => 'E', 'É' => 'E',
				 'Ô' => 'O', 'Ó' => 'O', 'Õ' => 'O', 'Ö' => 'O',
				 'Ú' => 'U', 'Ü' => 'U',
				 'Í' => 'I', 'Ç' => 'C', 'Ñ' => 'N',
				 'ª' => 'a', 'º' => 'o'
);
?>

Share this post


Link to post
Share on other sites

1.the files must be in \includes\modules\ultimate_seo_urls5\includes\character_conversion

2. make 1 file per language

3. your file seems to be the spanish version. Rename it as espanol.php

4. if you installed for example 3 languages in your osc, delete the other ones folders. = 1 folder per languaje(default espanol, english, german)

5. It seems to be right but try with this one:

<?php // Spanish
$char_convert = array('á' => 'a', 'é' => 'e', 'í' => 'i', 'ñ' => 'n', 'ã' => 'a', 'á' => 'a', 'ó' => 'o', 'ú' => 'u', 'ü' => 'u', 'Á' => 'A', 'É' => 'E', 'Í' => 'I', 'Ñ' => 'N', 'Ó' => 'O', 'Ú' => 'U', 'Ü' => 'U', '¿' => '-', '¡' => '-');
?>

 

 

 

6. this is the code that gets the error:

	 $final_text_array = array();
 foreach ( $text_array as $key => $text ) {
 if ( tep_not_null( trim( $text ) ) ) {
	 $final_text_array[$key] = $text;
 }
 }
 // We will cache this result
 Usu_Main::i()->getVar( 'registry' )->attach( $this->key, $this->keys_index[$this->key], $final_text_array );
 return $final_text_array;
}

Could be that you have some products without any products_name asigned (empty or null). Try to write some name description for all languages. Then RESET cache.

Edited by bhbilbao

Share this post


Link to post
Share on other sites

Hi,

 

 

Hi guys,

Please help me in redirecting...

 

My OSC is installed in a folder /store/

I want all domain.com or www.domain.com to redirect to domain.com/store (without www)

 

I've tried it but a strange issue appears, it work fine for products but when I access info pages with www.domain.com/store/contact_us.php it redirect to domain.com/contact_us.php and give 404 error (ofcourse there is nothig)

 

even if I clear my root .htaccess contact_us page still give same problem.

 

here is .htaccess of my root (domain.com)

RewriteEngine on
RewriteCond %{HTTP_HOST} ^.*$
RewriteRule ^/?$ http://ambiancehome.ca/store/ [R=301,L]
RewriteCond %{HTTP_HOST} ^(www\.)?domain\.com$ [NC]
RewriteRule ^$ http://domain.com/store [R=301,L]
#additional redirect of a product which is moved/removed / changed
Redirect 301 /store/bed-loungers-c-21.html http://ambiancehome.ca/store/product_info.php/bed-lounge-back-rest-reading-pillow-p-104.html

 

here is .htaccess of my /store/ folder

Options +SymLinksIfOwnerMatch
<IfModule mod_rewrite.c>
RewriteEngine On[/font][/color]
[color=#282828][font=helvetica, arial, sans-serif]# RewriteBase instructions
# Change RewriteBase dependent on how your shop is accessed as below.
# http://www.mysite.com = RewriteBase /
# http://ambiancehome.ca/store/ = RewriteBase /store/
# http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/
# Change RewriteBase using the instructions above
RewriteBase /store/
RewriteRule ^([a-z0-9/-]+)-p-([0-9]+).html$ product_info.php [NC,L,QSA]
RewriteRule ^([a-z0-9/-]+)-c-([0-9_]+).html$ index.php [NC,L,QSA]
RewriteRule ^([a-z0-9/-]+)-m-([0-9]+).html$ index.php [NC,L,QSA]
RewriteRule ^([a-z0-9/-]+)-pi-([0-9]+).html$ popup_image.php [NC,L,QSA]
RewriteRule ^([a-z0-9/-]+)-pr-([0-9]+).html$ product_reviews.php [NC,L,QSA]
RewriteRule ^([a-z0-9/-]+)-pri-([0-9]+).html$ product_reviews_info.php [NC,L,QSA]
# Articles contribution
RewriteRule ^([a-z0-9/-]+)-t-([0-9_]+).html$ articles.php [NC,L,QSA]
RewriteRule ^([a-z0-9/-]+)-au-([0-9]+).html$ articles.php [NC,L,QSA]
RewriteRule ^([a-z0-9/-]+)-a-([0-9]+).html$ article_info.php [NC,L,QSA]
# Information pages
RewriteRule ^([a-z0-9/-]+)-i-([0-9]+).html$ information.php [NC,L,QSA]
# Links contribution
RewriteRule ^([a-z0-9/-]+)-links-([0-9_]+).html$ links.php [NC,L,QSA]
# Newsdesk contribution
RewriteRule ^([a-z0-9/-]+)-n-([0-9]+).html$ newsdesk_info.php [NC,L,QSA]
RewriteRule ^([a-z0-9/-]+)-nc-([0-9]+).html$ newsdesk_index.php [NC,L,QSA]
RewriteRule ^([a-z0-9/-]+)-nri-([0-9]+).html$ newsdesk_reviews_info.php [NC,L,QSA]
RewriteRule ^([a-z0-9/-]+)-nra-([0-9]+).html$ newsdesk_reviews_article.php [NC,L,QSA]
</IfModule>

 

Help is really appreciated

 

thanks in Advance

Share this post


Link to post
Share on other sites

1.the files must be in \includes\modules\ultimate_seo_urls5\includes\character_conversion

2. make 1 file per language

3. your file seems to be the spanish version. Rename it as espanol.php

4. if you installed for example 3 languages in your osc, delete the other ones folders. = 1 folder per languaje(default espanol, english, german)

5. It seems to be right but try with this one:

<?php // Spanish
$char_convert = array('á' => 'a', 'é' => 'e', 'í' => 'i', 'ñ' => 'n', 'ã' => 'a', 'á' => 'a', 'ó' => 'o', 'ú' => 'u', 'ü' => 'u', 'Á' => 'A', 'É' => 'E', 'Í' => 'I', 'Ñ' => 'N', 'Ó' => 'O', 'Ú' => 'U', 'Ü' => 'U', '¿' => '-', '¡' => '-');
?>

 

1. The file path is \includes\modules\ultimate_seo_urls5\includes\character_conversion\portugues.php

2. I only have one language, theres only one file in the folder.

3. No, its Portuguese. I rename to "portugues.php" because this is the name of my language file.

4. Only have one.

5. I use the code but the only word that was convert was the "á" and the strange thing is that it uses the wrong conversion. If I change 'á' => 'a' to 'á' => 'c' the result of this word, for example, "tá" become "tc". But the letter 'á' don't exist in the word "tá". If I delete the 'á' => 'a' (this word don't exist in portuguese language) it stop to convert the word "á". All other words never convert.

 

Hope that what I say don't seems confuse.

 

6. this is the code that gets the error:

	 $final_text_array = array();
 foreach ( $text_array as $key => $text ) {
 if ( tep_not_null( trim( $text ) ) ) {
	 $final_text_array[$key] = $text;
 }
 }
 // We will cache this result
 Usu_Main::i()->getVar( 'registry' )->attach( $this->key, $this->keys_index[$this->key], $final_text_array );
 return $final_text_array;
}

Could be that you have some products without any products_name asigned (empty or null). Try to write some name description for all languages. Then RESET cache.

 

Ok, I have one product with products_name empty and after I change it the 120 error disappear.

Share this post


Link to post
Share on other sites

Ok, I enable the variable report and see this result:

 

[character_conversion] => Array
 (
	 [�] => a
	 [�] => a
	 [�] => a
	 [�] => a
	 [�] => e
	 [�] => e
	 [�] => o
	 [�] => o
	 [�] => o
	 [�] => u
	 [�] => i
	 [�] => c
	 [�] => A
	 [�] => A
	 [�] => A
	 [�] => A
	 [�] => E
	 [�] => E
	 [�] => O
	 [�] => O
	 [�] => O
	 [�] => U
	 [�] => I
	 [�] => C
	 [�] => a
	 [�] => o

 

Remove the character file from folder and and adding manual on admin it works ok.

 

[character_conversion] => Array
 (
	 [à] => a
	 [â] => a
	 [á] => a
	 [ã] => a
	 [ê] => e
	 [é] => e
	 [ô] => o
	 [ó] => o
	 [õ] => o
	 [ú] => u
	 [í] => i
	 [ç] => c
	 [À] => A
	 [Â] => A
	 [Á] => A
	 [Ã] => A
	 [Ê] => E
	 [É] => E
	 [Ô] => O
	 [Ó] => O
	 [Õ] => O
	 [Ú] => U
	 [Í] => I
	 [Ç] => C
	 [ª] => a
	 [º] => o

 

Theres something that don't read well my convert file variables.

 

Any help?

 

Regards,

Share this post


Link to post
Share on other sites

In meantime I have another problem.

 

My site look like www.mysite.com/index.php/hardware-c-1 and I want to look lik look like www.mysite.com/hardware-c-1.

 

I read the documentation and and the .htaccess to my root folder with the follow code:

 

# If you are getting errors you may need to comment this out like ..
# Options +FollowSymLinks
Options +SymLinksIfOwnerMatch
<IfModule mod_rewrite.c>
 RewriteEngine On
 # RewriteBase instructions
 # Change RewriteBase dependent on how your shop is accessed as below.
 # http://www.mysite.com = RewriteBase /
 # http://www.mysite.com/catalog/ = RewriteBase /catalog/
 # http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/
 # Change RewriteBase using the instructions above 
 RewriteBase /
 RewriteRule ^([a-z0-9/-]+)-p-([0-9]+).html$ product_info.php [NC,L,QSA]
 RewriteRule ^([a-z0-9/-]+)-c-([0-9_]+).html$ index.php [NC,L,QSA]
 RewriteRule ^([a-z0-9/-]+)-m-([0-9]+).html$ index.php [NC,L,QSA]
 RewriteRule ^([a-z0-9/-]+)-pi-([0-9]+).html$ popup_image.php [NC,L,QSA]
 RewriteRule ^([a-z0-9/-]+)-pr-([0-9]+).html$ product_reviews.php [NC,L,QSA]
 RewriteRule ^([a-z0-9/-]+)-pri-([0-9]+).html$ product_reviews_info.php [NC,L,QSA]
 # Articles contribution
 RewriteRule ^([a-z0-9/-]+)-t-([0-9_]+).html$ articles.php [NC,L,QSA]
 RewriteRule ^([a-z0-9/-]+)-au-([0-9]+).html$ articles.php [NC,L,QSA]
 RewriteRule ^([a-z0-9/-]+)-a-([0-9]+).html$ article_info.php [NC,L,QSA]
 # Information pages
 RewriteRule ^([a-z0-9/-]+)-i-([0-9]+).html$ information.php [NC,L,QSA]
 # Links contribution
 RewriteRule ^([a-z0-9/-]+)-links-([0-9_]+).html$ links.php [NC,L,QSA]
 # Newsdesk contribution
 RewriteRule ^([a-z0-9/-]+)-n-([0-9]+).html$ newsdesk_info.php [NC,L,QSA]
 RewriteRule ^([a-z0-9/-]+)-nc-([0-9]+).html$ newsdesk_index.php [NC,L,QSA]
 RewriteRule ^([a-z0-9/-]+)-nri-([0-9]+).html$ newsdesk_reviews_info.php [NC,L,QSA]
 RewriteRule ^([a-z0-9/-]+)-nra-([0-9]+).html$ newsdesk_reviews_article.php [NC,L,QSA]
</IfModule>

 

I already change in Admin the force option to true, but it stays the same. Don't see where I made a wrong turn.

 

Thank in advance.

Share this post


Link to post
Share on other sites

I have the Ultimate SEO URLS 5 Pro working well in OS 2.3.3.4 - I need a little guidance - I have the Gift Voucher Module installed as well.

 

The problem is adding $ to a product title ie.$100.00 gift certificate - obviously this is a special character..., How can I get the $ to enable the product..., this is my error...

 

Warning: Invalid argument supplied for foreach() in catalog/includes/modules/ultimate_seo_urls5/page_modules/product_info.php on line 104

 

Catchable fatal error: Argument 1 passed to aPage_Modules::linkText() must be an array, null given, called in catalog/includes/modules/ultimate_seo_urls5/page_modules/product_info.php on line 174 and defined in /home/content/47/9476647/html/catalog/includes/modules/ultimate_seo_urls5/abstracts/page_modules.php on line 339

Share this post


Link to post
Share on other sites

it uses the wrong conversion. If I change 'á' => 'a' to 'á' => 'c' the result of this word

 

7.Could be a problem with the database engine. I dont know about portugues. Look in languages/portugues.php

define('CHARSET', 'iso-8859-1');

Some new versions of osc uses UTF-8

 

Compare it with the database engine & collation.

Good luck.

Share this post


Link to post
Share on other sites
I already change in Admin the force option to true, but it stays the same. Don't see where I made a wrong turn.

above that option there is a mode to change the path rewrite. Try changing the mode.

Share this post


Link to post
Share on other sites

Theres something that don't read well my convert file variables.

Any help?

Regards,

 

8. Try converting the file codification to UTF-8 without BOM.

Share this post


Link to post
Share on other sites

7.Could be a problem with the database engine. I dont know about portugues. Look in languages/portugues.php

define('CHARSET', 'iso-8859-1');

Some new versions of osc uses UTF-8

 

Compare it with the database engine & collation.

Good luck.

 

Yes, with the osc upgrade I convert all to UTF-8. All my sql tables are all in utf8_unicode_ci

 

above that option there is a mode to change the path rewrite. Try changing the mode.

 

Yehhhh... that do the trick. Thank you very much :)

 

8. Try converting the file codification to UTF-8 without BOM.

 

Every day a new lesson. Never eared before about BOM or without BOM. I save the file without BOM and work like a charm. Many thanks once again, you are a master ;)

Share this post


Link to post
Share on other sites

PHP Catchable fatal error: Argument 1 passed to aPage_Modules::linkText() must be an array, null given, called in C:\Inetpub\wwwroot\xxxxxx\includes\modules\ultimate_seo_urls5\page_modules\product_info.php on line 170 and defined in C:\Inetpub\wwwroot\xxxx\includes\modules\ultimate_seo_urls5\abstracts\page_modules.php on line 338

 

PHP Warning: Invalid argument supplied for foreach() in C:\Inetpub\wwwroot\xxx\includes\modules\ultimate_seo_urls5\page_modules\product_reviews.php on line 94

 

PHP Warning: Invalid argument supplied for foreach() in C:\Inetpub\wwwroot\xxx\includes\modules\ultimate_seo_urls5\page_modules\index.php on line 111

 

PHP Warning: Invalid argument supplied for foreach() in C:\Inetpub\wwwroot\xxx\includes\modules\ultimate_seo_urls5\page_modules\product_info.php on line 102

 

PHP Warning: Invalid argument supplied for foreach() in C:\Inetpub\wwwroot\xxx\includes\modules\ultimate_seo_urls5\page_modules\product_reviews.php on line 94

 

I am sure this is something I messed up.

Thanks for looking

Edited by badbo

Share this post


Link to post
Share on other sites

Hi all,

 

I want to ask how can i add word in Title of product_info page in USU5 ???

 

e.g:

Seagate Expansion Backup 1TB (before)

Sale Seagate Expansion Backup 1TB (after)

 

in which part should i add code??

 

thanks before..

Edited by feversam

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×