Jump to content
FWR Media

Ultimate Seo Urls 5 Pro

Recommended Posts

RESET the cache!!

 

Just to clarify.

 

With USU5 PRO the cache is independent of the URI strategies so you don't need to reset the USU5 cache if you change strategy.

 

BUT if osCommerce has cached e.g. the categories then you will need to reset the osCommerce cache.

Share this post


Link to post
Share on other sites

Just to clarify.

 

With USU5 PRO the cache is independent of the URI strategies so you don't need to reset the USU5 cache if you change strategy.

 

BUT if osCommerce has cached e.g. the categories then you will need to reset the osCommerce cache.

 

That is something else that I have learned today. Thanks

Share this post


Link to post
Share on other sites

Just to clarify.

 

With USU5 PRO the cache is independent of the URI strategies so you don't need to reset the USU5 cache if you change strategy.

 

BUT if osCommerce has cached e.g. the categories then you will need to reset the osCommerce cache.

 

Thank very much for your answer.

 

As I thought it was something related to cache I've changed:

 

Set the number of days to store the cache to "0", and the problem has been solved, the URLs are ok now.

 

Because my settings of oscommerce cache are "false".

 

I have to wait now to see if I don't have duplicates in subcategories metadescriptions and titles.

 

Thank you again

Share this post


Link to post
Share on other sites

Hi,

 

Since I have changed my settings of Ultimate Seo pro from "rewrite" to "path_rewrite", I'm having problem with duplicate metadescriptions in google webmaster tools. Because of that I decided to change again "path_rewrite" for "rewrite", but this has not solved the problem and now I have one more problem with categories in my sitemaps:

error 301, because google detect two URLs for the same page: http://www.joyeriaplaor.com/joyas-plata-acero/pulseras-acero-plata-c-41_62.html redirects to http://www.joyeriaplaor.com/joyas-plata-acero-pulseras-acero-plata-c-41_62.html.

 

I have the contribution header tags seo for my metatags and my oscommerce cache is set to false.

 

I don't know what to do now to solve this problem. I think it could be a problem of caches, may be the header tags seo cache, but I don't dare to reset this cache.

 

I've seen that there is a new contribution: KissMT Dynamic SEO Meta & Canonical Header Tags. I don´t now if I could change from header tags seo contribution to this one and if this change would solve my problem.

 

Could you help me?

 

Thank you.

Share this post


Link to post
Share on other sites

Sorry to cross-post, but I installed the Pro version and I've been posting in the non-pro support thread (Robert, your signature still links to that old thread, BTW) and I cannot delete my posts there. So please allow me to ask here:

 

Is there a uri format that is preferred by Google over another? I like the path_rewrite the best. How much penalty is incurred if I change it from what I had been using before? Is that SEO suicide?

 

Also, does this add-in take care of the "linked-product-in-a-different-category" duplicity issue as far as Google is concerned?

 

Thanks again for a GREAT mod!

Share this post


Link to post
Share on other sites

Sorry to cross-post, but I installed the Pro version and I've been posting in the non-pro support thread (Robert, your signature still links to that old thread, BTW) and I cannot delete my posts there. So please allow me to ask here:

 

Is there a uri format that is preferred by Google over another? I like the path_rewrite the best. How much penalty is incurred if I change it from what I had been using before? Is that SEO suicide?

 

Also, does this add-in take care of the "linked-product-in-a-different-category" duplicity issue as far as Google is concerned?

 

Thanks again for a GREAT mod!

 

Hi Michael

 

The original post was in the correct location, this was the original development topic for the PRO version.

Share this post


Link to post
Share on other sites

Please note that this was the original development topic for USU5 PRO.

 

As the contribution has now been released for support please use the USU5 support topic.

Share this post


Link to post
Share on other sites

im problem canonical tags in to reviews,

page product: http://www.intimoclick.it/giacca-uomo-rams-con-bottoni-p-402.html

<link rel="canonical" href="http://www.intimoclick.it/giacca-uomo-rams-con-bottoni-p-402.html">

 

page reviews: http://www.intimoclick.it/giacca-uomo-rams-con-bottoni-pr-402.html

<link rel="canonical" href="http://www.intimoclick.it/giacca-uomo-rams-con-bottoni-pr-402.html">

 

as exchange canonical rewiews to product?

i want equal 2 canonical (product and reviews): <link rel="canonical" href="http://www.intimoclick.it/giacca-uomo-rams-con-bottoni-p-402.html">

as? thanks

Share this post


Link to post
Share on other sites

im problem canonical tags in to reviews,

page product: http://www.intimocli...toni-p-402.html

<link rel="canonical" href="http://www.intimoclick.it/giacca-uomo-rams-con-bottoni-p-402.html">

 

page reviews: http://www.intimocli...oni-pr-402.html

<link rel="canonical" href="http://www.intimoclick.it/giacca-uomo-rams-con-bottoni-pr-402.html">

 

as exchange canonical rewiews to product?

i want equal 2 canonical (product and reviews): <link rel="canonical" href="http://www.intimoclick.it/giacca-uomo-rams-con-bottoni-p-402.html">

as? thanks

 

What you have shown is correct. Page reviews is a different page to products and should therefore have a different URL.

Share this post


Link to post
Share on other sites

I know that this is correct,I wanted to know if you can change.

 

Anything in code can be changed.

Share this post


Link to post
Share on other sites

Hi,

I just noticed a serious problem.

When I try to edit or add a new product, the values ​​in the table products_description: products_description and products_name are deleted.

The result is a message on on the product info page:

Catchable fatal error: Argument 1 passed to aPage_Modules: linktext () must be an array, null given, called in a /***/***/****/ includes/modules/ultimate_seo_urls5/page_modules/product_info.php line 170 and defined in /***/***/****/ includes/modules/ultimate_seo_urls5/abstracts/page_modules.php on line 338

 

The problem was discussed here http://forums.oscommerce.com/topic/336702-ultimate-seo-urls-5-by-fwr-media/page__st__2460, but I have not found a good and working solution.

 

I'm not sure, but it may be that the problem appeared after installing HeaderTags_SEO_V_3.2.5. (on ​​osCommerce Online Merchant v2.2 RC2a)

 

Please help in resolving the problem.

 

Yours

Plustm

Share this post


Link to post
Share on other sites

 

Please help in resolving the problem.

 

Yours

Plustm

 

Wow! that's rather bad news.

 

It's not USU5 as it reads from the database fields but never writes ( only to the USU5 cache ).

Share this post


Link to post
Share on other sites

Hi,

 

I've just installed the USU 5 Pro, but it reinstalls all configuration settings in every minute, so can not be setup properly.

What can be wrong ? :blink:

Share this post


Link to post
Share on other sites

It is in the instructions

 

Sorry, but in the instruction I only found information about force www.mysite.com/ when www.mysite.com/index.php but nothing about force www.mysite.com/it when www.mysite.com/index.php/it

 

Eduardo

Share this post


Link to post
Share on other sites

Sorry, but in the instruction I only found information about force www.mysite.com/ when www.mysite.com/index.php but nothing about force www.mysite.com/it when www.mysite.com/index.php/it

 

Eduardo

 

Hi again,

 

I mean, I get that the URL my.site.com/it is working by using the rewrite options but the problem is how to get that USU 5 produces uri's like my.site.com/it and not www.site.com/index.php/it in the language box?

 

Regards,

 

Eduardo

Share this post


Link to post
Share on other sites

Hi again,

 

I mean, I get that the URL my.site.com/it is working by using the rewrite options but the problem is how to get that USU 5 produces uri's like my.site.com/it and not www.site.com/index.php/it in the language box?

 

Regards,

 

Eduardo

 

The multi language system is coded the way it is for a reason: -

 

www.mysite.com/ - the server will load index.php

 

www.mysite.com/index.php/it - the server will load index.php ( if server settings are as required )

 

www.mysite.com/it - will load nothing, the server hasn't a clue what you want loaded. You would need to write RewriteRules in .htaccess to enable the server to deal with the request.

Edited by FWR Media

Share this post


Link to post
Share on other sites

The multi language system is coded the way it is for a reason: -

 

www.mysite.com/ - the server will load index.php

 

www.mysite.com/index.php/it - the server will load index.php ( if server settings are as required )

 

www.mysite.com/it - will load nothing, the server hasn't a clue what you want loaded. You would need to write RewriteRules in .htaccess to enable the server to deal with the request.

 

I already got that the server to deal successfully with the request www.mysite.com/it by using Rewrite

 

My problem now is how to get that for example the language box produces uri's like www.mysite.com/it and not www.mysite.com/index.php/it

 

Regards,

Share this post


Link to post
Share on other sites

Hello,

 

I upgraded from Chemos Ultimate Seo Urls version 2 (from which I made a slight modification as I replaced '-' by '_' in the urls).

 

My old products url read : product_number_one-p-125.html

 

Now, with Seo Urls Pro, I have an issue because of the underscore in the url.

product_number_one-p-125.html won't redirect to product-number-one/manufacturer/model-p-125.html

 

Is there a way not to loose our referencing and so to have the redirection works?

 

Sorry for my bad English.

 

Thank you.


OSC2.2

Share this post


Link to post
Share on other sites

Thanks for this great contribution!

 

I can confirm that this contribution installs fine on OSCommerce BTS version and works fine on Windows IIS7 server without any modifications.

 

---

 

I have one question for developers and it is very important for me. How to make the product_info links shorter? It will be very great if I could

choose 'number of whole words to use from product description' parameter in Admin panel!

 

For example now I have the links like:

 

mysite.com/this-product-has-very-very-very-very-long-description-p-1.html

 

and it will be great if I could choose '2 whole words to use' and achieve the link like:

 

mysite.com/this-product-p-1.html

 

If it is difficult to add this in Admin please advise how to change the code.

 

Thanks in advance!

Share this post


Link to post
Share on other sites

Thanks for this great contribution!

 

I can confirm that this contribution installs fine on OSCommerce BTS version and works fine on Windows IIS7 server without any modifications.

 

---

 

I have one question for developers and it is very important for me. How to make the product_info links shorter? It will be very great if I could

choose 'number of whole words to use from product description' parameter in Admin panel!

 

For example now I have the links like:

 

mysite.com/this-product-has-very-very-very-very-long-description-p-1.html

 

and it will be great if I could choose '2 whole words to use' and achieve the link like:

 

mysite.com/this-product-p-1.html

 

If it is difficult to add this in Admin please advise how to change the code.

 

Thanks in advance!

 

You would need to adapt the following code in the page_modules/product_info.php

 

  	$final_text_array = array();
 	foreach ( $text_array as $key => $text ) {
   	if ( tep_not_null( trim( $text ) ) ) {
     	$final_text_array[$key] = $text;
   	}
 	}

 

It is dangerous though .. what if a product was named: -

This must be the greatest wiggit

 

Restrict it to two words and you could end up with: -

 

this-must-p-37.html :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×