Jump to content
FWR Media

Ultimate Seo Urls 5 Pro

Recommended Posts

I’ve installed the last version of Ultimate seo url: Ultimate Seo Urls 5 PRO. All seems to work well but I’m having problems with my URL in google webmaster tools. When I first enter my website and click for the first time a category or a product appears the url like this ” http://www.joyeriaplaor.com/joyas-oro-pulseras-c-30_34.html?'>http://www.joyeriaplaor.com/joyas-oro-pulseras-c-30_34.html? page=1&sort=4d” and not the clean ” http://www.joyeriaplaor.com/joyas-oro-pulseras-c-30_34.html ”. When you click again, not problems it appears the clean one. This causes redirect error in google, because I have two url for the same page. How could I solve this problem?

 

I have another question my data base is mysql so, the settings of “Select your chosen cache system?” should be changed to mysql instead of sqlite.

 

Thank you

Share this post


Link to post
Share on other sites

Sorry I forgot in my last post to comment another problem I have with Google, it is still crawling products I deleted and gives error 404.Is it possible to solve this?

 

Thank you

Share this post


Link to post
Share on other sites

Sorry I forgot in my last post to comment another problem I have with Google, it is still crawling products I deleted and gives error 404.Is it possible to solve this?

 

Thank you

 

I don't see a problem. If a product does not exist then a 404 header is absolutely correct.

 

If you wanted to pass on the "link juice" to an existant product then you could make use of the uri_redirects functionality.

Share this post


Link to post
Share on other sites

I don't see a problem. If a product does not exist then a 404 header is absolutely correct.

 

If you wanted to pass on the "link juice" to an existant product then you could make use of the uri_redirects functionality.

 

Thanks for your answer. I Thought it was a negative thing that google found all this non existent urls.

 

And about my previous post: error 303 in some of my pages, because as I told you, the fist time you click a category or product appears the url with "...html? page=1&sort=4d", for example, and then google found two pages for the same product and gives error 303.

Share this post


Link to post
Share on other sites

Thanks for your answer. I Thought it was a negative thing that google found all this non existent urls.

 

And about my previous post: error 303 in some of my pages, because as I told you, the fist time you click a category or product appears the url with "...html? page=1&sort=4d", for example, and then google found two pages for the same product and gives error 303.

 

I didn't say it was ideal ... just correct .. ideally you would be passing the "link juice" to an existant product url.

 

When I first enter my website and click for the first time a category or a product appears the url like this ” http://www.joyeriapl...s-c-30_34.html? page=1&sort=4d”

and not the clean ” http://www.joyeriapl...as-c-30_34.html ”.

When you click again, not problems it appears the clean one.

This causes redirect error in google, because I have two url for the same page. How could I solve this problem?

 

That is misinformation, that doesn't happen at all.

 

When I visit the front of your site the URLs are perfect.

 

When a category has paging ( more than one page of results ) then the url looks like ..

 

[--YOUR-DOMAIN--]/joyas-plata-acero-joyas-agatha-ruiz-c-41_42.html?page=2&sort=2a

 

This is also correct and the canonical element is also correctly displayed as ..

 

[--YOUR-DOMAIN--]/joyas-plata-acero-joyas-agatha-ruiz-c-41_42.html

 

I have another question my data base is mysql so, the settings of “Select your chosen cache system?” should be changed to mysql instead of sqlite.

 

These are options .. you can choose File or SQLite or MySQL the choice is yours ( although I wouldn't recommend SQLite until the new version is uploaded ).

Share this post


Link to post
Share on other sites

Hey Rob,

Hope all is well with you. Just a little report and a question here;

 

We upgraded to RC2a as I mentioned before, adding Ultimate Seo Urls 5 Pro to the mix along with memcache.

I thought a rather cool touch was to run a cron robot to prepopulate the memcache cache as in;

wget --cache=off --delete after -m http://www.mydomain.com

This all seemed to go well although I was distressed by how long it took to run, {HOURS!} I had it set to send an email report back and of course that email was like way too big. ERRORS!!!

PLEASE RECALL WE'RE DEALING WITH A BIG STORE OF ITEMS.

Anyway, after a week and 4 days we saw a hit to miss ratio of 36 hits to 64 misses, this is on 141,869 items. I immediately thought let's do it differently.

I cleared the cache (restarted memcached).

Currently, not employing the WGET robot. This time it's strictly human and search engine robots, and after 1 week and 1 day we're at 57 misses to 43 hits (102,040) Current Items(total).

Any thoughts or suggestions?

If not I'll keep reporting here. Unless you have other suggestions as to where to put em.

Thanks for all your hard work that makes this possible.

Joe - Motorcity

Share this post


Link to post
Share on other sites

I didn't say it was ideal ... just correct .. ideally you would be passing the "link juice" to an existant product url.

 

 

 

That is misinformation, that doesn't happen at all.

 

When I visit the front of your site the URLs are perfect.

 

When a category has paging ( more than one page of results ) then the url looks like ..

 

[--YOUR-DOMAIN--]/joyas-plata-acero-joyas-agatha-ruiz-c-41_42.html?page=2&sort=2a

 

This is also correct and the canonical element is also correctly displayed as ..

 

[--YOUR-DOMAIN--]/joyas-plata-acero-joyas-agatha-ruiz-c-41_42.html

 

 

 

These are options .. you can choose File or SQLite or MySQL the choice is yours ( although I wouldn't recommend SQLite until the new version is uploaded ).

 

Thank you very much for your answer.

 

You say my url are perfect, but my google sitemaps.xml have errors because of that, every time I send my sitemaps I

 

have a different problem, for example, this time is this url http://www.joyeriaplaor.com

 

/product_info.php?products_id=558, which is the same as: http://www.joyeriaplaor.com/llamador-angeles-plata-piedras-

 

negro-p-558.html and this gives error 301, in categories I have a similar problem with another url. If this is not

 

important I'll forget it.

Share this post


Link to post
Share on other sites

Thank you very much for your answer.

 

You say my url are perfect, but my google sitemaps.xml have errors because of that, every time I send my sitemaps I

 

have a different problem, for example, this time is this url http://www.joyeriaplaor.com

 

/product_info.php?products_id=558, which is the same as: http://www.joyeriapl...-plata-piedras-

 

negro-p-558.html and this gives error 301, in categories I have a similar problem with another url. If this is not

 

important I'll forget it.

 

Are you using the USU5 sitemaps or another contribution?

Share this post


Link to post
Share on other sites

hello

nice addons ... i install the Ultimate SEO Urls 5 PRO and i had Optional Related Products, Version 4.0 ... so the Optional Related Productsits still work but there is something wrong :

1- in Optional Related Products module .the buy now not work .. its not go anywhere it just add to the link (?action=rp_buy_now&rp_products_id=495) .

2- continue shopping botton its go back to last product ..coz i think b4 i add the Ultimate SEO Urls 5 PRO its was go back to the last Category.

 

here is the Optional Related Products module

<?php

/*
 $Id: optional_related_products.php, ver 1.0 02/05/2007 Exp $

 Copyright (c) 2007 Anita Cross (http://www.callofthewildphoto.com/)

 Part of Contribution: Optional Related Products Ver 4.0

 Based on code from Optional Relate Products, ver 2.0 05/01/2005
 Copyright (c) 2004-2005 Daniel Bahna (daniel.bahna@gmail.com)

 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Released under the GNU General Public License
*/

 $orderBy = 'ORDER BY ';
 $orderBy .= (RELATED_PRODUCTS_RANDOMIZE)?'rand()':'pop_order_id, pop_id';
 $orderBy .= (RELATED_PRODUCTS_MAX_DISP)?' limit ' . RELATED_PRODUCTS_MAX_DISP:'';
 $attributes = "
        SELECT
        pop_products_id_slave,
        products_name,
        products_model,
        products_price,
        products_quantity,
        products_tax_class_id,
        products_image
        FROM " .
        TABLE_PRODUCTS_RELATED_PRODUCTS . ", " .
        TABLE_PRODUCTS_DESCRIPTION . " pa, ".
        TABLE_PRODUCTS . " pb
        WHERE pop_products_id_slave = pa.products_id
        AND pa.products_id = pb.products_id
        AND language_id = '" . (int)$languages_id . "'
        AND pop_products_id_master = '".$HTTP_GET_VARS['products_id']."'
        AND products_status='1' " . $orderBy;
 $attribute_query = tep_db_query($attributes);

 if (mysql_num_rows($attribute_query)>0) {
 $count = 0;
?>
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<title></title>
</head>
<body>
<table>
<tr>
<td>
<table class="productlisting" border="0" cellspacing="0"
cellpadding="2" width="100%">
<tr>
<td align="center" class="productListing-heading">
<?php echo TEXT_RELATED_PRODUCTS ?></td>
</tr>
<tr>
<td align="center" class="productListing-data">
<table border="0" cellspacing="0" cellpadding="2" width="100%"
align="center">
<tr><?php
   while ($attributes_values = tep_db_fetch_array($attribute_query)) {
     $products_name_slave = ($attributes_values['products_name']);
     $products_model_slave = ($attributes_values['products_model']);
     $products_qty_slave = ($attributes_values['products_quantity']);
     $products_id_slave = ($attributes_values['pop_products_id_slave']);
     if ($new_price = tep_get_products_special_price($products_id_slave)) {
       $products_price_slave = $currencies->display_price($new_price, tep_get_tax_rate($attributes_values['products_tax_class_id']));
     } else {
       $products_price_slave = $currencies->display_price($attributes_values['products_price'], tep_get_tax_rate($attributes_values['products_tax_class_id']));
     }
     echo '<td class="productListing-data" align="center">' . "\n";
     // show thumb image if Enabled
     if (RELATED_PRODUCTS_SHOW_THUMBS == 'True') {
       echo '<a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $products_id_slave) . '">' . "\n"
            . tep_image(DIR_WS_IMAGES . $attributes_values['products_image'], $attributes_values['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, 'hspace="5" vspace="5"').'</a><br>' . "\n";
     }
     $caption = '';
     if (RELATED_PRODUCTS_SHOW_NAME == 'True') {
       $caption .= '<p>' . $products_name_slave;
       if (RELATED_PRODUCTS_SHOW_MODEL == 'True') {
         $caption .= sprintf(RELATED_PRODUCTS_MODEL_COMBO, $products_model_slave);
       }
       $caption .= '</p>' . "\n";
     } elseif (RELATED_PRODUCTS_SHOW_MODEL == 'True') {
       $caption .=  '<p>' . $products_model_slave . '</p>' . "\n";
     }
     if (RELATED_PRODUCTS_SHOW_PRICE == 'True') {
       $caption .= '<p>' . sprintf(RELATED_PRODUCTS_PRICE_TEXT, $products_price_slave) . '</p>' . "\n";
     }
     if (RELATED_PRODUCTS_SHOW_QUANTITY == 'True') {
       $caption .= '<p>' . sprintf(RELATED_PRODUCTS_QUANTITY_TEXT, $products_qty_slave) . '</p>' . "\n";
     }
     echo '<a href="'
           . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $products_id_slave) . '">'
           . $caption . '</a>' . "\n";
     if (RELATED_PRODUCTS_SHOW_BUY_NOW== 'True') {
       echo '<a href="'
           . tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('action'))
           . 'action=rp_buy_now&rp_products_id=' . $products_id_slave) . '">'
           . tep_image_button('button_rp_buy_now.gif', IMAGE_BUTTON_RP_BUY_NOW) . '</a>';
     }
     echo '</td>' . "\n";
     $count++;
     if ((RELATED_PRODUCTS_USE_ROWS == 'True') && ($count%RELATED_PRODUCTS_PER_ROW == 0)) {
       echo '</tr><tr>' . "\n";
     }
   }
?></tr>
</table>
</td>
</tr>
</table>
</td>
</tr>
<?php
}
?></table>
</body>
</html>

 

 

 

i think the problem is here

 if (RELATED_PRODUCTS_SHOW_BUY_NOW== 'True') {
       echo '<a href="'
           . tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('action'))
           . 'action=rp_buy_now&rp_products_id=' . $products_id_slave) . '">'
           . tep_image_button('button_rp_buy_now.gif', IMAGE_BUTTON_RP_BUY_NOW) . '</a>';

any help plz

Thanks

Omar

Share this post


Link to post
Share on other sites

hello

nice addons ... i install the Ultimate SEO Urls 5 PRO and i had Optional Related Products, Version 4.0 ... so the Optional Related Productsits still work but there is something wrong :

 

Omar please don't post complete files here it makes it difficult for others to find valid support answers.

 

I haven't a clue why that contribution doesn't work I've never used it, post a question in its support thread.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Omar please don't post complete files here it makes it difficult for others to find valid support answers.

 

I haven't a clue why that contribution doesn't work I've never used it, post a question in its support thread.

 

i am sorry about post the whole file . :)

thanks for your answer .. i will post question in its support thread.

 

thanks

Omar

Share this post


Link to post
Share on other sites

Are you using the USU5 sitemaps or another contribution?

 

I'm using googlexml sitemap seo v1.5.

Share this post


Link to post
Share on other sites

I'm using googlexml sitemap seo v1.5.

 

 

Do I have to change googlexml sitemap seo v1.5. and use another contribution?

 

Thanks

Share this post


Link to post
Share on other sites

Hey,

Installed ultimate seo 5 pro on my site vitamins today

 

Is there a way to remove the product_info.php part of the url from the url? e.g. from this

 

http://www.vitaminstoday.com.au/product_info.php/lecithin-1200mg-100-caps-p-1404

to this

http://www.vitaminstoday.com.au/lecithin-1200mg-100-caps-p-1404

 

and also removing the index.php from the categories e.g. http://www.vitaminstoday.com.au/index.php/body-skin-care-c-113

 

Regards,

Mike

 

Share this post


Link to post
Share on other sites

Hey,

Installed ultimate seo 5 pro on my site vitamins today

 

Is there a way to remove the product_info.php part of the url from the url? e.g. from this

 

http://www.vitaminstoday.com.au/product_info.php/lecithin-1200mg-100-caps-p-1404

to this

http://www.vitaminstoday.com.au/lecithin-1200mg-100-caps-p-1404

 

and also removing the index.php from the categories e.g. http://www.vitaminstoday.com.au/index.php/body-skin-care-c-113

 

Regards,

Mike

 

 

If you follow the instructions in the contribution, it will tell you how to do this

Share this post


Link to post
Share on other sites

As I don't have an answer to my problem with error 301 in google sitemaps xml, I imagine there is no solution for it.

 

My xml google sitemaps are correctly generated, but every time I send them I have some problems with

 

sitemapcategories or sitemapproducts or sitemapproducts etc, error 301, because I have duplicated url for on product

 

page or one category page etc. For example in sitemapcategories.xml i have this two url for the same page

 

http://www.joyeriaplaor.com/index.php?cPath=50_63, which is the same page as http://www.joyeriaplaor.com/joyas-finor-

 

joyas-del-amor-c-50_63.html. I always have problems with only one page in every sitemap, but this is enough to have

 

error 301. My uri format is "rewrite"

 

Using google sitemaps from usu5 pro contribution would solve this problem?

 

Thanks

Share this post


Link to post
Share on other sites

I installed as per instructions, what am i doing wrong?

This part of the instructions?

 

 

Choose the URI format

There are 4 options

The difference between the four is shown below: -

 

Standard Seo Urls ( does not require mod_rewrite )

www.mysite.com/product_info.php/the-brand-etc-great-product-p-3

Path Standard Seo Urls ( does not require mod_rewrite )

www.mysite.com/product_info.php/the-brand-etc/great-product-p-3

Traditional Rewrite Seo Urls ( Requires mod_rewrite and RewriteRules added to .htaccess )

www.mysite.com/the-brand-etc-great-product-p-3.html

Path Rewrite Seo Urls ( Requires mod_rewrite and RewriteRules added to .htaccess )

www.mysite.com/the-brand-etc/great-product-p-3.html

Choose how your product link text is made up

There are 49 different ways to write your products link text. Any combination of the below ( e.g. bp produces brand-product name or brand/product name if the uri type is path based )

p = products name

c = category name

b = manufacturer name ( b for brand )

m = model

cbmp produces category-brand-model-product-name or category/brand/model/product-name if the uri type is path based

Share this post


Link to post
Share on other sites

This part of the instructions?

 

 

Choose the URI format

There are 4 options

The difference between the four is shown below: -

 

Standard Seo Urls ( does not require mod_rewrite )

www.mysite.com/product_info.php/the-brand-etc-great-product-p-3

Path Standard Seo Urls ( does not require mod_rewrite )

www.mysite.com/product_info.php/the-brand-etc/great-product-p-3

Traditional Rewrite Seo Urls ( Requires mod_rewrite and RewriteRules added to .htaccess )

www.mysite.com/the-brand-etc-great-product-p-3.html

Path Rewrite Seo Urls ( Requires mod_rewrite and RewriteRules added to .htaccess )

www.mysite.com/the-brand-etc/great-product-p-3.html

Choose how your product link text is made up

There are 49 different ways to write your products link text. Any combination of the below ( e.g. bp produces brand-product name or brand/product name if the uri type is path based )

p = products name

c = category name

b = manufacturer name ( b for brand )

m = model

cbmp produces category-brand-model-product-name or category/brand/model/product-name if the uri type is path based

 

 

Thanks for that. Changed the setting to "rewrite" and am using the .htaccess file provided whit mod_rewrite.so enabled but the urls are still in standard form. What else can i try?

Share this post


Link to post
Share on other sites

This part of the instructions?

 

 

Choose the URI format

There are 4 options

The difference between the four is shown below: -

 

Standard Seo Urls ( does not require mod_rewrite )

www.mysite.com/product_info.php/the-brand-etc-great-product-p-3

Path Standard Seo Urls ( does not require mod_rewrite )

www.mysite.com/product_info.php/the-brand-etc/great-product-p-3

Traditional Rewrite Seo Urls ( Requires mod_rewrite and RewriteRules added to .htaccess )

www.mysite.com/the-brand-etc-great-product-p-3.html

Path Rewrite Seo Urls ( Requires mod_rewrite and RewriteRules added to .htaccess )

www.mysite.com/the-brand-etc/great-product-p-3.html

Choose how your product link text is made up

There are 49 different ways to write your products link text. Any combination of the below ( e.g. bp produces brand-product name or brand/product name if the uri type is path based )

p = products name

c = category name

b = manufacturer name ( b for brand )

m = model

cbmp produces category-brand-model-product-name or category/brand/model/product-name if the uri type is path based

 

 

Tried an older version ultimate_seo_urls_5_r119 and am now getting this error "Fatal error: Call to undefined function usu_dir_iterator() in C:\**\includes\modules\ultimate_seo_urls5\main\bootstrap.php on line 340"

Share this post


Link to post
Share on other sites

Tried an older version ultimate_seo_urls_5_r119 and am now getting this error "Fatal error: Call to undefined function usu_dir_iterator() in C:\**\includes\modules\ultimate_seo_urls5\main\bootstrap.php on line 340"

 

never-mind, i got it working, only problem now is adding products to cart when clicking on buy doesn't work. Just ads "?action=add_product" to the url with nothing in the cart

Share this post


Link to post
Share on other sites

This is the original development thread for PRO the support topic is the USU5 support topic.

Share this post


Link to post
Share on other sites

As I don't have an answer to my problem with error 301 in google sitemaps xml, I imagine there is no solution for it.

 

My xml google sitemaps are correctly generated, but every time I send them I have some problems with

 

sitemapcategories or sitemapproducts or sitemapproducts etc, error 301, because I have duplicated url for on product

 

page or one category page etc. For example in sitemapcategories.xml i have this two url for the same page

 

http://www.joyeriaplaor.com/index.php?cPath=50_63, which is the same page as http://www.joyeriaplaor.com/joyas-finor-

 

joyas-del-amor-c-50_63.html. I always have problems with only one page in every sitemap, but this is enough to have

 

error 301. My uri format is "rewrite"

 

Using google sitemaps from usu5 pro contribution would solve this problem?

 

Thanks

 

Nobody could answer my question?

 

The contribution Ultimate Seo Urls 5 PRO say that it has 301 redirection and url validation. ( avoid SEO penalties )and in my case as I told in this message I still have this problem.

 

Thanks

Share this post


Link to post
Share on other sites

Nobody could answer my question?

 

The contribution Ultimate Seo Urls 5 PRO say that it has 301 redirection and url validation. ( avoid SEO penalties )and in my case as I told in this message I still have this problem.

 

Thanks

 

You are using a contribution written by somebody else. Probably the one by Chemo that is currently maintained by jack_mcs.

 

If the sitemap is not producing SEO urls then you need to speak with the author of that contribution and not with me. USU5 produces valid SEO URLs so long as the script in question uses the standard osCommerce function which must always be used when producing URLs which is tep_href_link().

Edited by FWR Media

Share this post


Link to post
Share on other sites

You are using a contribution written by somebody else. Probably the one by Chemo that is currently maintained by jack_mcs.

 

If the sitemap is not producing SEO urls then you need to speak with the author of that contribution and not with me. USU5 produces valid SEO URLs so long as the script in question uses the standard osCommerce function which must always be used when producing URLs which is tep_href_link().

 

I'm not using the contribution of Chemo. I used the contribution Ultimate urls 5 and i updated to Ultimate urls 5 pro and it works very well, the only problem is with the googlesitemaps xml. To generate the googlesitemaps.xml i'm using the contribution googlexml_sitemap_seo_v_1.5, which generate: sitemappages.xml, sitemapcategories.xml, sitemapproducts.xml, sitemapmanufacturers.xml and sitemapindex.xml.

 

And I have errors 301 in my googlesitemaps.xml. Like this:

Every time I send my sitemaps I have a different problem, for example, this time in the sitemapproducts.xml is this url http://www.joyeriaplaor.com/product_info.php?products_id=555, which is the same as: http://www.joyeriaplaor.com/llamador-angeles-plata-piedras-p-555.html and this gives error 301.

Do I have to use then the usu5 xml sitempas to avoid this problem? Although if I use this extra of usu5 pro to generate the sitemaps.xml it only generates 3 xml sitemaps (sitemapIndex.xml, sitemapCategories.xml, sitemapProducts.xml). Moreover I don't know what to do to change from one contribution to another and remove the other sitemaps.xml I've sent to google.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×