Jump to content
Sign in to follow this  
marleenverbeek

Get new products on homepage

Recommended Posts

Hi all,

 

Normally when you install oscommerce, the page will show new products on the homepage. I removed this, because I thoight I wanted to do something else with this space, now I would like to place them back... Can anybody tell me how I do that? I even might want to place products there from only a certain category. I use STS and I read that there is a code to do that, but I don't know how to do that exactly.

 

Hope someone can help!

 

Thanks,

Marleen

Share this post


Link to post
Share on other sites

you find the zip with the original files, and find the section which has the includes/modules/products_new.php construction in it under the DEFAULT case statement.

 

STS I do not know


KEEP CALM AND CARRY ON

I do not use the responsive bootstrap version since i coded my responsive version earlier, but i have bought every 28d of code package to support burts effort and keep this forum alive (albeit more like on life support).

So if you are still here ? What are you waiting for ?!

 

Find the most frequent unique errors to fix:

grep "PHP" php_error_log.txt | sed "s/^.* PHP/PHP/g" |grep "line" |sort | uniq -c | sort -r > counterrors.txt

Share this post


Link to post
Share on other sites

you find the zip with the original files, and find the section which has the includes/modules/products_new.php construction in it under the DEFAULT case statement.

 

STS I do not know

 

I have to know it for STS cause it works differently and that is why I posted it here. So I hope somebody can help.

 

Thanks

Share this post


Link to post
Share on other sites

I have to know it for STS cause it works differently and that is why I posted it here. So I hope somebody can help.

 

Thanks

 

Well, thats not the STS forum here......

 

There are different ways to add the module back, depending on how you create your templates.

 

If you use just the default template, or if you have the templates content displayed just by the $content tag, then,the only think you need to do is to put back the following into your html structure of index.php

          <tr>
           <td><?php include(DIR_WS_MODULES . FILENAME_NEW_PRODUCTS); ?></td>
         </tr>

I don't know how you "removed" the module, maybe you deleted more? You can do a file comparison with an original file as suggested

 

If you create your templates in a different way, then please post in the STSv4 forum, describing also what templates you use for the index files

Edited by multimixer

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×