Jump to content
Sign in to follow this  
spooks

Simple Multi Image Add-on Plus PrettyPhoto popups

Recommended Posts

Ooops! Forgive the double post. Accidentally hit the button twice :wacko:

 

 

Hi Spooks,

 

first let me say that I love this contribution. It was a super easy install that works great! Props to the folk at "no-margin-for-errors" also for their great work.

 

Now for what may be the dumb question. :-" As I stated it works great but I think I need to add some code somewhere else. If you go to product reviews on my site, click on a product to read a review, then that click-able thumb will only popup as the standard Oscommerce ones do. I tried adding the your javascript to the product_reviews_info.php, the popup_image.php, and the reviews.php, all to no avail. I did add the code to them individually and then removed , and replace it with the existing code when it didn't work for me. Any ideas on how to get this to work on the review popups?

 

Thanks,

David

Edited by insanerc

Share this post


Link to post
Share on other sites

 

 

 

The next update will include code for the reviews, just as soom as I get the time to write it.sweatingbullets.gif


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

The next update will include code for the reviews, just as soom as I get the time to write it.sweatingbullets.gif

 

 

Thank you sir. I'll keep an eye out for it.

Share this post


Link to post
Share on other sites

OK I have installed this at http://www.supercheaphobbies.com.au/catalog/ but I have found what might be a bug

 

If you go to http://www.supercheaphobbies.com.au/catalog/product_info.php?cPath=1_9&products_id=3 and open and extra image if you keep clicking next on the little arrows bottom left if you click on it after you get to image 4 and click on it, it take you to the catalog top page instead of back to the product you are looking at..

 

Can this be fixed?

 

Thanks Troy

Share this post


Link to post
Share on other sites

 

 

 

It does annoy when u take the trouble to create a add-on with all the testing & support involved & people install it, make errors so have an issue, but then don't bother to check their own work instead assume thier error is a bug in the package!! mad.gif


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Sam, this same error appears on the test site that has been supplied in the package

Also bear in mind I have asked if this is a bug, as it might be normal operation. But if it is normal then it does not make sense

 

Hence my question

Share this post


Link to post
Share on other sites

Sam this is a great release and I understand the amount of time you must put in to these things, but surely you can also accept some feedback when someone feels something might not be right

 

I do not understand why you attacked me for asking a question, I have just looked threw the 3 pages looking for others that may have posted there shop url up and the only one which is still running is http://hammockdreaming.com/ and that site suffers from the same problem, if you click on the next arrow on the last image it takes you back to the top of the shop not the product you are looking at.

 

Perhaps you could have more of a look and get back to me.

 

Thanks Troy

Share this post


Link to post
Share on other sites

 

 

 

Hi, yes, you're right, the issue can occur, I apolagize for my reaction blush.gif , its just that many say they have a bug when they mess up, and exactly the same issue as yours can occur due to errors in the page structure.

 

Unfortunatly I don't have time to double check every time someone has an issue, I have too many add-ons to support & other works to do. biggrin.gif

 

I will look into the issue as soon as I`ve a moment. smile.gif


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Hi there,

 

First i want to thank you for being one of the first to write a so detailed and good setup.

 

For me it all worked just fine.

 

Only one problem:

 

The product_info.php does not display the article right.

 

If you go to my shop: http://stoffgrosshandel-holland.de/catalog/product_info.php?cPath=32&products_id=60

 

you will see it displays on the far right and not in the center.

Also there is nomore white box around the article

 

 

This is my code:

 

 

<?php

/*

$Id: product_info.php 1739 2007-12-20 00:52:16Z hpdl $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

require('includes/application_top.php');

require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_PRODUCT_INFO);

// Simple multi image addon

$image_group = TINY_IMAGE_GROUP_SIZE; //Number of images to show per row/column

$vertical_format = (ADDITIONAL_IMAGE_FORMAT == 'vertical');

$max_title_length = 40; //Set the maximm length of popup titles before they are broken into multiple lines.

$product_info_query = tep_db_query("select p.products_id, pd.products_name, pd.products_description, p.products_model, p.products_quantity, p.products_image, p.products_image_array, pd.products_url, p.products_price, p.products_tax_class_id, p.products_date_added, p.products_date_available, p.manufacturers_id from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_status = '1' and p.products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and pd.products_id = p.products_id and pd.language_id = '" . (int)$languages_id . "'");

$product_info = tep_db_fetch_array($product_info_query);

$products_image_array = unserialize($product_info['products_image_array']);

if (!is_array($products_image_array)) $products_image_array = array();

// EOF Simple multi image addon

?>

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">

<html <?php echo HTML_PARAMS; ?>>

<head>

<!-- Simple multi image addon -->

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />

<!-- EOF Simple multi image addon -->

<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">

<title><?php echo TITLE; ?></title>

<base href="<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_CATALOG; ?>">

<link rel="stylesheet" type="text/css" href="stylesheet.css">

<!-- Simple multi image addon -->

<script type="text/javascript" src="<?php echo DIR_WS_IMAGES ?>js/jquery.js"></script>

<script src="<?php echo DIR_WS_IMAGES ?>js/jquery.prettyPhoto.js" type="text/javascript" charset="utf-8"></script>

<link rel="stylesheet" href="<?php echo DIR_WS_IMAGES ?>js/prettyPhoto.css" type="text/css" media="screen">

<script type="text/javascript" charset="utf-8">

 

$(document).ready(function(){

$("a[rel^=prettyPhoto]").prettyPhoto({

animationSpeed: 'normal', /* fast/slow/normal */

padding: 30, /* padding for each side of the picture */

opacity: <?php echo (BKG_LUMA/10); ?>, /* Value betwee 0 and 1 */

showTitle: true, /* true/false */

allowresize: true, /* true/false */

counter_separator_label: '/', /* The separator for the gallery counter 1 "of" 2 */

theme: 'light_rounded', /* light_rounded / dark_rounded / light_square / dark_square */

hideflash: false, /* Hides all the flash object on a page, set to TRUE if flash appears over prettyPhoto */

modal: false, /* If set to true, only the close button will close the window */

changepicturecallback: function(){}, /* Called everytime an item is shown/changed */

callback: function(){} /* Called when prettyPhoto is closed */

});

});

</script>

 

<!-- EOF Simple multi image addon -->

</head>

<body marginwidth="0" marginheight="0" topmargin="0" bottommargin="0" leftmargin="0" rightmargin="0">

<!-- header //-->

<?php require(DIR_WS_INCLUDES . 'header.php'); ?>

<!-- header_eof //-->

 

<!-- body //-->

<table border="0" width="100%" cellspacing="3" cellpadding="3">

<tr>

<td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2">

<!-- left_navigation //-->

<?php require(DIR_WS_INCLUDES . 'column_left.php'); ?>

<!-- left_navigation_eof //-->

</table></td>

<!-- body_text //-->

<td width="100%" valign="top"><?php echo tep_draw_form('cart_quantity', tep_href_link(FILENAME_PRODUCT_INFO, tep_get_all_get_params(array('action')) . 'action=add_product')); ?><table border="0" width="100%" cellspacing="0" cellpadding="0">

<?php

// Simple multi image addon

if (!tep_db_num_rows($product_info_query)) {

// EOF Simple multi image addon

?>

<tr>

<td><?php new infoBox(array(array('text' => TEXT_PRODUCT_NOT_FOUND))); ?></td>

</tr>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<tr>

<td><table border="0" width="100%" cellspacing="1" cellpadding="2" class="infoBox">

<tr class="infoBoxContents">

<td><table border="0" width="100%" cellspacing="0" cellpadding="2">

<tr>

<td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>

<td align="right"><?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image_button('button_continue.gif', IMAGE_BUTTON_CONTINUE) . '</a>'; ?></td>

<td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>

</tr>

</table></td>

</tr>

</table></td>

</tr>

<?php

} else {

// Simple multi image addon section moved

 

tep_db_query("update " . TABLE_PRODUCTS_DESCRIPTION . " set products_viewed = products_viewed+1 where products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and language_id = '" . (int)$languages_id . "'");

 

if ($new_price = tep_get_products_special_price($product_info['products_id'])) {

$products_price = '<s>' . $currencies->display_price($product_info['products_price'], tep_get_tax_rate($product_info['products_tax_class_id'])) . '</s> <span class="productSpecialPrice">' . $currencies->display_price($new_price, tep_get_tax_rate($product_info['products_tax_class_id'])) . '</span>';

} else {

$products_price = $currencies->display_price($product_info['products_price'], tep_get_tax_rate($product_info['products_tax_class_id']));

}

 

if (tep_not_null($product_info['products_model'])) {

$products_name = $product_info['products_name'] . '<br><span class="smallText">[' . $product_info['products_model'] . ']</span>';

} else {

$products_name = $product_info['products_name'];

}

?>

<tr>

<td><table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr>

<td class="pageHeading" valign="top"><?php echo $products_name; ?></td>

<td class="pageHeading" align="right" valign="top"><?php echo $products_price; ?></td>

</tr>

</table></td>

</tr>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<tr>

<td class="main">

<?php

if (tep_not_null($product_info['products_image'])) {

?>

<!-- Simple multi image addon -->

<div id="fancy">

<table border="0" cellspacing="0" cellpadding="2" align="right">

<tr>

<td align="center" class="smallText">

 

<?php if (strlen($product_info['products_name']) > $max_title_length) { $title = wordwrap(htmlspecialchars($product_info['products_name']), $max_title_length, '<br>');

} else { $title = htmlspecialchars($product_info['products_name']); }

$m_source = ''; $thumb = (class_exists('oscthumb') && CFG_MASTER_SWITCH == 'On'); if ($thumb) { preg_match('/"([^"]+)"/',htmlentities ( tep_image(DIR_WS_IMAGES . $product_info['products_image'],'','','','','',5), ENT_NOQUOTES), $image); $m_source=str_replace('&','&',$image[1]); }

echo '<a rel="prettyPhoto[gallery1]" title="'.$title.'" href="' . ($m_source ? $m_source : DIR_WS_IMAGES . $product_info['products_image']) . '" alt="' . $product_info['products_name'] . '" target="_blank">' . tep_image(DIR_WS_IMAGES . $product_info['products_image'], $product_info['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, 'hspace="5" vspace="5"', false, 5) . '</a><br />';

if(!$vertical_format) { echo ''; $row = 1; reset($products_image_array); foreach($products_image_array as $value) {

if ($thumb) {

$source = ''; preg_match('/"([^"]+)"/',htmlentities ( tep_image(DIR_WS_IMAGES . $value,'','','','','',5), ENT_NOQUOTES), $image); $source=str_replace('&','&',$image[1]);

}

echo '<a rel="prettyPhoto[gallery1]" title="'.$title.'" href="' . ($source ? $source : DIR_WS_IMAGES . $value) . '" target="_blank">' . tep_image(DIR_WS_IMAGES . $value, $product_info['products_name'], TINY_IMAGE_WIDTH, TINY_IMAGE_HEIGHT, 'hspace="5" vspace="5"') . '</a>';

 

++$row; if ($row > $image_group) { echo '<br />'; $row = 1; } } }

echo '</td>';

if($vertical_format) { echo '<td>'; $row = 1; reset($products_image_array); foreach($products_image_array as $value) {

if ($thumb) {

$source = ''; preg_match('/"([^"]+)"/',htmlentities ( tep_image(DIR_WS_IMAGES . $value,'','','','','',5), ENT_NOQUOTES), $image); $source=str_replace('&','&',$image[1]);

}

echo '<a rel="prettyPhoto[gallery1]" title="'.$title.'" href="' . ($source ? $source : DIR_WS_IMAGES . $value) . '" target="_blank">' . tep_image(DIR_WS_IMAGES . $value, $product_info['products_name'], TINY_IMAGE_WIDTH, TINY_IMAGE_HEIGHT, 'hspace="5" vspace="5"') . '<br />' . '</a>';

 

++$row; if ($row > $image_group) { echo '</td><td>'; $row = 1; } } echo '</td>'; } ?>

 

 

</tr><?php echo '<tr><td class="smallText">' . TEXT_CLICK_TO_ENLARGE . '</td></tr>'; ?>

</table>

</div>

<!-- EOF Simple multi image addon -->

<?php

}

?>

<!-- </td></tr><tr><td class="smallText"> --><p><?php echo stripslashes($product_info['products_description']); ?></p>

<?php

$products_attributes_query = tep_db_query("select count(*) as total from " . TABLE_PRODUCTS_OPTIONS . " popt, " . TABLE_PRODUCTS_ATTRIBUTES . " patrib where patrib.products_id='" . (int)$HTTP_GET_VARS['products_id'] . "' and patrib.options_id = popt.products_options_id and popt.language_id = '" . (int)$languages_id . "'");

$products_attributes = tep_db_fetch_array($products_attributes_query);

if ($products_attributes['total'] > 0) {

?>

<table border="0" cellspacing="0" cellpadding="2">

<tr>

<td class="main" colspan="2"><?php echo TEXT_PRODUCT_OPTIONS; ?></td>

</tr>

<?php

$products_options_name_query = tep_db_query("select distinct popt.products_options_id, popt.products_options_name from " . TABLE_PRODUCTS_OPTIONS . " popt, " . TABLE_PRODUCTS_ATTRIBUTES . " patrib where patrib.products_id='" . (int)$HTTP_GET_VARS['products_id'] . "' and patrib.options_id = popt.products_options_id and popt.language_id = '" . (int)$languages_id . "' order by popt.products_options_name");

while ($products_options_name = tep_db_fetch_array($products_options_name_query)) {

$products_options_array = array();

$products_options_query = tep_db_query("select pov.products_options_values_id, pov.products_options_values_name, pa.options_values_price, pa.price_prefix from " . TABLE_PRODUCTS_ATTRIBUTES . " pa, " . TABLE_PRODUCTS_OPTIONS_VALUES . " pov where pa.products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and pa.options_id = '" . (int)$products_options_name['products_options_id'] . "' and pa.options_values_id = pov.products_options_values_id and pov.language_id = '" . (int)$languages_id . "'");

while ($products_options = tep_db_fetch_array($products_options_query)) {

$products_options_array[] = array('id' => $products_options['products_options_values_id'], 'text' => $products_options['products_options_values_name']);

if ($products_options['options_values_price'] != '0') {

$products_options_array[sizeof($products_options_array)-1]['text'] .= ' (' . $products_options['price_prefix'] . $currencies->display_price($products_options['options_values_price'], tep_get_tax_rate($product_info['products_tax_class_id'])) .') ';

}

}

 

if (isset($cart->contents[$HTTP_GET_VARS['products_id']]['attributes'][$products_options_name['products_options_id']])) {

$selected_attribute = $cart->contents[$HTTP_GET_VARS['products_id']]['attributes'][$products_options_name['products_options_id']];

} else {

$selected_attribute = false;

}

?>

<tr>

<td class="main"><?php echo $products_options_name['products_options_name'] . ':'; ?></td>

<td class="main"><?php echo tep_draw_pull_down_menu('id[' . $products_options_name['products_options_id'] . ']', $products_options_array, $selected_attribute); ?></td>

</tr>

<?php

}

?>

</table>

<?php

}

?>

</td>

</tr>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<?php

$reviews_query = tep_db_query("select count(*) as count from " . TABLE_REVIEWS . " where products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "'");

$reviews = tep_db_fetch_array($reviews_query);

if ($reviews['count'] > 0) {

?>

<tr>

<td class="main"><?php echo TEXT_CURRENT_REVIEWS . ' ' . $reviews['count']; ?></td>

</tr>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<?php

}

 

if (tep_not_null($product_info['products_url'])) {

?>

<tr>

<td class="main"><?php echo sprintf(TEXT_MORE_INFORMATION, tep_href_link(FILENAME_REDIRECT, 'action=url&goto=' . urlencode($product_info['products_url']), 'NONSSL', true, false)); ?></td>

</tr>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<?php

}

 

if ($product_info['products_date_available'] > date('Y-m-d H:i:s')) {

?>

<tr>

<td align="center" class="smallText"><?php echo sprintf(TEXT_DATE_AVAILABLE, tep_date_long($product_info['products_date_available'])); ?></td>

</tr>

<?php

} else {

?>

<tr>

<td align="center" class="smallText"><?php echo sprintf(TEXT_DATE_ADDED, tep_date_long($product_info['products_date_added'])); ?></td>

</tr>

<?php

}

?>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<tr>

<td><table border="0" width="100%" cellspacing="1" cellpadding="2" class="infoBox">

<tr class="infoBoxContents">

<td><table border="0" width="100%" cellspacing="0" cellpadding="2">

<tr>

<td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>

<td class="main"><?php echo '<a href="' . tep_href_link(FILENAME_PRODUCT_REVIEWS, tep_get_all_get_params()) . '">' . tep_image_button('button_reviews.gif', IMAGE_BUTTON_REVIEWS) . '</a>'; ?></td>

<td class="main" align="right"><?php echo tep_draw_hidden_field('products_id', $product_info['products_id']) . tep_image_submit('button_in_cart.gif', IMAGE_BUTTON_IN_CART); ?></td>

<td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>

</tr>

</table></td>

</tr>

</table></td>

</tr>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<tr>

<td>

<?php

if ((USE_CACHE == 'true') && empty($SID)) {

echo tep_cache_also_purchased(3600);

} else {

include(DIR_WS_MODULES . FILENAME_ALSO_PURCHASED_PRODUCTS);

}

}

?>

</td>

</tr>

</table></form></td>

<!-- body_text_eof //-->

<td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2">

<!-- right_navigation //-->

<?php require(DIR_WS_INCLUDES . 'column_right.php'); ?>

<!-- right_navigation_eof //-->

</table></td>

</tr>

</table>

<!-- body_eof //-->

 

<!-- footer //-->

<?php require(DIR_WS_INCLUDES . 'footer.php'); ?>

<!-- footer_eof //-->

<br>

</body>

</html>

<?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?>

 

 

 

 

Hope that someone can help me

Share this post


Link to post
Share on other sites

 

 

You have a template, therefore non standard code, that always makes installing add-ons harder.

 

As I don't know what you had b4 I cant say why its not there now!!

 

It sounds like you need to adjust some aligns, also remember columns are at minimum size for content unless a size is specified.


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Spooks-

Awesome contrib - thanks a bunch.

I have a few questions...

First, I installed this on a fresh OSC setup and it works great. I am having just two small problems. At the bottom of the popup where it displays the title, Prev and Next arrows and the text "x of y" where x is the current picture and y is the total number of pictures, it is not displaying this correctly (or at least not as I would expect). I believe the title should be on one line and then just below it, the arrows and "x of y" text should all be on one line as well. Instead, it all appears vertical. The Title text only goes about 300 pixels before it starts to wrap to the next line. Even worse, below that, I get the Prev arrow, then under that the "x", below that the "of", below that the "y" and finally below that, the Next arrow. It's almost like all those elements are in a html table cell that's about 10 pixels wide, so what would normally go across in a straight line gets wrapped at each space. I hope I am explaining this clearly.

 

The other problem I am having is that I simply cannot figure out how to change the fonts of any of that text - the title or the "x of y" stuff. I know it has been brought up here before and I have made the mentioned modifications to the CSS as described, but it simply does not do anything.

I'm pretty good with PHP, not just some moron trying to blindly following instructions. I am certain that I installed it correctly and I have checked and re-checked the installation. I am not using STS or any other crazy stuff that would be likely to interfere. If you can provide any insight on why I'm having the "vertical" problem and why I cannot change the fonts, I would really appreciate it.

 

Finally, I noticed someone else made a mention of the Facebook style at no-margin-for-errors.com. Based on your response, I think you might have misinterpreted the question - your answer seemed to be about the prettySociable project he has there. In fact the question the poster had (and I have too), is in regard to the facebook theme for prettyPhoto. Your contrib is based on version 2.5.4 of prettyPhoto, but the current version is 2.5.6. In the 2.5.5 version they added the facebook theme, and you can see this at the bottom of this page: http://www.no-margin-for-errors.com/projects/prettyphoto-jquery-lightbox-clone/

So the question is, how can we add this theme? I tried copying all the relevant lines into the CSS file and copying the 2.5.6 version of jquery.prettyPhoto.js over the one with your contrib, but it didn't work, so I am assuming you are doing something custom in the prettyPhoto.js file. I guess at this point, unless you can point to a simple do it yourself way to add this theme, is this something you can put on your list for future releases?

 

 

Thanks again for the awesome contrib.

Share this post


Link to post
Share on other sites

Hello Sam:

 

I just installed this contribution about 2 days ago, everything seems to be working great!!! The thing is after I installed it, I'm having problems with a contribution that I had Option Types V2, I did post a thread on the official support thread for it, but was wondering if you had the time and could take a look at the post, maybe give me a suggestion as to where to look. I am not getting error messages, from neither your contribution or the Option Types V2, so I really don't know where to look. The thread is here: Click I don't want to lose either one, I really love 2 of them and need them. Thanks so much!!!

 

Glenda


I Hate PHP, LoLssss

Visit My Site, Any constructive comments and suggestions Welcome :)

WARNING: IT'S STILL UNDER CONSTRUCTION, LOLS

Share this post


Link to post
Share on other sites

Hello Sam:

 

I just installed this contribution about 2 days ago, everything seems to be working great!!! The thing is after I installed it, I'm having problems with a contribution that I had Option Types V2, I did post a thread on the official support thread for it, but was wondering if you had the time and could take a look at the post, maybe give me a suggestion as to where to look. I am not getting error messages, from neither your contribution or the Option Types V2, so I really don't know where to look. The thread is here: Click I don't want to lose either one, I really love 2 of them and need them. Thanks so much!!!

 

Glenda

 

The changes this make happen b4 the product description, options occur after that, so there can be no conflict other than sql issues, and as this only adds one field there should be none there.

 

The other files u mention in your other thread are not touched by this.

 

Sometimes u introduce unrelated errors that you mistakenly atribute to your last edition, take care to check your precise problems.


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

A slight update to my previous post (#87).

Regarding changing fonts - I think I figured out the problem. I was under the assumption you had to change the .pp_description in the given theme you are using, so for example I am using dark rounded, and there is an entry in the .css file for div.dark_rounded .pp_description. When I changed this nothing happened. Then I found there is also a .pp_description at the bottom of the .css file. I changed that and it changed my font!

Is this a bug or is it by design? Just curious - as long as it works I don't really care, but it is a bit confusing and counterintuitive, and seems to break a potential feature where a user might want a different font for each theme and might want to quickly switch back and forth between themes.

 

Ok, so that's the good news - the thing I seemed to figure out on my own.

I'm still having failures on the other issues listed in that post and I'm really hoping you can take just a moment to guide me on them.

First is the issue with how the "x of y" is being displayed. I hope my description of the problem is clear, but if not, please let me know and I will try to explain it better.

Second is the 2.5.4 version of prettyPhoto vs 2.5.6 version, and most notably the "facebook" theme included in the newer version. I have tried every way I can think of to manually add that theme, but it simply does not work. Any thoughts here? Not a critical issue, but certainly a nice to have.

 

Finally, one other thing I would like to bring up. the jquery.prettyPhoto.js file you include in the package is formatted to contain no linefeeds. I have loaded it up in Zend Eclipse, Windows Notepad, WordPad and MS Word and in all cases, it is just a straight line of text. As you can imagine, this makes it extremely difficult to read through the code for anyone wanting to modify or just understand what it is doing to look for possible problems. Did you do this on purpose or is it some byproduct of the editing software you are using? Anyway, if possible, can you re-post a copy of this file with properly formatted linefeeds - that would be greatly appreciated.

 

Thanks again for any help you can provide.

Share this post


Link to post
Share on other sites

Hi Sam,

 

I have a question regarding your marvalous contri.

 

Some IE8 users get a warning message about compatability of websites designed for old browsers when entering my site.

They have to press a warning screen to put compatablity on in the right side of the URL line in IE8.

If they press that warning thing the user is redirected to the login screen of my shop.

In the user tracking software I use, I can see that a lot of people don't click further on the site.

I have thoughts that that this issue has to do with the line of meta code in the product_info.php:

 

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />

 

Can you please confirm if this is the cause, perhaps this line needs an update?

What is the exact purpose of this meta regarding the contri?

If this IE8 issue has nothing to do with your contri excuse me!

 

Kind Regards

Share this post


Link to post
Share on other sites

 

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />

 

Can you please confirm if this is the cause, perhaps this line needs an update?

What is the exact purpose of this meta regarding the contri?

 

 

 

Having never come accross the issue I can't say why their seeing that error.

 

 

The purpose of that line is to make ie8 work.

 

IE has always needed helper files to make it display css correctly that other browsers don't need as they are 'standards complient' .

 

MS 'think' ie8 is 'standards complient' so they removed the support for the helper files. ohmy.gif

 

The trouble is ie8 is only partly 'standards complient' so for the most part still needs the helper files it no longer supports. crying.gif

 

MS realised this issue so created that tag as a workaround, what it does is make ie8 like ie7, so support the helper files it needs. laugh.gif


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

i don't have already install the contribution...I need a better explain with this steps:

2. Copy the js directory & all files within in the included images folder to your sites images folder:

please tell me: just the js directory i need to upload in my server? in which directory?

the other files don't need? (pe admin categories.php?)

 

3. Apply the included SQL with phpMyAdmin.

where is the included sql??? is the SQL V1? I need to copy the txt content and paste in the db or in a specific db item?

sorry for the stupid question, but i'm not english I don't want to make some strong mistake!!

thanks

Share this post


Link to post
Share on other sites

The changes this make happen b4 the product description, options occur after that, so there can be no conflict other than sql issues, and as this only adds one field there should be none there.

 

The other files u mention in your other thread are not touched by this.

 

Sometimes u introduce unrelated errors that you mistakenly atribute to your last edition, take care to check your precise problems.

Hi Sam:

 

Thanks for your reply, since you posted this answer i have been verifying my work, I have restored the database to earlier points in time. I uninstalled and reinstalled and uninstalled your application, to see if that was the problem, but nothing seems to be working. I even restored the whole shop to an earlier date, but nothing. You mentioned i could be having SQL problems, wouldn't these resolve if I restore the database? I know it's not your contribution that is causing the problem, but I was wondering if you could tell me, what type of Sql problem it could be... I have received no answer from the other post. Just wanted to know if you could give me a suggestion as to what type of problem and how I can fix it. Thanks so much in advance.

 

Glenda


I Hate PHP, LoLssss

Visit My Site, Any constructive comments and suggestions Welcome :)

WARNING: IT'S STILL UNDER CONSTRUCTION, LOLS

Share this post


Link to post
Share on other sites

Hi Sam:

 

Thanks for your reply, since you posted this answer i have been verifying my work, I have restored the database to earlier points in time. I uninstalled and reinstalled and uninstalled your application, to see if that was the problem, but nothing seems to be working. I even restored the whole shop to an earlier date, but nothing. You mentioned i could be having SQL problems, wouldn't these resolve if I restore the database? I know it's not your contribution that is causing the problem, but I was wondering if you could tell me, what type of Sql problem it could be... I have received no answer from the other post. Just wanted to know if you could give me a suggestion as to what type of problem and how I can fix it. Thanks so much in advance.

 

Glenda

Hey Sam:

 

Just wanted to update, just to let you know, it was not your contribution that conflicted with the Option Types V2, ofcourse you already knew that :blush:, but just in case someone else comes accross my previous posts. It was actually the MPQ, minimum quantity per product contribution causing the problem. For some reason unknown to php ignorants like myself :rolleyes: the product attributes from Option Types are dropped by the MPQ, or it cannot keep them, don't know, it keeps the normal attributes though. If anyone searches the topic, they will find many people having problems with the MPQ and different product attribute contributions. Anyways, I have both this contribution and Option Types working fine. Thanks again for the contribution, :) really needed it, anddddddd most importantly for me, veryyyyyyy easyyy to install :thumbsup:


I Hate PHP, LoLssss

Visit My Site, Any constructive comments and suggestions Welcome :)

WARNING: IT'S STILL UNDER CONSTRUCTION, LOLS

Share this post


Link to post
Share on other sites

I am also having trouble again install this addon. This is because, I'm sure, I am using a template with a JS already in use. Would anybody, who feels capable, in helping me out, be interested in installing and setting up this addon for me? Please email me and name your price. I'll need this job done ASAP. Thanks! daniel@gruntstyle.com


This is my signature.

Share this post


Link to post
Share on other sites

Hey!

 

First i love the Idea and the Perfekt Installation instructions from your Plugin!

The Most others just say... Upload the Files (and everything break) Or use a tool to compare... which is gay xD

 

But i have a Problem.

i really did everything you said, i checked and really hope i'm write now...

BUT, when i create or change a Produkt, there are 3 Fields for extra Pictures...

 

But when i click to Update, there are no more Images...

On the "Finish Page" ist just:

 

Additional Images:

 

And nothing beyound... i really dont know what to do now...

I have no idea, which file should make this workable...

 

i really hope you can help, as fast as possible... (my costumer will be very happy :rolleyes: )

 

 

Greetings

c0de

Share this post


Link to post
Share on other sites

Dig the addon idea, but I'm having what seems to be a typical problem. Stated solution is to double check your work, so I've restored files and DB and am re-doing the install right now.

 

Meanwhile I have the following question:

 

Where the instructions tell-

Find(762)

 

<td align="center" class="smallText"><?php echo sprintf(TEXT_PRODUCT_DATE_ADDED, tep_date_long($pInfo->products_date_added)); ?></td>

</tr>

<?php

}

?>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td>

</tr>

</table>

<?php

}

?>

 

 

 

My admin/categories.php reads:

<td align="center" class="smallText"><?php echo sprintf(TEXT_PRODUCT_DATE_ADDED, tep_date_long($pInfo->products_date_added)); ?></td>

</tr>

<?php

}

?>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td>

</tr>

<?php

}

 

if (isset($HTTP_GET_VARS['read']) && ($HTTP_GET_VARS['read'] == 'only')) {

if (isset($HTTP_GET_VARS['origin'])) {

$pos_params = strpos($HTTP_GET_VARS['origin'], '?', 0);

if ($pos_params != false) {

$back_url = substr($HTTP_GET_VARS['origin'], 0, $pos_params);

$back_url_params = substr($HTTP_GET_VARS['origin'], $pos_params + 1);

} else {

$back_url = $HTTP_GET_VARS['origin'];

$back_url_params = '';

}

} else {

$back_url = FILENAME_CATEGORIES;

$back_url_params = 'cPath=' . $cPath . '&pID=' . $pInfo->products_id;

}

?>

 

So here is what I did:

<td align="center" class="smallText"><?php echo sprintf(TEXT_PRODUCT_DATE_ADDED, tep_date_long($pInfo->products_date_added)); ?></td>

</tr>

<?php

}

?>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td>

</tr>

<?php

}

 

if (isset($HTTP_GET_VARS['read']) && ($HTTP_GET_VARS['read'] == 'only')) {

if (isset($HTTP_GET_VARS['origin'])) {

$pos_params = strpos($HTTP_GET_VARS['origin'], '?', 0);

if ($pos_params != false) {

$back_url = substr($HTTP_GET_VARS['origin'], 0, $pos_params);

$back_url_params = substr($HTTP_GET_VARS['origin'], $pos_params + 1);

} else {

$back_url = $HTTP_GET_VARS['origin'];

$back_url_params = '';

}

} else {

$back_url = FILENAME_CATEGORIES;

$back_url_params = 'cPath=' . $cPath . '&pID=' . $pInfo->products_id;

}

?>

<!-- Simple multi image addon -->

<table summary=""><tr><td>Additional Images:</td><td class="main" colspan="3"><table summary=""><tr>

 

<?php $i=1; while (list($key, $value) = each($products_image_array)) { ?>

 

 

<?php echo '<td align="center">' . tep_image(DIR_WS_CATALOG_IMAGES . $value, $value, SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, ' hspace="8" vspace="5"');

if($HTTP_POST_VARS['delete_image_' .$i] == 'on') echo '<br />To Be Deleted';

echo '</td>'; ++$i; } ?>

 

</tr>

</table></td></tr></table>

<!-- EOF Simple multi image addon -->

 

Does this look okay?

Share this post


Link to post
Share on other sites

The re-install seems to have fixed my previous issue.

 

Dig the addon idea, but I'm having what seems to be a typical problem. Stated solution is to double check your work, so I've restored files and DB and am re-doing the install right now.

 

Meanwhile I have the following question:

 

Where the instructions tell-

 

 

 

 

My admin/categories.php reads:

 

 

So here is what I did:

 

 

Does this look okay?

Share this post


Link to post
Share on other sites

Thanks for this great contrb.

I have one issue though - Whenever i edit a product, the additional images are simply dumped and i need to re-add them.

Any ideas ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×