Jump to content
Richard Cranium

[Contribution] Scrolling Customer Testimonials

Recommended Posts

Rocha,

 

What are you using to power your scrolling images on the right side of your store? There may be a conflict between that routine and the scrolling for the testimonials.

 

Regards,

David

 

Do not know this, but deactivated the 3rd scroll of my colunn_right and the problem remained the same. Everything works correct and the box is there, you can click and go to post new testimonials or read those already, but just does not show the text of the testimonials on the box or at least stopped. (this only when selected "scrolling" in the admin, if you select "static" everything works very well).

 

Cordially.

Rocha

Share this post


Link to post
Share on other sites

Hi,

 

I really like the stars thing of the normal osC review system, and I do not see in the instructions or in the screenshot how to activate it.

 

Am I wrong or has it been removed?

Share this post


Link to post
Share on other sites

Hi,

 

I really like the stars thing of the normal osC review system, and I do not see in the instructions or in the screenshot how to activate it.

 

Am I wrong or has it been removed?

 

Hello Gomino.

 

That function is related to Customer Reviews. Customer Testimonials are a separate entity. The difference is that Reviews are about specific products and Testimonials are comments about the website.

Share this post


Link to post
Share on other sites

Yes sir!

I add the numbers of lines here for you.

Look:

108 // draw the text
109      	$testimonial_list .= '<tr><td class="infoBoxContents" valign="top" align="left">';  

This is your code and i change nothing in.

(sorry for my english..)

Can you help me?

 

I think I see the problem now. There is a typo in line 109. It should read:

 

     	$testimonials_list .= '<tr><td class="infoBoxContents" valign="top" align="left">';

 

The variable was missing the letter "s" in "testimonials". Can't believe that I missed that! :(

 

Try that and let me know if it works now.

Share this post


Link to post
Share on other sites

Do not know this, but deactivated the 3rd scroll of my colunn_right and the problem remained the same. Everything works correct and the box is there, you can click and go to post new testimonials or read those already, but just does not show the text of the testimonials on the box or at least stopped. (this only when selected "scrolling" in the admin, if you select "static" everything works very well).

 

Rocha,

 

First, can you be sure you are not hovering the mouse over the Scrolling Testimonials infobox? That would cause it to pause.

 

If that is not the case, please try the following:

 

1. Edit /includes/boxes/customer_testimonials.php and REMOVE the following code - lines 119-143 (or REM it out for the moment):

 

?>

<!-- Make sure we don't interrupt any other onLoad event -->
<!-- Load event handler by Peter-Paul Koch -->
<script type="text/javascript">
function addLoadEvent(func) {
 var oldonload = window.onload;
 if (typeof window.onload != 'function') {
   window.onload = func;
 } else {
   window.onload = function() {
     if (oldonload) {
       oldonload();
     }
     func();
   }
 }
}

addLoadEvent(function() {
    document.getElementById('marquee').className='marquee_show'; 
});
</script>

<?php

 

2. Edit /stylesheet.css

 

Find

 

.marquee_hide {
    visibility:hidden;
}

 

 

CHANGE to:

 

.marquee_hide {
    visibility:visible;
}

 

 

This should turn on scrolling. You will see some text flash on the screen before the scrolling starts. Not a long term solution, but I want to see if the scrolling works for you. Let me know what you see after those changes.

 

BTW, which browser are you using and on what platform (i.e. Mac, PC, etc.)? Please also include your browser version (e.g. Firefox 3.4, etc.).

 

Regards,

David

Edited by Richard Cranium

Share this post


Link to post
Share on other sites

I give you a good translation in French of your /includes/languages/french/customer_testimonials.php

 

This is more French than your translation.... :-)

 

Hexa,

 

Thank you for the better translation!! BabelFish is mediocre at best!

 

Regards,

David

Share this post


Link to post
Share on other sites

Rocha,

 

First, can you be sure you are not hovering the mouse over the Scrolling Testimonials infobox? That would cause it to pause.

 

If that is not the case, please try the following:

 

1. Edit /includes/boxes/customer_testimonials.php and REMOVE the following code - lines 119-143 (or REM it out for the moment):

 

?>

<!-- Make sure we don't interrupt any other onLoad event -->
<!-- Load event handler by Peter-Paul Koch -->
<script type="text/javascript">
function addLoadEvent(func) {
 var oldonload = window.onload;
 if (typeof window.onload != 'function') {
   window.onload = func;
 } else {
   window.onload = function() {
     if (oldonload) {
       oldonload();
     }
     func();
   }
 }
}

addLoadEvent(function() {
    document.getElementById('marquee').className='marquee_show'; 
});
</script>

<?php

 

2. Edit /stylesheet.css

 

Find

 

.marquee_hide {
    visibility:hidden;
}

 

 

CHANGE to:

 

.marquee_hide {
    visibility:visible;
}

 

 

This should turn on scrolling. You will see some text flash on the screen before the scrolling starts. Not a long term solution, but I want to see if the scrolling works for you. Let me know what you see after those changes.

 

BTW, which browser are you using and on what platform (i.e. Mac, PC, etc.)? Please also include your browser version (e.g. Firefox 3.4, etc.).

 

Regards,

David

 

 

Ohhhh! Now is working. I made the changes recommended and it worked.

See for yourself: www.shazammagicas.com

 

I use PC running Windows XP Professional Service Pack 3, Internet Explorer 7 (I have used the 8 but gave me problems).

 

Thanks

 

Rocha / Shazam_Brasil

Share this post


Link to post
Share on other sites

This is one of the few Contributions I have left to install on my store. However, I am 2 hours into the installation of v1.1 and I am no farther long than 1.5 hours ago. I do not know PHP, but I can follow directions. I am quite positive the correct files have the correct changes, based on your directions.

 

Quite simply, the info box does not show. I have tried checking and unchecking boxes (no matter what they said), I have tried SSL and no SSL. Captcha On, Captcha off. I have manually added 2 Testimonials (and tried on/off combinations to no avail)

 

Funny though, the only thing that seems to make any difference is the Column Left/Right.php

 

This shows nothing:

if ($request_type != 'SSL') {

include(DIR_WS_BOXES . 'customer_testimonials.php');

}

 

This shows an error message:

include(DIR_WS_BOXES . 'customer_testimonials.php');

 

1146 - Table 'osc_pf.table_customer_testimonials' doesn't exist

select * FROM TABLE_CUSTOMER_TESTIMONIALS WHERE status = 1 AND language_id = 1 ORDER BY rand() LIMIT 1

[TEP STOP]

 

Yes, the table is there, and quite happy, with the 2 testimonials I manually added in the Admin.

Share this post


Link to post
Share on other sites

Ohhhh! Now is working. I made the changes recommended and it worked.

See for yourself: www.shazammagicas.com

 

I use PC running Windows XP Professional Service Pack 3, Internet Explorer 7 (I have used the 8 but gave me problems).

 

Thanks

 

Rocha / Shazam_Brasil

 

Good! As I suspected, the problem was with a Javascript conflict. It should be possible to get it work by leaving the JS code in SCT, but how to do that is beyond the scope of this forum. You'd need to locate all your JS code scripts and integrate the code that runs when the window loads. Anyway, for now I am glad it's working for you. :)

 

David

Share this post


Link to post
Share on other sites

This is one of the few Contributions I have left to install on my store. However, I am 2 hours into the installation of v1.1 and I am no farther long than 1.5 hours ago. I do not know PHP, but I can follow directions. I am quite positive the correct files have the correct changes, based on your directions.

 

Quite simply, the info box does not show. I have tried checking and unchecking boxes (no matter what they said), I have tried SSL and no SSL. Captcha On, Captcha off. I have manually added 2 Testimonials (and tried on/off combinations to no avail)

 

Funny though, the only thing that seems to make any difference is the Column Left/Right.php

 

This shows nothing:

if ($request_type != 'SSL') {

include(DIR_WS_BOXES . 'customer_testimonials.php');

}

 

This shows an error message:

include(DIR_WS_BOXES . 'customer_testimonials.php');

 

1146 - Table 'osc_pf.table_customer_testimonials' doesn't exist

select * FROM TABLE_CUSTOMER_TESTIMONIALS WHERE status = 1 AND language_id = 1 ORDER BY rand() LIMIT 1

[TEP STOP]

 

Yes, the table is there, and quite happy, with the 2 testimonials I manually added in the Admin.

 

LRK,

 

First, try fixing this bug and see if it will cause the box to appear: http://forums.oscommerce.com/topic/348761-contribution-scrolling-customer-testimonials/page__view__findpost__p__1461728

 

That SQL statement is not right. It looks like the database table is not defined (catalog/includes/database_tables.php). Make sure you are modifying / adding files in the correct directory. It's easy to get something into the catalog/admin/ tree when it should be under catalog/ or vice versa.

 

Which version of OSC are you using?

Edited by Richard Cranium

Share this post


Link to post
Share on other sites

Good! As I suspected, the problem was with a Javascript conflict. It should be possible to get it work by leaving the JS code in SCT, but how to do that is beyond the scope of this forum. You'd need to locate all your JS code scripts and integrate the code that runs when the window loads. Anyway, for now I am glad it's working for you. :)

 

David

 

Hello Richard,

 

But my clients will see working as normal I see here with any configuration of their computer or for each setting will see different?

 

Rocha

Share this post


Link to post
Share on other sites

Hello, Michael.

 

Thanks for your comments. I am a bit stumped on your problem as well. Would you mind removing any secure info and PM'ing me your index.php file so I can take a look at it?

 

Sounds like something is interfering with the Marquee scroll. Could be a load timing issue for example.

 

Regards,

David

 

Also check your admin setting "Testimonials language display setting" and "Testimonials Language Default"

 

Depending on how these are setup, if all of your testimonials are in one language and you are viewing in another language then this will cause the InfoBox to appear empty (which is a bug I need to fix, it should tell you there are no testimonials or not display the box at all depending on your other preferences).

 

The key is usually how you have "Testimonials language display setting" defined. If it is set to "User Language Only" then the InfoBox will only display testimonials with language ID tags that match the person's language choice when viewing your store. This matters only for multi-language stores. Let's say you offer German, Itailian, and English language versions of your store. Using these settings you can filter your testimonials so that customers only see testimonials for their language or you can have them view all of them (i.e. testimonials written in any of your supported languages).

 

David

Share this post


Link to post
Share on other sites

Hello Richard,

 

But my clients will see working as normal I see here with any configuration of their computer or for each setting will see different?

 

Rocha

 

Rocha,

 

If I understand your question correctly, your clients should see what you see. Just be sure to check on different browsers or different browser versions (e.g. Internet Explorer 7, 8 and FireFox, Safari, etc.)

 

Regards,

David

Share this post


Link to post
Share on other sites

Scrolling Customer Testimonials v1.11 now available. I just uploaded it. Since it is >300k it will need to be manually approved by OSC staff, but it should be in the Contributions download area soon.

 

Update release with a couple of bug fixes and minor functionality improvements.

Share this post


Link to post
Share on other sites

Hi

thanks for the nice contrib. I have installed it and it works fine.

The only problem is that when scrolling option is used only one same testimonial is shown. There are 2 in the DB now but only one of them is shown.

"Minimum number of testimonials before scrolling customer testimonials 2" <--- this is in admin

Help appreciated.


OSC beginner

Share this post


Link to post
Share on other sites

Hi

thanks for the nice contrib. I have installed it and it works fine.

The only problem is that when scrolling option is used only one same testimonial is shown. There are 2 in the DB now but only one of them is shown.

"Minimum number of testimonials before scrolling customer testimonials 2" <--- this is in admin

Help appreciated.

 

Garnet,

 

Hello. It should work fine even with just 2. I tested it and it works for me. So.... there are a few possible causes but it typically boils down to either that you missed something during the install or there is a Javascript conflict. Do you have any other JS scripts running aside from the standard OSC code? There is a routine in SCT that tries to not interfere with other JS calls by making the SCT code wait in line for other scripts to execute first, if they load when the window loads. However, it does not seem to work all the time. I'm trying to figure out what the problem is.

 

Can you give me a list of all the mods that you have installed? And are you using OSC 2.2RC2a? If so, are you sure you have the "final" version of 2.2RC2a installed or perhaps actually 2.2RC2?

 

Mostly a list of your mods would help. I've got to try and correlate what mods are installed when people have this problem.

 

Which version of SCT are you using? The latest is version 1.11. If you are not using that one, try installing it first. There are thorough update instructions included in the download.

 

Also, try these instructions and let me know if it starts working: http://forums.oscommerce.com/topic/348761-contribution-scrolling-customer-testimonials/page__view__findpost__p__1461733

 

Regards,

David

Edited by Richard Cranium

Share this post


Link to post
Share on other sites

This works fine except in the testimonials box sometimes i have the same testimonial showing up twice or even three times...

 

It's normal behavior. The code relies on SQL to pick a random testimonial, and the request is made separately on each call to the database. So, it is possible to get the same testimonial more than once in any given scroll. The more testimonials you have, the less likely this is to occur.

 

I have not had time to code a version that checks for duplicates. One problem with dup checking is it will tie up the server with more processing. I may add this feature in the future. I agree it would be ideal to allow it, probably with an admin on/off switch so that admins who want to minimize the processor use can turn it off (or if you have lots of testimonials the feature is also less useful).

Share this post


Link to post
Share on other sites

Hi.

 

I have installed the contribution successfully.

 

However, there is one thing I'm getting confused.

 

When there is no testimonial, there will be duplicate info box for testimonials. But when I inserted testimonial, then is no problem at all.

 

Please help me on this issue.

 

Thanks

Share this post


Link to post
Share on other sites

When there is no testimonial, there will be duplicate info box for testimonials. But when I inserted testimonial, then is no problem at all.

 

Henry,

 

Sorry for my slow response. I am just returning from the holidays.

 

Have you installed the latest version? If you are then it sounds like you might have some code duplicated, but it sounds more like it could be an older version that you have installed. There was a bug - I believe in the first rev - which was possible to produce the behavior you are describing.

 

David

Share this post


Link to post
Share on other sites

I use PC running Windows XP Professional Service Pack 3, Internet Explorer 7 (I have used the 8 but gave me problems).

 

Another tip regarding IE browsers is to be sure to check your DOCTYPE designation on your forms. At least some OSC 2.2 stock forms have outdated definitions.

 

If you have trouble rendering the scrolling properly in IE but it works in other browsers, try changing your DOCTYPE on the problematic form to something like this:

 

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">

 

For an overview of this topic, I suggest visiting this website: http://www.w3schools.com/tags/tag_doctype.asp

 

David

Share this post


Link to post
Share on other sites

it's possible show only name in box testimonial? (no name complete with surname) ?

 

You mean that you just want a scrolling list of names that appears like this?

 

<name 1>

 

<name 2>

 

<name 3>

 

etc.

Share this post


Link to post
Share on other sites

it's possible show only name in box testimonial? (no name complete with surname) ?

 

You mean that you just want a scrolling list of names that appears like this?

 

<name 1>

 

<name 2>

 

<name 3>

 

etc.

Share this post


Link to post
Share on other sites

Posting a new version today (v1.11a). Very minor upgrade, just 1 bug fix.

 

The bug is the admin setting for maximum number of testimonials is ignored and the incorrect value is used. This change corrects that. It is only 1 line. Download and install v1.11a or make the following change:

 

 

Open catalog/includes/boxes/customer_testimonials.php

 

Find (should be line 28):

 

	$testimonials_limit = TESTIMONIALS_LIMIT;

 

And REPLACE with:

 

	$testimonials_limit = TESTIMONIALS_SCROLL_TRIGGER; 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×